Welcome to ActionScript Dictionary Help!

РУССКАЯ РЕДАКЦИЯ

Перевод сделан силами участников мейл-конференции
"RuFlash"
Перевод сделан силами участников мейл-конференции здесь


Help Contents

Краткий обзор
Словарь ActionScript: Краткий обзор
Типовые заголовки для большинства элементов ActionScript
Типовые заголовки для объектов
Содержание словаря

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы
-- (уменьшение)
++ (увеличение)
! (логическое НЕ)
!= (неравенство)
% (модуль)
%= (присваивание модуля)
& (побитовое И)
&& (короткое И)
&= (присваивание побитового И)
() (круглые скобки)
- (минус)
* (умножение)
*= (присвоение умножения)
, (запятая)
. (точка)
?: (импликация)
/ (деление)
// (комментарий)
/* (ограничитель комментария)
/= (назначение деления)
[] (оператор доступа к массиву)
^ (побитовое исключающее ИЛИ)
^= (присвоение побитового исключающего ИЛИ)
{} (инициализатор объектов)
| (побитовое ИЛИ)
|| (ИЛИ)
|= (назначение побитового ИЛИ)
~ (побитовое НЕ)
+ (сложение)
+= (назначение сложения)
< (меньше чем)
<< (побитовое смещение влево)
<<= (побитовое смещение влево и присвоение)
<= (меньше чем или равно)
<> (неравенство)
= (присвоение)
-= (присвоение отрицания)
== (равенство)
> (больше чем)
>= (больше или равно)
>> (побитовое смещение вправо)
>>= (побитовое смещение вправо и присвоение)
>>> (побитовое смещение вправо без знака)
>>>= (побитовое смещение вправо без знака и присвоение)

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C
add
_alpha
and
Array (object)
Array.concat
Array.join
Array.length
Array.pop
Array.push
Array.reverse
Array.shift
Array.slice
Array.sort
Array.splice
Array.toString
Array.unshift
Boolean (function)
Boolean (object)
Boolean.toString
Boolean.valueOf
break
call
chr
Color (object)
Color.getRGB
Color.getTransform
Color.setRGB
Color.setTransform
continue
_currentframe

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date
Date (object)
Date.getDate
Date.getDay
Date.getFullYear
Date.getHours
Date.getMilliseconds
Date.getMinutes
Date.getMonth
Date.getSeconds
Date.getTime
Date.getTimezoneOffset
Date.getUTCDate
Date.getUTCDay
Date.getUTCFullYear
Date.getUTCHours
Date.getUTCMilliseconds
Date.getUTCMinutes
Date.getUTCMonth
Date.getUTCSeconds
Date.getYear
Date.setDate
Date.setFullYear
Date.setHours
Date.setMilliseconds
Date.setMinutes
Date.setMonth
Date.setSeconds
Date.setTime
Date.setUTCDate
Date.setUTCFullYear
Date.setUTCHours
Date.setUTCMilliseconds
Date.setUTCMinutes
Date.setUTCMonth
Date.setUTCSeconds
Date.setYear
Date.toString
Date.UTC

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I
delete
do... while
_droptarget
duplicateMovieClip
else
eq (строковое равенство)
escape
eval
evaluate
_focusrect
for
for..in
_framesloaded
fscommand
function
ge (больше или равно для строк)
getProperty
getTimer
getURL
getVersion
gotoAndPlay
gotoAndStop
gt (больше для строк)
_height
_highquality
if
ifFrameLoaded
#include
Infinity
int
isFinite
isNaN

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L
Key (object)
Key.BACKSPACE
Key.CAPSLOCK
Key.CONTROL
Key.DELETEKEY
Key.DOWN
Key.END
Key.ENTER
Key.ESCAPE
Key.getAscii
Key.getCode
Key.HOME
Key.INSERT
Key.isDown
Key.isToggled
Key.LEFT
Key.PGDN
Key.PGUP
Key.RIGHT
Key.SHIFT
Key.SPACE
Key.TAB
Key.UP
le (less than or equal to — string specific)
length
_level
loadMovie
loadVariables
lt (less than — string specific)

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math
Math (object)
Math.abs
Math.acos
Math.asin
Math.atan
Math.atan2
Math.ceil
Math.cos
Math.E
Math.exp
Math.floor
Math.log
Math.LOG2E
Math.LOG10E
Math.LN2
Math.LN10
Math.max
Math.min
Math.PI
Math.pow
Math.random
Math.round
Math.sin
Math.sqrt
Math.SQRT1_2
Math.SQRT2
Math.tan

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov
maxscroll
mbchr
mblength
mbord
mbsubstring
Mouse (object)
Mouse.hide
Mouse.show
MovieClip (object)
MovieClip.attachMovie
MovieClip.duplicateMovieClip
MovieClip.getBounds
MovieClip.getBytesLoaded
MovieClip.getBytesTotal
MovieClip.getURL
MovieClip.globalToLocal
MovieClip.gotoAndPlay
MovieClip.gotoAndStop
MovieClip.hitTest
MovieClip.loadMovie
MovieClip.loadVariables
MovieClip.localToGlobal
MovieClip.nextFrame
MovieClip.play
MovieClip.prevFrame
MovieClip.removeMovieClip
MovieClip.startDrag
MovieClip.stop
MovieClip.stopDrag
MovieClip.swapDepths
MovieClip.unloadMovie

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R
_name
NaN
ne (not equal — string specific)
new
newline
nextFrame
nextScene
not
null
Number (function)
Number (object)
Number.MAX_VALUE
Number.MIN_VALUE
Number.NaN
Number.NEGATIVE_INFINITY
Number.POSITIVE_INFINITY
Number.toString
Number.valueOf
Object (object)
Object.toString
Object.valueOf
onClipEvent
on(mouseEvent)
or
ord
_parent
parseFloat
parseInt
play
prevFrame
prevScene
print
printAsBitmap
_quality
random
removeMovieClip
return
_root
_rotation

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S
scroll
Selection (object)
Selection.getBeginIndex
Selection.getCaretIndex
Selection.getEndIndex
Selection.getFocus
Selection.setFocus
Selection.setSelection
set
setProperty
Sound (object)
Sound.attachSound
Sound.getPan
Sound.getTransform
Sound.getVolume
Sound.setPan
Sound.setTransform
Sound.setVolume
Sound.start
Sound.stop
_soundbuftime
startDrag
stop
stopAllSounds
stopDrag
String (function)
" " (string delimiter)
String (object)
String.charAt
String.charCodeAt
String.concat
String.fromCharCode
String.indexOf
String.lastIndexOf
String.length
String.slice
String.split
String.substr
String.substring
String.toLowerCase
String.toUpperCase
substring

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W
_target
targetPath
tellTarget
this
toggleHighQuality
_totalframes
trace
typeof
unescape
unloadMovie
updateAfterEvent
_url
var
_visible
void
while
_width
with

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z
_x
XML (object)
XML.appendChild
XML.attributes
XML.childNodes
XML.cloneNode
XML.createElement
XML.createTextNode
XML.docTypeDecl
XML.firstChild
XML.haschildNodes
XML.insertBefore
XML.lastChild
XML.load
XML.loaded
XML.nextSibling
XML.nodeName
XML.nodeType
XML.nodeValue
XML.onLoad
XML.parentNode
XML.parseXML
XML.previousSibling
XML.removeNode
XML.send
XML.sendAndLoad
XML.status
XML.toString
XML.xmlDecl
XMLSocket (object)
XMLSocket.close
XMLSocket.connect
XMLSocket.onClose
XMLSocket.onConnect
XMLSocket.onXML
XMLSocket.send
_xmouse
_xscale
_y
_ymouse
_yscale

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки
Мейл-конференция "RuFlash"


ActionScript dictionary: Краткий обзор

Краткий обзор > Словарь ActionScript: Краткий обзор

Словарь ActionScript: Краткий обзор

Эта часть документации описывает синтаксис и использование элементов ActionScript во Flash 5 и его более поздних версиях. Чтобы использовать примеры в своем скрипте, скопируйте текст с соответствующей страницы словаря ActionScript и вставьте его в панель Actions в режиме Expert Mode.

Словарь содержит все элементы языка ActionScript: операторы, ключевые слова, выражения, команды, свойства, функции, объекты и методы. Чтобы ознакомиться со всем этим более подробно, смотрите Содержание словаря. Находящиеся там таблицы, прекрасный отправной пункт для поиска операторов или методов, объектный класс которых вы не знаете.

ActionScript соответствует стандарту ECMA-262 (спецификации написанной Европейской Ассоциацией Производителей Компьютеров), при условии, что нет других пометок.

В словаре два типа статей:

Отдельные статьи для операторов, ключевых слов, функций, переменных, свойств, методов и выражений
Статьи об объектах, описывающие основные подробности предопределённых объектов

Используйте информацию данной главы справки, для понимания структуры и принятых соглашений для этих двух типов статей.


Sample entry for most ActionScript elements

Краткий обзор > Типовые заголовки для большинства элементов ActionScript

Типовые заголовки для большинства элементов ActionScript

В следующих примерах типовых заголовков объясняются принятые соглашения для всех элементов ActionScript, не являющихся объектами.

Заголовки

Все статьи словаря расположены в алфавитном порядке. Регистр, символ подчёркивания в начале и т.д. в расчёт не принимаются.

Синтаксис

Раздел "Синтаксис" содержит правильный синтаксис элементов ActionScript для вашего кода. Часть кода синтаксиса выделена монотипным шрифтом, а аргументы, которые можно назначать, монотипным курсивом 1. Необязательные аргументы заключены в скобки.

Аргументы

Этот раздел содержит описание всех аргументов, указанных в разделе синтаксиса.

Описание

В этом разделе указывается тип элемента (например оператор, метод, функция и т.д.) и объясняется, как он используется.

Player

Этот раздел содерит информацию о том, какие версии плэйера поддерживают данный элемент. Не путать с версией Flash-редактора, используемого для создания содержимого. Например, если вы создаёте содержимое для Flash 4 Player, используя при этом инструменты Flash 5, вы не сможете использовать те элементы ActionScript, которые доступны Flash 5 Player.

С появлением версии Flash 5 ActionScript, некоторые элементы Flash 4 и более ранних версий Flash ActionScript вышли из употребления. Несмотря на то, что эти элементы всё ещё поддерживаются во Flash 5 Player, рекомендуется использовать новые элементы Flash 5.

Кроме того, функциональность операторов значительно возросла в 5-й версии. Не только многие новые математические операторы, но и некоторые операторы старых версий теперь оптимизированы для работы с дополнительным объёмом данных. Для того чтобы избежать конфликта версий, файлы Flash 4 автоматически модифицируются при их импорте в среду Flash 5. Эти изменения не повлияют на функциональность первоначального скрипта. Для получения более детальной информации смотрите статьи по + (сложение), < (меньше), > (больше), <= (меньше или равно), >= (больше или равно), != (неравно) и = (равно).

Примеры

Этот раздел содержит примеры кодов, показывающие, как использовать элемент.

Смотри также

Этот раздел содержит ссылки на статьи словаря ActionScript, относящиеся к данной теме.

От редактора:

  1. Если Вам не нравится внешний вид справки в броузере, можете отредактировать файлы с описанием каскадных стилей по своему вкусу:
    help.css - стиль, которым выводится содержание страницы, например той, которую вы сейчас читаете;
    cont.css - стиль, которым выводится навигационное меню в левом фрейме.

    Эти файлы находятся вместе с HTML-файлами, в каждой из трех директорий справки.


Sample entry for objects

Краткий обзор > Типовые заголовки для объектов

Типовые заголовки для объектов

В следующих примерах типовых заголовков объясняются принятые соглашения для предопределённых объектов ActionScript. Объекты перечислены в алфавитном порядке наряду с другими элементами словаря.

Заголовок статьи

Заголовок статьи - это имя объекта. За ним следует параграф, содержащий общую информацию об объекте.

Сводные таблицы методов и свойств

Каждая статья с описанием объекта содержит таблицу со всеми методами, относящимися к объекту. Если объект имеет свойства (часто константы), то эти элементы приводятся в дополнительной таблице. Все методы и свойства, приводимые в таких таблицах, также имеют свои собственные словарные статьи, которые следуют за статьей с описанием объекта.

Конструктор

Если объект, для получения доступа к его свойствам и методам, требует использования конструктора, он описывается в конце статьи. Это описание включает все стандартные элементы других словарных статей (синтаксис, описание и др.)

Список методов и свойств

Методы и свойства объекта приведены в алфавитном порядке после статьи с описанием объекта.


Contents of the dictionary

Краткий обзор > Содержание словаря

Содержание словаря

Все словарные статьи приведены в алфавитном порядке. Однако, некоторые операторы являются символьными (не буквы) и приведены в виде соответствующих ASCII символов. Кроме того, методы, относящиеся к объектам, приведены вместе с именами этих объектов - например, метод abs объекта "Math", как Math.abs.

Следующие две таблицы помогут вам найти такие элементы. В первой таблице представлены символьные операторы в том порядке, в котором они расположены в словаре, во второй - все другие элементы ActionScript.

Обратите внимание: информацию о старшинстве и ассоциативности операторов см. в приложении А.
Символьные операторы |
-- | (decrement)
++ | (increment)
! | (logical NOT)
!= | (inequality)
% | (modulo)
%= | (modulo assignment)
& | (bitwise AND)
&& | (short-circuit AND)
&= | (bitwise AND assignment)
( ) | (parentheses)
- | (minus)
* | (multiplication)
*= | (multiplication assignment)
, | (comma)
. | (dot)
? : | (conditional)
/ | (division)
// | (comment delimiter)
/* | (comment delimiter)
/= | (division assignment)
[] | (array access)
^ | (bitwise XOR)
^= | (bitwise XOR assignment)
{} | (object initializer)
| | (bitwise OR)
|| | (logical OR)
|= | (bitwise OR assignment)
~ | (bitwise NOT)
+ | (addition)
+= | (addition assignment)
< | (less than)
<< | (bitwise left shift)
<<= | (bitwise left shift and assignment)
<= | (less than or equal to)
<> | (inequality)
= | (assignment)
-= | (negation assignment)
== | (equality)
> | (greater than)
>= | (greater than or equal to)
>> | (bitwise right shift)
>>= | (bitwise right shift and assignment)
>>> | (bitwise unsigned right shift)
>>>= | (bitwise unsigned right shift and assignment)

В следующей таблице приведены все элементы ActionScript, не являющиеся операторами.
Элемент ActionScript | См. статью
abs | Math.abs
acos | Math.acos
add | add
and | and
_alpha | _alpha
appendChild | XML.appendChild
Array | Array (object)
asin | Math.asin
atan | Math.atan
atan2 | Math.atan2
attachMovie | MovieClip.attachMovie
attachSound | Sound.attachSound
attributes | XML.attributes
BACKSPACE | Key.BACKSPACE
Boolean | Boolean (function), Boolean (object)
break | break
call | call
CAPSLOCK | Key.CAPSLOCK
ceil | Math.ceil
charAt | String.charAt
charCodeAt | String.charCodeAt
childNodes | XML.childNodes
chr | chr
cloneNode | XML.cloneNode
close | XMLSocket.close
Color | Color (object)
concat | Array.concat, String.concat
connect | XMLSocket.connect
constructor | Array, Boolean, Color, Date, Number, Object, Sound, String, XML, XMLSocket
continue | continue
CONTROL | Key.CONTROL
cos | Math.cos
createElement | XML.createElement
createTextNode | XML.createTextNode
_currentframe | _currentframe
Date | Date (object)
delete | delete
DELETEKEY | Key.DELETEKEY
docTypeDecl | XML.docTypeDecl
do...while | do... while
DOWN | Key.DOWN
_droptarget | _droptarget
duplicateMovieClip | duplicateMovieClip, MovieClip.duplicateMovieClip
E | Math.E
else | else
END | Key.END
ENTER | Key.ENTER
eq | eq (equal—string specific)
escape (function) | escape
ESCAPE (constant) | Key.ESCAPE
eval | eval
evaluate | evaluate
exp | Math.exp
firstChild | XML.firstChild
floor | Math.floor
_focusrect | _focusrect
for | for
for.. in | for..in
_framesloaded | _framesloaded
fromCharCode | String.fromCharCode
fscommand | fscommand
function | function
ge | ge (greater than or equal to—string specific)
getAscii | Key.getAscii
getBeginIndex | Selection.getBeginIndex
getBounds | MovieClip.getBounds
getBytesLoaded | MovieClip.getBytesLoaded
getBytesTotal | MovieClip.getBytesTotal
getCaretIndex | Selection.getCaretIndex
getCode | Key.getCode
getDate | Date.getDate
getDay | Date.getDay
getEndIndex | Selection.getEndIndex
getFocus | Selection.getFocus
getFullYear | Date.getFullYear
getHours | Date.getHours
getMilliseconds | Date.getMilliseconds
getMinutes | Date.getMinutes
getMonth | Date.getMonth
getPan | Sound.getPan
getProperty | getProperty
getRGB | Color.setRGB
getSeconds | Date.getSeconds
getTime | Date.getTime
getTimer | getTimer
getTimezoneOffset | Date.getTimezoneOffset
getTransform | Color.getTransform, Sound.getTransform
getURL | getURL, MovieClip.getURL
getUTCDate | Date.getUTCDate
getUTCDay | Date.getUTCDay
getUTCFullYear | Date.getUTCFullYear
getUTCHours | Date.getUTCHours
getUTCMilliseconds | Date.getUTCMilliseconds
getUTCMinutes | Date.getUTCMinutes
getUTCMonth | Date.getUTCMonth
getUTCSeconds | Date.getUTCSeconds
getVersion | getVersion
getVolume | Sound.getVolume
getYear | Date.getYear
globalToLocal | MovieClip.globalToLocal
gotoAndPlay | gotoAndPlay, MovieClip.gotoAndPlay
gotoAndStop | gotoAndStop, MovieClip.gotoAndStop
gt | gt (greater than —string specific)
hasChildNodes | XML.haschildNodes
_height | _height
hide | Mouse.hide
_highquality | _highquality
hitTest | MovieClip.hitTest
HOME | Key.HOME
if | if
ifFrameLoaded | ifFrameLoaded
#include | #include
indexOf | String.indexOf
Infinity | Infinity
INSERT | Key.INSERT
insertBefore | XML.insertBefore
int | int
isDown | Key.isDown
isFinite | isFinite
isNaN | isNaN
isToggled | Key.isToggled
join | Array.join
Key | Key (object)
lastChild | XML.lastChild
lastIndexOf | String.indexOf
le | le (less than or equal to — string specific)
LEFT | Key.LEFT
length | length, Array.length, String.length
LN2 | Math.LN2
LN10 | Math.LN10
load | XML.load
loaded | XML.loaded
loadMovie | loadMovie, MovieClip.loadMovie
loadVariables | loadVariables, MovieClip.loadVariables
localToGlobal | MovieClip.localToGlobal
log | Math.log
LOG2E | Math.LOG2E
LOG10E | Math.LOG10E
lt | le (less than or equal to — string specific)
Math | Math (object)
max | Math.max
maxscroll | maxscroll
MAX_VALUE | Number.MAX_VALUE
mbchr | mbchr
mblength | mblength
mbord | mbord
mbsubstring | mbsubstring
min | Math.min
MIN_VALUE | Number.MIN_VALUE
Mouse | Mouse (object)
MovieClip | MovieClip (object)
_name | _name
NaN | NaN, Number.NaN
ne | ne (not equal — string specific)
NEGATIVE_INFINITY | Number.NEGATIVE_INFINITY
new (operator) | new
newline | newline
nextFrame | nextFrame, MovieClip.nextFrame
nextScene | nextScene
nextSibling | XML.nextSibling
nodeName | XML.nodeName
nodeType | XML.nodeType
nodeValue | XML.nodeValue
not | not
null | null
Number | Number (function), Number (object)
Object | Object (object)
On | on(mouseEvent)
onClipEvent | onClipEvent
onClose | XMLSocket.onClose
onConnect | XMLSocket.onConnect
OnLoad | XML.onLoad
onXML | XMLSocket.onXML
or (logical OR) | or
ord | ord
_parent | _parent
parentNode | XML.parentNode
parseFloat | parseFloat
parseInt | parseInt
parseXML | XML.parseXML
PGDN | Key.PGDN
PGUP | Key.PGUP
PI | Math.PI
play | play, MovieClip.play
pop | Array.pop
POSITIVE_INFINITY | Number.POSITIVE_INFINITY
pow | Math.pow
prevFrame | prevFrame, MovieClip.prevFrame
previousSibling | XML.previousSibling
prevScene | prevScene
print | print
printAsBitmap | printAsBitmap
push | Array.push
_quality | _quality
random | random, Math.random
removeMovieClip | removeMovieClip, MovieClip.removeMovieClip
removeNode | XML.removeNode
return | return
reverse | Array.reverse
RIGHT | Key.RIGHT
_root | _root
_rotation | _rotation
round | Math.round
scroll | scroll
Selection | Selection (object)
send | XML.send, XMLSocket.send
sendAndLoad | XML.sendAndLoad
set | set
setDate | Date.setDate
setFocus | Selection.setFocus
setFullYear | Date.setFullYear
setHours | Date.setHours
setMilliseconds | Date.setMilliseconds
setMinutes | Date.setMinutes
setMonth | Date.setMonth
setPan | Sound.setPan
setProperty | setProperty
setRGB | Color.setRGB
setSeconds | Date.setSeconds
setSelection | Selection.setSelection
setTime | Date.setTime
setTransform | Color.setTransform,Sound.setTransform
setUTCDate | Date.setUTCDate
setUTCFullYear | Date.setUTCFullYear
setUTCHours | Date.setUTCHours
setUTCMilliseconds | Date.setUTCMilliseconds
setUTCMinutes | Date.setUTCMinutes
setUTCMonth | Date.setUTCMonth
setUTCSeconds | Date.setUTCSeconds
setVolume | Sound.setVolume
setYear | Date.setYear
shift (method) | Array.shift
SHIFT (constant) | Key.SHIFT
show | Mouse.show
sin | Math.sin
slice | Array.slice, String.slice
sort | Array.sort
Sound | Sound (object)
_soundbuftime | _soundbuftime
SPACE | Key.SPACE
splice | Array.splice
split | String.split
sqrt | Math.sqrt
SQRT1_2 | Math.SQRT1_2
SQRT2 | Math.SQRT2
start | Sound.start
startDrag | startDrag, MovieClip.startDrag
status | XML.status
stop | stop,MovieClip.stop,Sound.stop
stopAllSounds | stopAllSounds
stopDrag | stopDrag, MovieClip.stopDrag
String | String (function), String (object)," " (string delimiter)
substr | String.substr
substring | substring, String.substring
swapDepths | MovieClip.swapDepths
TAB | Key.TAB
tan | Math.tan
_target | _target
targetPath | targetPath
tellTarget | tellTarget
this | this
toggleHighQuality | toggleHighQuality
toLowerCase | String.toLowerCase
toString | Array.toString,Boolean.toString, Date.toString, Number.toString, Object.toString, XML.toString
_totalframes | _totalframes
toUpperCase | String.toUpperCase
trace | trace
typeof | typeof
unescape | unescape
unloadMovie | unloadMovie, MovieClip.unloadMovie
unshift | Array.shift
UP | Key.UP
updateAfterEvent | updateAfterEvent
_url | _url
UTC | Date.UTC
valueOf | Boolean.valueOf, Number.valueOf, Object.valueOf
var | var
_visible | _visible
void | void
while | while
_width | _width
with | with
_x | _x
XML | XML (object)
xmlDecl | XML.xmlDecl
XMLSocket | XMLSocket (object)
_xmouse | _xmouse
_xscale | _xscale
_y | _y
_ymouse | _ymouse
_yscale | _yscale


-- (decrement)

Операторы > -- (decrement)

-- (уменьшение)

Синтаксис

--expressionexpression--

Аргументы

expression Переменная, число, элемент в массиве или свойство объекта.

Описание

Оператор; унарный оператор пре- и пост-декремента (уменьшения), вычитающий 1 из expression. Пре-декрементная форма оператора (--expression) вычитает 1 из expression и возвращает результат. Пост-декрементная форма (expression--) вычитает 1 из expression и возвращает первоначальное значение expression (результат до вычитания).

Player

Flash 4 или более поздней версии.

Пример

Пре-декрементная форма оператора уменьшает x до 2 (x - 1 = 2) и возвращает результат, как y:

x = 3;

y = --x

Пост-декрементная форма оператора уменьшает x до 2 (x - 1 = 2) и возвращает первоначальное значение (x = 3), как результат y:

If x = 3;

y = x--


++ (increment)

Операторы > ++ (increment)

++ (увеличение)

Синтаксис

++expressionexpression++

Аргументы

expression Переменная, число, элемент в массиве или свойство объекта.

Описание

Оператор; унарный оператор пре- и пост-инкремента (увеличения), добавляющий 1 к expression. Пре-инкрементная форма оператора (++expression) добавляет 1 к expression и возвращает результат. Пост-инкрементная форма оператора (expression++) добавляет 1 к expression и возвращает первоначальное значение expression (результат перед сложением).

Пре-инкрементная форма оператора увеличивает x до 2 (x + 1 = 2) и возвращает результат, как y:

x = 1;y = ++x

Пост-инкрементная форма оператора увеличивает x до 2 (x + 1 = 2) и возвращает первоначальное значение (x = 1), как результат y:

x = 1;y = x++;

Player

Flash 4 или более поздней версии.

Пример

Этот пример использует ++ как пост-инкрементный оператор с выражением while.

i = 0while(i++ < 5){// Этот цикл будет повторен 5 раз}

Этот пример использует ++ как пре-инкрементный оператор:

var a = [];var i = 0;while (i < 10) {	a.push(++i);}trace(a.join());

Результат выполнения этого скритпа:

1,2,3,4,5,6,7,8,9,10

Этот пример использует ++ как оператор пост-инкремента:

var a = [];var i = 0;while (i < 10) {a.push(i++);	}trace(a.join());

Результат выполнения этого скритпа:

0,1,2,3,4,5,6,7,8,9


! (logical NOT)

Операторы > ! (logical NOT)

! (логическое НЕ)

Синтаксис

!expression

Аргументы

expression Переменная или оцениваемое выражение.

Описание

Логический оператор; инвертирует булево значение переменной или выражения. Если expression является переменной с абсолютным или конвертированным значением true, то !expression будет соответствовать false. Если выражение x && y оценивается как false, то !(x && y), как true. Этот оператор идентичен оператору not, который использовался во Flash 4.

Player

Flash 4 или более поздней версии.

Пример

В этом примере переменная happy принята за false, оператор if проверяет условие !happy, и если оно есть true, то trace посылает строку в Output окно.

happy = false;if (!happy){trace("don't worry be happy");}

Следующие строки иллюстрируют результат действия оператора !:

! true возвращает false

! false возвращает true


!= (inequality)

Операторы > != (inequality)

!= (неравенство)

Синтаксис

expression1 != expression2

Аргументы

expression1, expression2 Числа, строки, булевы значения, переменные, объекты, массивы или функции.

Описание

Оператор (эквивалентности); тестирует два выражения прямо противоположным образом, нежели оператор ==. Если expression1 эквивалентен expression2, то результат есть false. Так же как и при использовании оператора ==, определение эквивалентности зависит от сравниваемых типов данных.

Числа, строки, булевы значения сравниваются по значению.
Переменные, объекты, массивы и функции сравниваются по содержанию 1.

Player

Flash 5 или более поздней версии.

Пример

Этот пример показывает результат действий оператора !=.

5 != 8 возвращает true

5 != 5 возвращает false

Следующий пример показывает использование оператора != в команде if :

a = "David";b = "Fool" if (a != b){trace("David is not a fool");}

Смотри также

== (equality)

От редактора:

  1. Имеется в виду, что в отличие от чисел, булеанов и строк, являющихся по сути константами, переменные, объекты, массивы и функции, являются контейнерами с переменным содержанием.


% (modulo)

Операторы > % (modulo)

% (модуль)

Синтаксис

expression1 % expression2

Аргументы

expression1, expression2 Целые числа, числа с плавающей запятой или строки, которые нужно конвертировать в числовое значение.

Описание

Оператор (арифметический); подсчитывает остаток от деления expression1 на expression2. Если один из аргументов expression нечисловой, оператор пытается конвертировать его в число.

Player

Flash 4 или более поздней версии. В файлах Flash 4, оператор % расширен в SWF файле как x - int(x/y) * y, и может работать не так быстро и точно, как тот, который реализован во Flash 5 Player.

Пример

Ниже пример использования оператора % для работы с числами:

12 % 5 возвращает 2

4.3 % 2.1 возвращает 0.1


%= (modulo assignment)

Операторы > %= (modulo assignment)

%= (присваивание модуля)

Синтаксис

expression1 %= expression2

Аргументы

expression1,expression2 Целые числа и переменные.

Описание

Оператор присваивания; присваивает expression1 значение expression1 % expression2.

Player

Flash 4 или более поздней версии.

Пример

Этот пример показывает, как использовать оператор %= с переменными и числами:

x %= y то же самое, что x = x % y

Если x = 14 и y = 5 то

x %= 5 возвращает 4

Смотри также

% (modulo)


& (bitwise AND)

Операторы > & (bitwise AND)

& (побитовое И)

Синтаксис

expression1 & expression2

Аргументы

expression1, expression2 Любое число.

Описание

Оператор (побитовый); конвертирует expression1 и expression2 в 32-битные целые числа, и выполняет операцию "булево И" над каждым битом аргумента целого числа. В результате мы имеем новое беззнаковое целое число.

Player

Flash 5 или более поздней версии. Во Flash 4, оператор & использовался для объединения строк. Во Flash 5 оператор & является "побитовым И" оператором, а операторы add и + объединяют строки. Файлы Flash 4, использующие оператор &, автоматически обновляются для использования add во время переноса в рабочую среду Flash 5.


&& (short-circuit AND)

Операторы > && (short-circuit AND)

&& (короткое И)

Синтаксис

expression1 && expression2

Аргументы

expression1, expression2 Числа, строки, переменные или функции.

Описание

Логический оператор; производит булеву операцию над значениями одного или обоих выражений. Интерпретатор Flash анализирует левое expression1 и возвращает false, если выражение оценивается как false. Если expression1 оценивается как true, то рассматривается правое expression2. Если и expression2 оценивается как true, то окончательный результат - true, в противном случае результат - false.

Player

Flash 4 или более поздней версии.

Пример

В этом примере переменным winner и loser присваивается соответствующие значения, как результат оценки правых частей выражений:

winner = (chocolateEggs >=10) && (jellyBeans >=25);loser = (chocolateEggs <=1) && (jellyBeans <= 5);if (winner) {	alert = "You Win the Hunt!";	if (loser) {		alert = "Now THAT'S Unhappy Hunting!";	}} else {	alert = "We're all winners!";}


&= (bitwise AND assignment)

Операторы > &= (bitwise AND assignment)

&= (присваивание побитового И)

Синтаксис

expression1 &= expression2

Аргументы

expression1, expression2 Целые числа и переменные.

Описание

Побитовый оператор присваивает expression1 значение expression1 & expression2.

Player

Flash 5 или более поздней версии.

Пример

Ниже иллюстрации использования оператора &= с переменными и числами:

x &= y то же самое, что x = x & y

If x = 15 and y = 9 then

x &= 9 возвращает 9

Смотри также

& (bitwise AND)


() (parentheses)

Операторы > () (parentheses)

() (круглые скобки)

Синтаксис

(expression1, expression2);function(functionCall1, ..., functionCallN);

Аргументы

expression1, expression2 Числа, строки, переменные или текст.

function Функция, выполняющая содержание круглых скобок.

functionCall1...functionCallN Последовательность функций, которые должны быть выполнены прежде, чем результат будет передан функции, находящейся вне круглых скобок.

Описание

Оператор (общий); выполняет операцию группировки с одним или большим количеством аргументов или окружает один или более аргументов и передаёт результат - параметр функции вне круглых скобок.

Использование 1: выполняет операцию группировки над одним или более выражениями, контролируя порядок выполнения операторов в выражении. Этот оператор игнорирует автоматическую последовательность по старшинству и даёт команду первым рассматривать выражение внутри круглых скобок. После этого Flash в первую очередь рассматривает содержимое ближайших круглых скобок, затем - следующих.

Использование 2: окружает один или более аргументов и передаёт их функции вне круглых скобок, как параметры.

Player

Flash 4 или более поздней версии.

Пример

(Использование 1) Следующие выражения иллюстрируют использование круглых скобок для контроля последовательности исполнения выражений. (Результат дан под каждым выражением.)

(2 + 3) * (4 + 5)452 + (3 * (4 + 5))292 + (3 * 4) + 519

(Использование 2) Следующий пример иллюстрируют использование круглых скобок с функцией:

getDate();invoice(item, amount);

Смотри также

with


- (minus)

Операторы > - (minus)

- (минус)

Синтаксис

(Отрицание) -expression

(вычитание) expression1 - expression2

Аргументы

expression1, expression2 Любое число.

Описание

Оператор (арифметический); используется для отрицания и вычитания. В случае с отрицанием он переворачивает знак числового expression. В случае с вычитанием он выполняет арифметическое вычитание над двумя числовыми выражениями, вычитая expression2 из expression1. Если оба выражения являются целыми, разность также будет целым числом. Если одно или оба выражения являются выражениями с плавающей запятой, разность будет числом с плавающей запятой.

Player

Flash 4 или более поздней версии.

Пример

(Отрицание) Этот оператор переворачивает знак выражения 2 + 3:

-(2 + 3)

Результат: -5.

(Вычитание) Этот оператор вычитает целое число 2 из целого числа 5:

5 - 2

Результат - целое число 3.

(Вычитание): Этот оператор вычитает число с плавающей запятой 1.5 из числа с плавающей запятой 3.25:

put 3.25 - 1.5

Результат: 1.75 - число с плавающей запятой.


* (multiplication)

Операторы > * (multiplication)

* (умножение)

Синтаксис

expression1 * expression2

Аргументы

expression1, expression2 Целые числа или числа с плавающей запятой.

Описание

Оператор (арифметический); умножает два числовых выражения. Если оба выражения являются целыми числами, то результат - целое число. Если одно или оба выражения - числа с плавающей запятой, то результат - число с плавающей запятой.

Player

Flash 4 или более поздней версии.

Пример

Этот оператор перемножает целые числа 2 и 3:

2 * 3

Результат: 6 - целое число.

Пример

Этот оператор перемножает числа с плавающей запятой 2.0 и 3.1416:

2.0 * 3.1416

Результат - число с плавающей запятой 6.2832.


*= (multiplication assignment)

Операторы > *= (multiplication assignment)

*= (присвоение умножения)

Синтаксис

expression1 *= expression2

Аргументы

expression1, expression2 Целые числа, числа с плавающей запятой или строки.

Описание

Оператор (присваивания); присваивает expression1 значение expression1 * expression2.

Player

Flash 4 или более поздней версии.

Пример

Пример использования оператора *= с переменными и числами:

x *= y то же, что и x = x * y

If x = 5 и y = 10 , то

x *= 10 вернёт 50

Смотри также

* (multiplication)


, (comma)

Операторы > , (comma)

, (запятая)

Синтаксис

expression1, expression2

Аргументы

expression Любое число, переменная, строка, элемент массива или другие данные.

Описание

Оператор; даёт команду Flash'у проанализировать expression1, потом expression2 и затем вернуть значение expression2. Этот оператор чаще всего используется с оператором цикла for.

Player

Flash 4 или более поздней версии.

Пример

Код, использующий данный оператор:

var a=1, b=2, c=3;

Это равноценно следующий записи:

var a=1;var b=2;var c=3;


. (dot operator)

Операторы > . (dot operator)

. (точка)

Синтаксис

object.property_or_methodinstancename.variableinstancename.childinstance.variable

Аргументы

object Экземпляр объекта. Некоторые объекты должны быть созданы с использованием конструктора для этого объекта. Объектом может быть любой предопределенный объект ActionScript или специальный объект. Этот аргумент всегда находится слева от оператора точка (.).

property_or_method Имя свойства или метода, относящегося к объекту. Все валидные методы и свойства предопределенного объекта приведены в таблицах Методы и Свойства для данного объекта. Этот аргумент всегда находится справа от оператора точка (.).

instancename Имя мувиклипа.

childinstance Имя мувиклипа, являющегося дочерним по отношению к главному клипу.

variable Переменная в мувиклипе.

Описание

Оператор; используется для управления иерархией клипа, доступа к вложенным дочерним клипам, переменным или свойствам. Оператор точка (.) также используется для проверки или установки свойств объекта, для выполнения метода объекта или создания структуры данных.

Player

Flash 4 или более поздней версии.

Смотри также

[] (array access operator)

Пример

Этот оператор идентифицирует текущее значение переменной hairColor мувиклипа person:

person.hairColor

Это равноценно следующему синтаксису Flash 4:

/person:hairColor

Пример

Этот код bkk.cnhbhetn, как можно использовать оператор точка (.) для создания структуры массива:

account.name = "Gary Smith";account.address = "123 Main St ";account.city = "Any Town";account.state = "CA";account.zip = "12345";


?: (conditional)

Операторы > ?: (conditional)

?: (импликация)

Синтаксис

expression1 ? expression2 : expression3

Аргументы

expression1 Выражение, оценивающееся булевым значением, обычно сравнительное выражение.

expression2, expression3 Любое значение.

Описание

Оператор (импликация); анализирует expression1 и возвращает значение expression2 если expression1 есть true, в противном случае возвращает значение expression3.

Player

Flash 4 или более поздней версии.


/ (division)

Операторы > / (division)

/ (деление)

Синтаксис

expression1 / expression2

Аргументы

expression Любое число.

Описание

Оператор (арифметический); делит expression1 на expression2. Аргументы выражений и результаты деления обрабатываются и представляются, как числа с плавающей запятой с удвоенной точностью.

Player

Flash 4 или более поздней версии.

Пример

Этот оператор делит число с плавающей запятой 22.0 на 7.0 и показывает результат в окне Output:

trace(22.0 / 7.0);

Результат - число с плавающей запятой 3.1429.


// (comment delimiter)

Операторы > // (comment delimiter)

// (комментарий)

Синтаксис

// comment

Аргументы

comment Текст, который не является частью кода и должен игнорироваться интерпретатором.

Описание

Комментарий; указывает начало комментария. Любой текст между ограничителем и знаком конца строки является комментарием и игнорируется интерпретатором ActionScript.

Player

Flash 1 или более поздней версии.

Пример

Этот скрипт использует двойной слеш для идентификации первой, третьей, пятой и седьмой строк, как комментариев:

// set the X position of the ball movie clipball = getProperty(ball._x);// set the Y position of the ball movie clipball = getProperty(ball._y);// set the X position of the kitty movie clipkitty = getProperty(kitty._x);// set the Y position of the kitty movie clipkitty_y = getProperty(kitty._y);

Смотри также

/* (comment delimiter)


/* (comment delimiter)

Операторы > /* (comment delimiter)

/* (ограничитель комментария)

Синтаксис

/* comment *//** comment* comment*/

Аргументы

comment Любой текст

Описание

Ограничитель; указывает на одну или более строк комментария в скрипте. Любой текст между открывающим /* и закрывающим */ тегами ограничителя является комментарием и игнорируется интерпретатором ActionScript. Используйте первый тип синтаксиса, для однострочных комментариев и второй тип, для комментариев на нескольких последовательных строках. "Не закрытие" ограничителя */ при использовании этого типа синтаксиса, повлечёт за собой сообщение об ошибке, которое выдаст компилятор ActionScript.

Player

Flash 5 или более поздней версии.

Смотри также

// (comment delimiter)


/= (division assignment)

Операторы > /= (division assignment)

/= (назначение деления)

Синтаксис

expression1 /= expression2

Аргументы

expression1, expression2 Целые числа, числа с плавающей запятой или строки.

Описание

Оператор (присваивания); присваивает expression1 значение expression1 / expression2.

Player

Flash 4 или более поздней версии.

Пример

Использование оператора /= с переменными и числами:

x /= y то же самое, что и x = x /yx = 10;y = 2;x /= y;x теперь имеет значение 5


[] (array access operator)

Операторы > [] (array access operator)

[] (оператор доступа к массиву)

Синтаксис

myArray["a0", "a1",..."aN"];object[value1, value2, ...valueN];

Аргументы

myArray Имя массива.

a0, a1,...aN Элементы в массиве.

value1, 2,...N Имена свойств.

Описание

Оператор; создаёт новый объект и задействует свойства, указанные в аргументах или задействует новую массив с элементами (a0), указанными в аргументах.

Созданный объект имеет свой групповой прототип. Использование этого оператора идентично вызову new Object и заполнению свойств с использованием оператора присваивания. Использование этого оператора является альтернативой использованию оператора new, который помогает быстро и удобно создавать объекты.

Player

Flash 4 или более поздней версии.

Пример

Эти коды - два различных способа создания нового пустого объекта Array (Массив):

myArray =[];myArray = new Array();

Ниже пример простого массива:

myArray = ["red", "orange", "yellow", "green", "blue", "purple"]myArray[0]="red"myArray[1]="yellow"myArray[2]="green"myArray[3]="blue"myArray[4]="purple"


^(bitwise XOR)

Операторы > ^(bitwise XOR)

^ (побитовое исключающее ИЛИ)

Синтаксис

expression1 ^ expression2

Аргументы

expression1, expression2 Любое число.

Описание

Оператор; конвертирует expression1 и expression2 в 32-битные беззнаковые целые числа, и возвращает 1 в каждую битовую позицию, где соответствующие биты в выражениях expression1 или expression1, но не в обоих, представлены как 1.

Player

Flash 5 или более поздней версии.

Пример

15 ^ 9 возвращает 6(1111 ^ 1001 = 0110)


^= (bitwise XOR assignment)

Операторы > ^= (bitwise XOR assignment)

^= (присвоение побитового исключающего ИЛИ)

Синтаксис

expression1 ^= expression2

Аргументы

expression1, expression2 Целые числа и переменные.

Описание

Оператор (составного назначения); присваивает expression1 значение expression1 ^ expression2.

Player

Flash 5 или более поздней версии.

Пример

Пример операции ^= :

// 15 decimal = 1111 binaryx = 15;// 9 decimal = 1001 binaryx ^= y;returnsx ^ y (0110 binary)

Пример использования оператора ^= с переменными и числами:

x ^= y то же самое, что и x = x ^ yЕсли x = 15 и y = 9 , тогда15 ^= 9  возвращает 6

Смотри также

^(bitwise XOR)


{} (object initializer)

Операторы > {} (object initializer)

{} (инициализатор объектов)

Синтаксис

object {name1: value1,	name1: value2,...	nameN: valueN };

Аргументы

object Объект, который нужно создать.

name1,2,...N Имя свойства.

value1,2,...N Соответствующее значение для свойств каждого name.

Описание

Оператор; создаёт новый объект и инициализирует его с парами свойств указанного имени name и значения value. Созданный объект имеет универсальный объект Object как прототип. Использование этого оператора аналогично вызову new Object и заполнению пар свойств, посредством использования оператора назначений. Использование этого оператора - это альтернатива использованию оператора new, допускающая быстрое и удобное создание объектов.

Player

Flash 5 или более поздней версии.

Пример

Этот код показывает как можно создать пустой объект, используя оператор инициализатор объектов и new Object :

object = {};object = new Object();

Ниже создается объект account и инициализируются свойства name, address, city, state, zip и balance:

account = { name: "John Smith",	address: "123 Main Street",	city: "Blossomville",	state: "California",	zip: "12345",	balance: "1000" };

Этот пример показывает, как массив и инициализатор объектов можно вложить друг в друга:

person = { name: "Peter Piper",	children: [ "Jack", "Jill", "Moe",] };

Вот ещё способ использования информации из предыдущего примера с такими же результатами:

person = new Person();person.name = 'John Smith';person.children = new Array();person.children[0] = 'Jack';person.children[1] = 'Jill';person.children[2] = 'Moe';

Смотри также


| (bitwise OR)

Операторы > | (bitwise OR)

| (побитовое ИЛИ)

Синтаксис

expression1 | expression2

Аргументы

expression1, expression2 Любое число.

Описание

Оператор (побитовый); конвертирует expression1 и expression2 в 32-битные беззнаковые целые числа, и возвращает 1 в каждую битовую позицию, где соответствующие биты в выражении expression1 или expression2 представлены как 1.

Player

Flash 5 или более поздней версии.

Пример

Вот пример операции с побитовым ИЛИ. Примечание: 15 - это бинарное 1111:

// 15 decimal = 1111 binaryx = 15;// 9 decimal = 1001 binaryy = 9;// x | y = binaryz = x | y;z = 15

Вот ещё способ выражения предыдущего примера:

15 | 9 возвращает 15(1111 | 0011 = 1111)


|| (OR)

Операторы > || (OR)

|| (ИЛИ)

Синтаксис

expression1 || expression2

Аргументы

expression1, expression2 Булево значение, или выражение, конвертируемое в булево значение.

Описание

Оператор (логический); анализирует expression1 и expression2. Результат есть (true), если одно или оба эти выражения оцениваются как true; результат есть (false), только если оба эти выражения оцениваются как false.

С не булевыми выражениями, логический оператор OR анализирует выражения, находящееся слева, если оно может быть конвертировано в true, результат - true. В противном случае он оценивает выражение справа и результат - это значение этого выражения.

Player

Flash 4 или более поздней версии.

Пример

Этот пример использует оператор || в операторе if:

want = true;need = true;love = false;if (want || need || love){trace("two out of 3 ain't bad");}


|= (bitwise OR assignment)

Операторы > |= (bitwise OR assignment)

|= (назначение побитового ИЛИ)

Синтаксис

expression1 |= expression2

Аргументы

expression1, expression2 Целые числа и переменные.

Описание

Оператор (присваивания); присваивает expression1 значение expression1 | expression2.

Player

Flash 5 или более поздней версии.

Пример

Ниже пример использования оператора |= с переменными и числами:

x |= y то же, что и x = x | y

если x = 15 и y = 9 , то

x |= 9 вернёт 15

Смотри также

| (bitwise OR)


~ (bitwise NOT)

Операторы > ~ (bitwise NOT)

~ (побитовое НЕ)

Синтаксис

~ expression

Аргументы

expression Любое число.

Описание

Оператор (побитовый); конвертирует expression в 32-битное целое беззнаковое число, затем инвертирует биты. Или же, проще говоря, изменяет знак числа и вычитает 1.

"Побитовый НЕ" оператор изменяет знак числа и вычитает 1.

Player

Flash 5 или более поздней версии.

Пример

Ниже числовое объяснение операции над переменной с использованием "побитового НЕ" оператора:

~a, возвращает -1, если a = 0 и возвращает -2, если a = 1, таким образом:

~0=-1 and ~1=-2


+ (addition)

Операторы > + (addition)

+ (сложение)

Синтаксис

expression1 + expression2

Аргументы

expression1, expression2 Целые числа, числа с плавающей запятой или строки.

Описание

Оператор; складывает числовые выражения или связывает строки. Если одно выражение является строкой, все другие выражения конвертируются в строки и связываются.

Если оба выражения являются целыми числами, то сумма - целое число. Если одно или оба выражения являются числами с плавающей запятой, то сумма - число с плавающей запятой.

Player

Flash 4, 5 или более поздней версии. В пятой версии, + является числовым оператором или объединителем строк в зависимости от типа данных аргумента. В четвертой версии, + является только числовым оператором. Файлы Flash 4 при переносе в рабочую среду Flash 5 подвергаются преобразованию, с целью сохранить целостность типа данных. Первый из нижеприведённых примеров показывает процесс преобразования.

Пример

Этот пример показывает преобразование файла Flash 4, содержащего числовое качественное сравнение:

Файл Flash 4:

x + y

Конвертированный файл Flash 5:

Number(x) + Number(y)

В этом операторе происходит сложение целых чисел 2 и 3, результат выводится в окне Output:

trace (2 + 3);

Здесь складываются числа с плавающей запятой 2.5 и 3.25, результат, 5.7500, число с плавающей запятой, выводится в окне Output:

trace (2.5 + 3.25);

Ниже происходит объединение двух строк и результат, "today is my birthday", выводится в окне Output:

"today is my" + "birthday"

Смотри также

add


+= (addition assignment)

Операторы > += (addition assignment)

+= (назначение сложения)

Синтаксис

expression1 += expression2

Аргументы

expression1, expression2 Целые, числа с плавающей запятой или строки.

Описание

Оператор; присваивает expression1 значение expression1 + expression2. Этот оператор также выполняет объединение строк.

Player

Flash 4 или более поздней версии.

Пример

Это пример числового использования оператора +=:

x += y это то же, что и x = x + y

если x = 5 и y = 10, то

>x += 10 вернёт 15

Это пример использования оператора += со строковым выражением:

x = "My name is"x += "Mary"

Результат этого кода будет следующим:

"My name is Mary"

Также смотри

+ (addition)


< (less than)

Операторы > < (less than)

< (меньше чем)

Синтаксис

expression1 < expression2

Аргументы

expression1, expression2 Числа или строки.

Описание

Оператор (сравнения); сравнивает два выражения и определяет, меньше ли expression1 чем expression2 (true), или expression1 больше или равно expression2 (false). Строчные выражения оцениваются и сравниваются на основе числа знаков в строке.

Player

Flash 4; Flash 5 or later. In Flash 5 < is a comparison operator capable of handling various data types. In Flash 4 < is an numeric operator. Flash 4 files brought into the Flash 5 authoring environment undergo a conversion process to maintain data type integrity. The first example below illustrates the conversion process.

Flash 4, 5, или более поздней версии. В пятой версии, < - это оператор, работающий с данными различных типов. В четвертой версии, < - это числовой оператор. Файлы Flash 4, будучи перенесёнными в среду Flash 5, подвергаются преобразованию, с целью сохранить целостность типа данных. Первый из нижеприведённых примеров показывает процесс конвертации.

Пример

Это пример преобразования файла Flash 4, содержащего числовое качественное сравнение.

Файл Flash 4:

x < y

Преобразованный файл Flash 5:

Number(x) < Number(y)

Ниже примеры, показывающие возврат true и false для чисел и строк:

3 < 10 или "Al" < "Jack" возвращает true

10 < 3 или "Jack" < "Al" возвращает false


<< (bitwise left shift)

Операторы > << (bitwise left shift)

<< (побитовое смещение влево)

Синтаксис

expression1 << expression2

Аргументы

expression1 Число, строка, или выражение, которое нужно сместить влево.

expression2 Число, строка, или выражение, конвертируемое в целое число от 0 до 31.

Описание

Оператор; конвертирует expression1 и expression2 в 32-битное целое число и смещает все биты expression1 влево в соответствии с числом, получающимся при преобразовании expression2. Освобождённые в результате операции битовые позиции заполняются нулями. Смещение значения на одну позицию влево идентично умножению на 2.

Player

Flash 5 или более поздней версии.

Пример

Это пример смещения целого числа 1 на десять бит влево:

x = 1 << 10

Результат этой операции есть x = 1024. Он таков потому, что десятичное число 1 равняется двоичному числу 1, двоичное число 1, смещённое на 10 бит влево, будет равняться двоичному числу 10000000000, а двоичное число 10000000000 равняется десятичному числу 1024.

Это пример смещения целого числа 7 на 8 бит влево:

x = 7 << 8

Результат этой операции есть x = 1792. Он таков потому, что десятичное число 7 равняется двоичному числу 111, двоичное число 111, смещённое на 8 бит влево, будет равняться двоичному числу 11100000000, а двоичное число 11100000000 равняется десятичному числу 1792.

Смотри также

>>= (bitwise right shift and assignment)


<<= (bitwise left shift and assignment)

Операторы > <<= (bitwise left shift and assignment)

<<= (побитовое смещение влево и присвоение)

Синтаксис

expression1 <<= expression2

Аргументы

expression1 Число, строка, или выражение, которые нужно сместить влево.

expression2 Число, строка, или выражение, конвертируемые в целое число от 0 до 31.

Описание

Оператор; производит побитовый сдвиг влево и сохраняет содержимое, как результат в expression1.

Player

Flash 5 или более поздней версии.

Пример

Два следующих выражения эквивалентны:

A <<= B A = (A << B)

Смотри также


<= (less than or equal to)

Операторы > <= (less than or equal to)

<= (меньше чем или равно)

Синтаксис

expression1 <= expression2

Аргументы

expression1, expression2 Число или строки.

Описание

Оператор сравнивает два выражения и определяет, expression1 меньше чем или равно expression2 (true), или больше (false).

Player

Flash 4, 5, или более поздней версии. В пятой версии, <= является оператором сравнения, работающим с различными типами данных. В четвертой версии <= является числовым оператором. Файлы Flash 4, перенесённые в рабочую среду Flash 5 преобразуются для сохранения целостности типа данных. Первый из нижеприведённых примеров показывает процесс преобразования.

Пример

Это пример преобразования файла Flash 4, содержащего числовое качественное сравнение.

Файл Flash 4:

x <= y

Преобразованный файл Flash 5:

Number(x) <= Number(y)

Следующий пример показывает возврат true и false для чисел и строк:

5 <= 10 или "Al" <= "Jack" возвращает true

10<= 5 или "Jack" <= "Al" возвращает false


<> (inequality)

Операторы > <> (inequality)

<> (неравенство)

Синтаксис

expression1 <> expression2

Аргументы

expression1, expression2 Числа, строки, булевы значения, переменные, объекты, массивы или функции.

Описание

Оператор (сравнения); противоположность оператору ==. Если expression1 равно expression2, то результат false. Также как и при использовании оператора ==, процесс определения зависит от типов сравниваемых данных:

Числа, строки, булевы значения сравниваются по значению.
Переменные, объекты, массивы и функции сравниваются по содержанию.

Этот оператор в 5 версии Flash неэффективен. Рекомендуется пользоваться новым оператором !=.

Player

Flash 2 или более поздней версии.

Смотри также

!= (inequality)


= (assignment)

Операторы > = (assignment)

= (присвоение)

Синтаксис

expression1 = expression2

Аргументы

expression1 Переменная, элемент массива или свойство объекта.

expression2 Любое значение.

Описание

Оператор (присваивания); присваивает тип expression2 (аргумент справа) переменной, элементу массива или свойству в expression1.

Player

Flash 4, 5, или более поздней версии. В пятой версии, = является оператором присвоения, а оператор == используется для оценки равенства. В четвертой версии = является числовым качественным оператором. Файлы Flash 4, перенесённые в рабочую среду Flash 5 преобразуются для сохранения целостности типа данных. Первый из нижеприведённых примеров показывает процесс преобразования.

Пример

Это пример, показывающий процесс преобразования файла flash 4, содержащего числовое качественное сравнение.

Файл Flash 4:

x = y

Преобразованный файл Flash 5:

Number(x) == Number(y)

Ниже показано, как использовать оператор для присвоения числа типа данных переменной x:

x = 5

Следующий пример показывает, как использовать оператор для присвоения строки типа данных переменной x:

x = "hello"


-= (negation assignment)

Операторы > -= (negation assignment)

-= (присвоение отрицания)

Синтаксис

expression1 -= expression2

Аргументы

expression1, expression2 Целые числа, числа с плавающей запятой или строки.

Описание

Оператор (присваивания); присваивает expression1 значение expression1 - expression2.

Player

Flash 4 или более поздней версии.

Пример

Это пример использования оператора -= с переменными и числами:

x -= y это то же, что и x = x - y

если x = 5 и y = 10 , то

x -= 10 вернёт -5


== (equality)

Операторы > == (equality)

== (равенство)

Синтаксис

expression1 == expression2

Аргументы

expression1,expression2 Числа, строки, булевы значения, переменные, объекты, массивы или функции.

Описание

Оператор (эквивалентности); проверяет два выражения на равенство. Результат true, если выражения равны.

Определение равенства зависит от типа данных аргумента:

Числа, строки, булевы значения сравниваются по значению и считаются равными, если имеют одно и то же значение. Например, две строки равны, если они содержат одинаковое число символов.
Переменные, объекты, массивы и функции сравниваются по содержанию. Две переменные равны, если они ссылаются на один и тот же объект, массив или функцию. Две отдельных массива никогда не считаются равными, даже если они имеют одинаковое число элементов.

Player

Flash 5 или более поздней версии.

Пример

Вот пример использования оператора == с оператором if:

a = "David" , b = "David";if (a == b){trace("David is David");}


> (greater than)

Операторы > > (greater than)

> (больше чем)

Синтаксис

expression1 > expression2

Аргументы

expression1, expression2 Целые числа, числа с плавающей запятой, строки.

Описание

Оператор (равнения); сравнивает два выражения и определяет больше ли expression1 чем expression2 (true) или меньше (false) или равно (false).

Player

Flash 4, 5, или более поздней версии. В пятой версии, > является оператором сравнения, работающим с различными типами данных. В четвертой версии > является числовым оператором. Файлы Flash 4, перенесённые в рабочую среду Flash 5 преобразуются для сохранения целостности типа данных. Приведённый ниже пример показывает процесс преобразования.

Пример

Этот пример показывает процесс преобразования файла Flash 4, содержащего числовое качественное сравнение.

Файл Flash 4:

x > y

Преобразованный файл Flash 5:

Number(x) > Number(y)


>= (greater than or equal to)

Операторы > >= (greater than or equal to)

>= (больше или равно)

Синтаксис

expression1 >= expression2

Аргументы

expression1, expression2 Строки, целые числа, числа с плавающей запятой.

Описание

Оператор (сравнения); сравнивает два выражения и определяет больше ли expression1 чем expression2 (true), равно ли expression2 (true), или меньше (false).

Player

Flash 4, 5, или более поздней версии. В пятой версии, >= является оператором сравнения, работающим с различными типами данных. В четвертой версии >= является числовым оператором. Файлы Flash 4, перенесённые в рабочую среду Flash 5 преобразуются для сохранения целостности типа данных. Ниже приведён пример, показывающий процесс преобразования.

Пример

Этот пример показывает процесс преобразования файла Flash 4, содержащего числовое качественное сравнение.

Файл Flash 4:

x >= y

Преобразованный файл Flash 5:

Number(x) >= Number(y)


>> (bitwise right shift)

Операторы > >> (bitwise right shift)

>> (побитовое смещение вправо)

Синтаксис

expression1 >> expression2

Аргументы

expression1 Число, строка или выражение, которые нужно сместить вправо.

expression2 Число, строка или выражение, конвертируемые в целое число от 0 до 31.

Описание

Побитовый оператор конвертирует expression1 и expression2 в 32-битное целое число и смещает все биты в expression1 вправо на число разрядов, указанное целым числом, результирующим от преобразования expression2. Биты, смещённые вправо, игнорируются. Чтобы сохранить знак изначального expression, биты слева заполняются нулями, если самый значимый бит (самый левый) expression1 будет нулём, или заполняются единицами, если самый значимый бит будет единицей. Смещение значения вправо на одну позицию эквивалентно делению на 2, пренебрегая остатком.

Player

Flash 5 или более поздней версии.

Пример

Этот пример показывает процесс преобразования числа 65535 в 32-битное целое число и смещение этого числа на восемь битов вправо:

x = 65535 >> 8

Результатом вышеописанной операции будет:

x = 255

Результат таков, потому что десятичное число 65535 равно двоичному числу 1111111111111111 (шестнадцать единиц), двоичное число 1111111111111111, смещённое вправо на восемь бит даст нам двоичное число 11111111, а двоичное число 11111111 равняется десятичному числу 255. Самый значимый бит - 0, так как целые числа 32-битные.

Следующий пример показывает процесс преобразования числа -1 в 32-битное целое число и смещение этого числа на один бит вправо:

x = -1 >> 1

Результатом вышеописанной операции будет:

x = -1

Результат таков, потому что десятичное число -1 равно двоичному числу 11111111111111111111111111111111 (тридцать две единицы). Смещение вправо на один бит заставляет игнорировать наименее значимый бит (самый правый), и заполнить единицей наиболее значимый бит (самый левый). Результатом будет двоичное число 11111111111111111111111111111111 (тридцать две единицы), которое представляет собой 32-битное целое число -1.

Смотри также

>>= (bitwise right shift and assignment)


>>= (bitwise right shift and assignment)

Операторы > >>= (bitwise right shift and assignment)

>>= (побитовое смещение вправо и присвоение)

Синтаксис

expression1 =>>expression2

Аргументы

expression1 Число, строка или выражение, которые необходимо сместить влево.

expression2 Число, строка или выражение, конвертируемые в целое число от 0 до 31.

Описание

Оператор; производит побитовое смещение вправо и записывает содержимое, как результат в expression1.

Player

Flash 5 или более поздней версии.

Пример

Данные два выражения эквивалентны:

A >>= B A = (A >> B)

Данный закомментированный код использует побитовый оператор >>=. Это также является примером использования всех побитовых операторов.

function convertToBinary(number){var result = "";for (var i=0; i<32; i++) {// Extract least significant bit using bitwise ANDvar lsb = number & 1;// Add this bit to our result stringresult = (lsb ? "1" : "0") + result;// Shift number right by one bit, to see next bit}number >>= 1;return result;}convertToBinary(479)//Returns the string00000000000000000000000111011111//The above string is the binary representation of the decimal number 479.

Смотри также

<< (bitwise left shift)


>>> (bitwise unsigned right shift)

Операторы > >>> (bitwise unsigned right shift)

>>> (побитовое смещение вправо без знака)

Синтаксис

expression1 >>> expression2

Аргументы

expression1 Число, строка или выражение, которые необходимо сместить вправо.

expression2 Число, строка или выражение, конвертируемые в целое число от 0 до 31.

Описание

Этот побитовый оператор ничем не отличается от побитового оператора смещения вправо (>>), кроме знака изначального expression, так как биты слева всегда заполняются нолями.

Player

Flash 5 или более поздней версии.

Пример

Следующий пример показывает процесс преобразования числа -1 в 32-битное целое число и смещение этого числа на один бит вправо:

x = -1 >>> 1

Результатом вышеописанной операции будет:

x = 2147483647

Результат таков, потому что десятичное число -1 равно двоичному числу 11111111111111111111111111111111 (тридцать две единицы). Смещение вправо на один бит без знака заставляет игнорировать наименее значимый бит (самый правый), и заполнить нулём наиболее значимый бит (самый левый). Результатом будет двоичное число 01111111111111111111111111111111, которое представляет собой 32-битное целое число 2147483647.

Смотри также

>>= (bitwise right shift and assignment)


>>>= (bitwise unsigned right shift and assignment)

Операторы > >>>= (bitwise unsigned right shift and assignment)

>>>= (побитовое смещение вправо без знака и присвоение)

Синтаксис

expression1 >>>= expression2

Аргументы

expression1 Число, строка или выражение, которые нужно сместить вправо.

expression2 Число, строка или выражение, преобразуемые в целое число от 0 до 31.

Описание

Оператор; производит побитовое смещение вправо без знака и записывает содержимое, как результат в expression1.

Player

Flash 5 или более поздней версии.

Пример

Следующие два выражения эквивалентны:

A >>>= B A = (A >>> B)

Смотри также


add

A-C > add

add

Синтаксис

string1 add string2

Аргументы

string1,2 - произвольные строки.

Описание

Оператор; "склеивает" две или более строк. Оператор add заменил оператор & , существовавший в Flash 4; Flash 4 файлы, использующие & оператор, автоматически преобразуются к использованию add оператора для сложения строк при работе в среде Flash 5 Player. Однако не рекомендуется использовать оператор add во Flash 5; вместо него лучше использовать оператор + при работе с Flash 5 Player. Используйте оператор add только в том случае, если вы работаете с Flash Player версии 4 или ниже.

Player

Flash 4 или ниже.

См. также

+ (addition)


_alpha

A-C > _alpha

_alpha

Синтаксис

instancename._alpha
instancename._alpha = value;

Аргументы

instancename Имя экземпляра (образца) муви-клипа.

value Целое число от 0 до 100, определяющее прозрачность.

Описание

Свойство муви-клипа; устанавливает прозрачность (value) муви-клипа. Диапазон от 0 (полная прозрачность) до 100 (полная видимость). Объекты в клипе с установленным _alpha в 0 остаются активными, даже если полностью невидимы. Например, кнопка в мувике с нулевым _alpha преспокойно может быть кликнута.

Player

Flash 4 или ниже.

Пример

Следующий пример показывает, что после клика по кнопке свойство _alpha экземпляра star устанавливается в 30%:

on(release) {
    setProperty(star._alpha = 30);
}

или

on(release) {
    star._alpha = 30;
}


and

A-C > and

and

Синтаксис

condition1 and condition2

Аргументы

condition1,condition2 Условия или выражения, характеризующиеся состояниями true или false.

Описание

Оператор; выполняет логическую операцию AND в Flash 4 Player. Если оба выражения установлены в true, получаем true.

Player

Flash 4 или ниже. Этот оператор не рекомендуется использовать в Flash 5, вместо него используйте новый оператор &&.

См. также

&& (short-circuit AND)


Array (object)

A-C > Array (object)

Array (object)

Объект Array позволяет вам работать с массивами. Объект Array - это объект, чьи свойства идентифицируются порядковым номером, позицией в массиве. Номер этот называют индексом. Первый элемент массива всегда имеет нулевой индекс, второй - [1], третий - [2], и т. д. В следующем примере массив myArray состоит из проиндексированных названий месяцев года.

myArray[0] = "January"

myArray[1] = "February"

myArray[2] = "March"

myArray[3] = "April"

Для создания объекта Array необходимо воспользоваться конструктором new Array. Чтобы получить доступ к отдельному элементу массива, используйте оператор [ ].

Таблица методов объекта Array
Метод | Описание
concat | Соединяет аргументы (последовательности массивов), и возвращает их уже как новый массив.
join | Объединяет элементы массива в строку.
pop | Удаляет последний элемент массива и возвращает его значение.
push | Добавляет один или больше элементов в конец массива и возвращает длину нового массива.
reverse | Выворачивает массив наизнанку, т. е. первый элемент становится последним, второй - предпоследним, и т. д ., и наоборот.
shift | Удаляет первый элемент массива и возвращает его значение.
slice | Извлекает из массива часть и возвращает ее как новый массив.
sort | Сортирует массив.
splice | Добавляет и/или удаляет элементы из массива.
toString | Возвращает значение строки, которую представляют из себя элементы массива.
unshift | Добавляет один или больше элементов в начало массива и возвращает длину нового массива.

Таблица свойств объекта Array
Свойство | Описание
length | Возвращает длину массива.

Конструктор Array объекта

Синтаксис

new Array();
new Array(length);
new Array(element0, element1, element2,...elementN);

Аргументы

length Целое число, равное количеству элементов в массиве. Если элементы не смежные, length равен индексу последнего элемента плюс 1. Для дополнительной информации смотри свойства Array.length.

element0...elementN Список двух или более произвольно выбранных значений. Это могут быть числа, имена или другие элементы. Первый элемент массива всегда имеет индекс, или позицию, равную 0.

Описание

Конструктор; позволяет создать массив и работать с ним. Индексы начинаются с нуля, и растут с ростом порядкового номера элемента.

Если аргументы не определялись, создается нулевой массив.

Player

Flash 5 или выше.

Пример

В этом примере создается нулевой объект Array:

myArray = new Array();

В этом примере создается новый объект Array A-Team, с длиной length равной 4:

A-Team = new Array("Jody", "Mary", "Marcelle", "Judy");

Ниже показана возможная инициализация элементов массива A-Team:

myArray[0] = "Jody"

myArray[1] = "Mary"

myArray[2] = "Marcelle"

myArray[3] = "Judy"

См. также

Array.length


Array.concat

A-C > Array.concat

Array.concat

Синтаксис

myArray.concat(value0,value1,...valueN);

Аргументы

value0,...valueN Числа, элементы массивов или строки, которые должны быть представлены как единый массив.

Описание

Метод; представляет элементы, определенные в качестве аргументов, как новый массив. Если аргументами являются массивы, элементы нового массива располагаются в том же порядке.

Player

Flash 5 или выше.

Пример

В этом примере складываются два массива:

alpha = new Array("a","b","c");
numeric = new Array(1,2,3);
alphaNumeric=alpha.concat(numeric);
// создается массив ["a","b","c",1,2,3]

В этом примере складываются три массива:

num1=[1,3,5];
num2=[2,4,6];
num3=[7,8,9];
nums=num1.concat(num2,num3) // создается массив [1,3,5,2,4,6,7,8,9]


Array.join

A-C > Array.join

Array.join

Синтаксис

myArray.join();
myArray.join(separator);

Аргументы

separator Символ или строка, которая будет отделять друг от друга элементы массива в возвращаемой строке. Если разделитель не указан, по умолчанию будет использоваться запятая.

Описание

Метод; преобразует элементы массива в строку, вставляет между ними символы - разделители, и возвращает ее.

Player

Flash 5 или выше.

Example

В следующем примере создается массив с тремя элементами. Затем элементы объединяются тремя способами: с разделителем по умолчанию, с запятой и пробелом, и со знаком плюс.

a = new Array("Earth","Moon","Sun")
// присваиваем значение "Earth,Moon,Sun" массиву myVar1
myVar1=a.join();
// присваиваем значение "Earth, Moon, Sun" массиву myVar2
myVar2=a.join(", ");
// присваиваем значение "Earth + Moon + Sun" массиву myVar3
myVar3=a.join(" + ");


Array.length

A-C > Array.length

Array.length

Синтаксис

myArray.length;

Аргументы

Нет.

Описание

Свойство; содержит в себе длину массива. Автоматически обновляется, когда элементы добавляются в массив. Допустим, присваиваем myArray[index] = value; если index какой-то номер, и index+1 больше, чем length , свойство length обновится до index + 1.

Player

Flash 5 или выше.

Пример

Ниже поясняется, как обновляется свойство length:

//initial length is 0
myArray = new Array();
//myArray.length обновляется до 1
myArray[0] = 'a';
//myArray.length обновляется до 2
myArray[1] = 'b';
//myArray.length обновляется до 10
myArray[9] = 'c';


Array.pop

A-C > Array.pop

Array.pop

Синтаксис

myArray.pop();

Аргументы

Нет.

Описание

Метод; удаляет последний элемент массива и возвращает его значение.

Player

Flash 5 или выше.

Пример

В примере создается массив myPets, содержащий четыре элемента, а затем последний удаляется:

myPets = ["cat", "dog", "bird", "fish"];
popped = myPets.pop();


Array.push

A-C > Array.push

Array.push

Синтаксис

myArray.push(value,...);

Аргументы

value Одно или несколько значений, добавляемых в массив.

Описание

Метод; добавляет один или больше элементов в конец массива и возвращает длину нового массива.

Player

Flash 5 или выше.

Пример

Создается массив myPets, содержащий два элемента, затем добавляются еще два, после чего pushed содержит 4 элемента.

myPets = ["cat", "dog"];
pushed = myPets.push("bird", "fish");


Array.reverse

A-C > Array.reverse

Array.reverse

Синтаксис

myArray.reverse();

Аргументы

Нет.

Description

Метод; меняет порядок следования элементов на обратный.

Player

Flash 5 или выше.

Пример

Использование метода Array.reverse:

var numbers = [1, 2, 3, 4, 5, 6];
trace(numbers.join());
    numbers.reverse();
    trace(numbers.join());

На выходе:

1,2,3,4,5,6
6,5,4,3,2,1


Array.shift

A-C > Array.shift

Array.shift

Синтаксис

myArray.shift();

Аргументы

Нет.

Description

Метод; удаляет первый элемент массива и возвращает его значение.

Player

Flash 5 или выше.

Пример

Создаем массив myPets и удаляем из него первый элемент:

myPets = ["cat", "dog", "bird", "fish"];
shifted = myPets.shift();

Возвращаемое значение равно cat.

См. также


Array.slice

A-C > Array.slice

Array.slice

Синтаксис

myArray.slice(start, end);

Аргументы

start Целое число, определяющее индекс первого в извлекаемом сегменте элемента. Если start отрицательное число, отсчет начинается с конца массива, при этом -1 последний элемент.

end Целое число, определяющее индекс последнего в извлекаемом сегменте элемента. Если оно не указано, сегмент заканчивается на последнем элементе массива. Если end отрицательное число, сегмент заканчивается в конце массива, -1 последний элемент.

Описание

Метод; извлекает из массива часть (сегмент) и возвращает ее как новый массив, оставляя при этом основной массив без изменений. Новый массив включает в себя start элемент, и все элементы до элемента end, не включая его самого.

Player

Flash 5 или выше.


Array.sort

A-C > Array.sort

Array.sort

Синтаксис

myArray.sort();
myArray.sort(orderfunc);

Аргументы

orderfunc Произвольная сравнивающая функция, определяющая порядок сортировки. Учитывая аргументы А и В, указанная функция должна выполнять сортировку следующим образом:

-1 если A появляется прежде чем B в сортируемой последовательности
0 если A = B
1 если A появляется после B в сортируемой последовательности

Описание

Метод; сортирует массив на месте, т.е. без создания копии. Если аргумент orderfunc не указан, Flash сортирует элементы, используя оператор <.

Player

Flash 5 или выше.

Пример

Используем Array.sort без определения аргумента orderfunc:

var fruits = ["oranges", "apples", "strawberries",
                "pineapples", "cherries"];
    trace(fruits.join());
    fruits.sort();
    trace(fruits.join());

Получаем:

oranges,apples,strawberries,pineapples,cherries
apples,cherries,oranges,pineapples,strawberries

Используем Array.sort, определяя аргумент orderfunc:

var passwords = [
   "gary:foo",
   "mike:bar",
   "john:snafu",
   "steve:yuck",
   "daniel:1234"
 ];
 function order (a, b) {
   // Элементы записаны в форме
   // name:password
   // Сортируем, используя в качестве ключа
   // только часть name.
   var name1 = a.split(':')[0];
   var name2 = b.split(':')[0];
   if (name1 < name2) {
     return -1;
   } else if (name1 > name2) {
     return 1;
   } else {
     return 0;
   }
 }
 for (var i=0; i< password.length; i++) {
   trace (passwords.join());
 }
 passwords.sort(order);
 trace ("Sorted:");
 for (var i=0; i< password.length; i++) {
   trace (passwords.join());
 }

Получаем:

daniel:1234
gary:foo
john:snafu
mike:bar
steve:yuck


Array.splice

A-C > Array.splice

Array.splice

Синтаксис

myArray.splice(start, deleteCount, value0,value1...valueN);

Аргументы

start Индекс элемента массива, где начинается добавление/удаление элементов.

deleteCount Количество удаляемых элементов, включающее в себя элемент start. Если deleteCount не задан, метод удаляет все элементы от start до конца массива.

value Вставляемые в массив элементы, начиная с точки start. Не обязателен.

Описание

Метод; добавляет и/или удаляет элементы из массива. Модифицирует массив без создания копии.

Player

Flash 5 или выше.


Array.toString

A-C > Array.toString

Array.toString

Синтаксис

myArray.toString();

Аргументы

Нет.

Описание

Метод; возвращает строку, которая представляет из себя последовательность элементов массива, разделенныx запятыми.

Player

Flash 5 или выше.

Пример

Создаем массив myArray и преобразуем его в строку:

myArray = new Array();
myArray[0] = 1;
myArray[1] = 2;
myArray[2] = 3;
myArray[3] = 4;
myArray[4] = 5;
trace(myArray.toString())

Получаем:

1,2,3,4,5


Array.unshift

A-C > Array.unshift

Array.unshift

Синтаксис

myArray.unshift(value1,value2,...valueN);

Аргументы

value1,...valueN Один или больше элементов, переменных или чисел, вставляемых в начало массива.

Описание

Метод; добавляет один или больше элементов в начало массива и возвращает длину нового массива.

Player

Flash 5 или выше.


Boolean (function)

A-C > Boolean (function)

Boolean (function)

Синтаксис

Boolean(expression);

Аргументы

expression Переменная, число или строка, преобразуемая в тип Boolean.

Описание

Функция; преобразует аргумент в Boolean и возвращает его значение.

Player

Flash 5 или выше.


Boolean (object)

A-C > Boolean (object)

Boolean (object)

Объект Boolean - простейший объект, с теми же сами функциональными возможностями, как и в JavaScript. Используйте объект Boolean, чтобы получить простейший тип данных или строковое представление объекта Boolean.

Таблица методов объекта Boolean
Метод | Описание
toString | Возвращает строковое представление (true) или (false) объекта Boolean.
valueOf | Возвращает значение объекта Boolean.

Конструктор объекта Boolean

Синтаксис

new Boolean();
new Boolean(x);

Аргументы

x Число, строка, Boolean, объект, муви-клип, или другое выражение. Необязательный аргумент.

Описание

Конструктор; создает экземпляр объекта Boolean. Если аргумент x не определен, новый объект Boolean инициализируется как false. Если же x определен, объект Boolean инициализируется на основании следующих правил:

Если x число, функция возвратит true при x отличном от 0, или false если x нулевой.
Если x имеет тип Boolean, функция просто вернет его значение.
Если x - объект или муви-клип, функция вернет true при x отличном от null; иначе вернет false.
Если x - строка, функция вернет true если Number(x) не равен 0; иначе вернет false.

Замечание: Для обеспечения совместимости с Flash 4, при работе со строками не использовать ECMA-262 стандарт.

Player

Flash 5 или выше.


Boolean.toString

A-C > Boolean.toString

Boolean.toString

Синтаксис

Boolean.toString();

Аргументы

Нет.

Описание

Метод; возвращает строковое представление, true или false, булевского объекта.

Player

Flash 5 или выше.


Boolean.valueOf

A-C > Boolean.valueOf

Boolean.valueOf

Синтаксис

Boolean.valueOf();

Аргументы

Нет.

Описание

Метод; возвращает значение заданного объекта Boolean.

Player

Flash 5 или выше.


break

A-C > break

break

Синтаксис

break;

Аргументы

Нет.

Описание

Команда; используется в циклах (for, for..in, do...while или while). Команда break предписывает Flash-у прервать выполнение цикла и выполнять следующее за циклом выражение. Используйте break при работе с вложенными циклами.

Player

Flash 4 или выше.

Пример

Используем break, чтобы прервать бесконечный цикл:

i = 0;
while (true) {
    if (i >= 100) {
        break;
    }
    i++;
}


call

A-C > call

call

Синтаксис

call(frame);

Аргументы

frame Имя или номер фрейма, где содержится вызываемый скрипт.

Описание

Команда; вызывает из текущего скрипта прикрепленный скрипт - "подпрограмму". Когда его выполнение закончится, локальные переменные уничтожаются.

Player

Flash 4 или выше. В Flash 5 рекомендуется использовать команду function.

См. также

function


chr

A-C > chr

chr

Синтаксис

chr(number);

Аргументы

number ASCII-код для представления его в виде строковой переменной.

Описание

Строковая функция; преобразует ASCII-код в строковую переменную.

Player

Flash 4 или выше. В Flash 5 используйте метод String.fromCharCode.

Пример

Преобразуем ASCII-код 65 в букву "A":

chr(65) = "A"

См. также

String.fromCharCode


Color (object)

A-C > Color (object)

Color (object)

Объект Color позволяет устанавливать и получать RGB-значение цвета муви-клипа и изменять его. Объект Color поддерживается в Flash 5 и более поздними версиями Flash Player.

Прежде чем пользоваться методами Color объекта, необходимо с помощью конструктора new Color() создать экземпляр объекта Color.

Таблица методов объекта Color
Метод | Описание
getRGB | Возвращает значение RGB, установленное последним вызовом setRGB.
getTransform | Возвращает информацию об изменениях, внесенных последним вызовом setTransform.
setRGB | Устанавливает шестнадцатеричное RGB значение для Color объекта.
setTransform | Производит изменения с цветом в Color объекте.

Конструктор объекта Color

Синтаксис

new Color(target);

Аргументы

target Имя муви-клипа, цвет которого хотят изменить.

Описание

Конструктор; создает объект Color для муви-клипа, определенного в качестве аргумента target.

Player

Flash 5 или выше.

Пример

Создаем объект Color по имени myColor для муви-клипа myMovie:

myColor = new Color(myMovie);


Color.getRGB

A-C > Color.getRGB

Color.getRGB

Синтаксис

myColor.getRGB();

Аргументы

Нет.

Описание

Метод; Возвращает значение RGB, установленное последним вызовом setRGB.

Player

Flash 5 или выше.

Пример

Получаем шестнадцатеричное RGB значение в виде строки:

value = (getRGB()).toString(16);

See also

Color.setRGB


Color.getTransform

A-C > Color.getTransform

Color.getTransform

Синтаксис

myColor.getTransform();

Аргументы

Нет.

Описание

Метод; возвращает информацию об изменениях, внесенных последним вызовом setTransform.

Player

Flash 5 или выше.

См. также

Color.setTransform


Color.setRGB

A-C > Color.setRGB

Color.setRGB

Синтаксис

myColor.setRGB(0xRRGGBB);

Аргументы

0xRRGGBB Шестнадцатеричное RGB значение устанавливаемого цвета. Каждая компонента RR, GG, и BB кодируется двумя шестнадцатеричными цифрами.

Описание

Метод; устанавливает шестнадцатеричное RGB значение для Color объекта. Вызов этого метода отменяет все изменения, вызванные последним вызовом setTransform.

Player

Flash 5 или выше.

Пример

Выставляем RGB цвет для муви-клипа myMovie:

myColor = new Color(myMovie);
myColor.setRGB(0x993366);

См. также

Color.setTransform


Color.setTransform

A-C > Color.setTransform

Color.setTransform

Синтаксис

myColor.setTransform(colorTransformObject);

Аргументы

colorTransformObject объект, созданный при помощи конструктора объекта Object, устанавливающий изменения цвета значениями параметров. colorTransformObject имеет параметры ra, rb, ga, gb, ba, bb, aa, ab, значение которых определяется ниже.

Описание

Метод; задает изменение цвет объекта Color. Аргумент colorTransformObject - это объект, созданный конструктором объекта Object, с параметрами, задающими процентное или абсолютное изменение трех цветовых компонент (red, green, blue), и прозрачности alpha, в формате 0xRRGGBBAA.

Параметры объекта colorTransformObject:

ra процентное изменение красной компоненты (-100 to 100).
rb абсолютное изменение красной компоненты (-255 to 255).
ga процентное изменение зеленой компоненты (-100 to 100).
gb абсолютное изменение зеленой компоненты (-255 to 255).
ba процентное изменение синей компоненты (-100 to 100).
bb абсолютное изменение синей компоненты (-255 to 255).
aa процентное изменение прозрачности (-100 to 100).
ab абсолютное изменение прозрачности (-255 to 255).

Изменение цвета производится следующим образом:

myColorTransform = new Object();
myColorTransform.ra = 50;
myColorTransform.rb = 244;
myColorTransform.ga = 40;
myColorTransform.gb = 112;
myColorTransform.ba = 12;
myColorTransform.bb = 90;
myColorTransform.aa = 40;
myColorTransform.ab = 70;

Можете использовать также следующий синтаксис:

myColorTransform = { ra: '50', rb: '244', ga: '40', gb: '112', ba: '12', bb: '90', aa: '40', ab: '70'}

Player

Flash 5 или выше.

Пример

Создаем новый объект Color для муви-клипа, color transformobject с описанными выше параметрами, используя конструктор объекта Object, и передаем объекту Color этот color transformobject, используя метод setTransform.

// Создаем объект Color
myColor = new Color(myMovie);

// Вызываем myColorTransfrom и создаем color transform object
// the generic Object object
myColorTransform = new Object;

// Задаем параметры
myColorTransform = { ra: '50', rb: '244', ga: '40', gb: '112', ba: '12', bb: '90', aa: '40', ab: '70'}

// Связываем color transform object с объектом Color, созданным выше
myColor.setTransform(myColorTransform);


continue

A-C > continue

continue

Синтаксис

continue;

Аргументы

Нет.

Описание

Команда; фигурирует внутри некоторых типах операторов цикла.

В цикле while, continue заставляет Flash пропустить оставшуюся часть тела цикла, и перейти к его вершине, где проверяется условие выхода из цикла.

В цикле do...while, continue заставляет Flash пропустить оставшуюся часть тела цикла, и перейти к его окончанию, где проверяется условие выхода из цикла.

В цикле for, continue заставляет Flash пропустить оставшуюся часть тела цикла, и перейти туда, где вычисляется условие выхода из цикла.

В цикле for...in, continue заставляет Flash пропустить оставшуюся часть тела цикла, и перейти к его вершине, где обрабатывается следующее значение.

Player

Flash 4 или выше.

См. также


_currentframe

A-C > _currentframe

_currentframe

Синтаксис

instancename._currentframe

Аргументы

instancename Имя экземпляра муви-клипа.

Описание

Свойство (только возвращаемое, установить нельзя); возвращает номер кадра, где муви-клип находится в данный момент.

Player

Flash 4 или выше.

Пример

Используем _currentframe, чтобы отправить клип на фрэйм, отстоящий от текущего на пять кадров впереди:

gotoAndStop(_currentframe + 5);


Date (object)

Date > Date (object)

Date (object)

Объект Date позволяет получить дату и время по Гринвичу (глобальные) и текущие (системные), где запущен Flash Player. Чтобы воспользоваться методами объекта Date, необходимо сначала создать его экземпляр с помощью конструктора.

При работе с объектом Date необходим Flash 5 Player.

Методы объекта Date не статичные и применяются отдельно для каждого экземпляра объекта Date, для которого были вызваны.

Таблица методов объекта Date
Метод | Описание
getDate | Возвращает день месяца указанного объекта Date согласно системному времени.
getDay | Возвращает день недели указанного объекта Date согласно системному времени.
getFullYear | Возвращает четырехзначное значение года указанного объекта Date согласно системному времени.
getHours | Возвращает час указанного объекта Date согласно системному времени.
getMilliseconds | Возвращает количество миллисекунд указанного объекта Date согласно системному времени.
getMinutes | Возвращает количество минут указанного объекта Date согласно системному времени.
getMonth | Возвращает месяц указанного объекта Date согласно системному времени.
getSeconds | Возвращает количество секунд указанного объекта Date согласно системному времени.
getTime | Возвращает количество миллисекунд, прошедших с 1 января 1970, для указанного объекта Date.
getTimezoneOffset | Возвращает разницу в минутах между системным и глобальным временем.
getUTCDate | Возвращает день месяца указанного объекта Date согласно глобальному времени.
getUTCDay | Возвращает день недели указанного объекта Date согласно глобальному времени.
getUTCFullYear | Возвращает четырехзначное значение года указанного объекта Date согласно глобальному времени.
getUTCHours | Возвращает час указанного объекта Date согласно глобальному времени.
getUTCMilliseconds | Возвращает количество миллисекунд указанного объекта Date согласно глобальному времени.
getUTCMinutes | Возвращает количество минут указанного объекта Date согласно глобальному времени.
getUTCMonth | Возвращает месяц указанного объекта Date согласно глобальному времени.
getUTCSeconds | Возвращает количество секунд указанного объекта Date согласно глобальному времени.
getYear | Возвращает значение года указанного объекта Date согласно системному времени.
setDate | Выставляет день месяца объекта Date согласно системному времени.
setFullYear | Выставляет полную дату объекта Date согласно системному времени.
setHours | Выставляет час объекта Date согласно системному времени.
setMilliseconds | Выставляет количество миллисекунд объекта Date согласно системному времени.
setMinutes | Выставляет количество минут объекта Date согласно системному времени.
setMonth | Выставляет месяц объекта Date согласно системному времени.
setSeconds | Выставляет количество секунд объекта Date согласно системному времени.
setTime | Выставляет дату указанного объекта Date в миллисекундах.
setUTCDate | Выставляет дату указанного объекта Date согласно глобальному времени.
setUTCFullYear | Выставляет год указанного объекта Date согласно глобальному времени.
setUTCHours | Выставляет час указанного объекта Date согласно глобальному времени.
setUTCMilliseconds | Выставляет миллисекунды указанного объекта Date согласно глобальному времени.
setUTCMinutes | Выставляет минуты указанного объекта Date согласно глобальному времени.
setUTCMonth | Выставляет месяц указанного объекта Date согласно глобальному времени.
setUTCSeconds | Выставляет секунды указанного объекта Date согласно глобальному времени.
setYear | Выставляет год указанного объекта Date согласно системному времени.
toString | Возвращает строку, представляющую дату и время, содержащиеся в объекте Date.
Date.UTC | Возвращает количество миллисекунд, прошедших с 00.00 1 января 1970 г. по глобальному времени до заданного времени.

Конструктор объекта Date

Синтаксис

new Date();
new Date(year [, month [, date [, hour [, minute [, second [, millisecond ]]]]]] );

Аргументы

year Число от 0 до 99, задающих год между 1900 и 1999, иначе должны быть заданы все четыре цифры.

month Целое от 0 (январь) до 11 (декабрь); необязательный аргумент.

date Целое от 0 до 31; необязательный аргумент.

hour Целое от 0 (полночь) до 23 (11 вечера).

minute Целое от 0 до 59; необязательный аргумент.

second Целое от 0 до 59; необязательный аргумент.

millisecond Целое от 0 до 999; необязательный аргумент.

Описание

Объект; создает и хранит дату и время.

Player

Flash 5 или выше.

Пример

Получаем текущие дату и время:

now = new Date();

Создаем новый объект Date, хранящий день рождения Гарри, 7 августа 1974:

gary_birthday = new Date (74, 7, 7);

Создаем новый объект Date, получаем данные с помощью методов getMonth, getDate, и getFullYear, форматируем их, а получившуюся строку отправляем в текстовое поле dateTextField.

myDate = new Date();
dateTextField = (mydate.getMonth() + "/" + myDate.getDate() + "/" + mydate.getFullYear());


Date.getDate

Date > Date.getDate

Date.getDate

Синтаксис

myDate.getDate();

Аргументы

Нет.

Описание

Метод; Возвращает день месяца (целое от 1 до 31) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getDay

Date > Date.getDay

Date.getDay

Синтаксис

myDate.getDay();

Аргументы

Нет.

Описание

Метод; Возвращает день недели (0 для воскресенья, 1 для понедельника, и т.д.) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getFullYear

Date > Date.getFullYear

Date.getFullYear

Синтаксис

myDate.getFullYear();

Аргументы

Нет.

Описание

Метод; возвращает четырехзначное значение года указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.

Пример

Создаем новый объект Date и посылаем значение, полученное методом getFullYear, в окно Output:

myDate = new Date();
trace(myDate.getFullYear());


Date.getHours

Date > Date.getHours

Date.getHours

Синтаксис

myDate.getHours();

Аргументы

Нет.

Описание

Метод; Возвращает час (целое от 0 до 23) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getMilliseconds

Date > Date.getMilliseconds

Date.getMilliseconds

Синтаксис

myDate.getMilliseconds();

Аргументы

Нет.

Описание

Метод; возвращает количество миллисекунд (целое от 0 до 999) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getMinutes

Date > Date.getMinutes

Date.getMinutes

Синтаксис

myDate.getMinutes();

Аргументы

Нет.

Описание

Метод; возвращает количество минут (целое от 0 до 59) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getMonth

Date > Date.getMonth

Date.getMonth

Синтаксис

myDate.getMonth();

Аргументы

Нет.

Описание

Метод; возвращает месяц (0 - январь, 1 - февраль, и т.д.) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getSeconds

Date > Date.getSeconds

Date.getSeconds

Синтаксис

myDate.getSeconds();

Аргументы

Нет.

Описание

Метод; возвращает количество секунд (целое от 0 до 59) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getTime

Date > Date.getTime

Date.getTime

Синтаксис

myDate.getTime();

Аргументы

Нет.

Описание

Метод; Возвращает количество миллисекунд (целое от 0 до 999), прошедших с 1 января 1970, для указанного объекта Date; глобальное время. Используйте этот метод для представления определенного момента времени в различных часовых поясах.

Player

Flash 5 или выше


Date.getTimezoneOffset

Date > Date.getTimezoneOffset

Date.getTimezoneOffset

Синтаксис

mydate.getTimezoneOffset();

Аргументы

Нет.

Описание

Метод; возвращает разницу в минутах между системным и глобальным временем.

Player

Flash 5 и выше.

Пример

Получаем разницу между летним временем в Сан-Франциско и гринвичским. Поправка на летнее время происходит, если метод был вызван именно в это время.

new Date().getTimezoneOffset();

Результат:

420 (7 hours * 60 minutes/hour = 420 minutes)


Date.getUTCDate

Date > Date.getUTCDate

Date.getUTCDate

Синтаксис

myDate.getUTCDate();

Аргументы

Нет.

Описание

Метод; возвращает день месяца указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getUTCDay

Date > Date.getUTCDay

Date.getUTCDay

Синтаксис

myDate.getUTCDate();

Аргументы

Нет.

Описание

Метод; возвращает день недели указанного объекта Date согласно глобальному времени.


Date.getUTCFullYear

Date > Date.getUTCFullYear

Date.getUTCFullYear

Синтаксис

myDate.getUTCFullYear();

Аргументы

Нет.

Описание

Метод; возвращает четырехзначное значение года указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getUTCHours

Date > Date.getUTCHours

Date.getUTCHours

Синтаксис

myDate.getUTCHours();

Аргументы

Нет.

Описание

Метод; возвращает час указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getUTCMilliseconds

Date > Date.getUTCMilliseconds

Date.getUTCMilliseconds

Синтаксис

myDate.getUTCMilliseconds();

Аргументы

Нет.

Описание

Метод; возвращает количество миллисекунд указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getUTCMinutes

Date > Date.getUTCMinutes

Date.getUTCMinutes

Синтаксис

myDate.getUTCMinutes();

Аргументы

Нет.

Описание

Метод; возвращает количество минут указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getUTCMonth

Date > Date.getUTCMonth

Date.getUTCMonth

Синтаксис

myDate.getUTCMonth();

Аргументы

Нет.

Описание

Метод; возвращает месяц указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getUTCSeconds

Date > Date.getUTCSeconds

Date.getUTCSeconds

Синтаксис

myDate.getUTCSeconds();

Аргументы

Нет.

Описание

Метод; возвращает количество секунд указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getYear

Date > Date.getYear

Date.getYear

Синтаксис

myDate.getYear();

Аргументы

Нет.

Описание

Метод; возвращает значение года указанного объекта Date согласно системному времени. Значение года представлено как "четырехзначный год" - 1900; например, год 2000 будет представлен как 100.

Player

Flash 5 или выше.


Date.setDate

Date > Date.setDate

Date.setDate

Синтаксис

myDate.setDate(date);

Аргументы

date Целое от 1 до 31.

Описание

Метод; выставляет день месяца объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.setFullYear

Date > Date.setFullYear

Date.setFullYear

Синтаксис

myDate.setFullYear(year [, month [, date]] );

Аргументы

year Четырехзначное число, обозначающее год; например, 99 - это не 1999 год, а 99 год.

month Целое от 0 (январь) до 11 (декабрь). Аргумент необязателен.

date Целое от 1 до 31. Аргумент необязателен.

Описание

Метод; выставляет полную дату объекта Date согласно системному времени. Если month и date определены, они также привязываются к системному времени.

Результаты вызовов getUTCDay и getDay могут быть изменены вызовом этой функции.

Player

Flash 5 или выше.


Date.setHours

Date > Date.setHours

Date.setHours

Синтаксис

myDate.setHours(hour);

Аргументы

hour Целое от 0 (полночь) до 23 (11 вечера).

Описание

Метод; выставляет час объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.setMilliseconds

Date > Date.setMilliseconds

Date.setMilliseconds

Синтаксис

myDate.setMilliseconds(millisecond);

Аргументы

millisecond Целое от 0 до 999.

Описание

Метод; выставляет количество миллисекунд объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.setMinutes

Date > Date.setMinutes

Date.setMinutes

Синтаксис

myDate.setMinutes(minute);

Аргументы

minute Целое от 0 до 59.

Описание

Метод; выставляет количество минут объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.setMonth

Date > Date.setMonth

Date.setMonth

Синтаксис

myDate.setMonth(month [, date ]);

Аргументы

month Целое от 0 (январь) до 11 (декабрь).

date Целое от 1 to 31. Необязательный аргумент.

Описание

Метод; выставляет месяц объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.setSeconds

Date > Date.setSeconds

Date.setSeconds

Синтаксис

myDate.setSeconds(second);

Аргументы

second Целое от 0 до 59.

Описание

Метод; выставляет количество секунд объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.setTime

Date > Date.setTime

Date.setTime

Синтаксис

myDate.setTime(millisecond);

Аргументы

millisecond Целое от 0 до 999.

Описание

Метод; выставляет дату указанного объекта Date в миллисекундах.

Player

Flash 5 или выше.


Date.setUTCDate

Date > Date.setUTCDate

Date.setUTCDate

Синтаксис

myDate.setUTCDate(date);

Аргументы

date Целое от 1 до 31.

Описание

Метод; выставляет дату указанного объекта Date согласно глобальному времени. Вызов этого метода не обновляет другие поля объекта Date, в отличие от getUTCDay и getDay методов, которые в соответствии с изменением выставляют другой день недели.

Player

Flash 5 или выше.


Date.setUTCFullYear

Date > Date.setUTCFullYear

Date.setUTCFullYear

Синтаксис

myDate.setUTCFullYear(year [, month [, date]]);

Аргументы

year Четырехзначный год, например 2000.

month Целое от 0 (январь) до 11 (декабрь); необязательный аргумент.

date Целое от 1 до 31; необязательный аргумент.

Описание

Метод; выставляет год указанного объекта Date (mydate) в глобальном времени.

Метод может также выставить месяц и дату объекта; метод не обновляет значений в других полях, однако вызов getUTCDay и getDay позволяет видеть измененные значения, если, например, поменялся день недели.

Player

Flash 5 или выше.


Date.setUTCHours

Date > Date.setUTCHours

Date.setUTCHours

Синтаксис

myDate.setUTCHours(hour [, minute [, second [, millisecond]]]));

Аргументы

hour Целое от 0 (полночь) до 23 (11 вечера).

minute Целое от 0 до 59; необязательный аргумент.

second Целое от 0 до 59; необязательный аргумент.

millisecond Целое от 0 до 999; необязательный аргумент.

Описание

Метод; выставляет час указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.setUTCMilliseconds

Date > Date.setUTCMilliseconds

Date.setUTCMilliseconds

Синтаксис

myDate.setUTCMilliseconds(millisecond);

Аргументы

millisecond Целое от 0 до 999.

Описание

Метод; выставляет миллисекунды указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.setUTCMinutes

Date > Date.setUTCMinutes

Date.setUTCMinutes

Синтаксис

myDate.setUTCMinutes(minute [, second [, millisecond]]));

Аргументы

minute Целое от 0 до 59.

second Целое от 0 до 59; необязательный аргумент.

millisecond Целое от 0 до 999; необязательный аргумент.

Описание

Метод; выставляет минуты указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.setUTCMonth

Date > Date.setUTCMonth

Date.setUTCMonth

Синтаксис

myDate.setUTCMonth(month [, date]);

Аргументы

month Целое от 0 (январь) до 11 (декабрь).

date Целое от 1 до 31; необязательный аргумент.

Описание

Метод; выставляет месяц и, если необходимо, день (дату), указанного объекта Date согласно глобальному времени. Метод не обновляет значений в других полях, однако вызов getUTCDay и getDay позволяет видеть измененные значения, если, например, поменялся день недели.

Player

Flash 5 или выше.


Date.setUTCSeconds

Date > Date.setUTCSeconds

Date.setUTCSeconds

Синтаксис

myDate.setUTCSeconds(second [, millisecond]));

Аргументы

second Целое от 0 до 59.

millisecond Целое от 0 до 999; необязательный аргумент.

Описание

Метод; выставляет секунды указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.setYear

Date > Date.setYear

Date.setYear

Синтаксис

myDate.setYear(year);

Аргументы

year Четырехзначный год, например, 2000.

Описание

Метод; выставляет год указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.toString

Date > Date.toString

Date.toString

Синтаксис

myDate.toString();

Аргументы

Нет.

Описание

Метод; возвращает строку, представляющую дату и время, содержащиеся в объекте Date.

Player

Flash 5 или выше.

Пример

Получаем в виде строчки информацию, содержащуюся в dateOfBirth:

var dateOfBirth = newDate(74, 7, 7, 18, 15);
trace (dateOfBirth.toString());

На выходе:

Wed Aug 7 18:15:00 GMT-0700 1974


Date.UTC

Date > Date.UTC

Date.UTC

Синтаксис

Date.UTC(year, month [, date [, hour [, minute [, second [, millisecond ]]]]]);

Аргументы

year Четырехзначный номер, например, 2000.

month Целое от 0 (январь) до 11 (декабрь).

date Целое от 1 до 31; необязательный аргумент.

hour Целое от 0 (полночь) до 23 (11 вечера).

minute Целое от 0 до 59; необязательный аргумент.

second Целое от 0 до 59; необязательный аргумент.

millisecond Целое от 0 до 999; необязательный аргумент.

Описание

Метод; возвращает количество миллисекунд, прошедших с 00.00 1 января 1970 г. по глобальному времени до заданного времени. Это статичный метод, активизирующийся через конструктор объекта Date, а не через данный объект Date. Метод позволяет создавать объект Date на основании глобального времени, в то время как конструктор объекта Date основывается на системном.

Player

Flash 5 или выше.

Пример

Создаем новый объект Date gary_birthday, определенным в глобальном времени:

gary_birthday = new Date(Date.UTC(1974, 7, 8));


delete

De-I > delete

delete

Синтаксис

delete (reference);

Аргументы

reference имя переменной или объекта, подлежащего удалению.

Описание

Оператор; уничтожает объект или переменную, имя которой указывает reference, и возвращает true если объект был успешно удален; в противном случае возвращает false. Этот оператор полезен для высвобождения памяти, используемой скриптами, хотя, delete - оператор, который обычно применяется в формулировке:

delete x;

оператор delete может не сработать и возвратить false если reference не существует, или не может быть удален. Предопределенные функции и объекты, также как и переменные, объявленные с помощью var, не могут быть удалены.

Версия плугина

Flash 5 или более новый.

Примеры

В следующих примерах создается объект, используется, а затем удаляется за ненадобностью:

account = new Object();	account.name = 'Jon';	account.balance = 10000;	...	delete account;

В следующем примере удаляется свойство (property) объекта:

// создаем новый объект "account"account = new Object();// назначаем свойство name объекту account 	account.name = 'Jon'; // удаляем свойствоdelete account.name;

Еще один пример удаления свойства объекта:

// создаем массив длиной 0array = new Array(); // теперь его длина - 1	array[0] = "abc";// добавляем еще один элемент - длина - 2	array[1] = "def"; // теперь - 3	array[2] = "ghi";// удаляем array[2] но длина массива не меняется,	delete array[2];

Следующие примеры демонстрируют действие delete на объектные ссылки:

// создаем объект, присваиваем переменной ref1 значение ссылки на негоref1 = new Object();ref1.name = "Jody";// копируем ссылочную переменную, а затем удаляем ref1ref2 = ref1;delete ref1;

Если бы ref1 не была бы скопирована в ref2, то и объект был бы удален, так как на него не осталось бы ни одной ссылки. Когда же мы удалим ref2, больше не останется ссылок на объект, и он будет удален, так как на него не будет ссылаться ни одна переменная.

См. также

var


do... while

De-I > do... while

do... while

Синтаксис

do {statement;} while (condition);

Аргументы

condition Условие для продолжения итерирования.

statement Этот блок выполняется до тех пор, пока результат вычисления condition равен true.

Описание

Оператор; выполняет statements, потом вычисляет condition. Так - до тех пор, пока condition возвращает true.

Версия плугина

Flash 4 или более новый.

См. также


_droptarget

De-I > _droptarget

_droptarget

Синтаксис

draggableInstanceName._droptarget

Аргументы

draggableInstanceName Имя экземпляра мувика, который являлся target'ом команды startDrag.

Описание

Свойство (только для чтения); возвращает абсолютный путь (используя "/" в качестве разделителей) экземпляра мувика, на который draggableInstanceName был, собственно, положен (dropped). Свойство _droptarget всегда возвращает путь, начинающийся с /. Чтобы превратить _droptarget в ссылку на объект, необходимо использовать eval, который возвратит необходимую ссылку.

Версия плугина

Flash 4 или более новый.

Примеры

Следующий пример получает свойство _droptarget экземпляра мувика garbage и использует eval чтобы получить путь с "." в качестве разделителей. Ссылка на garbage затем сравнивается с экземпляром мувика trash. Если они равны, то garbage делаем невидимым (Visibility -> false). Если они не равны, то восстанавливаем изначальное положение garbage.

if (eval(garbage._droptarget) == _root.trash) {	garbage._visible = false;} else {	garbage._x = x_pos;	garbage._y = y_pos;}

The variables x_pos and y_pos are set on frame 1 of the movie with the following script:

x_pos = garbage._x;y_pos = garbage._y;

См. также

startDrag


duplicateMovieClip

De-I > duplicateMovieClip

duplicateMovieClip

Синтаксис

duplicateMovieClip(target, newname, depth);

Аргументы

target Путь мувика, который необходимо размножить.

newname Уникальный идентификатор для нового экземпляра мувика.

depth Глубина для нового мувика. Это - порядковый номер, который определяет, как мувики перекрывают друг-друга. Первый мувик, который вы создали имеет глубину - 0, дальше - больше. Вы должны присвоить каждому новому мувику уникальную глубину, так как если вы присвоите уже имеющуюся, то новый мувик заменит старый.
Комментарий: собственно, это иногда и надо.

Описание

Команда; создает экземпляр муви-клипа во время проигрывания фильма. Дублирование всегда начинается с кадра номер 1, вне зависимости от того, на каком кадре был клип. Переменные, содержащиеся в родительском мувике не копируются в дублируемый. Если удаляется родительский мувик, то дублированный - тоже удаляется. Используйте команду или метод removeMovieClip чтобы удалить экземпляр муви-клипа, созданного командой duplicateMovieClip.

Версия плугина

Flash 4 или более новый.

Примеры

Следующие строчки множат flower десять раз. Переменная i используется для того, чтобы создать уникальное имя и положить новый мувик на уникальную глубину.

on(release) {	amount = 10;	while(amount>0) {		duplicateMovieClip (_root.flower, "mc" + i, i);		setProperty("mc" + i, _x, random(275));		setProperty("mc" + i, _y, random(275));		setProperty("mc" + i, _alpha, random(275));		setProperty("mc" + i, _xscale, random(50));		setProperty("mc" + i, _yscale, random(50));		i = i + 1;		amount = amount-1;	}}

См. также


else

De-I > else

else

Синтаксис

else {statement(s)};

Аргументы

statement(s) Альтернативная серия команд, которая выполняется, если условие (condition), указанное в if - false.

Описание

Команда; указывает те команды, которые необходимо выполнить, если условие в if является ложным (возвращает false).
Примечание: На самом деле, конструкция if-else дополнена еще одним компонентом, получается if-else if-else. Операторы в else выполняются только в том случае, если неверны все условия, как в if, так и в else if.

Версия плугина

Flash 4 или более новый.

См. также

if


eq (equal—string specific)

De-I > eq (equal—string specific)

eq (equal—string specific)

Синтаксис

expression1 eq expression2

Аргументы

expression1, expression2 Числа, строки или переменные.

Описание

Оператор сравнения; сравнивает два выражения на равенство и возвращает true, если expression1 равно expression2; иначе возвращает false.

Версия плугина

Flash 1 или более новый. Этот оператор является устаревшим в Flash 5; рекомендуется использование нового оператора == (оператор равенства).

См. также

== (equality)


escape

De-I > escape

escape

Синтаксис

escape(expression);

Аргументы

expression Выражение, которое надо перевести в строку и преобразовать в формат для передачи в URL.

Описание

Функция; преобразует аргумент в строку и переводит ее в формат URL-encoded, где все знако-числовые значения кодируются шестнадцатеричными %-последовательностями.

Версия плугина

Flash 5 или более новый.

Примеры

escape("Hello{[World]}");

Результат будет следующим:

Hello%7B%5BWorld%5D%7D

См. также

unescape


eval

De-I > eval

eval

Синтаксис

eval(expression);

Аргументы

expression Строка, содержащая имя переменной, свойства, объекта или муви-клипа, ссылку на который необходимо получить.

Описание

Функция; предоставляет доступ к переменным, свойствам, объектам и мувикам по их имени. Если expression - это переменная или свойство, будет возвращено значение переменной или свойства. Если же expression - объект или мувик, возвращается ссылка на него. Если элемент, имя которого указано в expression не найден, возвращается неопределенное значение (undefined).

В Flash 4, функция eval использовалась для эмуляции массивов. В Flash 5 рекомендуется вместо этого использовать объект Array.

Note: Действие ActionScript eval - не то же самое, что функция eval в JavaScript, и не может быть использована для вычисления выражений.

Версия плугина

Flash 5 или более новый - для полной работоспособности. Вы можете использовать eval, когда экспортируете в Flash 4 Player, но Вы должны использовать "/" - запись и можете получить доступ таким образом только к переменным, но не к свойствам или объектам.

Примеры

Следующий пример использует eval, чтобы определить значение переменной x, и приравнять его к значению переменной y:

x = 3; y = eval("x");

Этот пример использует eval, чтобы сослаться на объект с именем Ball:

eval("_root.Ball");

См. также

Array (object)


evaluate

De-I > evaluate

evaluate

Синтаксис

statement;

Аргументы

None.

Описание

Действие; создает новую пустую строку, и вставляет ; для того, чтобы можно было ввести свой код в строку Expression панели Actions. Действие evaluate позволяет вызывать свои функции пользователю, который редактирует скрипт в режиме Normal Mode.

Версия плугина

Flash 5 или более новый.


_focusrect

De-I > _focusrect

_focusrect

Синтаксис

_focusrect = Boolean;

Аргументы

Boolean true или false.

Описание

Свойство (глобальное); Указывает, показывать ли вокруг активной кнопки желтенький прямоугольничек. Значение по умолчанию - true (не ноль) - указывает, что надо прорисовывать его вокруг активной кнопки или текстового поля и перемещать его, когда пользователь нажимает кнопку. Укажите false, чтобы показывать активное состояние только кадром кнопки "over" (если вообще он определен) по мере того, как пользователь перемещается по странице..

Версия плугина

Flash 4 или более новый.


for

De-I > for

for

Синтаксис

for(init; condition; next); {statement; }

Аргументы

init Выражение, которое надо вычислить перед началом цикла, обычно - присваивание (см. пример). Также возможно var - выражение в качестве этого аргумента.

condition Выражение, которое возвращает true или false. Сondition вычисляется перед каждой итерацией. Цикл оканчивается, когда возвращается false.

next Выражение, которое надо вычислять при каждой итерации в цикле. Обычно представляет собой оператор инкремента ++ (increment) или декремента -- (decrement).

statement Код, который надо выполнять в цикле.

Описание

Действие; циклическая конструкция, в которой сначала вычисляется выражение init (initialize), а потом начинается цикл, на каждом шаге которого проверяется, возвращает ли condition значение true и, если это так, то выполняется statement. Иначе цикл завершается

Некоторые свойства не могут быть перечислены с помощью команд for или for..in. Например, встроенные методы объекта Array (Array.sort и Array.reverse) не включены в перечисление объекта Array (массив), как и такие свойства мувика, как _x и _y, .

Версия плугина

Flash 5 или более новый.

Примеры

Следующие примеры используют for, чтобы добавить элементы в массив:

for(i=0; i<10; i++) {array [i] = (i + 5)*10;}

Returns the following array:

[50, 60, 70, 80, 90, 100, 110, 120, 130, 140]

А здесь цикл нужен для того, чтобы некоторое действие повторить несколько раз. В данном случае - сложить числа от одного до 100:

var sum = 0;	for (var i=1; i<=100; i++) {		sum = sum + i;	}

См. также


for..in

De-I > for..in

for..in

Синтаксис

for(variableiterant in object){statement; }

Аргументы

variableiterant Имя переменной, которая выступает в роли итератора, ей последовательно присваивается каждое свойство объекта или элемента массива.

object Имя объекта, который подлежит итерированию.

statement Выражение, которое необходимо выполнять каждую итерацию.

Описание

Действие; циклически обрабатывает свойства объекта или элементы массива, выполняя для каждого из них statement.

Некоторые свойства не могут быть перечислены с помощью команд for или for..in. Например, встроенные методы объекта Array (Array.sort и Array.reverse) не включены в перечисление объекта Array (массив), как и такие свойства мувика, как _x и _y, .

Цикл for...in итерирует по свойствам объекта, объявленным в прототипе. Итерирование по дочернему прототипу ведет за собой и итерирование по родительскому.

Версия плугина

Flash 5 или более новый.

Примеры

Далее представлены примеры использования for..in для итерирования по свойствам объекта:

myObject = { name:'Tara', age:27, city:'San Francisco' };for (name in myObject) {	trace ("myObject." + name + " = " + myObject[name]);}

The output of this Примеры is as follows:

myObject.name = TaramyObject.age = 27myObject.city = San Francisco

The following is an Примеры of using the typeof operator with for..in to iterate over a particular type of child:

for (name in myMovieClip) {	if (typeof (myMovieClip[name]) = "movieclip") {		trace ("I have a movie clip child named " + name);	}}

Следующий пример перечисляет дочерние объекты мувика и делает им всем и каждому GotoAndStop(2), то есть заставляет их перейти на 2 кадр. Мувик RadioButtonGroup - родительский клип с несколькими дочерними: _RedRadioButton_, _GreenRadioButton_ and _BlueRadioButton.

for (var name in RadioButtonGroup) {	RadioButtonGroup[name].gotoAndStop(2);}


_framesloaded

De-I > _framesloaded

_framesloaded

Синтаксис

instancename._framesloaded

Аргументы

instancename Имя мувика, который необходимо обработать.

Описание

Свойство (только для чтения); количество кадров мувика, которые были загружены с сервера. Это свойство полезно для определения, загружен ли определенный кадр и все кадры перед ним и, следовательно, могут ли они быть проиграны. Полезно для слежения за процессом загрузки больших мувиков. Например, можно выводить на экран количество кадров, которое уже загружено. (Простейший и не очень полезный прелоадер)

Версия плугина

Flash 4 или более новый.

Примеры

Этот пример показывает, как скоординировать количество кадров, которое уже загружено с моментом его запуска:

if (_framesloaded >= _totalframes) {gotoAndPlay ("Scene 1", "start");} else {setProperty ("_root.loader", _xscale, (_framesloaded/_totalframes)*100);}


fscommand

De-I > fscommand

fscommand

Синтаксис

fscommand(command, arguments);

Аргументы

command Строка, которая передается для использования приложению, запустившему муви-клип.

arguments Строка, которая передается для использования приложению, запустившему муви-клип.

Описание

Действие; позволяет муви-клипу Flash передавать данные программе, которая запустила этот клип. В браузере fscommand вызывает функцию на JavaScript с именем moviename_Dofscommand, находящуюся на странице, содержащую муви-клип. Здесь moviename - имя клипа, которое присваивается в атрибуте NAME тэга EMBED, или свойства ID тэга OBJECT. Например, если присвоено имя theMovie, функция JavaScript должна называться theMovie_Dofscommand.

Версия плугина

Flash 3 или более новый.


function

De-I > function

function

Синтаксис

function functionname ([argument0, argument1,...argumentN]){statement(s)}function ([argument0, argument1,...argumentN]){statement(s)}

Аргументы

functionname Название новой функции.

argument строки, числа или объекты в количестве, большем, либо равным нулю, которые передаются функции.

statements Ноль или более нуля операторов ActionScript, которые являются телом функции (function).

Описание

Действие; определяет набор операторов, которые вы определили для выполнения определенной задачи. Вы можете декларировать (declare), или определить (define), функцию в том же месте, где вы ее вызываете, или в любом другом месте муви-клипа. При определении функции, вы можете также определить ее аргументы. Туда можно поместить при вызове некоторые значения, которыми оперирует функция при ее вызове. Каждый раз, когда заново вызывается функция, можно вызывать ее с другими аргументами.

Используйте оператор return в теле функции statement(s), чтобы заставить функцию возвратить какое-либо значение.

Вариант использования номер раз: Определяем function с определенными functionname, arguments, и statement(s). Во время вызова имени функции, на самом деле вызывается описание этой функции с нужными параметрами. Разрешен вызов функции до того, как она определена в Action list, то есть функция может быть объявлена после того, как к ней обратились.

Вариант использования номер два: Создаем безыменную функцию и возвращаем ее. Такой вариант используется в выражениях, кроме того, он частично полезен при создании методов в объектах.

Версия плугина

Flash 5 или более новый.

Примеры

(Вариант 1) В следующем примере создается функция sqr, которая принимает один аргумент (число), возвращая его квадрат. Обратите внимание, что в этом скрипте объявление функции стоит после ее вызова.

y=sqr(3);function sqr(x) {return x*x;}

(Вариант 2) Следующий пример создает объект Окружность (Circle):

function Circle(radius) { this.radius = radius;}

А здесь создается безымянная функция, которая считает площадь круга и присоединяет ее значение, как метод, объекту Окружность (Circle):

Circle.prototype.area = function () {return Math.PI * this.radius * this.radius}


ge (greater than или equal to—string specific)

De-I > ge (greater than или equal to—string specific)

ge (больше или равно, характерно для строк)

Синтаксис

expression1 ge expression2

Аргументы

expression1, expression2 Числа, строки или переменные.

Описание

Оператор (сравнение); сравнивает expression1 и expression2 и возвращает true, если expression1 больше или равен expression2; иначе возвращает false.

Версия плугина

Flash 4 или более новый. Этот оператор является устаревшим в Flash 5; рекомендуется использование нового оператора >=.

См. также

>= (больше либо равно)


getProperty

De-I > getProperty

getProperty

Синтаксис

getProperty(instancename , property);

Аргументы

instancename Имя экземпляра мувика, свойство которого необходимо получить.

property Имя свойства мувика, такое, как координата x или y.

Описание

Функция; возвращает значение указанного свойства (property) указанного мувика.

Версия плугина

Flash 4 или более новый.

Примеры

Здесь мы получаем горизонтальную координату (_x) для мувика myMovie:

getProperty(_root.myMovie_item._x);


getTimer

De-I > getTimer

getTimer

Синтаксис

getTimer();

Аргументы

Нет.

Описание

Функция; возвращает количество миллисекунд, прошедших с момента старта муви-клипа.

Версия плугина

Flash 4 или более новый.


getURL

De-I > getURL

getURL

Синтаксис

getURL(url [, window [, variables]]);

Аргументы

url Адрес (URL), с которого необходимо получить документ. Должен принадлежать одному домену вместе с фильмом.

window Необязательный аргумент, определяющий окно или фрейм (frame) в HTML, куда должен быть помещен документ. Укажите здесь имя окна/фрейма, либо укажите одно из зарезервированных слов:

_self указывает на то же окно/тот же фрейм, откуда вызывается функция.
_blank указывает на новое окно.
_parent указывает на родительское по отношению к текущему окно.
_top указывает на самый верхний фрейм в окне.

variables Необязательный аргумент, указывающий на метод, которым надо пересылать переменные. Если переменные передавать не надо, пропустите этот аргумент, иначе укажите, использовать метод GET или POST. GET добавляет имена переменных вместе со значениями в конец URL, и обычно используется для небольшого количества (и небольшого суммарного объема имен+значений) переменных. POST посылает переменные в отдельном заголовке HTTP и используется для передачи длинных строк или больших по объему данных.

Описание

Действие; загружает документ с указанного адреса (URL) в окно, или передает переменные другому приложению по URL. Чтобы это действие сработало, убедитесь в наличии целевого документа. Чтобы использовать абсолютные URL (например, http://www.myserver.com), вам необходимо активное сетевое соединение.

Версия плугина

Flash 2 или более новый. Выбор типа метода доступен, начиная с 4 версии.

Примеры

Этот пример загружает документ с указанным URL в новое окно браузера. Действию getURL указана переменная incomingAd в качестве параметра url, поэтому можно менять адрес документа, который загружается, не редактируя Флэш клип. Значение переменной incomingAd берется Флэшом ранее из файла с помощью действия loadVariables.

on(release) {	getURL(incomingAd, "_blank");}

См. также


getVersion

De-I > getVersion

getVersion

Синтаксис

getVersion();

Аргументы

Нет.

Описание

Функция; возвращает строку, в которой содержится версия плейера и информация о платформе.

Эта функция не работает в режиме test-movie и возвращает значение только для версий 5 и выше.

Примеры

Здесь показан вариант строчки, возвращаемой функцией getVersion:

WIN 5,0,17,0

Она означает, что платформа - Windows, старшая версия плейера - 5, младшая версия - 17(5.0r17).

Версия плугина

Flash 5 или более новый.


gotoAndPlay

De-I > gotoAndPlay

gotoAndPlay

Синтаксис

gotoAndPlay(scene, frame);

Аргументы

scene Сцена, к которой применяется действие.

frame Кадр, с которого начинать проигрывание.

Описание

Действие; начинает проигрывание в указанной сцене с кадра frame. Если не указана сцена, считается, что указана текущая сцена.

Версия плугина

Flash 2 или более новый.

Примеры

Когда пользователь нажимает на кнопку, которой в действиях присвоено действие gotoAndPlay, начинается проигрывание с 16 кадра.

on(release) {	gotoAndPlay(16);}


gotoAndStop

De-I > gotoAndStop

gotoAndStop

Синтаксис

gotoAndPlay(scene, frame);

Аргументы

scene Сцена, к которой применяется действие.

frame Кадр, с которого начинать проигрывание.

Описание

Действие; начинает проигрывание в указанной сцене с кадра frame. Если не указана сцена, считается, что указана текущая сцена.

Версия плугина

Flash 2 или более новый.

Синтаксис

gotoAndStop(scene, frame);

Аргументы

scene Сцена, к которой применяется действие.

frame Кадр, который установить в качестве текущего.

Описание

Действие; устанавливает текущим указанный кадр. Если не указана сцена, считается, что указана текущая сцена. Проигрывание прекращается.

Версия плугина

Flash 2 или более новый.

Примеры

Когда пользователь нажимает на кнопку, которой в действиях присвоено действие gotoAndStop, активным устанавливается кадр номер 5 и клип прекращает проигрывание.

on(release) {	gotoAndStop(5);}


gt (greater than —string specific)

De-I > gt (greater than —string specific)

gt (greater than —string specific)

Синтаксис

expression1 gt expression2

Аргументы

expression1, expression2 Числа, строки или переменные.

Описание

Оператор (сравнение); сравнивает expression1 и expression2 и возвращает true если expression1 больше, чем expression2; иначе возвращает false.

Версия плугина

Flash 4 или более новый. Этот оператор является устаревшим в Flash 5; рекомендуется использование нового оператора >=.

См. также

> (greater than)


_height

De-I > _height

_height

Синтаксис

instancename._heightinstancename._height = value;

Аргументы

instancename Экземпляр мувика, для которого необходимо получить или изменить свойство _height (высота).

value Целое число, указывающее высоту мувика в пикселах.

Описание

Свойство; с его помощью можно получить или изменить высоту места, занимаемого содержимым мувика. В предыдущей версии высота и ширина ( _height и _width) были только читаемыми свойствами, их нельзя было менять, теперь - во Флэше 5 это можно делать.

Версия плугина

Flash 4 или более новый.

Примеры

В этом примере изменяются высота и ширина клипа, когда на нем кликают мышкой:

onClipEvent(mouseDown) {	_width=200;	_height=200;}


_highquality

De-I > _highquality

_highquality

Синтаксис

_highquality = value;

Аргументы

value Уровень сглаживания, который применяется к фильму. Укажите 2 (BEST), чтобы получить максимальное качество сглаживания, 1 (high quality) если хотите, чтобы битмапки (растровые картинки) сглаживались в случае, если нет анимации. 0 (low quality) - чтобы предотвратить сглаживание.

Описание

Свойство (глобальное); указывает качество сглаживания, применяемого к фильму.

Версия плугина

Flash 4 или более новый.

См. также


if

De-I > if

if

Синтаксис

if(condition) {statements;}

Аргументы

condition Выражение, которое возвращает true или false. Например, if(name == "Erica"), смотрит переменную с именем name и сравнивает ее значение со строкой "Erica."

statements Код, который должен выполняться, если значение condition - true.

Описание

Действие; вычисляет condition, чтобы определить следующее действие. Если значение condition - true, Flash исполняет statements. Используйте if, чтобы создать ветвление в ваших скриптах.

Версия плугина

Flash 4 или более новый.

См. также


ifFrameLoaded

De-I > ifFrameLoaded

ifFrameLoaded

Синтаксис

ifFrameLoaded(scene, frame) {statement;}ifFrameLoaded(frame) {statement;}

Аргументы

scene Опрашиваемая сцена.

frame Номер кадра или метка кадра, который необходимо загрузить перед тем, как исполнять statement.

Описание

Действие; проверяет, доступно ли содержимое указанного кадра локально (скачано ли уже?). Используйте для создания прелоадера, то есть небольшой анимации, пока загружается остальная часть фильма. Разница между использованием _framesloaded и ifFrameLoaded в том, что _framesloaded позволяет добавить if, или else, в то время, как ifFrameLoaded позволяет указать количество кадров в одном простом выражении.

Версия плугина

Flash 3 или более новый. Действие ifFrameLoaded устарело в Flash 5; используйте вместо него _framesloaded.

См. также

_framesloaded


#include

De-I > #include

#include

Синтаксис

#include "filename.as";

Аргументы

filename.as Имя включаемого файла; .as - рекомендованное разрешение файла.

Описание

Действие; включает содержимое файла, во время того, как клип тестируется, публикуется или экспортируется. Действие #include вызывается, когда вы тестируете, публикуете или экспортируете клип. Действие #include проверяется при проверке синтаксиса.

Версия плугина

N/A


Infinity

De-I > Infinity

Infinity

Синтаксис

Infinity

Аргументы

None.

Описание

Глобальная переменная; предопределенная для значения бесконечности ECMA-262

Версия плугина

Flash 5 или более новый.


int

De-I > int

int

Синтаксис

int(value);

Аргументы

value число, которое надо округлить.

Описание

Функция; округляет десятичное число до ближайшего целого.

Версия плугина

Flash 4 или более новый. Эта функция устарела в Flash 5; вместо нее используйте Math.floor.

См. также

Math.floor


isFinite

De-I > isFinite

isFinite

Синтаксис

isFinite(expression);

Аргументы

expression Булево выражение, переменная или другое выражение, которое необходимо проверить.

Описание

Глобальная функция; вычисляет аргумент и возвращает true, если это конечное число, и false, если результат бесконечен (плюс или минус бесконечность). Обычно бесконечность возникает при делении на 0.

Версия плугина

Flash 5 или более новый.

Примеры

Это примеры вызовов isFinite:

isFinite(56) возвращает true

isFinite(Number.POSITIVE_INFINITY) возвращает false

isNaN(Number.POSITIVE_INFINITY) возвращает false


isNaN

De-I > isNaN

isNaN

Синтаксис

isNaN(expression);

Аргументы

expression Булево выражение, переменная или другое выражение, которое необходимо проверить.

Описание

Глобальная функция; вычисляет аргумент и возвращает true, если это число, и false, если результат не является правильным числом (строка, число с допущенными ошибками).

Версия плугина

Flash 5 или более новый.

Примеры

Примеры применения isNan:

isNan("Tree") возвращает true

isNan(56) возвращает false

isNaN(Number.POSITIVE_INFINITY) возвращает false


Key (object)

K-L > Key (object)

Key (объект)

Объект Key является объектом верхнего уровня, к которому можно обращаться без использования конструктора. Методы этого объекта полезны для построения управляемого с клавиатуры интерфейса. Свойства объекта Key - константы, представляющие коды клавиш клавиатуры, обычно используемые для управления в играх. Смотри приложение Б (Appendix B), "Клавиши клавиатуры и их коды" для получения полного перечня значений кодов.

Примеры

onClipEvent (enterFrame) {	if(Key.isDown(Key.RIGHT)) {		setProperty ("", _x, _x+10);	}}oronClipEvent (enterFrame) {	if(Key.isDown(39)) {		setProperty("", _x, _x+10);	}}

Обзор методов для объекта Key
Метод | Описание
getAscii; | Возвращает ASCII-код последней нажатой клавиши.
getCode; | Возвращает виртуальный код последней нажатой клавиши.
isDown; | Возвращает true, если нажата клавиша, указанная в качестве аргумента.
isToggled; | Возвращает true, если активированы клавиши Num Lock или Caps Lock.

Обзор свойств для объекта Key

Все свойства объекта Key - константы.
Property | Описание
BACKSPACE | Константа, значение которой равно коду клавиши Backspace (9).
CAPSLOCK | Константа, значение которой равно коду клавиши Caps Lock (20).
CONTROL | Константа, значение которой равно коду клавиши Control (17).
DELETEKEY | Константа, значение которой равно коду клавиши Delete (46).
DOWN | Константа, значение которой равно коду клавиши Down Arrow (40).
END | Константа, значение которой равно коду клавиши End (35).
ENTER | Константа, значение которой равно коду клавиши Enter (13).
ESCAPE | Константа, значение которой равно коду клавиши Escape (27).
HOME | Константа, значение которой равно коду клавиши Home (36).
INSERT | Константа, значение которой равно коду клавиши Insert (45).
LEFT | Константа, значение которой равно коду клавиши Left Arrow (37).
PGDN | Константа, значение которой равно коду клавиши Page Down (34).
PGUP | Константа, значение которой равно коду клавиши Page Up (33).
RIGHT | Константа, значение которой равно коду клавиши Right Arrow (39).
SHIFT | Константа, значение которой равно коду клавиши Shift (16).
SPACE | Константа, значение которой равно коду клавиши Spacebar (32).
TAB | Константа, значение которой равно коду клавиши Tab (9).
UP | Константа, значение которой равно коду клавиши Up Arrow (38).


Key.BACKSPACE

K-L > Key.BACKSPACE

Key.BACKSPACE

Синтаксис

Key.BACKSPACE

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Backspace (9).

Player

Flash 5 или более новый.


Key.CAPSLOCK

K-L > Key.CAPSLOCK

Key.CAPSLOCK

Синтаксис

Key.CAPSLOCK

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Caps Lock (20).

Player

Flash 5 или более новый.


Key.CONTROL

K-L > Key.CONTROL

Key.CONTROL

Синтаксис

Key.CONTROL

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Control (17).

Player

Flash 5 или более новый.


Key.DELETEKEY

K-L > Key.DELETEKEY

Key.DELETEKEY

Синтаксис

Key.DELETEKEY

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Delete (46).

Player

Flash 5 или более новый.


Key.DOWN

K-L > Key.DOWN

Key.DOWN

Синтаксис

Key.DOWN

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Down Arrow (40).

Player

Flash 5 или более новый.


Key.END

K-L > Key.END

Key.END

Синтаксис

Key.END

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши End (35).

Player

Flash 5 или более новый.


Key.ENTER

K-L > Key.ENTER

Key.ENTER

Синтаксис

Key.ENTER

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Enter (13).

Player

Flash 5 или более новый.


Key.ESCAPE

K-L > Key.ESCAPE

Key.ESCAPE

Синтаксис

Key.ESCAPE

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Escape (27).

Player

Flash 5 или более новый.


Key.getAscii

K-L > Key.getAscii

Key.getAscii

Синтаксис

Key.getAscii();

Аргументы

Нет.

Описание

Метод; возвращает ASCII код последней нажатой или отпущенной клавиши.

Player

Flash 5 или более новый.


Key.getCode

K-L > Key.getCode

Key.getCode

Синтаксис

Key.getCode();

Аргументы

Нет.

Описание

Метод; возвращает код последней нажатой клавиши. Используйте информацию из приложения Б (Appendix B) для того, чтобы определить, какой клавише назначен полученый код на стандартной клавиатуре.

Player

Flash 5 или более новый.


Key.HOME

K-L > Key.HOME

Key.HOME

Синтаксис

Key.HOME

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Home (36).

Player

Flash 5 или более новый.


Key.INSERT

K-L > Key.INSERT

Key.INSERT

Синтаксис

Key.INSERT

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Insert(45).

Player

Flash 5 или более новый.


Key.isDown

K-L > Key.isDown

Key.isDown

Синтаксис

Key.isDown(keycode);

Аргументы

keycode Код, присвоенный либо определенной клавише, либо одно из свойств объекта Key, ассоциированное с клавишей. Приложение Б (Appendix B), "Клавиши клавиатуры и их коды" дает полный список всех кодов на стандартной клавиатуре.

Описание

Метод; возвращает true, если нажата клавиша keycode. На компьютерах Macintosh, коды клавиш Caps Lock и Num Lock идентичны.

Player

Flash 5 или более новый.


Key.isToggled

K-L > Key.isToggled

Key.isToggled

Синтаксис

Key.isToggled(keycode)

Аргументы

keycode код Caps Lock (20) или Num Lock (144).

Описание

Метод, возвращает true, если активизирована Caps Lock или Num Lock. На компьютерах Macintosh коды этих двух клавиш идентичны.

Player

Flash 5 или более новый.


Key.LEFT

K-L > Key.LEFT

Key.LEFT

x20949 | IDS_ACTIONHELP_KEY_LEFT2, Key.LEFT

Синтаксис

Key.LEFT

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Left Arrow (37).

Player

Flash 5 или более новый.


Key.PGDN

K-L > Key.PGDN

Key.PGDN

Синтаксис

Key.PGDN

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Page Down (34).

Player

Flash 5 или более новый.


Key.PGUP

K-L > Key.PGUP

Key.PGUP

Синтаксис

Key.PGUP

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Page Up (33).

Player

Flash 5 или более новый.


Key.RIGHT

K-L > Key.RIGHT

Key.RIGHT

Синтаксис

Key.RIGHT

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Right Arrow (39).

Player

Flash 5 или более новый.


Key.SHIFT

K-L > Key.SHIFT

Key.SHIFT

Синтаксис

Key.SHIFT

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Shift (16).

Player

Flash 5 или более новый.


Key.SPACE

K-L > Key.SPACE

Key.SPACE

Синтаксис

Key.SPACE

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Spacebar (32).

Player

Flash 5 или более новый.


Key.TAB

K-L > Key.TAB

Key.TAB

Синтаксис

Key.TAB

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Tab (9).

Player

Flash 5 или более новый.


Key.UP

K-L > Key.UP

Key.UP

Синтаксис

Key.UP

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Up Arrow (38).

Player

Flash 5 или более новый.


le (less than or equal to — string specific)

K-L > le (меньше или равно — строковой оператор)

le (меньше или равно — строковой оператор)

Синтаксис

expression1 le expression2

Аргументы

expression1,expression2 Числа, строки или переменные.

Описание

Оператор (сравнения); сравнивает expression1 с expression2 и возвращает true, если expression1 меньше чем или равно expression2, в противном случае возвращает false.

Player

Flash 4 или более новый. Этот оператор считается устаревшим в Flash 5; рекомендовано использование нового оператора <= .

См. также

<= (не больше)


length

K-L > length

length

Синтаксис

length(expression);length(variable);

Аргументы

expression Любая строка.

variable Имя переменной.

Описание

Строковая функция; возвращает длину строки, указанной в качестве аргумента.

Player

Flash 4 или более новый. Эта функция, так же, как и другие строковые функции считаются устаревшими в Flash 5. Рекомендуется использовать метод length объекта String для выполнения операций со строками.

Примеры

Следующий примеры возвращает длину строки Hello:

length("Hello");

Результат будет равным 5.

См. также


_level

K-L > _level

_level

Синтаксис

_levelN;

Аргументы

N Неотрицательное целое, обозначающее уровень (level). По умолчанию, _level равно 0, что соответствует базовому мувику.

Описание

Свойство; возвращает ссылку на корневой (root) мувиклип в тайм-лайн (Timeline) levelN. Перед тем, как указывать мувики в свойстве _level, вы должны загрузить их с помощью команды loadMovie.

Во Flash Player каждому мувику присваевается число в соответствии с порядком, в котором они загружены. Мувику, который загружен первым на нижний уровень - 0. Этот мувик задает для всех единый фреймрейт (frame rate - кол-во кадров в секунду), цвет фона, и размер окна. Другие мувиклипы подгружаеются на уровни выше нулевого, с номерами больше 0.

Player

Flash 4 или более новый.

Примеры

Следующий пример останавливает воспроизведение клипа на нулевом уровне:

_level0.stop();

Этот пример переводит воспроизведение клипа на 4-м уровне на пятый кадр, мувиклип на 4-м уровне должен быть предварительно загружен с помощью команды loadMovie:

_level4.gotoAndStop(5);

См. также


loadMovie

K-L > loadMovie

loadMovie

Синтаксис

loadMovie(url [,location/target, variables]]);

Аргументы

url Абсолютный или относительный адрес, с которого будет загружаться SWF файл. При подгрузке в сети, файл должен находиться в том же поддомене, что и исходный клип. В случае локального использования Flash Player и тестирования мувика из Flash-редактора, все подгружаемые файлы должны находиться в том же каталоге, имена файлов не должны содержать имен дисков или каталогов 1.

target Необязательный аргумент, указывающий, какой муви-клип будет заменен вновь загруженным. Новый мувик наследует положение, свойства поворота и масштабирования. Если target такое же, как и location (level), то необязательно указывать оба параметра.

location Необязательный аргумент, указывающий, уровень, куда загружается мувик. Новый мувик наследует положение, свойства поворота и масштабирования. Чтобы добавить мувик, просто укажите здесь номер еще не занятого уровня. Чтобы заменить какой-то мувик, занимающий целый уровень, укажите его. Чтобы заменить главный мувик и выгрузить все уровни, укажите здесь 0. Мувик на уровне 0 указывает для всех остальных скорость, размер экрана и цвет фона.

variables Необязательный аргумент, указывающий метод передачи переменных. Если переменные передавать не надо, не трогайте и этот параметр. Иначе - укажите, использовать для передачи метод GET или POST. GET добавляет переменные к концу строки URL и используется для передачи небольших переменных (и небольшого их количества). POST отсылает переменные отдельно от основного файла и может передать любые мыслимые объемы.

Описание

Команда; подгружает дополнительные мувики, не закрывая Flash Player. Обычно Flash Player отображает один мувик (SWF файл) и потом закрывается. Команда loadMovie позволяет отображать несколько мувиков сразу или переключаться между ними, не загружая другой документ HTML.

Можно загружать мувик на уровень, на котором уже загружен файл SWF. Для этого укажите в качестве параметра номер уровня, занимаемого этим клипом. Чтобы заменить главный мувик и выгрузить все уровни, укажите здесь 0. Используйте команду loadVariables, чтобы сохранить мувик, но загрузить туда новые переменные.

Используйте команду unloadMovie, чтобы выгрузить мувик, загруженный с помощью loadMovie .

Player

Flash 3 или более новый.

Примеры

Это выражение loadMovie присоединено к навигационной кнопке, названной Products. В мувике существует невидимый клип, который называется dropZone. Команда loadMovie использует этот муви-клип для того, чтобы загрузить в него SWF-файл:

on(release) {	loadMovie("products.swf",_root.dropZone);}

См. также

unloadMovie_level

От редактора

  1. См. комментарии на MovieClip.loadMovie


loadVariables

K-L > loadVariables

loadVariables

Синтаксис

loadVariables (url ,location [, variables]);

Аргументы

url Абсолютный или относительный адрес файла с переменными. При подгрузке в сети, файл должен находиться в том же поддомене, что и исходный клип.

location Уровень, или имя муви-клипа (target), куда необходимо заслать полученные переменные. Первый (базовый) клип находится на нулевом уровне (level0), подгруженные клипы могут находится на уровнях с другими номерами. Этот аргумент необязательный.

variables Необязательный аргумент, указывающий метод передачи переменных. Если переменные передавать не надо, не трогайте и этот параметр. Иначе - укажите, использовать для передачи метод GET или POST. GET добавляет переменные к концу строки URL и используется для передачи небольших переменных (и небольшого их количества). POST отсылает переменные отдельно от основного файла и может передать любые мыслимые объемы.

Описание

Команда; считывает данные из внешнего файла, например из текстового или файла, сгенерированный скриптом CGI, Active Server Pages (ASP) или Personal Home Page (PHP), и устанавливает значения переменных в муви-клипе. Эта команда также употребляется для обновления переменные.

указанный URL должен быть в стандартном формате MIME application/x-www-urlformencoded (стандартный формат, используемый в скриптах CGI). Главный мувик и файл с переменными должны находиться в одном поддомене. Передано может быть любое количество переменных. Например, так определяется несколько переменных:

company=Macromedia&address=600+Townsend&city=San+Francisco&zip=94103

Player

Flash 4 или более новый.

Примеры

Этот пример загружает переменные из текстового файла в базовую линейку (TimeLine) базового клипа (level 0).

on(release) {	loadVariables("data.txt", 0);}

См. также


lt (меньше, строковой оператор)

K-L > lt (меньше — строковой оператор)

lt (меньше — строковой оператор)

Синтаксис

expression1 lt expression2

Аргументы

expression1, expression2 Числа, строки или переменные.

Описание

Оператор (сравнения); сравнивает expression1 и expression2 и возвращает true, если expression1 меньше, чем expression2. В противном случае возвращает false.

Player

Flash 4 или более новый. Этот оператор считается устаревшим в Flash 5, рекомендовано использование нового оператора < (меньше).

См. также

< (меньше)


Math (object)

Math > Math (объект)

Math (объект)

Объект Math является объектом верхнего уровня, к которому вы можете обращаться без использования конструктора.

Используйте методы и свойства этого объекта для обращения к математическим константам и функциям и манипулирования ими. Все методы и свойства объекта Math являются статическими и должны вызываться с использованием синтаксиса Math.метод (аргумент) или Math.константа. В ActionScript константы определены с максимальной точностью по точности, определенной ИИЭР-754 для чисел с плавающей запятой с удвоенной точностью.

Объект Math полностью поддерживается во Flash 5 Player. Во Flash 4 методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5.

Некоторые методы объекта Math принимают в качестве аргумента значение угла в радианах. Вы можете использовать нижеприведенную формулу для вычисления значений в радианах или просто передать в аргумент формулу (введя значение в градусах) вычисления радианов.

Для вычисления значения в радианах используйте эту формулу:

радиан = Math.PI/180 * градус

А это пример использования передачи в аргумент формулы вычисления радианов для вычисления синуса угла 45 градусов.

Math.SIN(Math.PI/180 * 45) то же, что и Math.SIN(.7854)

Сводка методов объекта Math
Метод | Описание
abs | Вычисляет абсолютное значение.
acos | Вычисляет арккосинус.
asin | Вычисляет арксинус.
atan | Вычисляет арктангенс.
atan2 | Вычисляет угол от оси х до точки.
ceil | Округляет значение вверх до ближайшего целого.
cos | Вычисляет косинус.
exp | Вычисляет экспоненциальное значение.
floor | Округляет значение вниз до ближайшего целого.
log | Вычисляет натуральный логарифм.
max | Возвращает большее число из двух целых чисел.
min | Возвращает меньшее число из двух целых чисел.
pow | Вычисляет значение x возведенное в степень y.
random | Возвращает псевдослучайное число между 0.0 и 1.0.
round | Округляет до ближайшего целого числа.
sin | Вычисляет синус.
sqrt | Вычисляет квадратный корень.
tan | Вычисляет тангенс.

Сводка свойств объекта Math

Все свойства объекта Math являются константами.
Свойство | Описание
E | Константа Эйлера и основание натуральных логарифмов (приближенно 2.718).
LN2 | Натуральный логарифм числа 2 (приближенно 0.693).
LOG2E | Логарифм e с основанием 2 (приближенно 1.442).
LN10 | Натуральный логарифм числа 10 (приближенно 2.302).
LOG10E | Логарифм e с основанием 10 (приближенно 0.434).
PI | Отношение длины окружности к ее диаметру (приближенно 3.14159).
SQRT1_2 | Квадратный корень из 1/2 (приближенно 0.707).
SQRT2 | Квадратный корень из 2 (приближенно 1.414).


Math.abs

Math > Math.abs

Math.abs

Синтаксис

Math.abs(x);

Аргументы

x Любое число.

Описание

Метод; вычисляет и возвращает абсолютное значение числа, заданного в аргументе x.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.acos

Math > Math.acos

Math.acos

Синтаксис

Math.acos(x);

Аргументы

x Число от -1.0 до 1.0.

Описание

Метод; вычисляет и возвращает арккосинус числа, заданного в аргументе x в радианах.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.asin

Math > Math.asin

Math.asin

Синтаксис

Math.asin(x);

Аргументы

x Число от -1.0 до 1.0.

Описание

Метод; вычисляет и возвращает значение арксинуса числа, заданного в аргументе x, в радианах.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.atan

Math > Math.atan

Math.atan

Синтаксис

Math.atan(x);

Аргументы

x Любое число.

Описание

Метод; вычисляет и возвращает значение арктангенса числа x, заданного в аргументе в радианах.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.atan2

Math > Math.atan2

Math.atan2

Синтаксис

Math.atan2(y, x);

Аргументы

x Число, определяющее координату x точки.

y Число, определяющее координату y точки.

Описание

Метод; вычисляет и возвращает значение арктангенса y/x в радианах. Возвращаемое значение представляет собой дополняющий угол того угла прямоугольного треугольника, для которого x - длина смежной стороны, y - длина противоположной стороны.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.ceil

Math > Math.ceil

Math.ceil

Синтаксис

Math.ceil(x);

Аргументы

x Число или выражение.

Описание

Метод; возвращает наименьшее целое число, большее или равное по значению x.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.cos

Math > Math.cos

Math.cos

Синтаксис

Math.cos(x);

Аргументы

x Угол, заданный в радианах

Описание

Метод; возвращает косинус (значение от -1.0 до 1.0) угла, заданного аргументом x. Угол x должен быть задан в радианах. Для вычисления значения угла в радианах используйте способ, описанный в введении к объекту Math.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.E

Math > Math.E

Math.E

Синтаксис

Math.E

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой основание натуральных логарифмов и обозначаемая через e. Приближенное значение e равно 2.71828.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.exp

Math > Math.exp

Math.exp

Синтаксис

Math.exp(x);

Аргументы

x Экспонента; число или выражение.

Описание

Метод; возвращает значение основания натурального логарифма (е), возведенного в степень, заданного в аргументе х.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.floor

Math > Math.floor

Math.floor

Синтаксис

Math.floor(x);

Аргументы

x Число или выражение.

Описание

Метод; возвращает наибольшее целое число, меньшее или равное по значению числу или выражению, заданного аргументом х.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.

Пример

Следующее возвращает значение 12:

Math.floor(12.5);


Math.log

Math > Math.log

Math.log

Синтаксис

Math.log(x);

Аргументы

x Число или выражение со значением больше 0.

Описание

Метод; возвращает натуральный логарифм аргумента х.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.LOG2E

Math > Math.LOG2E

Math.LOG2E

Синтаксис

Math.LOG2E

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой значение логарифма с основанием 2 константы е (Math.E). Выражается через log2e. Приближенное значение равно 1.442695040888963387.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.LOG10E

Math > Math.LOG10E

Math.LOG10E

Синтаксис

Math.LOG10E

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой значение логарифма с основанием 10 константы е (Math.E). Выражается через log10e. Приближенное значение равно 0.43429448190325181667.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.LN2

Math > Math.LN2

Math.LN2

Синтаксис

Math.LN2

Аргументы

Отсутствуют.

Описание.

Константа; математическая константа, представляющая собой значение натурального логарифма числа 2. Выражается через ln2. Приближенное значение равно 0.69314718055994528623.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.LN10

Math > Math.LN10

Math.LN10

Синтаксис

Math.LN10

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой значение натурального логарифма числа 10. Выражается через ln10. Приближенное значение равно 2.3025850929940459011.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.max

Math > Math.max

Math.max

Синтаксис

Math.max(x , y);

Аргументы

x Число или выражение.

y Число или выражение.

Описание

Метод; сравнивает x и y и возвращает большее значение.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.min

Math > Math.min

Math.min

Синтаксис

Math.min(x , y);

Аргументы

x Число или выражение.

y Число или выражение.

Описание

Метод; сравнивает x и y и возвращает меньшее значение.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.PI

Math > Math.PI

Math.PI

Синтаксис

Math.PI

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой значение отношения длины окружности к ее диаметру. Обозначется через pi. Приближенное значение равно 3.14159265358979.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.pow

Math > Math.pow

Math.pow

Синтаксис

Math.pow(x , y);

Аргументы

x Число, которое должно быть возведено в степень.

y Число, задающее степень, в которую должен быть возведен аргумент x.

Описание

Метод; вычисляет и возвращает значение х возведенное в степень y.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.random

Math > Math.random

Math.random

Синтаксис

Math.random();

Аргументы

Отсутствуют.

Описание

Метод; возвращает псевдослучайное число между 0.0 и 1.0

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.

Cм. также

random


Math.round

Math > Math.round

Math.round

Синтаксис

Math.round(x);

Аргументы

x Любое число.

Описание

Метод; округляет значение аргумента x вверх или вниз до ближайшего целого и возвращает это значение.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.sin

Math > Math.sin

Math.sin

Синтаксис

Math.sin(x);

Аргументы

x Угол, заданный в радианах.

Описание

Метод; вычисляет и возвращает синус заданного в радианах угла. Для вычисления значения угла в радианах используйте способ, описанный в введении к объекту Math.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.

См. также

Math (object)


Math.sqrt

Math > Math.sqrt

Math.sqrt

Синтаксис

Math.sqrt(x);

Аргументы

x Любое число или выражение, большее или равное по значению 0.

Описание

Метод; вычисляет и возвращает квадратный корень заданного числа.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.SQRT1_2

Math > Math.SQRT1_2

Math.SQRT1_2

Синтаксис

Math.SQRT1_2

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой значение квадратного корня из 1/2. Приближенное значение равно 0.707106781186.

Проигрыватель

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.SQRT2

Math > Math.SQRT2

Math.SQRT2

Синтаксис

Math.SQRT2

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой значение квадратного корня из 2. Приближенное значение равно 1.414213562373.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.tan

Math > Math.tan

Math.tan

Синтаксис

Math.tan(x);

Аргументы

x Угол, заданный в радианах.

Описание

Метод; вычисляет и возвращает тангенс заданного угла. Для вычисления значения угла в радианах используйте способ, описанный в введении к объекту Math.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


maxscroll

Max-Mov > maxscroll

maxscroll

Синтаксис

variable_name.maxscroll = x

Аргументы

variable_name Имя переменной, ассоциированной с текстовым полем.

x Наибольшее значение номера строки, допустимое для свойства scroll, основанное на высоте текстового поля. Это значение "только для чтения", устанавливаемое со стороны Flash.

Описание

Свойство; свойство "только для чтения", которое работает со свойством scroll для контроля отображения информации в текстовом поле. Значение этого свойства невозможно изменить, оно может быть только считано.

Player

Flash 4 или выше.

См. также

scroll


mbchr

Max-Mov > mbchr

mbchr

Синтаксис

mbchr(number);

Аргументы

number Число, преобразуемое в многобайтный символ.

Описание

Строковая функция; преобразует число ASCII-кода в многобайтный символ.

Player

Flash 4 или выше. Эта функция нежелательна во Flash 5; рекомендуется пользоваться методом String.fromCharCode.

См. также

String.fromCharCode


mblength

Max-Mov > mblength

mblength

Синтаксис

mblength(string);

Аргументы

string Строка.

Описание

Строковая функция; возвращает длину строки многобайтных символов.

Player

Flash 4 или выше. Эта функция нежелательна во Flash 5; рекомендуется пользоваться объектом String и методами.


mbord

Max-Mov > mbord

mbord

Синтаксис

mbord(character);

Аргументы

character Символ, преобразуемый в многобайтное число.

Описание

Строковая функция; конвертирует заданный символ в многобайное число.

Player

Flash 4 или выше. Эта функция нежелательна во Flash 5; рекомендуется пользоваться методом String.charCodeAt.

См. также

String.fromCharCode


mbsubstring

Max-Mov > mbsubstring

mbsubstring

Синтаксис

mbsubstring(value, index, count);

Аргументы

value Многобайтная строка, из которой извлекается новая многобайтная строка.

index Номер первого извлекаемого символа.

count Количество символов, включаемые в извлекаемую строку, кроме символа index.

Описание

Строковая функция; извлекает новую строку многобайтных символов из существующей.

Player

Flash 4 или выше. Эта функция нежелательна во Flash 5; рекомендуется использовать метод string.substr.

См. также

String.substr


Mouse (object)

Max-Mov > Mouse (object)

Mouse (объект)

Для сокрытия и отображения курсора в клипе используются методы объекта Mouse. По умолчанию курсор является видимым, но его можно отклбчить и использовать свой вариант курсора, созданный в виде мувиклипа.

Список методов Mouse
Метод | Описание
hide | Отключает отображание курсора в клипе.
show | Включает отображание курсора.


Mouse.hide

Max-Mov > Mouse.hide

Mouse.hide

Синтаксис

Mouse.hide();

Аргументы

Отсутствуют.

Описание

Метод; Отключает отображание курсора мыши в клипе. По умолчанию курсор является видимым.

Player

Flash 5 или выше.

Образец

Следующий код, прописанный в мувиклипе находящемся на главной линейке, скрывает стандартный курсор и устанавливает координаты x и y мувика customCursor в позиции x и y мыши на главной линейке:

onClipEvent(enterFrame){
    Mouse.hide();
    customCursorMC_x = _root._xmouse;
    customCursorMC_y = _root._ymouse;
}

См. также


Mouse.show

Max-Mov > Mouse.show

Mouse.show

Синтаксис

Mouse.show();

Аргументы

Отсутствуют.

Описание

Метод; Включает отображение курсора мыши в клипе. По умолчанию курсор является видимым.

Player

Flash 5 или выше.

См. также


MovieClip (object)

Max-Mov > MovieClip (object)

MovieClip (object)

Методы для объекта MovieClip предоставляют те же функциональные возможности, что и стандартные команды для мувиклипов. Есть дополнительные методы, предоставляющие возможности, которые недоступны при использовании стандартных команд, перечисленных в категории Actions панели Actions. Не надо использовать способ конструирования для вызова методов объекта MovieClip; вместо этого вы обращаетесь к мувиклипу по имени, используя следующий синтаксис:

anyMovieClip.play();
anyMovieClip.gotoAndPlay(3);

Список методов объекта Movie Clip
Метод | Описание
attachMovie | Присоединяет клип в библиотеке.
duplicateMovieClip | Создает дубликат указанного мувиклипа.
getBounds | Возвращает минимальные и максимальные значения координат x и y мувиклипа в заданном координатном пространстве.
getBytesLoaded | Возвращает количество загруженных байтов для указанного мувиклипа.
getBytesTotal | Возвращает размер мувиклипа в байтах.
getURL | Загружает документ с URL.
globalToLocal | Преобразует глобальные координаты в локальные.
gotoAndPlay | Осуществляет переход в заданный кадр клипа и воспроизводит его дальше.
gotoAndStop | Осуществляет переход в заданный кадр клипа и останавливает его.
hitTest | Возвращает true если указанный мувиклип пересекается или перекрывается с другим мувиком.
loadMovie | Загружает указанный мувиклип.
loadVariables | Загружает переменные из URL или другого места в клип.
localToGlobal | Преобразует локальные координаты в глобальные.
nextFrame | Осуществляет переход на следующий кадр.
play | Воспроизводит указанный мувиклип.
prevFrame | Осуществляет переход на предыдущий кадр.
removeMovieclip | Удаляет мувиклип с линейки, если он был создан командой duplicateMovieClip или методом attachMovie.
startDrag | Определяет мувиклип как перетаскиваемым и начинает его перемещать.
stop | Останавливает воспроизведение текущего клипа.
stopDrag | Останавливает перемещение любого объекта, который является перетаскиваемым.
swapDepths | Производит замеру уровня указанного мувиклипа и мувиклипа на заданном уровне.
unloadMovie | Удаляет мувиклипа, загруженный с помощью loadMovie.


MovieClip.attachMovie

Max-Mov > MovieClip.attachMovie

MovieClip.attachMovie

Синтаксис

anyMovieClip.attachMovie(idName, newname, depth);

Аргументы

idName Имя (идентификатор) присоединяемого из библиотеки мувиклипа. Оно вводится в поле Identifier диалогового окна Symbol Linkage Properties.

newname Уникальное имя для присоединенного мувиклипа.

depth Целое число, задающее номер уровня 1, на каторый должен быть помещен мувиклип.

Описание

Метод; создает новый эталон мувиклипа в библиотеке и присоединяет его к клипу, указанному в anyMovieClip. Используйте команду или метод removeMovieClip или unloadMovie для удаления мувиклипа, присоединенного с помощью attachMovie.

Player

Flash 5 или выше.

См. также

removeMovieClip
unloadMovie
MovieClip.removeMovieClip
MovieClip.unloadMovie

От редактора

  1. Понятие "уровень" в данном контексте следует отличать от уровня, на который возможна подгрузка другого Flash-клипа по команде loadMovie. Данные уровни относятся к текущей линейке (Timeline) и не являются глобальными для всего клипа, т.е. возможно их создание как на основной линейке, так и внутри любого мувиклипа. По своему "физическому смыслу" они аналогичны слоям (lyers) линейки, и всегда, независимо от значения depth , образуются выше самого верхнего слоя текущей линейки.


MovieClip.duplicateMovieClip

Max-Mov > MovieClip.duplicateMovieClip

MovieClip.duplicateMovieClip

Синтаксис

anyMovieClip.duplicateMovieClip(newname, depth);

Аргументы

newname Уникальный идентификатор созданного дубликата мувиклипа.

depth Число, задающее уровень, на который должен быть помещен дубликат мувиклипа.

Описание

Метод; создает эталон заданного мувиклипа во время воспроизведения клипа. Дублированный мувиклип всегда начинает воспроизводиться с первого кадра, не имеет значения какой кадр является текущим в оригинальном клипе когда вызывается метод duplicateMovieClip. Переменные не копируются из оригинального мувиклипа в созданный дубль. При удалении родительского мувиклипа, его дубликат также удаляется 1. Мувиклип, добавленный с помощью duplicateMovieClip, может быть удален с помощью команды или метода removeMovieClip.

Player

Flash 5 или выше.

См. также

removeMovieClip
MovieClip.removeMovieClip

От редактора

  1. Интересно, читают ли девелоперы Макромедии свои доки? :)
    Нет, дочерний мувик не удаляется и продолжает жить своей жизнью, независимо от родителя. Достаточно сделать простенький эксперимент - создать какой-нибудь мувик в библиотеке, залинковать его с идентификатором "ааа" и в первый кадр клипа скопировать данный код:

    _root.attachMovie( "aaa", "qu", 0 );
for (n=1; n<=10; n++) {
    qu.duplicateMovieClip("a"+n, n);
    Eval("a"+n)._x=aaa._x+n*10+100; // это чтобы клоны
    Eval("a"+n)._y=aaa._y+n*10+100; // не сливались в одну проекцию
}
qu.removeMovieClip();

    В данном примере родительский мувиклип "qu" после клонирования 10 "детей" будет удален последней командой, а его "дети" остануться в неприкосновенности.


MovieClip.getBounds

Max-Mov > MovieClip.getBounds

MovieClip.getBounds

Синтаксис

anyMovieClip.getBounds(targetCoordinateSpace);

Аргументы

targetCoordinateSpace Путь к линейке (Timeline), пространство которой используется как система координат.

Описание

Метод; возвращает максимальные и минимальные значения координат x и y мувиклипа, в координатном пространстве (системе координат), заданном в аргументе. Возвращаемый объект будет содержать свойства {xMin, xMax, yMin, yMax}. Используйте методы localToGlobal и globalToLocal для преобразования локальных координат клипа в глобальные или глобальных в локальные соответственно.

Player

Flash 5 или выше.

Пример

Следующий пример использует getBounds для получения координат рамки ограничивающей мувиклип myMovieClip в системе координат основного клипа.

myMovieClip.getBounds(_root);

См. также


MovieClip.getBytesLoaded

Max-Mov > MovieClip.getBytesLoaded

MovieClip.getBytesLoaded

Синтаксис

anyMovieClip.getBytesLoaded();

Аргументы

Отсутствуют.

Описание

Метод; возвращает количество загруженных байтов, указанного мувиклипа. Поскольку внутренние клипы загружаются автоматически, то возвращаемое значение для этого метода будет равно возвращаемому значению метода MovieClip.getBytesTotal, если заданный мувиклип является внутренним. Этот метод предназначен для использования с загружаемыми клипами (например, для создания визуального прелоадера Прим. редактора). Можно сравнивать друг с другом значения getBytesLoaded и getBytesTotal для определения уже загруженной части внешнего клипа.

Player

Flash 5 или выше.


MovieClip.getBytesTotal

Max-Mov > MovieClip.getBytesTotal

MovieClip.getBytesTotal

Синтаксис

anyMovieClip.getBytesTotal();

Аргументы

Отсутствуют.

Описание

Метод; возвращает размер в байтах, указанного объекта Movie Clip. Для клипов, которые являются внешними (корневой клип или клип, подгружаемый в цель или уровень), возвращаемое значение является размером SWF файла.

Player

Flash 5 или выше.


MovieClip.getURL

Max-Mov > MovieClip.getURL

MovieClip.getURL

Синтаксис

anyMovieClip.getURL(URL [,window, variables]);

Аргументы

URL URL, откуда необходимо получить документ.

window Необязательный аргумент, задающий имя, фрейм или выражение, определяющие окно или фрейм HTML, в которое должен быть загружен документ. Можно также использовать одно из зарезервированных целевых имен: _self задает текущий фрейм в текущем окне, _blank задает новое окно, _parent задает родителя текущего фрейма, _top задает верхнеуровневый фрейм в текущем окне.

variables Необязательный аргумент, определяющий метод отсылки переменных из клипа на сервер. Если отсылать переменные не требуется, этот агрумент опускается. В противном случае, указывается метод ("GET" или "POST"). GET прицепляет переменные к концу URL и используется в случае малого количества переменных (длина запроса ограничена 256 символами Прим. редактора). POST отправляет переменные в отдельном HTTP заголовке и используется для длинных строковых переменных.

Описание

Метод; загружает документ с заданного URL в заданное окно. Метод getURL также может быть использован для передачи переменных другим приложениям, определенным через URL с помощью методов GET или POST.

Player

Flash 5 или выше.


MovieClip.globalToLocal

Max-Mov > MovieClip.globalToLocal

MovieClip.globalToLocal

Синтаксис

anyMovieClip.globalToLocal(point);

Аргументы

point Имя или идентификатор объекта, созданного с помощью общего объекта Object, с координатами x и y в качестве свойств.

Описание

Метод; конвертирует глобальные координаты объекта point в локальные координаты мувиклипа.

Player

Flash 5 или выше.

Пример

Следующий код преобразует глобальные координаты x и y объекта point в локальные координаты мувиклипа:

onClipEvent(mouseMove) {
    point = new object();
    point.x = _root._xmouse;
    point.y = _root._ymouse;
    globalToLocal(point);
    _root.out = _xmouse + " === " + _ymouse;
    _root.out2 = point.x + " === " + point.y;
    updateAfterEvent();
}

См. также


MovieClip.gotoAndPlay

Max-Mov > MovieClip.gotoAndPlay

MovieClip.gotoAndPlay

Синтаксис

anyMovieClip.gotoAndPlay(frame);

Аргументы

frame Номер кадра, на который должен перейти Player.

Описание

Метод; осуществляет переход и воспроизведение клипа с указанного кадра.

Player

Flash 5 или выше.


MovieClip.gotoAndStop

Max-Mov > MovieClip.gotoAndStop

MovieClip.gotoAndStop

Синтаксис

anyMovieClip.gotoAndStop(frame);

Аргументы

frame Номер кадра, на который должен перейти Player.

Описание

Метод; осуществляет переход и останавливает клип на указанном кадре.

Player

Flash 5 или выше.


MovieClip.hitTest

Max-Mov > MovieClip.hitTest

MovieClip.hitTest

Синтаксис

anyMovieClip.hitTest(x, y, shapeFlag);
anyMovieClip.hitTest(target);

Аргументы

x x-координата хит-области на сцене.

y y-координата хит-области на сцене.

Координаты x и y определены в глобальном координатном пространстве.

target Хит-область, которая может пересекаться или перекрываться с anyMovieClip. target; обычно представляет собой кнопку или динамическое текстовое поле.

shapeFlag Булево значение, указывающее воспринимать ли всю форму (площадь) мувиклипа - (true) или только его границу (рамку) - (false). Этот аргумент может быть задан только в том случае, если хит-область идентифицирована использованием координат-аргументов x и y.

Описание

Метод; вычисляет пересечение или перекрытие anyMovieClip и хит-области, указанной через target или координаты-аргументы x и y.

1-ое использование: сравнивает координаты x и y формы или ограничивающей рамки заданного мувика, в зависимости от установки shapeFlag. Если shapeFlag установлен в true, то обрабатывается только область, фактически занятая мувиком на сцене, и, если x и y совмещаются с любой точкой, возвращается значение true. Это полезно для определения находится ли мувиклип внутри указанной хит-области или нет.

2-ое использование: вычисляет пересекаются/перекрываются ли границы (рамки) target и заданного мувиклипа, если да, то возвращает true.

Player

Flash 5 или выше.

Пример

Следующий пример использует hitTest со свойствами x_mouse и y_mouse для определения местонахождения мыши:

if (hitTest( _root._xmouse, _root._ymouse, false));

Следующий пример использует hitTest чтобы определить перекрываются/пересекаются ли мувики ball и square или нет:

if(_root.ball, hittest(_root.square)){
    trace("ball intersects square");
}

См. также


MovieClip.loadMovie

Max-Mov > MovieClip.loadMovie

MovieClip.loadMovie

Синтаксис

anyMovieClip.loadMovie(url [,variables]);

Аргументы

url Абсолютный или относительный URL SWF-файла для загрузки. Относительный путь должен быть связан с SWF. URL должен быть в том же поддомене, что и URL текущего фильма. Для использования во Flash Player или в режиме теста все SWF-файлы должны быть размещены в одной папке и имена файлов не могут содержать спецификации папок или дисков 1.

variables Необязательный аргумент, определяющий способ отсылки переменных, ассоциированных с загружаемым фильмом. Аргумент должен содержать строку "GET" или "POST." Если нет необходимости отсылать переменные, опустите этот агрумент. В противном случае укажите метод загрузки переменных ("GET" или "POST"). GET прицепляет переменные к концу URL и используется в случае малого количества переменных. POST отправляет переменные в отдельном заголовке HTTP и используется для длинных строковых переменных.

Описание

Метод; загружает и воспроизводит дополнительные фильмы без закрытия Flash Player. Обычно Flash Player отображает один Flash-фильм (SWF файл) и затем закрывает. Метод loadMovie позволяет показывать одновременно несколько клипов или переключаться между ними без необходимости загрузки другого документа HTML.

Используйте команду unloadMovie для удаления клипов, загруженных с помощью команды loadMovie.

Используйте метод loadVariables для загрузки и обновления значения переменных извне.

Player

Flash 5 или выше.

См. также

MovieClip.loadVariables
MovieClip.unloadMovie

От редактора

  1. На самом деле можно иcпользовать относительную адресацию и размещать подгружаемые мувиклипы в другие директории. Необходимо только корректно прописывать путь к ним. Например, этот код подгрузит мувиклип "begin.swf" из директории movies в мувик с именем "place":

    place.loadMovie("movies/begin.swf");

    Другое дело, что если теперь сделать вызов из подгруженного begin.swf (например запросить файл со списком переменных), то надо понимать то обстоятельство, что такой вызов будет происходить из родительской, по отношению к movies директории и соответственно заранее скорректировать путь при создании begin.swf.


MovieClip.loadVariables

Max-Mov > MovieClip.loadVariables

MovieClip.loadVariables

Синтаксис

anyMovieClip.loadVariables(url, variables);

Аргументы

url Абсолютный или относительный адрес URL для внешнего файла. Хост URL должен быть в том же поддомене что и Flash-клип.

variables Метод для отсылки переменных. GET прикрепляет переменные к концу URL и используется в случае малого количества переменных. POST отправляет переменные в отдельном заголовке HTTP и используется для длинных строковых переменных.

Описание

Метод; читает данные из внешнего файла и устанавливает значения переменных во всем клипе или отдельном мувиклипе. Внешний файл может быть текстовым файлом, сгенерированным скриптами CGI, Active Server Pages (ASP) или PHP и может содержать любое количество переменных.

Этот метод также может быть использован для обновления переменных в текущем клипе их новыми значениями.

Этот метод требует, чтобы текст в URL был в стандартном формате MIME: application/x-www-urlformencoded (формат скрипта CGI).

Player

Flash 5 или выше.

См. также

MovieClip.loadMovie


MovieClip.localToGlobal

Max-Mov > MovieClip.localToGlobal

MovieClip.localToGlobal

Синтаксис

anyMovieClip.localToGlobal(point);

Аргументы

point Имя или идентификатор объекта, созданного с помощью общего объекта Object, заданного координатами x и y.

Описание

Метод; конвертирует объект point из локальных координат в глобальные координаты.

Player

Flash 5 или выше.

Образец

Следующий пример конвертирует координаты x и y объекта point из локальных в глобальные. Локальные координаты x и y определены с помощью xmouse и ymouse, считывающих координаты x и y позиции мыши.

onClipEvent(mouseMove) {
    point = new object();
    point.x = _xmouse;
    point.y = _ymouse;
    _root.out3 = point.x + " === " + point.y;
    _root.out = _root._xmouse + " === " + _root._ymouse;
    localToGlobal(point);
    _root.out2 = point.x + " === " + point.y;
    updateAfterEvent();
}

См. также

MovieClip.globalToLocal


MovieClip.nextFrame

Max-Mov > MovieClip.nextFrame

MovieClip.nextFrame

Синтаксис

anyMovieClip.nextFrame();

Аргументы

Отсутствуют.

Описание

Метод; осуществляет переход на следующий кадр и останавливает клип.

Player

Flash 5 или выше.


MovieClip.play

Max-Mov > MovieClip.play

MovieClip.play

Синтаксис

anyMovieClip.play();

Аргументы

Отсутствуют.

Описание

Метод; включает воспроизведение клипа.

Player

Flash 5 или выше.


MovieClip.prevFrame

Max-Mov > MovieClip.prevFrame

MovieClip.prevFrame

Синтаксис

anyMovieClip.prevFrame();

Аргументы

Отсутствуют.

Описание

Метод; осуществляет переход на предыдущий кадр и останавливает клип.

Player

Flash 5 или выше.


MovieClip.removeMovieClip

Max-Mov > MovieClip.removeMovieClip

MovieClip.removeMovieClip

Синтаксис

anyMovieClip.removeMovieClip();

Аргументы

отсутствуют.

Описание

Метод; удаляет мувиклип, созданный с помощью команды duplicateMovieclip или методов duplicateMovieClip и attachMovie объекта Movie Clip.

Player

Flash 5 или выше.

См. также


MovieClip.startDrag

Max-Mov > MovieClip.startDrag

MovieClip.startDrag

Синтаксис

anyMovieClip.startDrag([lock, left, right, top, bottom]);

Аргументы

lock Булево значение, определяющее является ли перемещаемый мувик прикрепленным к центру позиции мыши (true) или он будет прикреплен к точке, в которой пользователь впервые нажмет кнопку мыши (false). Этот аргумент не является обязательным.

left, top, right, bottom Значения относительно координат родительского клипа, определяющие ограниченный прямоугольник для мувиклипа. Эти аргументы необязательны.

Описание

Метод; позволяет пользователю перемещать заданный мувиклип, который является перетаскиваемым до тех пор, пока этот процесс не будет принудительно остановлен вызовом метода stopDrag или другой мувиклип не станет перемещаемым. Одновременно только один клип может быть перемещаемым.

Player

Flash 5 или выше.

См. также


MovieClip.stop

Max-Mov > MovieClip.stop

MovieClip.stop

Синтаксис

anyMovieClip.stop();

Аргументы

Отсутствуют.

Описание

Метод; останавливает воспроизведение текущего клипа.

Player

Flash 5 или выше.


MovieClip.stopDrag

Max-Mov > MovieClip.stopDrag

MovieClip.stopDrag

Синтаксис

anyMovieClip.stopDrag();

Аргументы

Отсутствуют.

Описание

Метод; прекращает процесс перемещения, начатый методом startDrag. Клип остается перемещаемым до тех пор, пока не будет вызван метод stopDrag или другой мувик не станет перемещаемым. Одновременно только один клип может быть перемещаемым.

Player

Flash 5 или выше.

См. также


MovieClip.swapDepths

Max-Mov > MovieClip.swapDepths

MovieClip.swapDepths

Синтаксис

anyMovieClip.swapDepths(depth);
anyMovieClip.swapDepths(target);

Аргументы

target Мувиклип, который должен обменять уровень своего местонахождения с уровнем клипа, заданным в anyMovieClip. Оба мувиклипа должны принадлежать одному и тому же родительскому клипу (находиться на одной линейке Прим. редактора)

depth Номер уровня, на который будет перемещен anyMovieClip.

Описание

Метод; обменивает порядок расположения, или Z-порядок (уровень глубины) данного мувиклипа с клипом, указанным в аргументе target или с клипом, который в данный момент занимает уровень depth, заданный в аргументе. Оба мувиклипа должны принадлежать к одному и тому же родительскому клипу. Обмен уровнями создает эффект перемещения одного клипа за или под другой. Если в момент вызова этого метода мувиклип находится в состоянии анимации "tweening", последняя останавливается.

Player

Flash 5 или выше.

См. также

_level


MovieClip.unloadMovie

Max-Mov > MovieClip.unloadMovie

MovieClip.unloadMovie

Синтаксис

anyMovieClip.unloadMovie();

Аргументы

Отсутствуют.

Описание

Метод; удаляет мувиклип, загруженный методом loadMovie или attachMovie.

Player

Flash 5 или выше.

См. также


_name

N-R > _name

_name

Синтаксис

instancename._name

instancename._name = value;

Аргументы

instancename Имя экземпляра (instance) мувиклипа, для которого свойство _name будет устанавливаться или определяться.

value Строка, задающая новое имя мувиклипа.

Описание

Свойство; определяет имя экземпляра мувиклипа.

Player

Flash 4 или более новый.


NaN

N-R > NaN

NaN

Синтаксис

NaN

Аргументы

Нет.

Описание

Переменная; Предопределенная переменная с IEEE-754 значением для NaN (Not a Number).

Player

Flash 5 или более новый.


ne (not equal — string specific)

N-R > ne (not equal — string specific)

ne (not equal — string specific)

Синтаксис

expression1 ne expression2

Аргументы

expression1, expression2 Числа, строки или переменные.

Описание

Оператор (сравнения); сравнивает expression1 с expression2 и возвращает true (истина), если expression1 не эквивалентно expression2, в противном случае возвращает false (ложь).

Player

Flash 4 или более новый. Этот оператор не приветствуется во Flash 5, рекомендуется использовать новый != (не эквивалентно).

См. также

!= (inequality)


new

N-R > new

new

Синтаксис

new constructor();

Аргументы

constructor Функция, сопровождаемая любыми факультативными параметрами в круглых скобках. Функция, это обычно имя типа создаваемого объекта. Например, Array, Math, Number, Object.

Описание

Оператор; создает новый, первоначально анонимный объект, вызывает функцию, идентифицированную параметром constructor , передает любые факультативные параметры в круглых скобках и передает недавно созданный объект, как значение ключевого слова this. Функция может затем использовать this для этого нового объекта.

Свойство _prototype_ конструктора объекта копируется в свойство _proto_ нового объекта. Как результат, новый объект поддерживает все методы и свойства объекта-прототипа.

Player

Flash 5 или более новый.

Пример

Следующий пример создает объекты book1 и book2, используя оператор new.

function Book(name, price)
{
    this.name = name;
    this.price = price;
}
book1 = new Book("Confederacy of Dunces", 19.95);
book2 = new Book("The Floating Opera", 10.95);

См. также

[] (array access operator)
{} (object initializer)

Раздел метода конструктора внутри объектного входа.


newline

N-R > newline

newline

Синтаксис

newline;

Аргументы

Нет.

Описание

Константа; вставляет символ возврата каретки ({) - пустую линию в ActionScript код. Использование newline создает пространство для информации, которое возвращается функцией или командой в вашем коде. 1

Player

Flash 4 или более новый.

От переводчика.

  1. На мой взгляд, это звучит довольно заумно и не очень понятно. Своими словами, newline принудительно переводит строку в значении строковой переменной. Например, у вас есть текстовое поле с именем txt и прописана такая команда:

    txt="Hello"+newline+"World";

    Значение txt, отражаемое в этом текстовом поле, будет разбито на две строки:

    Hello
World

    Для полноты картины можно добавить, что вместо newline, для этих целей, можно использовать код "\r", т.е. переменной txt присваивать следующее значение:

    txt="Hello\rWorld";

    Результат будет тем же самым, что и при использовании newline.


nextFrame

N-R > nextFrame

nextFrame

Синтаксис

nextFrame();

Аргументы

Нет.

Описание

Команда; переводит воспроизведение клипа на следующий кадр и останавливает на нем.

Player

Flash 2 или более новый.

Пример

Когда пользователь нажимает на кнопку, содержащую команду nextFrame, происходит переход на следующий кадр и остановка воспроизведения клипа.

on (release) {
    nextFrame();
}


nextScene

N-R > nextScene

nextScene

Синтаксис

nextScene();

Аргументы

Нет.

Описание

Команда; переводит воспроизведение клипа на первый кадр следующей сцены и останавливает на нем.

Player

Flash 2 или более новый.

Пример

При нажатии на кнопку, воспроизведение клипа перескакивает и останавливается на первом кадре следующей сцены.

on(release) {
    nextScene();
}


not

N-R > not

not

Синтаксис

not expression

Аргументы

expression Любая переменная или выражение, которое преобразуется в булеан (Boolean) значение.

Описание

Оператор; выполняет логическую операцию NOT (отрицание) во Flash 4 Player.

Player

Flash 4 или более новый. Этот оператор не приветствуется во Flash 5, рекомендуется использовать новый оператор ! (logical NOT).

См. также

! (logical NOT)


null

N-R > null

null

Синтаксис

null

Аргументы

Нет.

Описание

Ключевое слово; специальное значение, которое может быть назначено переменным или возвращено функцией, если она не обеспечена никакими данными. Можно использовать null для представления "пустых" переменных или переменных с неуказанным типом данных.

Player

Flash 5 или более новый.

Пример

В числовом контексте, null эквивалентен нулю. С null может производится проверка эквивалентности, как это сделано в следующем примере:

if (tree.left == null) {
    tree.left = new TreeNode();
}


Number (function)

N-R > Number (function)

Number (function)

Синтаксис

Number(expression);

Аргументы

expression Строка, булеан (Boolean) или любое выражение для конвертирования в число.

Описание

Функция; конвертирует аргумент x в число и возвращает значение как описано ниже:

Если x число, возвращает значение x.

Если x булеан (Boolean), возвращает единицу, если x есть true (истина) или ноль, если x есть false (ложь).

Если x строка, функция пытается анализировать x, как десятичное число.

Если x неопределено (undefined), возвращаемое значение равно нулю.

Эта функция используется для конвертирования файлов формата Flash 4 в формат Flash 5 и содержащих операторы, присутствие которых не рекомендовано для импорта в новую версию. Для большей информации см. описание оператора &.

Player

Flash 4 или более новый.

См. также

Number (object)


Number (object)

N-R > Number (object)

Number (object)

Объект Number - оболочка для данных типа число, позволяющая манипулировать исходными числовыми значениями, используя методы и свойства, связанные с объектом Number. Функциональные возможности этого объекта такие же, как у аналогичного объекта JavaScript Number.

Можно использовать конструктор Number при вызове методов объекта Number, но при вызове его свойств такой необходимости нет. Следующие примеры описывают синтаксис для вызова методов и свойств объекта Number:

Пример вызова метода toString объекта Number:

myNumber = new Number(1234);
myNumber.toString();

Возвращает строковое представление числа 1234.

Пример вызова свойства MIN_VALUE объекта Number:

smallest = Number.MIN_VALUE

Краткое описание методов объекта Number
Метод | Описание
toString | Возвращает строковое представление объекта Number.
valueOf | Возвращает исходное значение объекта Number.

Краткое описание свойств объекта Number
Свойство | Описание
MAX_VALUE | Константа, наибольшее возможное для представления число (с двойной точностью IEEE-754), приблизительно равно 1.7976931348623158e+308.
MIN_VALUE | Константа, наименьшее возможное для представления число (с двойной точностью IEEE-754), приблизительно равно 5e-324.
NaN | Константа, представляет значение для Not a Number (NaN).
NEGATIVE_INFINITY | Константа, представляет значение для отрицательной бесконечности.
POSITIVE_INFINITY | Константа, представляет значение для положительной бесконечности. Это значение такое же, как у глобальной переменной Infinity (Бесконечность).

Конструктор для объекта Number

Синтаксис

myNumber = new Number(value);

Аргументы

value Числовое значение создаваемого объекта Number или значение, которое будет преобразовано в число.

Описание

Конструктор; создает новый объект Number. При использовании методов toString и valueOf объекта Number, необходимо применять конструктор Number, в то же время такой необходимости нет, если использовать его свойства. Конструктор new Number прежде всего используется как оболочка. Экземпляр объекта Number не идентичен функции Number, которая преобразует аргумент в исходное значение.

Player

Flash 5 или более новый.

Пример

Следующий код создает новые объекты Number:

n1 = new Number(3.4);
n2 = new Number(-10);

См. также

Number (function)


Number.MAX_VALUE

N-R > Number.MAX_VALUE

Number.MAX_VALUE

Синтаксис

Number.MAX_VALUE

Аргументы

Нет.

Описание

Свойство; наибольшее возможное для представления число (с двойной точностью IEEE-754). Это число приблизительно равно 1.79E+308.

Player

Flash 5 или более новый.


Number.MIN_VALUE

N-R > Number.MIN_VALUE

Number.MIN_VALUE

Синтаксис

Number.MIN_VALUE

Аргументы

Нет.

Описание

Свойство; наименьшее возможное для представления число (с двойной точностью IEEE-754). Это число приблизительно равно 5e-324.

Player

Flash 5 или более новый.


Number.NaN

N-R > Number.NaN

Number.NaN

Синтаксис

Number.NaN

Аргументы

Нет.

Описание

Свойство; IEEE-754 значение представления Not A Number (NaN).

Player

Flash 5 или более новый.


Number.NEGATIVE_INFINITY

N-R > Number.NEGATIVE_INFINITY

Number.NEGATIVE_INFINITY

Синтаксис

Number.NEGATIVE_INFINITY

Аргументы

Нет.

Описание

Свойство; возвращает IEEE-754 значение представления отрицательной бесконечности. Это значение такое же, как у глобальной переменной Infinity (Бесконечность).

Отрицательная бесконечность - специальное числовое значение, которое возвращается тогда, когда математическая операция или функция выдает отрицательное значение больше, чем может быть представлено.

Player

Flash 5 или более новый.


Number.POSITIVE_INFINITY

N-R > Number.POSITIVE_INFINITY

Number.POSITIVE_INFINITY

Синтаксис

Number.POSITIVE_INFINITY

Аргументы

Нет.

Описание

Свойство; возвращает IEEE-754 значение представления положительной бесконечности. Это значение такое же, как у глобальной переменной Infinity (Бесконечность).

Положительная бесконечность - специальное числовое значение, которое возвращается тогда, когда математическая операция или функция выдает значение больше, чем может быть представлено.

Player

Flash 5 или более новый.


Number.toString

N-R > Number.toString

Number.toString

Синтаксис

myNumber.toString(radix);

Аргументы

radix задает основание числа (от 2 до 36), используемое для number-to-string преобразования. Если аргумент radix не указан, то по умолчанию используется 10 (десятичное число).

Описание

Метод; возвращает строковое представление Number объекта (myNumber).

Player

Flash 5 или более новый.

Пример

Следующий пример использует метод Number.toString, с основанием 2 для аргумента radix:

myNumber = new Number (1000);
(1000).toString(2);

Возвращает строку, содержащую бинарное представление числа 1000.


Number.valueOf

N-R > Number.valueOf

Number.valueOf

Синтаксис

myNumber.valueOf();

Аргументы

Нет.

Описание

Метод; возвращает первоначальное значение типа определяемого объекта Number и конвертирует упакованный объект Number в первоначальное значение типа.

Player

Flash 5 или более новый.


Object (object)

N-R > Object (object)

Object (object)

Универсальный объект Object находится в корне иерархии класса ActionScript. Функциональные возможности универсального объекта Object это маленькое подмножество, обеспечиваемое объектом JavaScript Object.

Универсальный объект Object требует Flash 5 Player.

Краткое описание методов объекта Object
Метод | Описание
toString | Конвертирует определяемый объект в строку и возвращает его.
valueOf | Возвращает исходное значение объекта Object.

Конструктор для объекта Object

Синтаксис

new Object();
new Object(value);

Аргументы

value Число, Булеан или строка, конвертируемые в объект. Это необязательный аргумент. Если вы не определяете value, конструктор создаст объект без описанных свойств.

Описание

Конструктор; создает новый объект Object.

Player

Flash 5 или более новый.

См. также


Object.toString

N-R > Object.toString

Object.toString

Синтаксис

myObject.toString();

Аргументы

Нет.

Описание

Метод; конвертирует объект в строку и возвращает.

Player

Flash 5 или более новый.


Object.valueOf

N-R > Object.valueOf

Object.valueOf

Синтаксис

myObject.valueOf();

Аргументы

Нет.

Описание

Метод; возвращает первоначальное значение определяемого объекта. Если объект не имеет такого значения, возвращается сам объект.

Player

Flash 5 или более новый.


onClipEvent

N-R > onClipEvent

onClipEvent

Синтаксис

onClipEvent(movieEvent);{
...
}

Аргументы

movieEvent переключатель приводимый в действие событием и выполняющий, в зависимости от события, те или иные команды, указанные в мувиклипе. Любое из следующих значений может быть определено для аргумента movieEvent:

load Инициализация команд в момент появления мувиклипа на линейке (Timeline).
unload Инициализация команд в первом кадре в момент удаления мувиклипа с линейки. Команды, связанные с событием Unload, обрабатываются прежде любых команд прописанных в кадре.
enterFrame Инициализация команд в каждом воспроизводимом кадре, так, как если бы они были прописаны в каждом кадре мувиклипа. Команды, связанные с событием OnEnterFrame, обрабатываются после любых команд прописанных в кадрах.
mouseMove Инициализация команд при каждом перемещении мыши. Для определения текущей позиции мыши используются свойства _xmouse и _ymouse.
mouseDown Инициализация команд при нажатии левой кнопки мыши.
mouseUp Инициализация команд при отпускании левой кнопки мыши.
keyDown Инициализация команд при нажатии клавиши клавиатуры. Метод Key.getCode используется для получения информации о нажатой клавише.
keyUp Инициализация команд при отпускании клавиши клавиатуры. Метод Key.getCode используется для получения информации о нажатой клавише.
data Инициализация команд при получении данных в командах loadVariables или loadMovie. Когда это связано с командой loadVariables, событие data происходит только один раз в момент окончания загрузки последней переменной. При использовании команды loadMovie, событие data может быть многократным, по мере подхода новых данных.

Описание

Драйвер; в зависимости от события переключает (инициализирует) команды, указанные в мувиклипе.

Player

Flash 5 или более новый.

Пример

Следующий оператор вставляет скрипт из внешнего файла в тот момент, когда мувиклип загружен и появляется на линейке (Timeline):

onClipEvent(load) {
    #include "myScript.as"
}

Следующий пример использует onClipEvent с событием keyDown. Обычно событие keyDown используется совместно с одним или более количеством методов и свойств, связанных с объектом Key. Ниже key.getCode применяется для определения клавиши, нажатой пользователем.

onClipEvent(keyDown) {
    if (Key.getCode() == Key.RIGHT) {
        } _parent.nextFrame();
    else if (Key.getCode() == Key.LEFT){
        _parent.prevFrame();
}

Этот пример использует onClipEvent с событием mouseMove. Свойства xmouse и ymouse отслеживают положение курсора.

onClipEvent(mouseMove) {
stageX=_root.xmouse;
stageY=_root.ymouse;
}

См. также


on(mouseEvent)

N-R > on(mouseEvent)

on(mouseEvent)

Синтаксис

on(mouseEvent) {
statement;
}

Аргументы

statement Команды, выполняемые в момент наступления события mouseEvent.

Команда mouseEvent может иметь один из следующих аргументов:

press Кнопка мыши нажата в момент нахождения курсора над кнопкой.
release Кнопка мыши отпущена в момент нахождения курсора над кнопкой.
releaseOutside Кнопка мыши отпущена в момент нахождения курсора снаружи кнопки.
rollOver Курсор входит в границы кнопки.
rollOut Курсор выходит за границы кнопки.
dragOver В момент нахождения курсора над кнопкой, нажимается кнопка мыши, затем курсор выводится за границы кнопки и вводится обратно.
dragOut В момент нахождения курсора над кнопкой, нажимается кнопка мыши, затем курсор выводится за границы кнопки.
keyPress ("key") Определяет нажатие key. Для указания аргумента key используются любое значение, из перечисленных в Приложении B "Клавиши клавиатуры и их коды" или любая из клавишных констант, перечисленных в Описание свойств объекта Key.

Описание

Драйвер; определяет событие мыши или нажатие клавиш клавиатуры, вызывающих переключение команд.

Player

Flash 2 или более новый.

Пример

В следующем скрипте команда startDrag выполняется при нажатии кнопки мыши, а проверка условия при ее отпускании:

on(press) {
    startDrag("rabbit");
}
on(release) {
    if(getproperty("", _droptarget) == target) {
        setProperty ("rabbit", _x, _root.rabbit_x);
        setProperty ("rabbit", _y, _root.rabbit_y);
    } else {
_root.rabbit_x = getProperty("rabbit", _x);
_root.rabbit_y = getProperty("rabbit", _y);
_root.target = "pasture";
    }
    trace(_root.rabbit_y);
    trace(_root.rabbit_x);
    stopDrag();
}

См. также


or

N-R > or

or

Синтаксис

condition1 or condition2

Аргументы

condition1,2 Выражение (условие), проверяемые на соответствие true (истина) или false (ложь).

Описание

Оператор; проверяет condition1 и condition2 и если любое из них соответствует true, то возвращает true, в противном случае возвращает false.

Player

Flash 4 или более новый. Этот оператор не приветствуется во Flash 5, предпочтительным является использование оператора ||.

См. также

|| (OR)


ord

N-R > ord

ord

Синтаксис

ord(character);

Аргументы

character Символ, конвертируемый в ASCII код.

Описание

Строковая функция; конвертирует текстовый символ в число, соответствующее его ASCII коду.

Player

Flash 4 или более новый. Эта функция не приветствуется во Flash 5, взамен рекомендуется использовать методы и свойства объекта String.

См. также

String (object)


_parent

N-R > _parent

_parent

Синтаксис

_parent.property = x
_parent._parent.property = x

Аргументы

property Свойство, определяемое для текущего и родительского мувиклипа.

x Значение, устанавливаемое для свойства. Это необязательный аргумент и может не нуждаться в установке, зависит от свойства.

Описание

Свойство; указывает или возвращает ссылку на мувиклип, в который вложен текущий мувик, содержащий в себе исполняемый в данный момент скрипт. Использование _parent, определяет относительный путь.

Player

Flash 4 или более новый.

Пример

В следующем примере мувиклип desk является дочерним по отношению к мувиклипу classroom. Когда скрипт внутри desk мувика будет исполнен, Flash-клип перескочит на десятый кадр линейки мувиклипа classroom.

_parent.gotoAndStop(10);

См. также


parseFloat

N-R > parseFloat

parseFloat

Синтаксис

parseFloat(string);

Аргументы

string Строка, анализируемая и конвертируемая в число с плавающей запятой.

Описание

Функция; конвертирует строку в число с плавающей запятой. Функция анализирует и возвращает числа в строке до тех пор, пока синтаксический анализатор не достигнет символа, не являющегося частью исходного числа. Если строка не начинается с числа, которое может быть проанализировано, parseFloat возвращает NaN или 0. Игнорируются пробелы, предшествующие валидному значению числа.

Player

Flash 5 или более новый.

Пример

Следующие примеры использования parseFloat анализируют различные типы чисел:

parseFloat("-2") возвращает -2

parseFloat("2.5") возвращает 2.5

parseFloat("3.5e6") возвращает 3.5e6 или 3500000

parseFloat("foobar") возвращает NaN


parseInt

N-R > parseInt

parseInt

Синтаксис

parseInt(expression, radix);

Аргументы

expression Строка, число с плавающей запятой или другое выражение для анализа и конвертации в целое.

radix Целое, представляющее для анализа основание системы счисления (базу) числа. Допустимые значения от 2 до 36. Этот параметр факультативный (необязательный).

Описание

Функция; конвертирует строку в число. Если представляемую строку нельзя перевести в число, функция возвращает NaN или ноль. Целые числа, начинающиеся нулем или определяемые по основанию 8, интерпретируются как восьмеричные числа, начинающиеся с 0x - как шестьнадцатиричные. Игнорируются пробелы, предшествующие валидному значению числа.

Player

Flash 5 или более новый.

Пример

Следующие примеры используют parseInt для анализа различных типов чисел:

parseInt("3.5") возвращает 3.5

parseInt("bar") возвращает NaN

parseInt("4foo") возвращает 4

Шестьнадцатиричное преобразование:

parseInt("0x3F8") возвращает 1016

parseInt("3E8", 16) возвращает 1000

Двоичное (бинарное) преобразование:

parseInt("1010", 2) возвращает 10 (десятичное представление бинарного 1010)

Синтаксический анализ восьмеричного числа (в этом случае восьмеричное число идентифицировано основанием 8):

parseInt("777", 8) возвращает 511 (десятичное представление восьмеричного 777)


play

N-R > play

play

Синтаксис

play();

Аргументы

Нет.

Описание

Команда; включает воспроизведение клипа на линейке (Timeline).

Player

Flash 2 или более новый.

Пример

Следующий код использует оператор if для проверки введенного значения имени пользователя. Если введено Steve, команда play включает дальнейшее воспроизведение клипа на линейке. В противном случае, в текстовом поле с переменной alert выдается соответствующее значение.

stop();
if (name = "Steve") {
    play();
} else {
    alert = "You are not Steve!";
}


prevFrame

N-R > prevFrame

prevFrame

Синтаксис

prevFrame();

Аргументы

Нет.

Описание

Команда; переводит клип на предыдущий кадр и останавливает его.

Player

Flash 2 или более новый.

Пример

При нажатии на кнопку, содержащей команду prevFrame, клип откатывает назад на предыдущий кадр и останавливается.

on(release) {
    prevFrame();
}

См. также

MovieClip.prevFrame


prevScene

N-R > prevScene

prevScene

Синтаксис

prevScene();

Аргументы

Нет.

Описание

Команда; переводит клип на перый кадр предыдущей сцены и останавливает его.

Player

Flash 2 или более новый.

См. также

nextScene


print

N-R > print

print

Синтаксис

print (target, "bmovie");
print (target, "bmax");
print (target, "bframe");

Аргументы

target Имя мувиклипа, предназначенного для печати. По умолчанию печатаются все кадры клипа. Если надо напечатать только определенных кадры, пометьте их для печати меткой (label) #P.

bmovie Определяет блок кадров, как область печати в клипе. Для обозначения границ блока, пометьте соответствующие кадры меткой (label) #b.

bmax Определяет состав всех блоков, как область печати. Укажите аргумент bmax, когда предназначенные для печати кадры изменяются по размеру.

bframe Определяет, что каждый предназначенный для печати кадр используется как область печати. Это изменяет область печати для каждого кадра и масштабирует объекты, подгоняя их размер под область печати. Используйте bframe, если имеете объекты различных размеров в каждом кадре и хотите, чтобы каждый объект заполнил напечатанную страницу.

Описание

Команда; печатает клип target согласно модификатору принтера, определенному в параметре. Если Вы хотите печатать только отдельные кадры клипа, пометьте их меткой (label) #P. Хотя команда print обеспечивает более высокое качество печати, чем printAsBitmap, она не может применяться для распечатки клипа, использующего альфа-прозрачность или специальные цветовые эффекты.

Если Вы не определяете аргумент области печати, по умолчанию она будет ограничена размером сцены загруженного клипа. Клип не наследует размер сцены основного клипа. Можно управлять областью печати, определяя bmovie, bmax или аргумент bframe.

Все предназначенные для печати элементы клипа должны быть полностью загружены до начала печати.

Flash Player поддерживает PostScript и non-PostScript принтеры. Non-PostScript преобразуют векторное изображение в растровое (bitmap).

Player

Flash 5 или более новый.

Пример

Следующий пример напечатает все предназначенные для печати кадры в myMovie с областью печати, определенной кадрами с меткой #b:

print("myMovie","bmovie");

Следующий пример напечатает все предназначенные для печати кадры в myMovie с областью печати, определенной каждым кадром:

print("myMovie","bframe");

См. также

printAsBitmap


printAsBitmap

N-R > printAsBitmap

printAsBitmap

Синтаксис

printAsBitmap(target, "bmovie");
printAsBitmap(target, "bmax");
printAsBitmap(target, "bframe");

Аргументы

target Имя мувиклипа, предназначенного для печати. По умолчанию печатаются все кадры клипа. Если надо напечатать только определенных кадры, пометьте их для печати меткой (label) #P.

bmovie Определяет блок кадров, как ограниченную область печати в клипе. Для обозначения границ блока, пометьте соответствующие кадры меткой (label) #b.

bmax Определяет состав всех блоков, как область печати. Укажите аргумент bmax, когда предназначенные для печати кадры изменяются по размеру.

bframe Определяет, что каждый предназначенный для печати кадр используется как область печати. Это изменяет область печати для каждого кадра и масштабирует объекты, подгоняя их размер под область печати. Используйте bframe, если имеете объекты различных размеров в каждом кадре и хотите, чтобы каждый объект заполнил напечатанную страницу.

Описание

Команда; печатает клип target как растровый рисунок. Используйте printAsBitmap, чтобы распечатать клип, который содержит кадры с объектами, использующие прозрачность или цветовые эффекты. Для обеспечения максимально возможного качества, команда printAsBitmap печатает в самой высокой доступной разрешающей способности принтера. Для вычисления размера файла для печати выбранного кадра, умножьте пиксельную ширину на пиксельную высоту разрешающей способностью принтера.

Если клип не содержит альфа-прозрачности или цветовых эффектов, рекомендуется использовать команду print для получения более качественных результатов.

По умолчанию, область печати определяется размером сцены загруженного клипа. Клип не наследует размер сцены основного клипа, можно регулировать область печати через аргументы bmovie, bmax или bframe.

Все предназначенные для печати элементы клипа должны быть полностью загружены до начала печати.

Flash Player поддерживает PostScript и non-PostScript принтеры. Non-PostScript преобразуют векторное изображение в растровое (bitmap).

Player

Flash 5 или более новый.

См. также

print


_quality

N-R > _quality

_quality

Синтаксис

_quality
_quality = x;

Аргументы

x Строка, определяющая одно из следующих значений:

LOW Низкое качество рендеринга (отображения). Графика (имеется в виду векторная. прим.Пер.) не сглаживается, растровые (bitmap) картинки тоже.

MEDIUM Среднее качество рендеринга. Графика сглаживается с использованием сетки 2х2, но растровые картинки не сглаживаются. Это режим подходит для клипов, которое не содержат текст.

HIGH Высокое качество рендеринга. Графика сглаживается с использованием сетки 4х4 и битмапы сглаживаются тоже, если не анимированы (статические). Это качество рендеринга установлено во Flash по умолчанию.

BEST Очень высокое качество рендеринга. Графика сглаживается с использованием сетки 4х4, растр сглаживается всегда.

Описание

Свойство (global - общее для всего клипа); устанавливает или возвращает качество, используемое для рендеринга клипа.

Player

Flash 5 или более новый.

Пример

Следующий пример присваивает текущее качество рендеринга переменной oldQuality и устанавливает новое со значением HIGH:

oldQualtiy = _quality
_quality = "HIGH";

См. также

_highquality


random

N-R > random

random

Синтаксис

random();

Аргументы

value Наибольшее целое, в диапазоне которого random будет возвращать значение.

Описание

Функция; возвращает случайное целое между нулем и числом, указанным в аргументе value.

Player

Flash 4. Эта функция не приветствуется во Flash 5, рекомендуется использовать метод Math.random.

Пример

Следующее использование random возвращает значения 0, 1, 2, 3 или 4:

random(5);

См. также

Math.random


removeMovieClip

N-R > removeMovieClip

removeMovieClip

Синтаксис

removeMovieClip(target);

Аргументы

target Путь (target path) до экземпляра мувиклипа, созданного при помощи duplicateMovieClip или имя мувика, созданного методами attachMovie или duplicateMovie, объекта MovieClip.

Описание

Команда; удаляет экземпляр мувиклипа, созданного при помощи методов attachMovie или duplicateMovie объекта MovieClip или командой duplicateMovieClip.

Player

Flash 4 или более новый.

См. также


return

N-R > return

return

Синтаксис

return[expression];
return;

Аргументы

expression Тип, строка, число, массив или объект, обрабатываемые функцией и возвращаемые, как ее значение. Это необязательный аргумент (опциональный).

Описание

Команда; определяет значение, возвращаемое функцией. Когда выполняется эта команда, обрабатывается expression и возвращается, как значение функции. Команда return останавливает выполнение функции. Если Flash в течение выполнения цикла не встречает оператора return, возвращается null.

Player

Flash 5 или более новый.

Пример

function sum(a, b, c){
return a + b + c;
}

См. также

function


_root

N-R > _root

_root

Синтаксис

_root;
_root.movieClip;
_root.action;

Аргументы

movieClip Имя мувиклипа.

action Значение, задаваемое свойству. Это необязательный аргумент и может не нуждаться в установке, зависит от свойства.

Описание

Свойство; указывает или возвращает ссылку на основную линейку (Timeline) мувиклипа, а попросту - корень. Если клип имеет много уровней (levels), корневой линейкой является уровень, содержащий исполняемый в данный момент скрипт. Например, если скрипт на первом уровне определяет _root, будет возвращен уровень 1.

Определение _root то же самое, что использование слэш нотации (/) для определения абсолютного пути для текущего уровня (level).

Player

Flash 4 или более новый.

Пример

Следующий пример остановит воспроизведение уровня, содержащего текущий исполняемый скрипт:

_root.stop();

В этом примере клип перескочит на третий кадр линейки текущего уровня:

_root.gotoAndStop(3);

См. также


_rotation

N-R > _rotation

_rotation

Синтаксис

instancename._rotation
instancename._rotation = integer

Аргументы

integer Угол поворота мувиклипа в градусах.

instancename Поворачиваемый мувиклип.

Описание

Свойство; поворачивает мувиклип на указанный в градусах угол.

Player

Flash 4 или более новый.


scroll

S > scroll

scroll

Синтаксис

variable_name.scroll = x

Аргументы

variable_name Имя переменной, связанной с текстовым полем.

x Номер верхней видимой линии в текстовом поле. Если значение не указано, используется 1 по умолчанию. Flash Player обновляет это значение, когда пользователь передвигается по текстовому полю вверх и вниз.

Описание

Свойство; контролирует отображение информации в текстовом поле, связанном с переменной. Свойство scroll определяет, с какой строки текстовое поле начинает выводить содержимое и обновляется автоматически при передвижении текста через текстовое поле. Свойство scroll используется для перелистывания длинного текста или для создания тестовых полей со скроллингом. Значение этого свойства можно как считывать, так и изменять.

Player

Flash 4 или выше.

Смотрите также

maxscroll


Selection (object)

S > Selection (object)

Selection (object)

Объект Selection позволяет устанавливать и контролировать фокус в редактируемом текстовом поле. Редактируемое текстовое поле имеющее фокус, это то поле, в котором размещен указатель мыши пользователя. Индекс этого поля начинается с нуля (0 - первая позиция, 1 - вторая и т.д.)

Для объекта Selection нет конструктивного метода, поэтому одновременно только одно текстовое поле может иметь фокус

Описание методов для объекта Selection
Метод | Описание
getBeginIndex | Возвращает индекс начала выделения. Возвращает -1 если нет индекса или текущего выбранного поля.
getCaretIndex | Возвращает текущую позицию каретки в выделенном диапазоне, имеющем фокус. Возвращает -1 если нет позиции каретки или выделенного диапазона, имеющего фокус.
getEndIndex | Возвращает индекс конца выделения. Возвращает -1 если нет индекса или текущего выбранного поля.
getFocus | Возвращает имя переменной для текущего текстового поля, имеющего фокус. Возвращает null если нет текущего выбранного поля.
setFocus | Устанавливает фокус на текстовое поле, связанное с переменной, указанной в аргументе.
setSelection | Выставляет начальный и конечный индекс выделенного диапазона.


Selection.getBeginIndex

S > Selection.getBeginIndex

Selection.getBeginIndex

Синтаксис

Selection.getBeginIndex();

Аргументы

Нет.

Описание

Метод; возвращает индекс в начале выбранного промежутка . Если никакой индекс не существует или никакое поле в настоящее время не имеет фокус, метод возвращает -1. Индекс выбранного промежутка отсчитывается от нуля (где первая позиция - 0, вторая позиция - 1, и так далее).

Player

Flash 5 или выше.


Selection.getCaretIndex

S > Selection.getCaretIndex

Selection.getCaretIndex

Синтаксис

Selection.getCaretIndex();

Аргументы

Нет.

Описание

Метод; возвращает индекс мигающей позиции курсора. Если нет мигающего указателя, метод возвращает -1. Индексы промежутка выбора отсчитываются от нуля (где первая позиция - 0, вторая позиция - 1, и так далее).

Player

Flash 5 или выше.


Selection.getEndIndex

S > Selection.getEndIndex

Selection.getEndIndex

Синтаксис

Selection.getEndIndex();

Аргументы

Нет.

Описание

Метод; возвращает последний индекс текущего выделенния (промежутка). Если индекса не существует или промежуток не выделен, метод возвращает -1. Индексы отсчитываются от нуля (где первая позиция - 0, вторая позиция - 1, и так далее).

Player

Flash 5 или выше.


Selection.getFocus

S > Selection.getFocus

Selection.getFocus

Синтаксис

Selection.getFocus();

Аргументы

Нет.

Описание

Метод; возвращает имя переменной доступного для редактирования текстового поля, выбранного в данный момент. Если никакое текстовое поле в настоящее время не выбрано, метод возвращает указатель null.

Player

Flash 5 или выше.

Example

Следующий код возвращает имя переменной:

_root.anyMovieClip.myTextField.


Selection.setFocus

S > Selection.setFocus

Selection.setFocus

Синтаксис

Selection.setFocus(variable);

Аргументы

variable Строка, определяющая имя переменной, связанной с текстовым полем, с использованием точечной или слэш нотацией.

Описание

Метод; устанавливает фокус на доступное для редактирования текстовое поле, связанное с указанным аргументом variable.

Player

Flash 5 или выше.


Selection.setSelection

S > Selection.setSelection

Selection.setSelection

Синтаксис

Selection.setSelection(start, end);

Аргументы

start Начальный индекс выделяемого промежутка.

end Конечный индекс выделяемого промежутка.

Описание

Метод; устанавливает промежуток, выделенный в редактируемом текстовом поле, имеющем фокус. Новый промежуток выделения начнется с индекса, указанного в параметре start и заканчиваться индексом, указанном в параметре end. Индексы промежутка отсчитываемые от нуля (где первая позиция - 0, вторая позиция - 1, и так далее). Этот метод не имеет никакого эффекта, если в настоящее время нет текстового поля, имеющего фокус.

Player

Flash 5 или выше.


set

S > set

set

Синтаксис

variable = expression;set(variable, expression);

Аргументы

variable Имя контейнера, содержащее значение параметра expression.

expression Значение (или фраза, которая может быть приведена к значению) которое назначено переменной.

Описание

Команда; присваивает значение переменной. Переменная является контейнером, содержащим информацию. Сам контейнер, всегда тот же самый, но его содержание может изменяться. Изменяя значение переменной во время воспроизведения клипа, можно записывать и сохранять информацию о действиях пользователя, записывать значения, изменяющиеся во время воспроизведения клипа или проверять условия true или false.

Переменные могут содержать или числа или строки символов. Каждый клип имеет свой собственный набор переменных и каждая переменная имеет свое собственное значение, независимое от переменных в другом клипе.

ActionScript - язык неконтролирующий типы. Это означает, что переменные не должны быть явно определены, как содержащие или число или строку. Flash интерпретирует тип данных, как целое число или строку соответственно.

Используйте оператор set вместе с командой call для передачи или получения значений.

Player

Flash 4 или выше.

Пример

Этот пример присваивает переменной, называемой orig_x_pos, оригинальную позицию x мувиклипа ship, чтобы позже можно было вернуть корабль на его стартовую позицию в клипе:

on(release) {	set(x_pos, getProperty ("ship", _x ));}

Это эквивалентно следующей записи:

on(release) {	orig_x_pos = getProperty ("ship", _x );}

Смотрите также


setProperty

S > setProperty

setProperty

Синтаксис

setProperty(target, property, expression);

Аргументы

target Путь к экземпляру мувиклипа, чье свойство нужно изменить.

property Свойство, которое нужно изменить.

expression Значение, присваемое свойству.

Описание

Команда; изменяет свойство экземпляра мувиклипа во время его воспроизведения.

Player

Flash 4 или выше.

Пример

При нажатии кнопки, эта команда присваивает свойству _alpha мувиклипа star значение равное 30 процентам:

on(release) {	setProperty("star", _alpha, 30);}

Смотрите также

getProperty


Sound (object)

S > Sound (object)

Sound (object)

Объект Sound позволяет управлять звуком в отдельном экземпляре мувиклипа или на основной Timeline, если при его создании target не был указан. Для создания экземпляра звукового объекта необходимо использовать конструктор new Sound перед вызовом его методов.

Объект Sound поддерживается только Flash 5 Player.

Список методов для Sound object
Метод | Описание
attachSound | Присоединяет звук, описанный в аргументе.
getPan | Возвращает значение предыдущего вызова setPan. 1
getTransform | Возвращает значение предыдущего вызова setTransform. 1
getVolume | Возвращает значение предыдущего вызова setVolume. 1
setPan | Выставляет левый/правый баланс звука.
setTransform | Выставляет трансформацию для звука.
setVolume | Выставляет громкость звука.
start | Начинает воспроизведение звука сначала или, опционально, с определенной точки, указанной в аргументе.
stop | Останавливает определенный звук или все звуки, которые воспроизводятся в данный момент.

Конструктор для объекта Sound

Синтаксис

new Sound();new Sound(target);

Аргументы

target Название экземпляра мувиклипа, к которому присоединяется объект Sound. Этот аргумент необязателен.

Описание

Метод; создает новый звуковой объект для определенного мувиклипа. Если target не указан, объект Sound будет контролировать все звуки на основной Timeline.

Player

Flash 5 или выше.

Пример

GlobalSound = new Sound();MovieSound = new Sound(mymovie);

От редактора.

  1. На мой взгляд, в родном доке написано не совсем корректно. Правильнее сказать не предыдущего вызова методов set*, а текущего значения этих свойств, т.к. они могли программно и не устанавливаться до вызова метода get*. В этом случае будет возвращено значение запрашиваемого свойства, установленное Flash'ем по умолчанию.


Sound.attachSound

S > Sound.attachSound

Sound.attachSound

Синтаксис

mySound.attachSound("idName");

Аргументы

idName Имя нового экземпляра звука. Оно должно быть тоже самое, что и имя введенное для идентификации в диалоговом окне Symbol Linkage Properties. Этот аргумент должен быть заключен в кавычки (" ").

Описание

Метод; присоединяет звук, указанный в аргументе idName, к определенному объекту Sound. Звук должен быть в библиотеке текущего фильма и идентифицирован для экспорта в диалоговом окне Symbol Linkage Properties. Чтобы начать его воспроизведение, необходимо воспользоваться методом Sound.start.

Player

Flash 5 или выше.

Смотрите также

Sound.start


Sound.getPan

S > Sound.getPan

Sound.getPan

Синтаксис

mySound.getPan();

Аргументы

Нет.

Описание

Метод; возвращает значение уровня баланса, который определен последним вызовом setPan 1, на выходе - целое число от -100 до 100. Эта установка контролирует баланс между левым-правым каналом, как в текущий момент, так и для будущего воспроизведения звука в клипе.

Этот метод общий с методами setVolume и setTransform.

Player

Flash 5 или выше.

Смотрите также

Sound.setPan

Sound.setTransform

От редактора

  1. См. комментарии для Sound (object).


Sound.getTransform

S > Sound.getTransform

Sound.getTransform

Синтаксис

mySound.getTransform();

Аргументы

Нет.

Описание

Метод; возвращает информацию по превращению звука определенного объекта Sound, выставленную последним вызовом setTransform 1.

Player

Flash 5 или выше.

Смотрите также

Sound.setTransform

От редактора

  1. См. комментарии для Sound (object).


Sound.getVolume

S > Sound.getVolume

Sound.getVolume

Синтаксис

mySound.getVolume();

Аргументы

Нет.

Описание

Метод; возвращает значение громкости звука, как целое число от 0 до 100, где 0 - нет звука, и 100 - полная громкость. Значение по умолчанию 100.

Player

Flash 5 или выше.

Смотрите также

Sound.setVolume


Sound.setPan

S > Sound.setPan

Sound.setPan

Синтаксис

mySound.setPan(pan);

Аргументы

pan Целое число, определяющее левый-правый баланс звука. Допустимые значения от -100 до 100, где -100 используется только для левого канала, 100 - только для правого и 0 - равный уровень громкости между двумя каналами.

Описание

Метод; определяет, как звук будет распределяться между левым и правым каналами (колонками). Когда этот метод используется для моно звуков, разница в его разделении между каналами будет определяться только громкостью.

Этот метод общий с методами setVolume и setTransform. Вызов этого метода удаляет и обновляет предыдущие настройки setPan и setTransform.

Player

Flash 5 или выше.

Пример

Следующий пример использует setVolume и setPan для контроля звукового объекта, с определенным именем "u2":

onClipEvent(mouseDown) {// создаем звуковой объект и s = new Sound(this);// присоединяем звук из библиотекиs.attachSound("u2");//выставляем громкость 50%s.setVolume(50);//выключаем звук в правом каналеs.setPan(-100);//начинаем воспроизведение звука с 30-й секунды и проигрываем его 5 разs.start(30, 5);

Смотрите также


Sound.setTransform

S > Sound.setTransform

Sound.setTransform

Синтаксис

mySound.setTransform(soundTransformObject);

Аргументы

soundTransformObject Объект, созданный с помощью универсального конструктора объекта Object.

Описание

Метод; определяет информацию для трансформирования звукового объекта. Этот метод общий с методами setVolume и setPan. Его вызов удаляет и обновляет любые предыдущие установки setPan или setVolume. Он предназначен для экспертов, которые хотят добавить звукам интересные эффекты.

Звуки используют значительный объем дискового пространства и памяти. Так как стерео звук требует вдвое больше данных, чем моно, лучше применять 22-Khz 6-bit моно звуки. Можно использовать метод setTransform для воспроизведения моно звука, как стерео, стерео звука как моно и делать интересные эффекты со звуком.

Аргумент soundTransformObject является объектом, который создается с помощью метода конструктора универсального объекта Object, с параметрами, определяющими распределение звука между левым и правым каналами (колонками).

Параметры для soundTransformObject следующие:

ll Значение характеризующее процентный уровень сигнала левого входа, воспроизводимого в левом динамике (-100 до 100).

lr Значение характеризующее процентный уровень сигнала правого входа, воспроизводимого в левом динамике (-100 до 100).

rr Значение характеризующее процентный уровень сигнала правого входа, воспроизводимого в правом динамике (-100 до 100).

rl Значение характеризующее процентный уровень сигнала левого входа, воспроизводимого в правом динамике (-100 до 100).

Новые параметры представлены в следующей формуле:

leftOutput = left input * ll + right input * lr

rightOutput = right lnput * rr + left input * rl

Значения левого и правого входов определяются типом (моно или стерео) звука в Вашем клипе.

Стерео звуки разделяются на входе равномерно между левой и правой колонками и имеют следующие установки по умолчанию:

ll = 100lr = 0rr = 100rl = 0

Моно звуки воспроизводятся в левом канале и имеют следующие установки по умолчанию:

ll = 100lr = 100rr = 0rl = 0

Player

Flash 5 или выше.

Пример

Следующий пример создает трансформацию звукового объекта, при которой оба канала и левый и правый воспроизводятся в левом канале:

mySoundTransformObject = new ObjectmySoundTransformObject.ll = 100mySoundTransformObject.lr = 100 mySoundTransformObject.rr = 0mySoundTransformObject.rl = 0

Для того, чтобы передать трансформ-информацию в объект Sound, необходимо передать объект в объект Sound используя setTransform:

mySound.setTransform(mySoundTransformObject);

Следующие примеры показывают установки, которые можно определить, используя setTransform, но нельзя определить с помощью setVolume или setPan, даже их сочетанием.

Этот код воспроизводит левый и правый канал в левом канале:

mySound.setTransform(soundTransformObjectLeft);

В вышеупомянутом коде, soundTransformObjectLeft имеет следующие параметры:

11 = 1001r = 100rr = 0rl = 0

Этот код воспроизводит стерео звук, как моно:

setTransform(soundTransformObjectMono);

В вышеупомянутом коде, soundTransformObjectLeft имеет следующие параметры:

ll = 50lr = 50rr = 50rl = 50

Этот код воспроизводит половину громкости левого канала и добавляет остальную часть левого канала к правому каналу:

setTransform(soundTransformObjectHalf);

В вышеупомянутом коде, soundTransformObjectLeft имеет следующие параметры:

11 = 50lr = 0rr = 100rl = 50

Смотрите также

Конструктор для объекта Object


Sound.setVolume

S > Sound.setVolume

Sound.setVolume

Синтаксис

mySound.setVolume(volume);

Аргументы

volume Число от 0 до 100 представляющее уровень громкости. 100 полная мощность и 0 выключить громкость. Значение по умолчанию 100.

Описание

Метод; определяет громкость звукового объекта.

Этот метод общий с методами setPan и setTransform.

Player

Flash 5 или выше.

Пример

Следующий пример определяет громкость в 50% и трансформирует звук с левого в правый канал:

onClipEvent (load) {	i = -100;	s = new sound();	s.setVolume(50);}onClipEvent (enterFrame) {	S.setPan(i++);}

Смотрите также


Sound.start

S > Sound.start

Sound.start

Синтаксис

mySound.start();mySound.start([secondOffset, loop]);

Аргументы

secondOffset Необязательный аргумент, позволяющий начать воспроизведение с определенной точки. Например, если у Вас есть 30-ти секундный звук, и Вам нужно начать его воспроизведение с середины, укажите 15 для аргумента secondOffset. Звук не задерживается на 15 секунд, а начинает играть с 15-ти секундной отметки.

loop Необязательный аргумент, позволяющий задать количество циклов воспроизведения звука.

Описание

Метод; начинает воспроизведение последнего присоединенного звука с начала, если аргумент не определен, или с точки, указанной в аргументе secondOffset.

Player

Flash 5 или выше.

Смотрите также


Sound.stop

S > Sound.stop

Sound.stop

Синтаксис

mySound.stop();mySound.stop(["idName"]);

Аргументы

idName Необязательный аргумент, позволяющий остановить определенный звук. Аргумент idName должен быть заключен в кавычки (" ").

Описание

Метод; останавливает все звуки, воспроизводимые в настоящий момент, или только тот, который определенный аргументом idName.

Player

Flash 5 или выше.

Смотрите также

Sound.start


_soundbuftime

S > _soundbuftime

_soundbuftime

Синтаксис

_soundbuftime = integer;

Аргументы

integer Число секунд, после которых клип переходит в режим stream для музыки.

Описание

Свойство (глобальное); определяет количество секунд для буферизации потокового звука. Значение по умолчанию 5 секунд.

Player

Flash 4 или выше.


startDrag

S > startDrag

startDrag

Синтаксис

startDrag(target);startDrag(target,[lock]);startDrag(target [,lock [,left , top , right, bottom]]);

Аргументы

target Путь к мувиклипу, который нужно переместить.

lock Двоичное значение, определяющее как перемещаемый мувиклип будет прикреплен к указателю мыши. true - по центру, false - точкой, в которой пользователь первый раз нажал по клипу. Этот аргумент необязателен.

left, top, right, bottom Значения, указывающие на координаты родительского клипа и описывающие прямоугольник, в котором будет перемещаться мувиклип. Этот аргумент необязателен.

Описание

Команда; делает мувиклип target перетаскиваемым, во время его воспроизведения. Одновременно только один мувиклип может обладать таким свойством. Как только выполнится команда startDrag, мувиклип становится доступным для перемещения до тех пор, пока не будет остановлен командой stopDrag или пока не будет выполнена команда startDrag для другого мувиклипа.

Пример

Для создания мувиклипа, который пользователь может перемещать в любое место, пока нажата клавиша мыши, присвойте команды startDrag и stopDrag кнопке внутри этого мувика, как описано ниже

on(press) {    startDrag("",true);}on(release) {    stopDrag();}

Смотрите также

stopDrag

_droptarget


stop

S > stop

stop

Синтаксис

stop;

Аргументы

Нет.

Описание

Команда; останавливает воспроизводимый клип. В большинстве случаев эта команда используется для управления клипами путем нажатия кнопок.

Player

Flash 3 или выше.


stopAllSounds

S > stopAllSounds

stopAllSounds

Синтаксис

stopAllSounds();

Аргументы

Нет.

Описание

Команда; останавливает все звуки, которые воспроизводятся в текущий момент, без остановки проигрывания самого клипа. Потоковый звук начнет снова играть, когда проигрыватель пройдет по кадру, в который он включен.

Player

Flash 3 или выше.

Пример

Следующий код может быть введен в кнопку, которая при нажатии выключит все звуки в клипе:

on(release) {	stopAllSounds();}

Смотрите также

Sound (object)


stopDrag

S > stopDrag

stopDrag

Синтаксис

stopDrag();

Аргументы

Нет.

Описание

Команда; останавливает текущую операцию перетаскивания.

Player

Flash 4 или выше.

Пример

Следующие команды останавливают перетаскивание мувиклипа mc, когда пользователь отпустит кнопку мыши:

on(press) {	startDrag("mc");}on(release) {	stopdrag();}

Смотрите также


String (function)

S > String (function)

String (function)

Синтаксис

String(expression);

Аргументы

expression Число, булеан, переменная или объект, преобразуемые в строковое представление.

Описание

Функция; Возвращает строковое представление указанного параметра следующим образом:

Если x булеан, возвращается строка true (истина) или false (ложь).

Если x число, возвращается его десятичное представление.

Если x строка, возвращается строка x.

Если x объект, возвращаемое значение - строковое представление объекта, сгенерированного вызовом строкового свойства объекта, или вызовом object.toString если такого свойства не существует.

Если x мувиклип, возвращаемое значение - путь к нему в слеш (/) нотации.

Если x неопределен, возвращаемое значение - пустая строка.

Player

Flash 3 или выше.

Смотрите также


" " (string delimiter)

S > " " (строковый разделитель)

" " (строковый разделитель)

Синтаксис

"text"

Аргументы

text Любой текст.

Описание

Строковый разделитель; при установке кавычек в начале и в конце строки, они указывают, что строка является литеральной - не переменной, числовым значением или другим ActionScript элементом.

Player

Flash 4 или выше.

Пример

Кавычки в этом операторе указывают, что строка "Prince Edward Island" является литеральной строкой, а не выражением:

province = "Prince Edward Island"

Смотрите также


String (object)

S > String (object)

String (object)

Объект String - оболочка для первоначального строкового типа данных, позволяет использовать методы и свойства объекта String для управления первоначальными строковыми значениями типов. Используя функцию String(), можно преобразовывать значение любого объекта в строку.

Все методы объекта String, за исключением concat, fromCharCode, slice и substr, являются универсальными. Это означает, что сами методы вызывают this.toString перед выполнением их операций и Вы можете использовать эти методы с другими не-строковыми объектами.

Можно вызывать любой метод объекта String, используя конструктор метода new String или литеральное строковое значение. Если Вы определяете строковый литерал, интерпретатор ActionScript автоматически конвертирует его во временный объект String, вызывает метод, а затем удаляет временный объект String. Можно также использовать свойство String.length со строковым литералом.

Важно не путать строковый литерал с экземпляром объекта String. В следующем примере в первой строке создается строковый литерал s1, а во второй, экземпляр объекта String s2.

s1 = "foo" s2 = new String("foo")

Рекомендуется использовать строковые литералы, если Вы определенно не будете использовать объект String, поскольку объекты String могут вести себя неоднозначно.

Описание методов для объекта String
Метод | Описание
charAt | Возвращает номер, указывающий на размещение символа в строке.
charCodeAt | Возвращает значение символа по данному индексу как 16-разрядное целое число между 0 и 65535.
concat | Объединяет текст двух строк и возвращает новую строку.
fromCharCode | Возвращает строку, составленную из символов, указанных в параметрах.
indexOf | Ищите строку и возвращает индекс значения, указанного в параметрах. Если значение найдено больше чем однажды, возвращается индекс первого возникновения. Если значение не найдено, возвращается -1.
lastIndexOf | Возвращает последнее местонахождение подстроки в пределах строки, перед позицией ее начала, указанной в параметре, или -1 если не найдена.
slice | Извлекает часть строки и возвращает новую строку.
split | Разбивает объект String на массив строк, отделяя строку в подстроки.
substr | Возвращает указанное число символов в строке, начиная с местоположения, указанного в параметре.
substring | Возвращает символы между двумя индексами, указанными в параметрах, в строку.
toLowerCase | Преобразовывает строку в нижний регистр и возвращает результат.
toUpperCase | Преобразовывает строку в верхний регистр и возвращает результат.

Список свойств объекта String
Свойство | Описание
length | Возвращает длину строки.

Конструктор для объекта String

Синтаксис

new String(value);

Аргументы

value Начальное значение нового объекта String.

Описание

Конструктор; создает новый объект String.

Player

Flash 5 или выше.

Смотрите также


String.charAt

S > String.charAt

String.charAt

Синтаксис

myString.charAt(index);

Аргументы

index Номер символа в строке, который будет возвращен.

Описание

Метод; возвращает символ, указанный параметром index. Индекс первого символа в строке - 0. Если index не является числом от 0 до string.length - 1, возвращается пустая строка.

Player

Flash 5 или выше.


String.charCodeAt

S > String.charCodeAt

String.charCodeAt

Синтаксис

myString.charCodeAt(index);

Аргументы

index Номер символа, значение которого востребовано.

Описание

Метод; возвращает значение символа, указанного индексом index. Возвращенное значение - 16-разрядное целое число от 0 до 65535.

Этот метод подобен string.charAt за исключением того, что возвращается значение символа в определенном местоположении, вместо подстроки, содержащей символ.

Player

Flash 5 или выше.


String.concat

S > String.concat

String.concat

Синтаксис

myString.concat(value1,...valueN);

Аргументы

значение1,...значениеN Ноль или большее количество значений, которые будут соединены.

Описание

Метод; объединяет указанные значения и возвращает новую строку. В случае необходимости, каждый аргумент value преобразуется к строке и добавляется в конец выходной строки.

Player

Flash 5 или выше.


String.fromCharCode

S > String.fromCharCode

String.fromCharCode

Синтаксис

myString.fromCharCode(c1,c2,...cN);

Аргументы

c1,c2,...cN Символы, которые будут превращены в строку.

Описание

Метод; возвращает строку, составленную из символов, указанных в параметрах.

Player

Flash 5 или выше.


String.indexOf

S > String.indexOf

String.indexOf

Синтаксис

myString.indexOf(value);myString.index of (value, start);

Аргументы

value Целое число или строка, определяющая подстроку, которую нужно искать в пределах myString.

start Целое число, определяющее начальную точку поиска. Этот параметр необязательный.

Описание

Метод; ищет строку и возвращает позицию первого совпадения с указанным значением. Если значение не найдено, метод возвращает -1.

Player

Flash 5 или выше.


String.lastIndexOf

S > String.lastIndexOf

String.lastIndexOf

Синтаксис

myString.lastIndexOf(substring);myString.lastIndexOf(substring, start);

Аргументы

substring Целое число или строка, определяющая строку, которую нужно искать.

start Целое число, определяющее точку начала поиска внутри подстроки. Этот параметр необязательный.

Описание

Метод; ищет строку и возвращает индекс последнего совпадения подстроки, найденной в пределах вызываемой строки. Если подстрока не найдена, метод возвращает -1.

Player

Flash 5 или выше.


String.length

S > String.length

String.length

Синтаксис

string.length

Аргументы

Нет.

Описание

Свойство; возвращает число символов в указанном объекте String. Индекс последнего символа для любой строки x - x.length-1.

Player

Flash 5 или выше.


String.slice

S > String.slice

String.slice

Синтаксис

myString.slice(start, end);

Аргументы

start Номер, определяющий индекс начальной точки сектора. Если start отрицательное число начальная точка определяется с конца строки, где -1 - последний символ.

end Номер, определяющий индекс конца сектора. Если end не определен, сектор включает все символы от начала до конца строки. Если end отрицательное число, то конечная точка определяется с конца строки, где -1 - последний символ.

Описание

Метод; извлекает сектор или подстроку, указанного объекта String, затем возвращает это как новую строку, без изменения оригинального объекта String. Возвращенная строка включает start символ и все символы до (но не включая) end символа.

Player

Flash 5 или выше.


String.split

S > String.split

String.split

Синтаксис

myString.split(delimiter);

Аргументы

delimiter Символ, используемый в качестве разделителя строки.

Описание

Метод; разбивает объект String везде, где встречается определенный аргумент delimiter и возвращает полученные подстроки в виде массива. Если никакой разделитель не определен, возвращенный массив содержит только один элемент - саму строку непосредственно. Если разделитель - пустая строка, каждый символ в объекте String становится элементом в массиве.

Player

Flash 5 или выше.


String.substr

S > String.substr

String.substr

Синтаксис

myString.substr(start, length);

Аргументы

start Целое число, которое указывает позицию первого символа в создаваемой подстроке. Если start отрицательное число, исходная позиция определяется с конца строки, где -1 - последний символ.

length Число символов в создаваемой подстроке. Если length не определен, подстрока включает все символы от начала до конца строки.

Описание

Метод; возвращает символы в строке от индекса, указанного в параметре start, длинной указанной в аргументе length.

Player

Flash 5 или выше.


String.substring

S > String.substring

String.substring

Синтаксис

myString.substring(from, to);

Аргументы

from Целое число, указывающее позицию первого символа в создаваемой подстроке. Допустимые значения для from от 0 до string.length - 1.

to Целое число, которое является 1 + индекс последнего символа в создаваемой подстроке. Допустимые значения для to от 1 до string.length. Если параметр to не определен, конец подстроки есть конец строки. Если from равно to, метод возвращает пустую строку. Если from больше чем to, параметры автоматически меняются прежде, чем функция выполняется.

Описание

Метод; возвращает строку, состоящую из символов между точками, указанными параметрами from и to.

Player

Flash 5 или выше.


String.toLowerCase

S > String.toLowerCase

String.toLowerCase

Синтаксис

myString.toLowerCase();

Аргументы

Нет.

Описание

Метод; возвращает копию объекта String, со всеми символами верхнего регистра, преобразованными в нижний регистр.

Player

Flash 5 или выше.


String.toUpperCase

S > String.toUpperCase

String.toUpperCase

Синтаксис

myString.toUpperCase();

Аргументы

Нет.

Описание

Метод; возвращает копию объекта String, со всеми символами нижнего регистра, преобразованными в верхний регистр.

Player

Flash 5 или выше.


substring

S > substring

substring

Синтаксис

substring(string, index, count);

Аргументы

string Исходная строка, из которой извлекается новая строка.

index Номер первого символа, с которого начинается извлечение.

count Число символов, которые нужно включить в извлеченную строку, не включая индексный символ.

Описание

Строковая функция; извлекает часть символьной строки.

Player

Flash 4 или выше. Эта функция нежелательна в Flash 5.

Смотрите также

String.substring


_target

T-W > _target

_target

Синтаксис

instancename._target

Аргументы

instancename имя экземпляра муви-клипа.

Описание

Свойство (только для чтения); возвращает полный путь (target path) до экземпляра муви-клипа, указанного в аргументе instancename.

Player

Flash 4 или более новый.


targetPath

T-W > targetPath

targetPath

Синтаксис

targetpath(movieClipObject);

Аргументы

movieClipObject Ссылка (например: _root или _parent) на муви-клип, до которого определяется путь (target path).

Описание

Функция; возвращает в виде строки путь (target path) до movieClipObject. Возвращаемая строка имеет дот-нотацию (разделитель параметров в виде точки - прим.перевод.). Если требуется возвращать строку в слэш-нотации, то следует использовать свойство _target.

Player

Flash 5 или более новый.

Пример

Следующие примеры эквивалентны. В первом примере используется дот-нотация, во втором - слэш.

targetPath (Board.Block[index*2+1]) {

play();

}

Это эквивалентно:

tellTarget ("Board/Block:" + (index*2+1)) {

play();

}

См. также

eval


tellTarget

T-W > tellTarget

tellTarget

Синтаксис

tellTarget(target) {
statement;
}

Аргументы

target Строка определяющая путь (target path) до управляемой линейки (Timeline).

statement Команды, направляемые на эту линейку.

Описание

Команда; запускает команды, определенные в аргументе statements на линейке (Timeline), указанной в аргументе target. Команда tellTarget полезна для управления навигацией. Назначьте tellTarget кнопкам, которые остановят или запустят клип с какого-нибудь другого места. Можно также сделать переход на другой кадр в том клипе. Например, назначать tellTarget кнопкам, которые останавливают или запускаю воспроизведение клипа на основной линейке или указывают мувиклипам перейти на определенный кадр.

Команда tellTarget очень похожа на команду with, за исключением того, что with понимает клип или другой объект как target, а tellTarget требует указания пути до клипа и не может управлять объектами.

Player

Flash 3 или более новый. Эта команда нежелательна во Flash 5, рекомендуется использовать команду with.

Пример

Этот tellTarget управляет мувиком с именем ball, расположенном на основной линейке. Первый кадр этого мувиклипа пустой и содержит команду stop, поэтому он остается невидимым. Когда нажимается кнопка, содержащая следующую команду, tellTarget указывает мувиклипу ball перейти на второй кадр и начать воспроизводить анимацию с этого кадра.

on(release) {
    tellTarget("ball") {
        gotoAndPlay(2);
    }
}

См. также

with


this

T-W > this

this

Синтаксис

this

Аргументы

None.

Описание

Ключевое слово; ссылается на объект или экземпляр мувиклипа. Ключевое слово this имеет ту же самую цель и функцию в ActionScript, как и в JavaScript, а так же некоторые дополнительные функциональные возможности. В ActionScript, во время его исполнения, this ссылается на образец (instance) мувиклипа, в котором выполняется скрипт. Когда используется метод вызова, this ссылается на тот объект, который содержит в себе выполненный метод.

Player

Flash 5 или более новый.

Пример

В следующем примере, this ссылается на объект Circle:

function Circle(radius){
    this.radius = radius;
    this.area = math.PI * radius * radius;
}

В этом выражении назначенном кадру, this ссылается на текущий мувиклип:

//установить свойство alpha текущего мувика равным 20.
this._alpha = 20;

В этом выражении, заключенном внутри обработчика onClipEvent, this ссылается на текущий мувиклип:

//когда мувик загружен, запустить для него команду startDrag.

onClipEvent (load) {
 startDrag (this, true);
}

См. также

new


toggleHighQuality

T-W > toggleHighQuality

toggleHighQuality

Синтаксис

toggleHighQuality();

Аргументы

Нет.

Описание

Команда; включает и выключает сглаживание (antialiasing) в флеш-плеере. Это может приводить к замедлению скорости воспроизведения клипа на слабых компьютерах. toggleHighQuality оказывает влияние сразу на весь клип.

Player

Flash 2 или более новый.

Пример

Следующий код может быть вставлен в кнопку, которая при нажатии будет включать/выключють сглаживание:

on(release) {
    toggleHighQuality();
}

См. также


_totalframes

T-W > _totalframes

_totalframes

Синтаксис

instancename._totalframes

Аргументы

instancename имя муви-клипа.

Описание

Свойство (только для чтения); возвращает общее количество кадров в клипе, заданном в аргументе instancename.

Player

Flash 4 или более новый.


trace

T-W > trace

trace

Синтаксис

trace(expression);

Аргументы

expression Строка или выражение, результат обработки которого в режиме тестирования клипа выводится в окне Output.

Описание

Команда; Обрабатывает expression и отображает результаты окне Output во время тестирования клипа.

Используйте trace для создания программных меток и/или вывода в окно Output сообщений при тестировании клипа. Используйте expression параметр для проверки валидности условий или для вывода в Output каких-либо значений. Команда trace подобна функции alert в JavaScript.

Player

Flash 4 или более новый.

Пример

Этот пример взят из игры, в которой "таскаемый" мувик под названием rabbi должен находится по определенному адресу (target). Условный оператор определяет свойство _droptarget и выполняет различные действия, в зависимости от местонахождения rabbi. Команда trace, расположенная в конце скрипта, предназначена для определения местонахождения мувика rabbi и вывода результата в окно Output. Если поведение rabbi не соответствует ожидаемому (например, если указан ошибочный target), значения, выводимые в окно Output командой trace, помогут локализовать и найти ошибку в скрипте.

on(press) {
rabbi.startDrag();
}
on(release) {
if(eval(_droptarget) != target) {
      rabbi._x = rabbi_x;
      rabbi._y = rabbi_y;
} else {
rabbi_x = rabbi._x;
rabbi_y = rabbi._y;
target = "_root.pasture";
}
trace("rabbi_y = " + rabbi_y);
trace("rabbi_x = " + rabbi_x);
stopDrag();
}


typeof

T-W > typeof

typeof

Синтаксис

typeof(expression);

Аргументы

expression Строка, муви-клип, объект или функция.

Описание

Оператор; унарный оператор, помещаемый перед отдельным аргументом (выражением). Результат - строка, определяющая является ли выражение строкой, муви-клипом, объектом или функцией.

Player

Flash 5 или более новый.

Пример

a = typeof ("Hello Word!!!");

Результат:

a = "string"


unescape

T-W > unescape

unescape

Синтаксис

unescape(x);

Аргументы

x Строка с последовательностью шестнадцатеричных (НЕХ) чисел.

Описание

Высокоуровневая функция; оценивает аргумент x как строку, декодирует ее из формата URL-encoded (конвертирует все HEX-последовательности в ASCII символы) и возвращает опять в виде строки.

Player

Flash 5 или более новый.

Пример

Следующий пример иллюстрирует escape-to-unescape процесс конвертации.

escape("Hello{[World]}");

Результат будет следующим:

("Hello%7B%5BWorld%5D%7D');

Использование unescape возвращает в прежний вид:

unescape("Hello%7B%5BWorld%5D%7D")

Результат следующий:

Hello{[World]}


unloadMovie

T-W > unloadMovie

unloadMovie

Синтаксис

unloadMovie(location);

Аргументы

location Значение уровня или пути (target) до выгружаемого муви-клипа.

Описание

Команда; удаляет (выгружает) из флеш-плеера клип, который до этого был загружен с использованием команды loadMovie.

Player

Flash 3 или более новый.

Пример

Следующий пример выгрузит основной клип, оставив пустым окно плеера:

unloadMovie(_root);

Следующий пример выгрузит клип с уровня 15, когда пользователь нажмет на кнопку:

on(press) {
    unloadMovie(_level15);
}

См. также

loadMovie


updateAfterEvent

T-W > updateAfterEvent

updateAfterEvent

Синтаксис

updateAfterEvent(movie clip event);

Аргументы

movie clip event Событие мувиклипа. Можно определить одно из следующих его значений:

mouseMove Действие, инициализируемое при каждом перемещении мыши. Свойства _xmouse и _ymouse определяют текущую позицию мыши.
mouseDown Действие, инициализируемое при нажатии левой кнопки мыши.
mouseUp Действие, инициализируемое при отпускании (отжатии) левой кнопки мыши.
keyDown Действие, инициализируемое при нажатии клавиши клавиатуры. Использует метод Key.getCode для определения нажатой клавиши.
keyUp Действие, инициализируемое при отпускании (отжатии) клавиши клавиатуры. Использует метод key.getCode для определения нажатой клавиши.

Описание

Команда; независимо от значения частоты кадров в секунду (fps), установленной для клипа, обновляет экран после завершения события клипа, определенного в аргументе. Эта команда не указана в панели команд 1. Использование updateAfterEvent с командой drag, определяющей свойства _x и _y в течение перемещения мыши, позволяет объектам перемещаться более гладко, без эффекта мерцающего экрана.

Player

Flash 5 или более новый.

См. также

onClipEvent

От переводчика:
  1. На самом деле указана, находится внизу раздела функций, хотя в этом доке и называется командой (Action). Не указаны те события, которые с ее помощью можно обрабатывать, их придется запомнить и вводить руками. Впрочем, лучше запомнить все команды и их синтаксис и работать в эксперт-режиме без подсказок пакета. Это очень ускоряет написание и отладку скриптов :)


_url

T-W > _url

_url

Синтаксис

instancename._url

Аргументы

instancename имя муви-клипа.

Описание

Свойство (только для чтения); возвращает URL (адрес) SWF-файла, с которого он был загружен.

Player

Flash 4 или более новый.


var

T-W > var

var

Синтаксис

var variableName1 [= value1] [...,variableNameN [=valueN]];

Аргументы

variableName Имя объявляемой переменной.

value Значение присваиваемое переменной.

Описание

Команда; используется для объявления локальных переменных. Если локальные переменные объявляются внутри функции, то они действуют только в ее пределах. Если переменные не объявлены внутри блока, но список команд был выполнен через вызов call, переменные являются локальными и действуют до конца текущего списка. Если переменные не объявлены внутри блока и текущий список команд не выполнялся командой call, переменные не являются локальными.

Player

Flash 5 или более новый.


_visible

T-W > _visible

_visible

Синтаксис

instancename._visible
instancename._visible = Boolean;

Аргументы

Boolean Значения true или false, определяющие будет ли клип видим или нет.

Описание

Свойство; определяет будет ли видим муви-клип, указанный в аргументе instancename. Невидимый мувик является недоступным для пользователя. Например, кнопки в муви-клипе со значением _visible равным false, не могут быть нажаты.

Player

Flash 4 или более новый.


void

T-W > void

void

Синтаксис

void (expression);

Аргументы

expression Любое выражение.

Описание

Оператор; унарный оператор отбрасывающий значение expression и возвращающий неопределенное (undefined) значение. Оператор void часто используется для оценки URL при тестировании побочных эффектов без отображения оцениваемого выражения в окне броузера (сорри, прямее не перевелось). void также используется в операциях сравнения == для тестирования undefined (неопределенных) значений.

Player

Flash 5 или более новый.

Пример

a = void(f2+15);

Результат:

a = undefined


while

T-W > while

while

Синтаксис

while(condition) {
statement(s);
}

Аргументы

condition Условие, проверяемое каждый раз при выполнении команды while. Если результат проверки соответствует истине (true), исполняется оператор(ы), указанный(е) в statement(s).

statement(s) Оператор(ы), исполняемый(е) в том случае, если условие соответствует истине (true).

Описание

Команда; выполняет оператор или серию операторов в цикле, пока условный аргумент соответствует истине (true). В конце каждого while-блока цикл перезапускается, с предварительной проверкой условия. Если условие не соответствует истине (false) или эквивалентно нулю, происходит переходит на следующую после while команду.

Цикл обычно используется для выполнения действий, пока переменная счетчика имеет значение меньше чем определенное условием. В конце каждого цикла счетчик увеличивает свое значение и цикл повторяется, и так происходит до тех пор, пока не счетчик не превысит порогового значения, определенного в условии condition, после чего цикл завершается.

Player

Flash 4 или более новый.

Пример

Это пример дублирования пяти мувиков, каждый из которых получает случайные координаты x и y, свойства xscale, yscale и _alpha. Переменная foo инициализируется со значения 0. Аргумент condition устанавливается таким, что while цикл будет выполнен пять раз или пока значение переменной foo будет меньше 5. Внутри while цикла мувик клонируется и через setProperty получает новые свойства. Последний оператор цикла увеличивает значение foo, и так происходит до тех пор, пока foo не достигнет значения 5, после чего при очередной проверке аргумента condition будет получено false и цикл завершит работу.

on(release) {
    foo = 0;
    while(foo < 5) {
        duplicateMovieClip("/flower", "mc" + foo, foo);
        setProperty("mc" + foo, _x, random(275));
        setProperty("mc" + foo, _y, random(275));
        setProperty("mc" + foo, _alpha, random(275));
        setProperty("mc" + foo, _xscale, random(200));
        setProperty("mc" + foo, _yscale, random(200));
        foo = foo + 1;
    }
}

См. также


_width

T-W > _width

_width

Синтаксис

instancename._width
instancename._width =value;

Аргументы

value Ширина клипа в пикселах.

instancename Имя муви-клипа, у которого изменяется свойство _width (ширина).

Описание

Свойство; устанавливает ширину клипа. В предыдущих версиях Flash свойства _height и _width были доступны только для чтения, во Flash 5 они могут быть заданы.

Player

Flash 4 - только для чтения. Во Flash 5 или более новом это свойство может быть задано.

Пример

Следующий код задает высоту и ширину муви-клипа когда пользователь нажимает на кнопку мыши:

onclipEvent(mouseDown) {
    _width=200;
    _height=200;
}

См. также

_height


with

T-W > with

with

Синтаксис

with (object) {
statement(s);
}

Аргументы

object Экземпляр ActionScript объекта или мувиклипа.

statement(s) Команда или группа команд, заключенных в фигурные скобки.

Описание

Команда; временно изменяет область контекстного действия (или путь), используемые для определения выражений и команд в statement(s). После выполнения команды with, область действия восстанавливается к первоначальному значению.

Object соответствует контекстной области, в которой читаются свойства, переменные и функции. Например, если object - myArray и два его свойства определены, как length и concat, эти свойства автоматически читаются как myArray.length и myArray.concat. В другом примере, если object есть state.california, то это то же самое, как если бы любая команда или операторы внутри команды with были вызваны изнутри экземпляра california.

Для нахождения значения идентификатора в statement(s), ActionScript начинает поиск в начале контекстной области, определенной object и ищет их в каждом уровне контекста в характерном порядке.

Контекстная область, используемая командой with, определяет идентификаторы начиная с первого элемента следующего списка и до последнего:

object вызванный изнутри команды with
object вызванный наиболее удаленным местом команды with
Активированный объект (временный объект, созданный автоматически, когда функция вызвана для хранения локальных переменных.)
Мувиклип, содержащий текущий исполняемый скрипт
Глобальный объект (предопределенные объекты, такие как Math, String)

Во Flash 5 команда with заменяет нежелательную команду tellTarget. Предпочтительнее использовать with вместо tellTarget, потому что стандарт ActionScript расширен к стандарту ECMA-262. Принципиальное различие между with и tellTarget командами то, что with обращается к клипу или другим объектам как к их аргументам, в то время как tellTarget обращается к пути (target path), идентифицирующем мувиклип и не может использовать объекты.

Для установки переменной внутри команды with, она должна быть объявлена снаружи или должен быть введен полный путь до линейки (Timeline) на которой необходимо разместить переменную. Если вы установили переменную в команде with без ее объявления, команда with будет искать значение согласно контексту. Если переменная уже не существует, новое значение будет установлено на линейке, с которой команда with была вызвана.

Пример

Следующий пример устанавливает свойства x и y экземпляра someOtherMovieClip и затем командует ему перейти на третий кадр и остановиться:

with (someOtherMovieClip) {
    _x = 50;
    _y = 100;
    gotoAndStop(3);
}

Следующий отрывок кода показывает, как можно написать предшествующий пример без использования команды with:

someOtherMovieClip._x = 50;
someOtherMovieClip._y = 100;
someOtherMovieClip.gotoAndStop(3);

Этот код также можно написать с использованием команды tellTarget:

tellTarget ("someOtherMovieClip") {
    _x = 50;
    _y = 100;
    gotoAndStop(3);
}

Использование команды with полезно для одновременного вызова многих элементов в контекстном листе. В следующем примере встроенный объект Math помещен в начало объектной области (контекста). Установка Math, как объекта по умолчанию, приводит идентификаторы cos, sin и PI к Math.cos, Math.sin и Math.PI соответственно. Идентификаторы a, x, y и r - не методы или свойства объекта Math, но так как они существуют в объектной области (контексте) функции polar, они приводятся к к соответствующим локальным переменным.

function polar(r){
    var a, x, y
    with (Math) {
        a = PI * r * r
        x = r * cos(PI)
        y = r * sin(PI/2)
}
trace("area = " +a)
trace("x = " + x)
trace("y = " + y)
}

Возможно использование вложенных команд with для доступа к информации во многих контекстных областях. В следующем примере экземпляры fresno и salinas являются дочерними по отношению к california. Оператор устанавливает значения _alpha для fresno и salinas без изменения значения _alpha у california.

with (california){
    with (fresno){
        _alpha = 20;
    }
    with (salinas){
        _alpha = 40;
    }
}

См. также

tellTarget


_x

X-Z > _x

_x

Синтаксис

instancename._xinstancename._x = integer

Аргументы

integer Локальная x-координата клипа.

instancename Имя экземпляра клипа.

Описание

Свойство; устанавливает x-координату клипа относительно локальных координат родительского клипа. Если клип расположен на главной монтажной линейке, то начало его системы координат (0, 0), находится в верхнем левом углу рабочего окна. Если клип вложен внутрь другого трансформированного клипа, он находится в локальной системе координат родительского клипа. Таким образом, после поворота родительского клипа на 90° против часовой стрелки, его дочерние клипы унаследуют систему координат, повернутую на 90° против часовой стрелки. Координаты клипа относятся к его точке отсчета (registration point).

Player

Flash 3 или выше.

Смотрите также


XML (object)

X-Z > XML (object)

XML (object)

Используйте методы и свойства объекта XML, чтобы загружать, анализировать, посылать, формировать и управлять XML деревьями документов.

Вы должны использовать конструктор new XML(), чтобы создать экземпляр объекта XML перед вызовом любого из методов объекта XML.

XML поддерживается Flash Player версии Flash 5 или выше.

Список методов для объекта XML
Метод | Описание
appendChild | Добавляет узел к концу дочернего списка указанного объекта.
cloneNode | Клонирует указанный узел и, опционально, рекурсивно клонирует все дочерние записи.
createElement | Создает новый элемент XML.
createTextNode | Создает новый текстовый узел XML.
hasChildNodes | Возвращает true, если указанный узел имеет подчиненные узлы, в противном случае, возвращает false.
insertBefore | Вставляет узел перед существующим узлом в дочернем списке указанного узла.
load | Загружает документ (указанный объектом XML) с адреса URL.
onLoad | Функция повторного вызова для load и sendAndLoad.
parseXML | Анализирует XML документ в указанное дерево объекта XML.
removeNode | Удаляет указанный узел из его родителя.
send | Посылает указанный объект XML на адрес URL.
sendAndLoad | Посылает указанный объект XML на адрес URL и загружает ответ сервера в другой объект XML.
toString | Преобразовывает указанный узел и любые дочерние записи в текст XML.

Список свойств объекта XML
Свойство | Описание
docTypeDecl | Устанавливает и возвращает информацию об объявлениях DOCTYPE в XML документах.
firstChild | Ссылки на первый подчиненный объект в списке для указанного узла.
lastChild | Ссылки на последний подчиненный объект в списке для указанного узла.
loaded | Проверяет загружен ли указанный объект XML.
nextSibling | Ссылки на следующего брата в дочернем списке родительского узла.
nodeName | Возвращает имя тега элемента XML.
nodeType | Возвращает тип указанного узла (XML элемента или текстового узла).
nodeValue | Возвращает текст выбранного узла, если узел является текстовым.
parentNode | Ссылки на родительскую вершину указанного узла.
previousSibling | Ссылки на предыдущего брата в дочернем списке родительского узла.
status | Возвращает числовой код состояния, указывающий успех или неудачу операции синтаксического анализа документа XML.
xmlDecl | Устанавливает и возвращает информацию об объявлениях документов в документе XML.

Список групповых операций над объектами XML
Метод | Описание
attributes | Возвращает ассоциативный массив, содержащий все атрибуты указанного узла.
childNodes | Возвращает массив, содержащий ссылки на подчиненные объекты указанного узла.

Конструктор для объекта XML

Синтаксис

new XML();new XML(source);

Аргументы

source Анализируемый документ XML для создания нового объекта XML.

Описание

Конструктор; создает новый объект XML. Вы должны использовать конструктор для создания экземпляра объекта XML перед вызовом его любых методов.

Первый синтаксис создает новый, пустой объект XML.
Второй синтаксис создает новый объект XML, анализируя XML документ, указанный в source параметре и заполняет созданный объект XML деревом XML документа.

Примечание: Методы createElement и createTextnode являются "конструкторскими" методами для создания элементов и текстовых узлов в дереве XML документа.

Player

Flash 5 или выше.

Пример

Следующий пример создает новый пустой объект XML:

myXML = new XML();

Смотрите также


XML.appendChild

X-Z > XML.appendChild

XML.appendChild

Синтаксис

myXML.appendChild(childNode);

Аргументы

childNode Дочерний узел, добавляемый в список дочерних объектов указанного XML объекта.

Описание

Метод; добавляет указанный дочерний узел в список объекта XML. Добавляемый дочерний узел будет размещен в древовидной структуре и удален из существующего родительского узла, если такой существует.

Player

Flash 5 или выше.

Пример

Следующий пример клонирует последний узел из doc1 и добавляет его в doc2:

doc1 = new XML(src1);doc2 = new XML();node = doc1.lastChild.cloneNode(true);doc2.appendChild(node);


XML.attributes

X-Z > XML.attributes

XML.attributes

Синтаксис

myXML.attributes;

Аргументы

Нет.

Описание

Совокупность (чтение - запись); возвращает ассоциативный массив, содержащий все атрибуты указанного XML объекта.

Player

Flash 5 или выше.

Пример

Следующий пример записывает, имена XML атрибутов в Окно вывода:

str = "<mytag name=\"Val\"> intem </mytage>";doc = new XML(str);y = doc.fristChild.attributes.name;	trace (y);doc.firstChild.attributes.order = "first";z = doc.firstChild.attributes.order	trace(z);

В окне Output будет показан следующий результат:

ValFirst


XML.childNodes

X-Z > XML.childNodes

XML.childNodes

Синтаксис

myXML.childNodes;

Аргументы

Нет.

Описание

Совокупность (только для чтения); возвращает массив указанных дочерних записей объекта XML. Каждый элемент в массиве есть ссылка на объект XML, который представляет дочернюю вершину. Это свойство только для чтения и не может использоваться для управления дочерними вершинами. Чтобы управлять ими, используйте методы appendChild, insertBefore и removeNode.

Эта совокупность неопределена для текстовых узлов (nodeType == 3).

Player

Flash 5 или выше.


XML.cloneNode

X-Z > XML.cloneNode

XML.cloneNode

Синтаксис

myXML.cloneNode(deep);

Аргументы

deep Булево значение, определяющее, клонируются ли дочерние записи указанного объекта XML рекурсивно.

Описание

Метод; создает и возвращает новый узел XML того же самого типа, имени, значения и атрибутов, как указанный объект XML. Если deep установлен в true, все дочерние вершины рекурсивно клонируются, создавая точную копию дерева документов первоначального объекта

Player

Flash 5 или выше.


XML.createElement

X-Z > XML.createElement

XML.createElement

Синтаксис

myXML.createElement(name);

Аргументы

name Тег (tag) имени создаваемого элемента XML.

Описание

Метод; создает новый XML элемент с именем, указанным в параметре. Новый элемент первоначально не имеет никакого родителя и никаких дочерних записей. Метод возвращает ссылку на недавно созданный объект XML, представляющий элемент. Этот метод и createTextNode - методы конструктора для создания узлов для объекта XML.

Player

Flash 5 или выше.


XML.createTextNode

X-Z > XML.createTextNode

XML.createTextNode

Синтаксис

myXML.createTextNode(text);

Аргументы

text Текст, используемый для создания нового текстового узла.

Описание

Метод; создает новый текстовый узел XML с указанным текстом. Новый узел первоначально не имеет никакого родителя и текстовые узлы не могут иметь дочерние записи. Этот метод возвращает ссылку на объект XML, представляющий новый текстовый узел. Этот метод и createElement - методы конструктора для создания узлов для объекта XML.

Player

Flash 5 или выше.


XML.docTypeDecl

X-Z > XML.docTypeDecl

XML.docTypeDecl

Синтаксис

myXML.XMLdocTypeDecl;

Аргументы

Нет.

Описание

Свойство; устанавливает и возвращает информацию об объявлении DOCTYPE документа XML. После анализа текста XML в объекте XML, свойство XML.docTypeDecl объекта XML устанавливается в текст объявления DOCTYPE документа XML. Например,

<!DOCTYPE greeting SYSTEM hello.dtd">.

Это свойство установлено используя текстовое представление объявления DOCTYPE, не является узлом объекта XML.

Синтаксический анализатор ActionScript XML не является анализатором достоверности. Объявление DOCTYPE читается синтаксическим анализатором и сохраняется в свойсте docTypeDecl, но никакая проверка правильности DTD не выполняется.

Если в течение операции синтаксического анализа не попалось никакого объявления DOCTYPE, XML.docTypeDecl устанавливается в неопределенный. XML.toString выводит содержимое XML.docTypeDecl немедленно после XML объявления, сохраненного в XML.xmlDecl и перед любым другим текстом в объекте XML. Если XML.docTypeDecl неопределен, никакое DOCTYPE объявление не выводится.

Player

Flash 5 или выше.

Пример

Следующий пример использует XML.docTypeDecl, чтобы установить DOCTYPE объявление для объекта XML.

myXML.docTypeDecl = "<!DOCTYPE greeting SYSTEM \"hello.dtd\">";

Смотрите также


XML.firstChild

X-Z > XML.firstChild

XML.firstChild

Синтаксис

myXML.firstChild;

Аргументы

Нет.

Описание

Свойство (только чтение); определяет заданный XML объект и указывает на первый объект в списке подчиненных объектов родительского узла. Это свойство принимает значение null, если родительский узел не имеет подчиненных объектов. Это свойство неопределенно, если узел является текстовым узлом. Это свойство только для чтения, поэтому оно не может применяться для управления подчиненными объектами, используйте для этих целей методы appendChild, insertBefore и removeNode.

Player

Flash 5 или выше.

Смотрите также


XML.haschildNodes

X-Z > XML.haschildNodes

XML.haschildNodes

Синтаксис

myXML.hasChildNodes();

Аргументы

Нет.

Описание

Метод; определяет указанный объект XML и возвращает true, если существуют подчиненные объекты, иначе возвращает false.

Player

Flash 5 или выше.

Пример

Следующий пример использует информацию из объекта XML в определенной пользователем функции:

if (rootNode.hasChildNodes()) {	myfunc (rootNode.firstChild);}


XML.insertBefore

X-Z > XML.insertBefore

XML.insertBefore

Синтаксис

myXML.insertBefore(childNode, beforeNode);

Аргументы

childNode Вставляемый узел.

beforeNode Узел, перед которым будет вставлен childNode.

Описание

Метод; вставляет новый подчиненный узел в список подчиненных узлов объекта XML, перед beforeNode.

Player

Flash 5 или выше.


XML.lastChild

X-Z > XML.lastChild

XML.lastChild

Синтаксис

myXML.lastChild;

Аргументы

Нет.

Описание

Свойство (только чтение); определяет заданный XML объект и указывает на последний объект в списке подчиненных объектов родительского узла. Это свойство принимает значение null, если родительский узел не имеет подчиненных объектов. Это свойство только для чтения, поэтому оно не может применяться для управления подчиненными объектами, используйте для этих целей методы appendChild, insertBefore и removeNode.

Player

Flash 5 или выше.

Смотрите также


XML.load

X-Z > XML.load

XML.load

Синтаксис

myXML.load(url);

Аргументы

url URL (ссылка) XML документа, который нужно загрузить. URL должен быть в том же поддомене, в котором находится текущий клип.

Описание

Метод; загружает XML документ с определенного адреса и замещает содержимое указанного объекта XML новыми загруженными данными XML. Процесс загрузки является асинхронным, он не заканчивается сразу после выполнения метода load. Когда метод load выполнен, свойство loaded объекта XML устанавливается в false. По окончании загрузки данных XML, свойство loaded устанавливается в true и выполняется метод onLoad. Данные XML не анализируются, пока они полностью не загружены. Если объект XML содержал любую древовидную структуру XML, она будет удалена.

Можно определить вашу собственную функцию повторного вызова на месте метода onLoad.

Player

Flash 5 или выше.

Пример

Ниже приведен простой пример, использующий XML.load:

doc = new XML();doc.load ("theFile.xml");

Смотрите также


XML.loaded

X-Z > XML.loaded

XML.loaded

Синтаксис

myXML.loaded;

Аргументы

Нет.

Описание

Свойство (только чтение); определяет, завершен ли процесс загрузки документа, инициализированный запросом XML.load. Если процесс загрузки завершен полностью, метод возвращает true, в противном случае - false.

Player

Flash 5 или выше.

Пример

Следующий пример использует XML.loaded в простой команде.

if (doc.loaded) {	gotoAndPlay(4)}


XML.nextSibling

X-Z > XML.nextSibling

XML.nextSibling

Синтаксис

myXML.nextSibling;

Аргументы

Нет.

Описание

Свойство (только для чтения); оценивает объект XML и ссылки следующего брата в дочернем списке родительского узла. Этот метод возвращает null, если узел не имеет следующего братского узла. Это свойство только для чтения и не может использоваться для управления дочерними вершинами. Используйте методы appendChild, insertBefore и removeNode для управления дочерними узлами.

Player

Flash 5 или выше.

Смотрите также


XML.nodeName

X-Z > XML.nodeName

XML.nodeName

Синтаксис

myXML.nodeName;

Аргументы

Нет.

Описание

Свойство; получает или возвращает имя узла объекта XML. Если объект XML есть XML элемент (nodeType == 1), nodeName это имя тега, представляющего узел в файле XML. Например, TITLE является nodeName HTML-тега TITLE. Если объект XML является текстовым узлом (nodeType == 3), nodeName принимает значение null.

Player

Flash 5 или выше.

Смотрите также

XML.nodeType


XML.nodeType

X-Z > XML.nodeType

XML.nodeType

Синтаксис

myXML.nodeType;

Аргументы

Нет.

Описание

Свойство (только чтение); получает или возвращает значение nodeType, где 1 - элемент XML и 3 - текстовый узел.

Player

Flash 5 или выше.

Смотрите также

XML.nodeValue


XML.nodeValue

X-Z > XML.nodeValue

XML.nodeValue

Синтаксис

myXML.nodeValue;

Аргументы

Нет.

Описание

Свойство; возвращает значение узла объекта XML. Если объект XML является текстовым узлом, nodeType имеет значение 3, а nodeValue принимает значение текста узла. Если объект XML является элементом XML, он имеет null nodeValue и свойство используется только для чтения.

Player

Flash 5 или выше.

Смотрите также

XML.nodeType


XML.onLoad

X-Z > XML.onLoad

XML.onLoad

Синтаксис

myXML.onLoad(success);

Аргументы

success Булево значение, указывающее, был ли объект XML успешно загружен операцией XML.load или XML.sendAndLoad.

Описание

Метод; вызывается Flash Player'ом, когда XML документ загружен с сервера. Если документ XML загружен успешно, аргумент success принимает значение true. Если документ не загружен или произошла ошибка подключения к серверу, аргумент success принимает значение false. Заданная по умолчанию реализация этого метода не активна. Чтобы отменить действие по умолчанию, Вы должны назначить функцию, содержащую ваши собственные команды.

Player

Flash 5 или выше.

Пример

Следующий пример создает простой клип для простого приложения веб-магазина. Мы используем метод sendAndLoad для передачи XML элемента, содержащего имя пользователя и пароль, и устанавливаем обработчик onLoad, чтобы проверить ответ от сервера.

var myLoginReply = new XML();myLoginReply.onLoad = myOnLoad;myXML.sendAndLoad("http://www.samplestore.com/login.cgi",						myLoginReply);function myOnLoad(success) {	if (success) {		if (e.firstChild.nodeName == "LOGINREPLY" &&				e.firstChild.attributes.status == "OK") {			gotoAndPlay("loggedIn")		} else {			gotoAndStop("loginFailed")		}	} else {		gotoAndStop("connectionFailed")	}}

Смотрите также


XML.parentNode

X-Z > XML.parentNode

XML.parentNode

Синтаксис

myXML.parentNode;

Аргументы

Нет.

Описание

Свойство (только чтение); ссылается на родительский узел указанного объекта XML или возвращает null, если у узла нет родителя. Это свойство только для чтения и оно не может быть использовано для управления подчиненными узлами, для этих целей используйте методы appendChild, insertBefore и removeNode.

Player

Flash 5 или выше.


XML.parseXML

X-Z > XML.parseXML

XML.parseXML

Синтаксис

myXML.parseXML(source);

Аргументы

source XML текст, который нужно проанализировать и передать определенному XML объекту.

Описание

Метод; анализирует текст XML, указанный в аргументе source и вставляет указанный объект XML в XML дерево. Любые существующие деревья в объекте XML будут отвергнуты.

Player

Flash 5 или выше


XML.previousSibling

X-Z > XML.previousSibling

XML.previousSibling

Синтаксис

myXML.previousSibling;

Описание

Свойство (только для чтения); оценивает объект XML и ссылки на предыдущего брата в дочернем списке родительского узла. Возвращает null, если узел не имеет предыдущего братского узла. Это свойство только для чтения и не может быть использовано, чтобы управлять дочерними узлами, используйте методы appendChild, insertBefore и removeNode для управления дочерними узлами.

Player

Flash 5 или выше.


XML.removeNode

X-Z > XML.removeNode

XML.removeNode

Синтаксис

myXML.removeNode();

Аргументы

Нет.

Описание

Метод; удаляет указанный объект XML из его родителя.

Player

Flash 5 или выше.


XML.send

X-Z > XML.send

XML.send

Синтаксис

myXML.send(url);myXML.send(url, window);

Аргументы

url Адрес URL для указанного объекта XML.

window Окно броузера для отображения данных, возвращенных сервером: _self указывает на текущий фрейм текущего окна, _blank указывает новое окно, _parent указывает на родителя текущего фрейма и _top указывает на фрейм верхнего уровня текущего окна.

Описание

Метод; кодирует указанный объект XML в документ XML и посылает его на указанный адрес URL, используя метод POST.

Player

Flash 5 или выше.


XML.sendAndLoad

X-Z > XML.sendAndLoad

XML.sendAndLoad

Синтаксис

myXML.sendAndLoad(url,targetXMLobject);

Аргументы

url Адресат URL для указанного объекта XML. URL должен быть в том же поддомене, что и URL, откуда был загружен клип.

targetXMLobject Объект XML, созданный конструктивным методом XML, который будет принимать и отправлять информацию на(с) сервер(а).

Описание

Метод; Кодирует указанный объект XML в документ XML, посылает его на указанный URL, используя метод POST, загружает ответ сервера и тогда передает его в targetXMLobject, указанный в аргументе. Ответ сервера загружается тем же самым способом, который используется в методе load.

Player

Flash 5 или выше.

Смотрите также

XML.load


XML.status

X-Z > XML.status

XML.status

Синтаксис

myXML.status;

Аргументы

Нет.

Описание

Свойство; автоматически устанавливает и возвращает числовое значение, указывающее, успешно ли был проведен синтаксический анализ документа XML в объекте XML. Ниже приведен список числовых кодов состояния и описание каждого:

0 Нет ошибок; Синтаксический анализ закончен успешно
-2 Раздел CDATA не был закончен должным образом.
-3 Объявление XML не было закончено должным образом.
-4 Объявление DOCTYPE не было закончено должным образом.
-5 Комментарий не был закончен должным образом.
-6 XML элемент неверен.
-7 Не хватает памяти.
-8 Значение атрибута не было закончено должным образом.
-9 Тег начала не был согласован с конечным тегом.
-10 Конечный тег указан без соответствующего начального тега.

Player

Flash 5 или выше.


XML.toString

X-Z > XML.toString

XML.toString

Синтаксис

myXML.toString();

Аргументы

Нет.

Описание

Метод; оценивает указанный объект XML, строит тестовое представление структуры XML включая узел, дочерние записи и атрибуты, и возвращает результат как строку.

Для объектов XML верхнего уровня (созданных конструктором), XML.toString выводит объявление документа XML (сохраненное в XML.xmlDecl), объявление DOCTYPE (сохраненное в XML.docTypeDecl) и текстовое представление всех XML узлов в объекте. XML объявление не выводится, если XML.xmlDecl неопределен. DOCTYPE объявление не выводится, если XML.docTypeDecl неопределен.

Player

Flash 5 или выше.

Пример

Следующий код является примером использования метода XML.toString:

node = new XML("<h1>test</h1>");trace(node.toString());sends<H1>test</H1>to the output window

Смотрите также


XML.xmlDecl

X-Z > XML.xmlDecl

XML.xmlDecl

Синтаксис

myXML.xmlDecl;

Аргументы

Нет.

Описание

Свойство; устанавливает и возвращает информацию относительно XML объявления. После того, как документ XML проанализирован в объекте XML, это свойство устанавливается, используя объявление документа XML. Это свойство устанавливается в строковое представление объявления XML, а не в объект узла XML. Если во время операции синтаксического анализа не было никаких объявлений XML, свойство неопределено. XML.toString выводит содержимое XML.xmlDecl перед любым другим текстом в объекте XML. Если XML.xmlDecl содержит тип undefined (неопределенный), никакое объявление XML не выводится.

Player

Flash 5 или выше.

Пример

Следующий пример использует XML.xmlDecl для того, чтобы установить объявление документа XML для XML объекта:

myXML.xmlDecl = "<?xml version=\"1.0\" ?>";

Смотрите также


XMLSocket (object)

X-Z > XMLSocket (object)

XMLSocket (object)

Объект XMLSocket осуществляет связь компьютера, на котором запущен Flash Player, с сервером, идентифицируя его по IP адресу или по доменному имени.

Использование объекта XMLSocket

Чтобы использовать объект XMLSocket, компьютер-сервер должен запустить "daemon", который понимает протокол объекта XMLSocket. Протоколы следующие:

XML сообщение передается через полное дуплексное потоковое TCP/IP соединение.
Каждое сообщение XML является законченным документом XML, заканчивающееся нулевым байтом.
Неограниченное количество сообщений XML может быть передано и принято за одно соединение XMLSocket.

Объект XMLSocket полезен для клиент-серверных приложений, которые требуют малого времени ожидания, типа чат-систем реального времени. Традиционные чат-системы, основанные на HTTP, часто опрашивают сервер и загружают с него новые сообщения, используя HTTP запрос. Напротив, чат-системы основанные на XMLSocket, поддерживают открытое подключение к серверу, которое позволяет серверу немедленно посылать входящие сообщения без запроса от клиента.

Установка сервера на постоянную связь с объектом XMLSocket может быть нежелательна. Если Ваше приложение не требует интерактивности в реальном времени, используйте loadVariables или XML связь с сервером, основанную на HTTP (XML.load, XML.sendAndLoad, XML.send), вместо объекта XMLSocket.

Для использования методов объекта XMLSocket, сначала необходимо использовать конструктор new XMLSocket, чтобы создать новый объект XMLSocket.

XMLSocket и безопасность

Поскольку объект XMLSocket устанавливает и поддерживает открытое подключение к серверу, из соображений безопасности в объект XMLSocket были помещены следующие ограничения:

Метод XMLSocket.connect может соединиться только с TCP портами, номера которых больше или равны 1024. Одно последствие этого ограничения - то, что серверный "daemons", который связывается с объектом XMLSocket, должен также быть назначен на порт больше или равный 1024. Порты номерами ниже 1024 часто используются системными сервисами, такими как FTP, Telnet и HTTP, поэтому объект XMLSocket не допускается к этим портам. Ограничение номеров портов ограничивает возможность того, что к этим ресурсам будут неуместно обращаться и неправильно эксплуатировать.
Метод XMLSocket.connect может соединиться только с компьютером в том-же поддомене, где расположен файл SWF (клип). Это ограничение не применяется к клипам, выполняемым на локальном диске. (Это ограничение идентично правилам безопасности для loadVariables, XML.sendAndLoad и XML.load.)

Список методов для объекта XMLSocket
Метод | Описание
close | Закрывает открытое сокетное соединение.
connect | Устанавливает связь с указанным сервером.
onClose | Возвратная функция, которая вызывается, когда XMLSocket соединение закрыто.
onConnect | Возвратная функция, которая вызывается, когда XMLSocket соединение установлено.
onXML | Возвратная функция, которая вызывается, когда с сервера прибывает объект XML.
send | Посылает объект XML на сервер.

Конструктор для объекта XMLSocket

Синтаксис

new XMLSocket();

Аргументы

Нет.

Описание

Конструктор; создает новый объект XMLSocket. Объект XMLSocket первоначально не связан ни с каким сервером. Вы должны вызвать метод XMLSocket.connect, чтобы связать объект с сервером.

Player

Flash 5 или выше.

Пример

myXMLSocket = new XMLSocket();

Смотрите также

XMLSocket.connect


XMLSocket.close

X-Z > XMLSocket.close

XMLSocket.close

Синтаксис

myXMLSocket.close();

Аргументы

Нет.

Описание

Метод; закрывает связь, указанную объектом XMLSocket.

Player

Flash 5 или выше.

Смотрите также

XMLSocket.connect


XMLSocket.connect

X-Z > XMLSocket.connect

XMLSocket.connect

Синтаксис

myXMLSocket.connect(host, port);

Аргументы

host Полностью квалифицированное имя домена DNS или адрес IP в виде aaa.bbb.ccc.ddd. Вы также можете указать null, чтобы связаться с сервером, на котором размещен клип.

port Номер TCP порта главного компьютера для установления связи. Номер порта должен быть равен 1024 или выше.

Описание

Метод; устанавливает подключение к указанному хосту Internet, используя указанный порт TCP (должен быть 1024 или выше) и возвращает true или false, в зависимости от того, установилось ли соединение. Если Вы не знаете номер порта Вашего Internet хоста, свяжитесь с Вашим сетевым администратором. Если используется Flash Netscape плагин или ActiveX компонент, хост указанный в аргументе должен иметь тот же поддомен, что и хост, с которого загружен клип.

Если Вы укажете null для аргумента host, произойдет связь с хостом, в котором находиться клип, вызвавший XMLSocket.connect. Например, если клип загружен с http://www.yoursite.com, указать null аргументу host тоже самое, что и ввести IP адрес www.yoursite.com.

Если XMLSocket.connect возвращает значение true, значит начальная стадия процесса подключения прошла успешно, потом метод XMLSocket.onConnect вызывается для того, чтобы определить, успешно ли прошло соединение. Если XMLSocket.connect возвращает false, значит соединение не удалось.

Player

Flash 5 или выше.

Пример

Следующий пример использует XMLSocket.connect для соединения с хостом, на котором он размещен и trace для вывода значения, показывающего успешно ли прошло соединение:

function myOnConnect(success) {	if (success) {		trace ("Connection succeeded!")  } else {		trace ("Connection failed!")	}}socket = new XMLSocket()socket.onConnect = myOnConnectif (!socket.connect(null, 2000)) {	trace ("Connection failed!")}

Смотрите также


XMLSocket.onClose

X-Z > XMLSocket.onClose

XMLSocket.onClose

Синтаксис

myXMLSocket.onClose();

Аргументы

Нет.

Описание

Метод; возвращающая функция, которая вызывается только в том случае, если связь закрыта сервером. Заданная по умолчанию реализация этого метода не выполняет никаких действий. Чтобы отменить заданное по умолчанию выполнение, Вы должны назначить функцию, содержащую ваши собственные действия.

Player

Flash 5 или выше.

Смотрите также


XMLSocket.onConnect

X-Z > XMLSocket.onConnect

XMLSocket.onConnect

Синтаксис

myXMLSocket.onConnect(success);

Аргументы

success Булево значение, указывающее, было ли подключение установлено успешно (true или false).

Описание

Метод; возвращающая функция, вызываемая Flash Player, когда запрос подключения, инициализированный через метод XMLSocket.connect удался или потерпел неудачу. Если связь удалась, аргумент success принимает значение true, иначе аргумент success принимает значение false.

Заданная по умолчанию реализация этого метода не выполняет никаких действий. Чтобы отменить заданное по умолчанию выполнение, Вы должны назначить функцию, содержащую ваши собственные действия.

Player

Flash 5 или выше.

Пример

Следующий пример иллюстрирует процесс определения функции замены для метода onConnect в простом чат-приложении.

Функция контролирует, какой экран показать пользователю в зависимости от того, успешно ли прошло подключение. Если соединение состоялось, пользователь получает основной экран чата в кадре с меткой startChat. Если соединение не состоялось, пользователь переходит на экран с информацией о проблеме связи в кадре с меткой connectionFailed.

function myOnConnect(success) {	if (success) {		gotoAndPlay("startChat")	} else {		gotoAndStop("connectionFailed")	}}

После создания объекта XMLSocket с помощью конструктивного метода, скрипт инициализирует метод onConnect с помощью оператора присвоения:

socket = new XMLSocket()socket.onConnect = myOnConnect

Наконец, подключение инициализировано. Если connect возвращает false, клип направляется прямо на кадр c меткой connectionFailed и onConnect не вызывается. Если connect возвращает true, клип переходит на кадр с меткой waitForConnection, в котором размещен экран "Пожалуйста подождите". Клип остается на кадре waitForConnection, пока не сработает обработчик onConnect, что может произойти через некоторое время, в зависимости от скорости сети.

if (!socket.connect(null, 2000)) {	gotoAndStop("connectionFailed")} else {	gotoAndStop("waitForConnection")}

Смотрите также


XMLSocket.onXML

X-Z > XMLSocket.onXML

XMLSocket.onXML

Синтаксис

myXMLSocket.onXML(object);

Аргументы

object Экземпляр XML объекта, содержащий анализируемый документ XML, принятый с сервера.

Описание

Метод; возвращающая функция, которая вызывается Flash Player, когда указанный объект XML, содержащий XML документ прибывает через открытую XMLSocket связь. Связь XMLSocket может быть использована для передачи неограниченного числа документов XML между клиентом и сервером. Каждый документ заканчивается нулевым байтом. Когда Flash Player принимает нулевой байт, он анализирует все принятые XML с последнего нулевого байта или с тех пор, как состоялось соединение, если принято первое сообщение. Каждый пакет анализируемого XML обрабатывается, как одиночный документ XML и передается методу onXML.

Заданная по умолчанию реализация этого метода не выполняет никаких действий. Чтобы отменить заданное по умолчанию выполнение, Вы должны назначить функцию, содержащую действия, которые Вы определяете.

Player

Flash 5 или выше.

Пример

Следующая функция отменяет заданное по умолчанию выполнение метода onXML в простом чат-приложении. Функция myOnXML указывает чат-приложению распознавать одиночный элемент XML, MESSAGE, в следующем формате:

<MESSAGE USER="John" TEXT="Hello, my name is John!" />.

Обработчик onXML должен сначала быть установлен в объекте XMLSocket следующим образом:

socket.onXML = myOnXML;

Функция displayMessage применена, чтобы быть определяемой пользователем функцией, которая отображает сообщение, полученное пользователем.

function myOnXML(doc) {	var e = doc.firstChild;	if (e != null && e.nodeName == "MESSAGE") {		displayMessage(e.attributes.user, e.attributes.text);	}}

Смотрите также

function


XMLSocket.send

X-Z > XMLSocket.send

XMLSocket.send

Синтаксис

myXMLSocket.send(object);

Аргументы

object Объект XML или другие данные, которые нужно передать на сервер.

Описание

Метод; Преобразует объект XML или данные, указанные в аргументе object в строку и передает это на сервер, сопровождая нулевым байтом. Если object объект XML, строка является текстовым представлением объекта XML. Посылающая операция асинхронная, она возвращается немедленно, но данные могут быть переданы в более позднее время. Метод XMLSocket.send не возвращает значение, указывающее, были ли данные успешно переданы.

Если myXMLSocket не связан с сервером (используя XMLSocket.connect), операция XMLSocket.send не выполнится.

Player

Flash 5 или выше.

Пример

Следующий пример иллюстрирует, как Вы могли определить имя пользователя и пароль, чтобы послать XML объект myXML серверу:

var myXML = new XML();var myLogin = myXML.createElement("login");myLogin.attributes.username = usernameTextField;myLogin.attributes.password = passwordTextField;myXML.appendChild(myLogin);myXMLSocket.send(myXML);

Смотрите также

XMLSocket.connect


_xmouse

X-Z > _xmouse

_xmouse

Синтаксис

instancename._xmouse

Аргументы

instancename Имя экземпляра клипа.

Описание

Свойство (только чтение); возвращает координату x указателя мыши.

Player

Flash 5 или выше.

Смотрите также


_xscale

X-Z > _xscale

_xscale

Синтаксис

instancename._xscaleinstancename._xscale = percentage;

Аргументы

percentage Процентное значение, определяющее процент для горизонтального масштабирования клипа. Значение по умолчанию - 100.

instancename Имя экземпляра клипа.

Описание

Свойство; определяет горизонтальный масштаб (percentage) клипа, принятый от точки отсчета клипа. По умолчанию точка отсчета есть (0,0).

Масштабирование локальной системы координат воздействует на установки свойств _x и _y, которые определены в пикселах. Например, если родительский клип масштабируется на 50%, установка свойства клипа _x передвинет объект в клипе на половину числа пикселов, как если бы клип был 100%.

Player

Flash 4 или выше.

Смотрите также

_xscale


_y

X-Z > _y

_y

Синтаксис

instancename._yinstancename._y = integer;

Аргументы

integer Локальная y-координата клипа.

instancename Имя экземпляра клипа.

Описание

Свойство; устанавливает y-координату клипа относительно локальных координат родительского клипа. Если клип расположен на главной монтажной линейке, то начало его системы координат (0, 0), находится в верхнем левом углу рабочего окна. Если клип вложен внутрь другого трансформированного клипа, он находится в локальной системе координат родительского клипа. Таким образом, после поворота родительского клипа на 90° против часовой стрелки, его дочерние клипы унаследуют систему координат, повернутую на 90° против часовой стрелки. Координаты клипа относятся к его точке отсчета (registration point).

Player

Flash 3 или выше.

Смотрите также

_yscale


_ymouse

X-Z > _ymouse

_ymouse

Синтаксис

instancename._ymouse

Аргументы

instancename Имя экземпляра клипа.

Описание

Свойство (только чтение); Указывает y-координату позиции мыши.

Player

Flash 5 или выше.

Смотрите также


_yscale

X-Z > _yscale

_yscale

Синтаксис

instancename._yscaleinstancename._yscale = percentage;

Аргументы

percentage Процентное значение, определяющее процент для вертикального масштабирования клипа. Значение по умолчанию - 100.

instancename Имя экземпляра клипа.

Описание

Свойство; определяет вертикальный масштаб (percentage) клипа, принятый от точки отсчета клипа. По умолчанию точка отсчета есть (0,0).

Масштабирование локальной системы координат воздействует на установки свойств _x и _y, которые определены в пикселах. Например, если родительский клип масштабируется на 50%, установка свойства клипа _y передвинет объект в клипе на половину числа пикселов, как если бы клип был 100%.

Player

Flash 4 или выше.

Смотрите также


RuFlash

Мейл-Конференция "RuFlash"

Перевод справки к пакету Flash 5 на русский язык сделан силами участников Мейл-Конференции "RuFlash"

Мейл-Конференция "RuFlash" ("RUSSIAN FLASH NEWS") предназначена для оперативного обмена новостями, мнениями между русскоязычными пользователями пакета Macromedia Flash, обсуждения технологии работы в этом и других аналогичных или связанных с ним пакетах и утилитах. Разрешается обсуждение вопросов близких к тематике рассылки или каким либо образом влияющих на развитие и распространение Flash технологии.

Подписчиком конференции может быть любой без каких либо ограничений "житель" Сети, имеющий адрес электронной почты, если он согласен с ее Правилами и соблюдает их при общении с другими подписчиками. Ознакомиться с Правилами конференции и подписаться на нее можно на http://www.vmstudio.com/web-designer/flash/mail-list.asp

Удачи,
VM
Модератор "RuFlash"
Редактор перевода


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


ActionScript dictionary: Overview

html/01_overview1.html ActionScript dictionary: Overview ActionScript dictionary: Overview Overview > ActionScript dictionary: Overview This portion of the ActionScript Reference Guide describes the syntax and use of ActionScript elements in Flash 5 and later versions. To use examples in a script, copy the example text from ActionScript Dictionary Help and paste it in the Actions panel in Expert Mode. The dictionary lists all ActionScript elements—operators, keywords, statements, actions, properties, functions, objects, and methods. For an overview of all dictionary entries, see Contents of the dictionary ; the tables in this section are a good starting point for looking up symbolic operators or methods whose object class you don't know. ActionScript follows the ECMA-262 standard (the specification written by the European Computer Manufacturers Association) unless otherwise noted. There are two types of entries in this dictionary: Individual entries for operators, keywords, functions, variables, properties, methods, and statements Object entries, which provide general detail about predefined objects Use the information in the sample entries to interpret the structure and conventions used in these two types of entries.html/01_overview2.html Sample entry for most ActionScript elements Sample entry for most ActionScript elements Overview > Sample entry for most ActionScript elements The following sample dictionary entry explains the conventions used for all ActionScript elements that are not objects. Entry title All entries are listed alphabetically. The alphabetization ignores capitalization, leading underscores, and so on. Syntax The "Syntax" section provides correct syntax for using the ActionScript element in your code. The code portion of the syntax is in code font , and the arguments you must provide are in italicized code font . Brackets indicate optional arguments. Arguments This section describes any arguments listed in the syntax. Description This section identifies the element (for example, as an operator, method, function, or other element) and then describes how the element is used. Player This section tells which versions of the Player support the element. This is not the same as the version of Flash used to author content. For example, if you are creating content for the Flash 4 Player using the Flash 5 authoring tool, you cannot use ActionScript elements that are only available to the Flash 5 Player. With the introduction of Flash 5 ActionScript, some Flash 4 (and earlier) ActionScript elements have been deprecated. Although deprecated elements are still supported by the Flash 5 Player, it is recommended that you use the new Flash 5 elements. In addition, operator functionality has been greatly expanded in Flash 5. Not only have many new mathematical operators been introduced, but some of the older operators are now capable of handling additional data types. To maintain data type consistency, Flash 4 files are automatically modified when imported into the Flash 5 authoring environment, but these modifications will not affect the functionality of the original script. For more information, see the entries for + (addition), < (less than), > (greater than), <= (less than or equal to), >= (greater than or equal to), != (inequality), and = (equality). Example This section provides a code sample demonstrating how to use the element. See also This section lists related ActionScript dictionary entries.html/01_overview3.html Sample entry for objects Sample entry for objects Overview > Sample entry for objects The following sample dictionary entry explains the conventions used for predefined ActionScript objects. Objects are listed alphabetically with all other elements in the dictionary. Entry title The entry title provides the name of the object. The object name is followed by a paragraph containing general information about the object. Method and property summary tables Each object entry contains a table listing all of the methods associated with the object. If the object has properties (often constants), these elements are summarized in an additional table. All of the methods and properties listed in these tables also have their own dictionary entries, which follow the object entry. Constructor If the object requires you to use a constructor to access its methods and properties, the constructor is described at the end of the object entry. This description has all of the standard elements (syntax description, and so on) of other dictionary entries. Method and property listings The methods and properties of an object are listed alphabetically after the object entry.html/01_overview4.html Contents of the dictionary Contents of the dictionary Overview > Contents of the dictionary All dictionary entries are listed alphabetically. However, some operators are symbols, and are presented in ASCII order. In addition, methods that are associated with an object are listed along with the object's name—for example, the abs method of the Math object is listed as Math.abs . The following two tables will help you locate these elements. The first table lists the symbolic operators in the order in which they occur in the dictionary. The second table lists all other ActionScript elements. Note: For precedence and associativity of operators, see Appendix A. Symbolic operators -- (decrement) ++ (increment) ! (logical NOT) != (inequality) % (modulo) %= (modulo assignment) & (bitwise AND) && (short-circuit AND) &= (bitwise AND assignment) ( ) (parentheses) - (minus) * (multiplication) *= (multiplication assignment) , (comma) . (dot) ? : (conditional) / (division) // (comment delimiter) /* (comment delimiter) /= (division assignment) [] (array access) ^ (bitwise XOR) ^= (bitwise XOR assignment) {} (object initializer) | (bitwise OR) || (logical OR) |= (bitwise OR assignment) ~ (bitwise NOT) + (addition) += (addition assignment) < (less than) << (bitwise left shift) <<= (bitwise left shift and assignment) <= (less than or equal to) <> (inequality) = (assignment) -= (negation assignment) == (equality) > (greater than) >= (greater than or equal to) >> (bitwise right shift) >>= (bitwise right shift and assignment) >>> (bitwise unsigned right shift) >>>= (bitwise unsigned right shift and assignment) The following table lists all ActionScript elements that are not symbolic operators. ActionScript element See entry abs Math.abs acos Math.acos add add and and _alpha _alpha appendChild XML.appendChild Array Array (object) asin Math.asin atan Math.atan atan2 Math.atan2 attachMovie MovieClip.attachMovie attachSound Sound.attachSound attributes XML.attributes BACKSPACE Key.BACKSPACE Boolean Boolean (function) , Boolean (object) break break call call CAPSLOCK Key.CAPSLOCK ceil Math.ceil charAt String.charAt charCodeAt String.charCodeAt childNodes XML.childNodes chr chr cloneNode XML.cloneNode close XMLSocket.close Color Color (object) concat Array.concat , String.concat connect XMLSocket.connect constructor Array, Boolean, Color, Date, Number, Object, Sound, String, XML, XMLSocket continue continue CONTROL Key.CONTROL cos Math.cos createElement XML.createElement createTextNode XML.createTextNode _currentframe _currentframe Date Date (object) delete delete DELETEKEY Key.DELETEKEY docTypeDecl XML.docTypeDecl do...while do... while DOWN Key.DOWN _droptarget _droptarget duplicateMovieClip duplicateMovieClip , MovieClip.duplicateMovieClip E Math.E else else END Key.END ENTER Key.ENTER eq eq (equal—string specific) escape (function) escape ESCAPE (constant) Key.ESCAPE eval eval evaluate evaluate exp Math.exp firstChild XML.firstChild floor Math.floor _focusrect _focusrect for for for.. in for..in _framesloaded _framesloaded fromCharCode String.fromCharCode fscommand fscommand function function ge ge (greater than or equal to—string specific) getAscii Key.getAscii getBeginIndex Selection.getBeginIndex getBounds MovieClip.getBounds getBytesLoaded MovieClip.getBytesLoaded getBytesTotal MovieClip.getBytesTotal getCaretIndex Selection.getCaretIndex getCode Key.getCode getDate Date.getDate getDay Date.getDay getEndIndex Selection.getEndIndex getFocus Selection.getFocus getFullYear Date.getFullYear getHours Date.getHours getMilliseconds Date.getMilliseconds getMinutes Date.getMinutes getMonth Date.getMonth getPan Sound.getPan getProperty getProperty getRGB Color.setRGB getSeconds Date.getSeconds getTime Date.getTime getTimer getTimer getTimezoneOffset Date.getTimezoneOffset getTransform Color.getTransform , Sound.getTransform getURL getURL , MovieClip.getURL getUTCDate Date.getUTCDate getUTCDay Date.getUTCDay getUTCFullYear Date.getUTCFullYear getUTCHours Date.getUTCHours getUTCMilliseconds Date.getUTCMilliseconds getUTCMinutes Date.getUTCMinutes getUTCMonth Date.getUTCMonth getUTCSeconds Date.getUTCSeconds getVersion getVersion getVolume Sound.getVolume getYear Date.getYear globalToLocal MovieClip.globalToLocal gotoAndPlay gotoAndPlay , MovieClip.gotoAndPlay gotoAndStop gotoAndStop , MovieClip.gotoAndStop gt gt (greater than —string specific) hasChildNodes XML.haschildNodes _height _height hide Mouse.hide _highquality _highquality hitTest MovieClip.hitTest HOME Key.HOME if if ifFrameLoaded ifFrameLoaded #include #include indexOf String.indexOf Infinity Infinity INSERT Key.INSERT insertBefore XML.insertBefore int int isDown Key.isDown isFinite isFinite isNaN isNaN isToggled Key.isToggled join Array.join Key Key (object) lastChild XML.lastChild lastIndexOf String.indexOf le le (less than or equal to — string specific) LEFT Key.LEFT length length , Array.length , String.length LN2 Math.LN2 LN10 Math.LN10 load XML.load loaded XML.loaded loadMovie loadMovie , MovieClip.loadMovie loadVariables loadVariables , MovieClip.loadVariables localToGlobal MovieClip.localToGlobal log Math.log LOG2E Math.LOG2E LOG10E Math.LOG10E lt le (less than or equal to — string specific) Math Math (object) max Math.max maxscroll maxscroll MAX_VALUE Number.MAX_VALUE mbchr mbchr mblength mblength mbord mbord mbsubstring mbsubstring min Math.min MIN_VALUE Number.MIN_VALUE Mouse Mouse (object) MovieClip MovieClip (object) _name _name NaN NaN , Number.NaN ne ne (not equal — string specific) NEGATIVE_INFINITY Number.NEGATIVE_INFINITY new (operator) new newline newline nextFrame nextFrame , MovieClip.nextFrame nextScene nextScene nextSibling XML.nextSibling nodeName XML.nodeName nodeType XML.nodeType nodeValue XML.nodeValue not not null null Number Number (function) , Number (object) Object Object (object) On on(mouseEvent) onClipEvent onClipEvent onClose XMLSocket.onClose onConnect XMLSocket.onConnect OnLoad XML.onLoad onXML XMLSocket.onXML or (logical OR) or ord ord _parent _parent parentNode XML.parentNode parseFloat parseFloat parseInt parseInt parseXML XML.parseXML PGDN Key.PGDN PGUP Key.PGUP PI Math.PI play play , MovieClip.play pop Array.pop POSITIVE_INFINITY Number.POSITIVE_INFINITY pow Math.pow prevFrame prevFrame , MovieClip.prevFrame previousSibling XML.previousSibling prevScene prevScene print print printAsBitmap printAsBitmap push Array.push _quality _quality random random , Math.random removeMovieClip removeMovieClip , MovieClip.removeMovieClip removeNode XML.removeNode return return reverse Array.reverse RIGHT Key.RIGHT _root _root _rotation _rotation round Math.round scroll scroll Selection Selection (object) send XML.send , XMLSocket.send sendAndLoad XML.sendAndLoad set set setDate Date.setDate setFocus Selection.setFocus setFullYear Date.setFullYear setHours Date.setHours setMilliseconds Date.setMilliseconds setMinutes Date.setMinutes setMonth Date.setMonth setPan Sound.setPan setProperty setProperty setRGB Color.setRGB setSeconds Date.setSeconds setSelection Selection.setSelection setTime Date.setTime setTransform Color.setTransform , Sound.setTransform setUTCDate Date.setUTCDate setUTCFullYear Date.setUTCFullYear setUTCHours Date.setUTCHours setUTCMilliseconds Date.setUTCMilliseconds setUTCMinutes Date.setUTCMinutes setUTCMonth Date.setUTCMonth setUTCSeconds Date.setUTCSeconds setVolume Sound.setVolume setYear Date.setYear shift (method) Array.shift SHIFT (constant) Key.SHIFT show Mouse.show sin Math.sin slice Array.slice , String.slice sort Array.sort Sound Sound (object) _soundbuftime _soundbuftime SPACE Key.SPACE splice Array.splice split String.split sqrt Math.sqrt SQRT1_2 Math.SQRT1_2 SQRT2 Math.SQRT2 start Sound.start startDrag startDrag , MovieClip.startDrag status XML.status stop stop , MovieClip.stop , Sound.stop stopAllSounds stopAllSounds stopDrag stopDrag , MovieClip.stopDrag String String (function) , String (object) , " " (string delimiter) substr String.substr substring substring , String.substring swapDepths MovieClip.swapDepths TAB Key.TAB tan Math.tan _target _target targetPath targetPath tellTarget tellTarget this this toggleHighQuality toggleHighQuality toLowerCase String.toLowerCase toString Array.toString , Boolean.toString , Date.toString , Number.toString , Object.toString , XML.toString _totalframes _totalframes toUpperCase String.toUpperCase trace trace typeof typeof unescape unescape unloadMovie unloadMovie , MovieClip.unloadMovie unshift Array.shift UP Key.UP updateAfterEvent updateAfterEvent _url _url UTC Date.UTC valueOf Boolean.valueOf , Number.valueOf , Object.valueOf var var _visible _visible void void while while _width _width with with _x _x XML XML (object) xmlDecl XML.xmlDecl XMLSocket XMLSocket (object) _xmouse _xmouse _xscale _xscale _y _y _ymouse _ymouse _yscale _yscalehtml/02_operators1.html-- (decrement) -- (decrement) Operators > -- (decrement) Syntax --expression expression-- Arguments expression A variable, number, element in an array, or property of an object. Description Operator; a pre-decrement and post-decrement unary operator that subtracts 1 from the expression . The pre-decrement form of the operator ( --expression ) subtracts 1 from expression and returns the result. The post-decrement form of the operator ( expression-- ) subtracts 1 from the expression and returns the initial value of the expression (the result prior to the subtraction). Player Flash 4 or later. Example The pre-decrement form of the operator decrements x to 2 ( x - 1 = 2 ), and returns the result as y : x = 3; y = --x The post-decrement form of the operator decrements x to 2 ( x - 1 = 2 ), and returns the original value ( x = 3 ) as the result y : If x = 3; y = x--html/02_operators10.html() (parentheses) () (parentheses) Operators > () (parentheses) Syntax ( expression1, expression2 ); function ( functionCall1, ..., functionCallN ); Arguments expression1, expression2 Numbers, strings, variables, or text. function The function to be performed on the contents of the parentheses. functionCall1...functionCallN A series of functions to execute before the result is passed to the function outside the parentheses. Description Operator (general); performs a grouping operation on one or more arguments, or surrounds one or more arguments and passes the results a parameter to a function outside the parentheses. Usage 1: Performs a grouping operation on one or more expressions to control the order of execution of the operators in the expression. This operator overrides the automatic precedence order, and causes the expressions within the parentheses to be evaluated first. When parentheses are nested, Flash evaluates the contents of the innermost parentheses before the contents of the outer ones. Usage 2: Surrounds one or more arguments and passes them as parameters to the function outside the parentheses. Player Flash 4 or later. Example (Usage 1) The following statements illustrate the use of parentheses to control the order of execution of expressions. (The result appears below each statement.) (2 + 3) * (4 + 5) 45 2 + (3 * (4 + 5)) 29 2 + (3 * 4) + 5 19 (Usage 2) The following example illustrates the use of parentheses with a function: getDate(); invoice(item, amount); See also withhtml/02_operators11.html- (minus) - (minus) Operators > - (minus) Syntax (Negation) - expression (Subtraction) expression1 - expression2 Arguments expression1, expression2 Any number. Description Operator (arithmetic); used for negating or subtracting. When used for negating, it reverses the sign of the numerical expression . When used for subtracting, it performs an arithmetic subtraction on two numerical expressions, subtracting expression2 from expression1 . When both expressions are integers, the difference is an integer. When either or both expressions are floating-point numbers, the difference is a floating-point number. Player Flash 4 or later. Example (Negation) This statement reverses the sign of the expression 2 + 3: -(2 + 3) The result is -5. (Subtraction) This statement subtracts the integer 2 from the integer 5: 5 - 2 The result is 3, which is an integer. (Subtraction) : This statement subtracts the floating-point number 1.5 from the floating-point number 3.25: put 3.25 - 1.5 The result is 1.75, which is a floating-point number.html/02_operators12.html* (multiplication) * (multiplication) Operators > * (multiplication) Syntax expression1 * expression2 Arguments expression1, expression2 Integers or floating-point numbers. Description Operator (arithmetic); multiplies two numerical expressions. If both expressions are integers, the product is an integer. If either or both expressions are floating-point numbers, the product is a floating-point number. Player Flash 4 or later. Example This statement multiplies the integers 2 and 3: 2 * 3 The result is 6, which is an integer. Example This statement multiplies the floating-point numbers 2.0 and 3.1416: 2.0 * 3.1416 The result is 6.2832, which is a floating-point number.html/02_operators13.html*= (multiplication assignment) *= (multiplication assignment) Operators > *= (multiplication assignment) Syntax expression1 *= expression2 Arguments expression1, expression2 Integers, floating-point numbers, or strings. Description Operator (assignment); assigns expression1 the value of expression1 * expression2 . Player Flash 4 or later. Example The following illustrates using the *= operator with variables and numbers: x *= y is the same as x = x * y If x = 5 and y = 10 then x *= 10 returns 50 See also * (multiplication)html/02_operators14.html, (comma) , (comma) Operators > , (comma) Syntax expression1 , expression2 Arguments expression Any number, variable, string, array element, or other data. Description Operator; instructs Flash to evaluate expression1 , then expression2 , and return the value of expression2 . This operator is primarily used with the for loop statement. Player Flash 4 or later. Example The following code sample uses the comma operator: var a=1, b=2, c=3; This is equivalent to writing the following: var a=1; var b=2; var c=3;html/02_operators15.html. (dot operator) . (dot operator) Operators > . (dot operator) Syntax object.property_or_method instancename.variable instancename.childinstance.variable Arguments object An instance of an object. Some objects require that instances be created using the constructor for that object. The object can be any of the predefined ActionScript objects or a custom object. This argument is always to the left of the dot (.) operator. property_or_method The name of a property or method associated with an object. All of the valid method and properties for the predefined objects are listed in the Method and Property summary tables for that object. This argument is always to the right of the dot (.) operator. instancename The name of a movie clip instance. childinstance An movie clip instance that is a child of the main movie clip. variable A variable in a movie clip. Description Operator; used to navigate movie clip hierarchies in order to access nested child movie clips, variables, or properties. The dot operator is also used to test or set the properties of an object, execute a method of an object, or create a data structure. Player Flash 4 or later. See also [] (array access operator) Example This statement identifies the current value of the variable hairColor by the movie clip person : person.hairColor This is equivalent to the following Flash 4 syntax: /person:hairColor Example The following code illustrates how the dot operator can be used to create a structure of an array: account.name = "Gary Smith"; account.address = "123 Main St "; account.city = "Any Town"; account.state = "CA"; account.zip = "12345";html/02_operators16.html?: (conditional) ?: (conditional) Operators > ?: (conditional) Syntax expression1 ? expression2 : expression3 Arguments expression1 An expression that evaluates to a Boolean value, usually a comparison expression. expression2, expression3 Values of any type. Description Operator (conditional); instructs Flash to evaluate expression1 , and return the value of expression2 if expression1 is true ; otherwise return the value of the expression3 . Player Flash 4 or later.html/02_operators17.html/ (division) / (division) Operators > / (division) Syntax expression1 / expression2 Arguments expression Any number. Description Operator (arithmetic); divides expression1 by expression2 . The expression arguments and results of the division operation are treated and expressed as double-precision floating-point numbers. Player Flash 4 or later. Example This statement divides the floating-point number 22.0 by 7.0 and then displays the result in the Output window: trace(22.0 / 7.0); The result is 3.1429, which is a floating-point number.html/02_operators18.html// (comment delimiter) // (comment delimiter) Operators > // (comment delimiter) Syntax // comment Arguments comment Text that is not part of the code, and should be ignored by the interpreter. Description Comment; indicates the beginning of a script comment. Any text that appears between the comment delimiter // and the end-of-line character is interpreted as a comment and ignored by the ActionScript interpreter. Player Flash 1 or later. Example This script uses comment delimiters slash to identify the first, third, fifth, and seventh lines as comments: // set the X position of the ball movie clip ball = getProperty(ball._x); // set the Y position of the ball movie clip ball = getProperty(ball._y); // set the X position of the kitty movie clip kitty = getProperty(kitty._x); // set the Y position of the kitty movie clip kitty_y = getProperty(kitty._y); See also /* (comment delimiter)html/02_operators19.html/* (comment delimiter) /* (comment delimiter) Operators > /* (comment delimiter) Syntax /* comment */ /* * comment * comment */ Arguments comment Any text Description Comment; indicates one or more lines of script comments. Any text that appears between the opening comment tag /* and the closing comment tag */ , is interpreted as a comment and ignored by the ActionScript interpreter. Use the first syntax to identify single-line comments, and use the second syntax to identify comments on multiple successive lines. Leaving off the closing tag */ when using this form of comment delimiter causes the ActionScript compiler to return an error message. Player Flash 5 or later. See also // (comment delimiter)html/02_operators2.html++ (increment) ++ (increment) Operators > ++ (increment) Syntax ++expression expression++ Arguments expression A variable, number, element in an array, or property of an object. Description Operator; a pre-increment and post-increment unary operator that adds 1 to the expression . The pre-increment form of the operator ( ++expression ) adds 1 to the expression and returns the result. The post-increment form of the operator ( expression++ ) adds 1 to the expression and returns the initial value of the expression (the result prior to the addition). The pre-increment form of the operator increments x to 2 ( x + 1 = 2 ), and returns the result as y : x = 1; y = ++x The post-increment form of the operator increments x to 2 ( x + 1 = 2 ), and returns the original value ( x = 1 ) as the result y : x = 1; y = x++; Player Flash 4 or later. Example The following example uses ++ as a pre-increment operator with a while statement. i = 0 while(i++ < 5){ // this section will execute five times } The following example uses ++ as a pre-increment operator: var a = []; var i = 0; while (i < 10) { a.push(++i); } trace(a.join()); This script prints the following: 1,2,3,4,5,6,7,8,9 The following example uses ++ as a post-increment operator: var a = []; var i = 0; while (i < 10) { a.push(i++); } trace(a.join()); This script prints the following: 0,1,2,3,4,5,6,7,8,9html/02_operators20.html/= (division assignment) /= (division assignment) Operators > /= (division assignment) Syntax expression1 /= expression2 Arguments expression1,expression2 Integers, floating-point numbers, or strings. Description Operator (assignment); assigns expression1 the value of expression1 / expression2 . Player Flash 4 or later. Example The following illustrates using the /= operator with variables and numbers: x /= y is the same as x = x /y x = 10; y = 2; x /= y; // x now contains the value 5html/02_operators21.html[] (array access operator) [] (array access operator) Operators > [] (array access operator) Syntax myArray [ "a0", "a1",..."aN" ]; object [ value1, value2, ...valueN ]; Arguments myArray The name of an array. a0, a1,...aN Elements in an array. value1, 2,...N Names of properties. Description Operator; creates a new object initializing the properties specified in the arguments, or initializes new array with the elements ( a0 ) specified in the arguments. The created object has the generic Object object as its prototype. Using this operator is the same as calling new Object and populating the properties using the assignment operator. Using this operator is an alternative to using the new operator, which allows for the quick and convenient creation of objects. Player Flash 4 or later. Example The following example code samples are two different ways of creating a new empty Array object: myArray =[]; myArray = new Array(); The following is an example of a simple array: myArray = ["red", "orange", "yellow", "green", "blue", "purple"] myArray[0]="red" myArray[1]="yellow" myArray[2]="green" myArray[3]="blue" myArray[4]="purple"html/02_operators22.html^(bitwise XOR) ^(bitwise XOR) Operators > ^(bitwise XOR) Syntax expression1 ^ expression2 Arguments expression1,expression2 Any number. Description Operator (bitwise); converts expression1 and expression2 to 32-bit unsigned integers, and returns a 1 in each bit position where the corresponding bits in expression1 or expression1 , but not both, are 1. Player Flash 5 or later. Example 15 ^ 9 returns 6 (1111 ^ 1001 = 0110)html/02_operators23.html^= (bitwise XOR assignment) ^= (bitwise XOR assignment) Operators > ^= (bitwise XOR assignment) Syntax expression1 ^= expression2 Arguments expression1,expression2 Integers and variables. Description Operator (compound assignment); assigns expression1 the value of expression1 ^ expression2 . Player Flash 5 or later. Example The following is an example of a ^= operation: // 15 decimal = 1111 binary x = 15; // 9 decimal = 1001 binary x ^= y; returns x ^ y (0110 binary) The following illustrates using the ^= operator with variables and numbers: x ^= y is the same as x = x ^ y If x = 15 and y = 9 then 15 ^= 9 returns 6 See also ^(bitwise XOR)html/02_operators24.html{} (object initializer) {} (object initializer) Operators > {} (object initializer) Syntax object { name1 : value1 , name1 : value2 , ... nameN : valueN }; Arguments object The object to create. name1,2,...N The name of the property. value1,2,...N The corresponding value for each name property. Description Operator; creates a new object and initializes it with the specified name and value property pairs. The created object has the generic Object object as its prototype. Using this operator is the same as calling new Object and populating the property pairs using the assignment operator. Using this operator is an alternative to using the new operator, which allows for the quick and convenient creation of objects. Player Flash 5 or later. Example The following code shows how an empty object can be created using the object initializer operator and using the new Object : object = {}; object = new Object(); The following creates an object account initializing the properties name , address , city , state , zip , and balance : account = { name: "John Smith", address: "123 Main Street", city: "Blossomville", state: "California", zip: "12345", balance: "1000" }; The following example shows how array and object initializers can be nested within each other: person = { name: "Peter Piper", children: [ "Jack", "Jill", "Moe",] }; The following example is another way of using the information in the previous example above, with the same results: person = new Person(); person.name = 'John Smith'; person.children = new Array(); person.children[0] = 'Jack'; person.children[1] = 'Jill'; person.children[2] = 'Moe'; See also [] (array access operator) new Object (object)html/02_operators25.html| (bitwise OR) | (bitwise OR) Operators > | (bitwise OR) Syntax expression1 | expression2 Arguments expression1,expression2 Any number. Description Operator (bitwise); converts expression1 and expression2 to 32-bit unsigned integers, and returns a 1 in each bit position where the corresponding bits of either expression1 or expression2 are 1. Player Flash 5 or later. Example The following is an example of a bitwise OR operation. Note that 15 is 1111 binary: // 15 decimal = 1111 binary x = 15; // 9 decimal = 1001 binary y = 9; // x | y = binary z = x | y; z = 15 The following is another way of expressing the preceding example: 15 | 9 returns 15 (1111 | 0011 = 1111)html/02_operators26.html|| (OR) || (OR) Operators > || (OR) Syntax expression1 || expression2 Arguments expression1,expression2 A Boolean value or expression that converts to a Boolean value. Description Operator (logical); evaluates expression1 and expression2 . The result is ( true ) if either or both expressions evaluate to true ; the result is ( false ) only if both expressions evaluate to false . With non-Boolean expressions, the logical OR operator causes Flash to evaluate the expression on the left; if it can be converted to true , the result is true . Otherwise, it evaluates the expression on the right and the result is the value of that expression. Player Flash 4 or later. Example The following example uses the || operator in an if statement: want = true; need = true; love = false; if (want || need || love){ trace("two out of 3 ain't bad"); }html/02_operators27.html|= (bitwise OR assignment) |= (bitwise OR assignment) Operators > |= (bitwise OR assignment) Syntax expression1 |= expression2 Arguments expression1,expression2 Integers and variables. Description Operator (assignment); assigns expression1 the value of expression1 | expression2 . Player Flash 5 or later. Example The following illustrates using the |= operator with variables and numbers: x |= y is the same as x = x | y If x = 15 and y = 9 then x |= 9 returns 15 See also | (bitwise OR)html/02_operators28.html~ (bitwise NOT) ~ (bitwise NOT) Operators > ~ (bitwise NOT) Syntax ~ expression Arguments expression Any number. Description Operator (bitwise); converts the expression to a 32-bit unsigned integer, then inverts the bits. Or, simply said, changes the sign of a number and subtracts 1. A bitwise NOT operation changes the sign of a number and subtracts 1. Player Flash 5 or later. Example The following is a numerical explanation of a bitwise NOT operation performed on a variable: ~a , returns -1 if a = 0 , and returns -2 if a = 1 , thus: ~0=-1 and ~1=-2html/02_operators29.html+ (addition) + (addition) Operators > + (addition) Syntax expression1 + expression2 Arguments expression1,expression2 Integers, numbers, floating-point numbers, or strings. Description Operator; adds numeric expressions or concatenates strings. If one expression is a string, all other expressions are converted to strings and concatenated. If both expressions are integers, the sum is an integer; if either or both expressions are floating-point numbers, the sum is a floating-point number. Player Flash 4; Flash 5 or later. In Flash 5, + is a numeric operator or string concatenator depending on the data type of the argument. In Flash 4, + is only a numeric operator. Flash 4 files brought into the Flash 5 authoring environment undergo a conversion process to maintain data type integrity. The first example below illustrates the conversion process. Example The following illustrates the conversion of a Flash 4 file containing a numeric quality comparison: Flash 4 file: x + y Converted Flash 5 file: Number(x) + Number(y) This statement adds the integers 2 and 3 and then displays the resulting integer, 5, in the Output window: trace (2 + 3); This statement adds the floating-point numbers 2.5 and 3.25 and displays the result, 5.7500, a floating-point number, in the Output window: trace (2.5 + 3.25); This statement concatenates two strings and displays the result, "today is my birthday," in the Output window: "today is my" + "birthday" See also addhtml/02_operators3.html! (logical NOT) ! (logical NOT) Operators > ! (logical NOT) Syntax ! expression Arguments expression A variable or evaluated expression. Description Operator (logical); inverts the Boolean value of a variable or expression. If expression is a variable with an absolute or converted value true , ! variable the value of ! expression is false . If the expression x && y evaluates to false , the expression !(x && y) evaluates to true . This operator is identical to the not operator that was used in Flash 4. Player Flash 4 or later. Example In the following example the variable happy is set to false , the if condition evaluates the condition !happy, and if the condition is true, trace sends a string to the Output window. happy = false; if (!happy){ trace("don't worry be happy"); } The following illustrates the results of the ! operator: ! true returns false ! false returns truehtml/02_operators30.html+= (addition assignment) += (addition assignment) Operators > += (addition assignment) Syntax expression1 += expression2 Arguments expression1,expression2 Integers, floating-point numbers, or strings. Description Operator (compound assignment); assigns expression1 the value of expression1 + expression2 . This operator also performs string concatenation. Player Flash 4 or later. Example This following illustrates a numeric use of the += operator: x += y is the same as x = x + y If x = 5 and y = 10 then x += 10 returns 15 This example illustrates using the += operator with a string expression: x = "My name is" x += "Mary" The result for the above code is as follows: "My name is Mary" See also + (addition)html/02_operators31.html< (less than) < (less than) Operators > < (less than) Syntax expression1 < expression2 Arguments expression1,expression2 Numbers or strings. Description Operator (comparison); compares two expressions and determines whether expression1 is less than expression2 ( true ), or whether expression1 is greater than or equal to expression2 ( false ). String expressions are evaluated and compared based on the number of characters in the string. Player Flash 4; Flash 5 or later. In Flash 5 < is a comparison operator capable of handling various data types. In Flash 4 < is an numeric operator. Flash 4 files brought into the Flash 5 authoring environment undergo a conversion process to maintain data type integrity. The first example below illustrates the conversion process. Example The following illustrates the conversion of a Flash 4 file containing a numeric quality comparison. Flash 4 file: x < y Converted Flash 5 file: Number(x) < Number(y) The following examples illustrate true and false returns for both numbers and strings: 3 < 10 or "Al" < "Jack" return true 10 < 3 or "Jack" < "Al" return falsehtml/02_operators32.html<< (bitwise left shift) << (bitwise left shift) Operators > << (bitwise left shift) Syntax expression1 << expression2 Arguments expression1 A number, string, or expression to be shifted left. expression2 A number, string, or expression that converts to an integer from 0 to 31. Description Operator (bitwise); converts expression1 and expression2 to 32-bit integers, and shifts all of the bits in expression1 to the left by the number of places specified by the integer resulting from the conversion of expression2 . The bit positions that are emptied as a result of this operation are filled in with 0. Shifting a value left by one position is the equivalent of multiplying it by 2. Player Flash 5 or later. Example The following example shifts the integer 1 ten bits to the left: x = 1 << 10 The result of this operation is x = 1024 . This is because 1 decimal equals 1 binary, 1 binary shifted left by 10 is 10000000000 binary, and 10000000000 binary is 1024 decimal. This following example shifts the integer 7 eight bits to the left: x = 7 << 8 The result of this operation is x = 1792 . This is because 7 decimal equals 111 binary, 111 binary shifted left by 8 bits is 11100000000 binary, and 11100000000 binary is 1792 decimal. See also >>= (bitwise right shift and assignment)html/02_operators33.html<<= (bitwise left shift and assignment) <<= (bitwise left shift and assignment) Operators > <<= (bitwise left shift and assignment) Syntax expression1 <<= expression2 Arguments expression1 A number, string, or expression to be shifted left. expression2 A number, string, or expression that converts to an integer from 0 to 31. Description Operator (compound assignment); this operator performs a bitwise left shift operation and stores the contents as a result in expression1 . Player Flash 5 or later. Example The following two expressions are equivalent: A <<= B A = (A << B) See also << (bitwise left shift) >>= (bitwise right shift and assignment)html/02_operators34.html<= (less than or equal to) <= (less than or equal to) Operators > <= (less than or equal to) Syntax expression1 <= expression2 Arguments expression1,expression2 Number or strings. Description Operator (comparison); compares two expressions and determines whether expression1 is less than or equal to expression2 ( true ), or whether expression1 is greater than expression2 ( false ). Player Flash 4; Flash 5 or later. In Flash 5 <= is a comparison operator capable of handling various data types. In Flash 4 <= is an numeric operator. Flash 4 files brought into the Flash 5 authoring environment undergo a conversion process to maintain data type integrity. The first example below illustrates the conversion process. Example The following illustrates the conversion of a Flash 4 file containing a numeric quality comparison. Flash 4 file: x <= y Converted Flash 5 file: Number(x) <= Number(y) The following examples illustrate true and false results for both numbers and strings: 5 <= 10 or "Al" <= "Jack" returns true 10<= 5 or "Jack" <= "Al" returns falsehtml/02_operators35.html<> (inequality) <> (inequality) Operators > <> (inequality) Syntax expression1 <> expression2 Arguments expression1,expression2 Numbers, strings, Booleans, variables, objects, arrays, or functions. Description Operator (equality); tests for the exact opposite of the == operator. If expression1 is equal to expression2 , the result is false . As with the == operator, the definition of equal depends on the data types being compared: Numbers, strings, and Boolean values are compared by value. Variables, objects, arrays, and functions are compared by reference. This operator has been deprecated in Flash 5, and users are encouraged to make use of the new != operator. Player Flash 2 or later. See also != (inequality)html/02_operators36.html= (assignment) = (assignment) Operators > = (assignment) Syntax expression1 = expression2 Arguments expression1 A variable, element of an array, or property of an object. expression2 A value of any type. Description Operator (assignment); assigns the type of expression2 (the argument on the right) to the variable, array element, or property in expression1 . Player Flash 4; Flash 5 or later. In Flash 5 = is an assignment operator and the == operator is used to evaluate equality. In Flash 4 = is a numeric equality operator. Flash 4 files brought into the Flash 5 authoring environment undergo a conversion process to maintain data type integrity. The first example below illustrates the conversion process. Example The following illustrates the conversion of a Flash 4 file containing a numeric quality comparison. Flash 4 file: x = y Converted Flash 5 file: Number(x) == Number(y) The following example uses the assignment operator to assign the number data type to the variable x : x = 5 The following example uses the assignment operator to assign the string data type to the variable x : x = " hello "html/02_operators37.html-= (negation assignment) -= (negation assignment) Operators > -= (negation assignment) Syntax expression1 -= expression2 Arguments expression1,expression2 Integers, floating-point numbers, or strings. Description Operator (compound assignment); assigns expression1 the value of expression1 - expression2 . Player Flash 4 or later. Example The following illustrates using the -= operator with variables and numbers: x -= y is the same as x = x - y If x = 5 and y = 10 then x -= 10 returns -5html/02_operators38.html== (equality) == (equality) Operators > == (equality) Syntax expression1 == expression2 Arguments expression1,expression2 Numbers, strings, Booleans, variables, objects, arrays, or functions. Description Operator (equality); tests two expressions for equality. The result is true if the expressions are equal. The definition of equal depends on the data type of the argument: Numbers, strings, and Boolean values are compared by value, and are considered equal if they have the same value. For instance, two strings are equal if they have the same number of characters. Variables, objects, arrays, and functions are compared by reference. Two variables are equal if they refer to the same object, array, or function. Two separate arrays are never considered equal, even if they have the same number of elements. Player Flash 5 or later. Example The following example uses the == operator with an if statement: a = "David" , b = "David"; if (a == b){ trace("David is David"); }html/02_operators39.html> (greater than) > (greater than) Operators > > (greater than) Syntax expression1 > expression2 Arguments expression1,expression2 Integers, floating-point numbers, or strings. Description Operator (comparison); compares two expressions and determines whether expression1 is greater than expression2 ( true ), or whether expression1 is less than or equal to expression2 ( false ). Player Flash 4; Flash 5 or later. In Flash 5 > is a comparison operator capable of handling various data types. In Flash 4 > is an numeric operator. Flash 4 files brought into the Flash 5 authoring environment undergo a conversion process to maintain data type integrity. The example below illustrates the conversion process. Example The following illustrates the conversion of a Flash 4 file containing a numeric quality comparison. Flash 4 file: x > y Converted Flash 5 file: Number(x) > Number(y)html/02_operators4.html!= (inequality) != (inequality) Operators > != (inequality) Syntax expression1 != expression2 Arguments expression1, expression2 Numbers, strings, Booleans, variables, objects, arrays, or functions. Description Operator (equality); tests for the exact opposite of the == operator. If expression1 is equal to expression2 , the result is false . As with the == operator, the definition of equal depends on the data types being compared. Numbers, strings, and Boolean values are compared by value. Variables, objects, arrays, and functions are compared by reference. Player Flash 5 or later. Example The following example illustrates the results of the != operator. 5 != 8 returns true 5 != 5 returns false The following example illustrates the use of the != operator in an if statement: a = "David"; b = "Fool" if (a != b){ trace("David is not a fool"); } See also == (equality)html/02_operators40.html>= (greater than or equal to) >= (greater than or equal to) Operators > >= (greater than or equal to) Syntax expression1 >= expression2 Arguments expression1, expression2 Strings, integers, or floating-point numbers. Description Operator (comparison); compares two expressions and determines whether expression1 is greater than or equal to expression2 ( true ), or whether expression1 is less than expression2 ( false ). Player Flash 4; Flash 5 or later. In Flash 5 >= is a comparison operator capable of handling various data types. In Flash 4 >= is a numeric operator. Flash 4 files brought into the Flash 5 authoring environment undergo a conversion process to maintain data type integrity. The example below illustrates the conversion process. Example The following illustrates the conversion of a Flash 4 file containing a numeric quality comparison. Flash 4 file: x >= y Converted Flash 5 file: Number(x) >= Number(y)html/02_operators41.html>> (bitwise right shift) >> (bitwise right shift) Operators > >> (bitwise right shift) Syntax expression1 >> expression2 Arguments expression1 A number, string, or expression to be shifted right. expression2 A number, string, or expression that converts to an integer from 0 to 31. Description Operator (bitwise); converts expression1 and expression2 to 32-bit integers, and shifts all of the bits in expression1 to the right by the number of places specified by the integer resulting from the conversion of expression2 . Bits that are shifted off to the right are discarded. To preserve the sign of the original expression , the bits on the left are filled in with 0 if the most significant bit (the bit farthest to the left) of expression1 is 0, and filled in with 1 if the most significant bit is 1. Shifting a value right by one position is the equivalent of dividing by 2 and discarding the remainder. Player Flash 5 or later. Example The following example converts 65535 to a 32-bit integer, and shifts it eight bits to the right: x = 65535 >> 8 The result of the above operation is as follows: x = 255 This is because 65535 decimal equals 1111111111111111 binary (sixteen 1's), 1111111111111111 binary shifted right by eight bits is 11111111 binary, and 11111111 binary is 255 decimal. The most significant bit is 0 because the integers are 32-bit, so the fill bit is 0. The following example converts -1 to a 32-bit integer and shifts it one bit to the right: x = -1 >> 1 The result of the above operation is as follows: x = -1 This is because -1 decimal equals 11111111111111111111111111111111 binary (thirty-two 1's), shifting right by one bit causes the least significant (bit farthest to the right) to be discarded and the most significant bit to be filled in with 1. The result is 11111111111111111111111111111111 (thirty-two 1's) binary, which represents the 32-bit integer -1. See also >>= (bitwise right shift and assignment)html/02_operators42.html>>= (bitwise right shift and assignment) >>= (bitwise right shift and assignment) Operators > >>= (bitwise right shift and assignment) Syntax expression1 =>> expression2 Arguments expression1 A number, string, or expression to be shifted left. expression2 A number, string, or expression that converts to an integer from 0 to 31. Description Operator (compound assignment); this operator performs a bitwise right shift operation and stores the contents as a result in expression1 . Player Flash 5 or later. Example The following two expressions are equivalent: A >>= B A = (A >> B) The following commented code uses the bitwise operator >>= . It is also an example of using all bitwise operators. function convertToBinary(number) { var result = ""; for (var i=0; i<32; i++) { // Extract least significant bit using bitwise AND var lsb = number & 1; // Add this bit to our result string result = (lsb ? "1" : "0") + result; // Shift number right by one bit, to see next bit }number >>= 1; return result; } convertToBinary(479) //Returns the string 00000000000000000000000111011111 //The above string is the binary representation of the decimal number 479. See also << (bitwise left shift)html/02_operators43.html>>> (bitwise unsigned right shift) >>> (bitwise unsigned right shift) Operators > >>> (bitwise unsigned right shift) Syntax expression1 >>> expression2 Arguments expression1 A number, string, or expression to be shifted right. expression2 A number, string, or expression that converts to an integer from 0 to 31. Description Operator (bitwise); the same as the bitwise right shift operator ( >> ) except that it does not preserve the sign of the original expression because the bits on the left are always filled with 0. Player Flash 5 or later. Example The following example converts -1 to a 32-bit integer and shifts it one bit to the right: x = -1 >>> 1 The result of the above operation is as follows: x = 2147483647 This is because -1 decimal is 11111111111111111111111111111111 binary (thirty-two 1's), and when you shift right (unsigned) by one bit, the least significant (rightmost) bit is discarded, and the most significant (leftmost) bit is filled with a 0. The result is: 01111111111111111111111111111111 binary, which represents the 32-bit integer 2147483647 . See also >>= (bitwise right shift and assignment)html/02_operators44.html>>>= (bitwise unsigned right shift and assignment) >>>= (bitwise unsigned right shift and assignment) Operators > >>>= (bitwise unsigned right shift and assignment) Syntax expression1 >>>= expression2 Arguments expression1 A number, string, or expression to be shifted left. expression2 A number, string, or expression that converts to an integer from 0 to 31. Description Operator (compound assignment); performs a unsigned bitwise right shift operation and stores the contents as a result in expression1 . Player Flash 5 or later. Example The following two expressions are equivalent: A >>>= B A = (A >>> B) See also >>> (bitwise unsigned right shift) >>= (bitwise right shift and assignment)html/02_operators5.html% (modulo) % (modulo) Operators > % (modulo) Syntax expression1 % expression2 Arguments expression1, expression2 Numbers, integers, floating-point numbers, or strings that convert to a numeric value. Description Operator (arithmetic); calculates the remainder of expression1 divided by expression2 . If either of the expression arguments are nonnumeric, the modulo operator attempts to convert them to numbers. Player Flash 4 or later. In Flash 4 files, the % operator is expanded in the SWF file as x - int(x/y) * y , and may not be as fast or as accurate as the Flash 5 Player implementation. Example The following is a numeric example of using the % operator: 12 % 5 returns 2 4.3 % 2.1 returns 0.1html/02_operators6.html%= (modulo assignment) %= (modulo assignment) Operators > %= (modulo assignment) Syntax expression1 %= expression2 Arguments expression1,expression2 Integers and variables. Description Operator (assignment); assigns expression1 the value of expression1 % expression2 . Player Flash 4 or later. Example The following illustrates using the %= operator with variables and numbers: x %= y is the same as x = x % y If x = 14 and y = 5 then x %= 5 returns 4 See also % (modulo)html/02_operators7.html& (bitwise AND) & (bitwise AND) Operators > & (bitwise AND) Syntax expression1 & expression2 Arguments expression1, expression2 Any number. Description Operator (bitwise); converts expression1 and expression2 to 32-bit unsigned integers, and performs a Boolean AND operation on each bit of the integer arguments. The result is a new 32-bit unsigned integer. Player Flash 5 or later. In Flash 4 the & operator was used for concatenating strings. In Flash 5 the & operator is a bitwise AND, and the add and + operators concatenate strings. Flash 4 files that use the & operator are automatically updated to use add when brought into the Flash 5 authoring environment.html/02_operators8.html&& (short-circuit AND) && (short-circuit AND) Operators > && (short-circuit AND) Syntax expression1 && expression2 Arguments expression1, expression2 Numbers, strings, variables, or functions. Description Operator (logical); performs a Boolean operation on the values of one or both of the expressions. Causes the Flash interpreter to evaluate expression1 (the left expression) and returns false if the expression evaluates to false . If expression1 evaluates to true , expression2 (the right) is evaluated. If expression2 evaluates to true , the final result is true ; otherwise, it is false . Player Flash 4 or later. Example This example assigns the values of the evaluated expressions to the variables winner and loser in order to perform a test: winner = (chocolateEggs >=10) && (jellyBeans >=25); loser = (chocolateEggs <=1) && (jellyBeans <= 5); if (winner) { alert = "You Win the Hunt!"; if (loser) { alert = "Now THAT'S Unhappy Hunting!"; } } else { alert = "We're all winners!"; }html/02_operators9.html&= (bitwise AND assignment) &= (bitwise AND assignment) Operators > &= (bitwise AND assignment) Syntax expression1 &= expression2 Arguments expression1, expression2 Integers and variables. Description Operator (bitwise assignment); assigns expression1 the value of expression1 & expression2 . Player Flash 5 or later. Example The following illustrates using the &= operator with variables and numbers: x &= y is the same as x = x & y If x = 15 and y = 9 then x &= 9 returns 9 See also & (bitwise AND)html/03_a_c1.html add add A-C > add Syntax string1 add string2 Arguments string1,2 Any string. Description Operator; concatenates two or more strings. The add operator replaces the Flash 4 & operator; Flash 4 files using the & operator are automatically converted to use the add operator for string concatenation when brought into the Flash 5 authoring environment. However, the add operator is deprecated in Flash 5, and use of the + operator is recommended when creating content for the Flash 5 Player. Use the add operator to concatentate strings if you are creating content for Flash 4 or earlier versions of the Player. Player Flash 4 or later. See also + (addition)html/03_a_c10.html Array.reverse Array.reverse A-C > Array.reverse Syntax myArray .reverse(); Arguments None. Description Method; reverses the array in place. Player Flash 5 or later. Example The following is an example of using the Array.reverse method: var numbers = [1, 2, 3, 4, 5, 6]; trace(numbers.join()); numbers.reverse(); trace(numbers.join()); Output: 1,2,3,4,5,6 6,5,4,3,2,1html/03_a_c11.html Array.shift Array.shift A-C > Array.shift Syntax myArray .shift(); Arguments None. Description Method; removes the first element from an array and returns that element. Player Flash 5 or later. Example The following code creates the array myPets and then removes the first element from the array: myPets = ["cat", "dog", "bird", "fish"]; shifted = myPets.shift(); The return value is cat . See also Array.pop Array.unshifthtml/03_a_c12.html Array.slice Array.slice A-C > Array.slice Syntax myArray .slice( start, end ); Arguments start A number specifying the index of the starting point for the slice. If start is a negative number, the starting point begins at the end of the array, where -1 is the last element. end A number specifying the index of the ending point for the slice. If you omit this argument, the slice includes all elements from the start to the end of the array. If end is a negative number, the ending point is specified from the end of the array, where -1 is the last element. Description Method; extracts a slice or a substring of the array and returns it as a new array without modifying the original array. The returned array includes the start element and all elements up to, but not including, the end element. Player Flash 5 or later.html/03_a_c13.html Array.sort Array.sort A-C > Array.sort Syntax myArray .sort(); myArray .sort( orderfunc ); Arguments orderfunc An optional comparison function used to determine the sorting order. Given the arguments A and B, the specified ordering function should perform a sort as follows: -1 if A appears before B in the sorted sequence 0 if A = B 1 if A appears after B in the sorted sequence Description Method; sorts the array in place, without making a copy. If you omit the orderfunc argument, Flash sorts the elements in place using the < comparison operator. Player Flash 5 or later. Example The following example uses Array.sort without specifying the orderfunc argument: var fruits = ["oranges", "apples", "strawberries", "pineapples", "cherries"]; trace(fruits.join()); fruits.sort(); trace(fruits.join()); Output: oranges,apples,strawberries,pineapples,cherries apples,cherries,oranges,pineapples,strawberries The following example uses array.sort with a specified order function: var passwords = [ "gary:foo", "mike:bar", "john:snafu", "steve:yuck", "daniel:1234" ]; function order (a, b) { // Entries to be sorted are in form // name:password // Sort using only the name part of the // entry as a key. var name1 = a.split(':')[0]; var name2 = b.split(':')[0]; if (name1 < name2) { return -1; } else if (name1 > name2) { return 1; } else { return 0; } } for (var i=0; i< password.length; i++) { trace (passwords.join()); } passwords.sort(order); trace ("Sorted:"); for (var i=0; i< password.length; i++) { trace (passwords.join()); } Output: daniel:1234 gary:foo john:snafu mike:bar steve:yuckhtml/03_a_c14.html Array.splice Array.splice A-C > Array.splice Syntax myArray .splice( start, deleteCount, value0,value1...valueN ); Arguments start The index of the element in the array where the insertion and/or deletion begins. deleteCount The number of elements to be deleted. This number includes the element specified in the start argument. If no value is specified for deleteCount , the method deletes all of the values from the start element to the last element in the array. value Zero or more values to insert into the array at the insertion point specified in the start argument. This argument is optional. Description Method; adds and/or removes elements from an array. This method modifies the array itself without making a copy. Player Flash 5 or later.html/03_a_c15.html Array.toString Array.toString A-C > Array.toString Syntax myArray .toString(); Arguments None. Description Method; returns a string value representing the elements in the specified Array object. Every element in the array, starting with index 0 and ending with index myArray .length-1 , is converted to a concatenated string separated by commas. Player Flash 5 or later. Example The following example creates myArray and converts it to a string: myArray = new Array(); myArray[0] = 1; myArray[1] = 2; myArray[2] = 3; myArray[3] = 4; myArray[4] = 5; trace(myArray.toString()) Output: 1,2,3,4,5html/03_a_c16.html Array.unshift Array.unshift A-C > Array.unshift Syntax myArray .unshift( value1,value2,...valueN ); Arguments value1,...valueN One or more numbers, elements, or variables to be inserted at the beginning of the array. Description Method; adds one or more elements to the beginning of an array and returns the array's new length. Player Flash 5 or later.html/03_a_c17.html Boolean (function) Boolean (function) A-C > Boolean (function) Syntax Boolean( expression ); Arguments expression The variable, number, or string to be converted to a Boolean. Description Function; converts the specified argument to a Boolean, and returns the Boolean value. Player Flash 5 or later.html/03_a_c18.html Boolean (object) Boolean (object) A-C > Boolean (object) The Boolean object is a simple wrapper object with the same functionality as the standard JavaScript Boolean object. Use the Boolean object to retrieve the primitive data type or string representation of Boolean object. Method summary for the Boolean object Method Description toString Returns the string representation (true) or (false) of the Boolean object. valueOf Returns the primitive value type of the specified Boolean object. Constructor for the Boolean object Syntax new Boolean(); new Boolean( x ); Arguments x A number, string, Boolean, object, movie clip, or other expression. This argument is optional. Description Constructor; creates an instance of the Boolean object. If you omit the x argument, the Boolean object is initialized with a value of false . If you specify x , the method evaluates the argument and returns the result as a Boolean value according to the following casting rules: If x is a number, the function returns true if x does not equal 0, or false if x is any other number. If x is a Boolean, the function returns x . If x is an object or movie clip, the function returns true if x does not equal null ; otherwise, the function returns false . If x is a string, the function returns true if Number( x ) does not equal 0; otherwise, the function returns false . Note: To maintain compatibility with Flash 4, the handling of strings by the Boolean object is not ECMA-262 standard. Player Flash 5 or later.html/03_a_c19.html Boolean.toString Boolean.toString A-C > Boolean.toString Syntax Boolean.toString(); Arguments None. Description Method; returns the string representation, true or false of the Boolean object. Player Flash 5 or later.html/03_a_c2.html_alpha _alpha A-C > _alpha Syntax instancename ._alpha instancename ._alpha = value ; Arguments instancename The name of a movie clip instance. value A number from 0 to 100 specifying the alpha transparency. Description Property; sets or retrieves the alpha transparency ( value ) of the movie clip.Valid values are 0 (fully transparent) to 100 (fully opaque). Objects in a movie clip with _alpha set to 0 are active, even though they are invisible. For example, a button in a movie clip with _alpha property set to 0 can still be clicked. Player Flash 4 or later. Example The following statements set the _alpha property of a movie clip named star to 30% when the button is clicked: on(release) { setProperty(star._alpha = 30); } or on(release) { star._alpha = 30; }html/03_a_c20.html Boolean.valueOf Boolean.valueOf A-C > Boolean.valueOf Syntax Boolean.valueOf(); Arguments None. Description Method; returns the primitive value type of the specified Boolean object, and converts the Boolean wrapper object to this primitive value type. Player Flash 5 or later.html/03_a_c21.html break break A-C > break Syntax break; Arguments None. Description Action; appears within a loop ( for , for..in , do...while or while ). The break action instructs Flash to skip the rest of the loop body, stop the looping action, and execute the statement following the loop statement. Use the break action to break out of a series of nested loops. Player Flash 4 or later. Example The following example uses the break action to exit an otherwise infinite loop: i = 0; while (true) { if (i >= 100) { break; } i++; }html/03_a_c22.html call call A-C > call Syntax call( frame ); Arguments frame The name or number of the frame to call into the context of the script. Description Action; switches the context from the current script to the script attached to the frame being called. Local variables will not exist once the script is finished executing. Player Flash 4 or later. This action is deprecated in Flash 5, and it is recommended that you use the function action. See also functionhtml/03_a_c23.html chr chr A-C > chr Syntax chr( number ); Arguments number The ASCII code number to convert to a character. Description String function; converts ASCII code numbers to characters. Player Flash 4 or later. This function has been deprecated in Flash 5; use of the String.fromCharCode method is recommended. Example The following example converts the number 65 to the letter "A": chr(65) = "A" See also String.fromCharCodehtml/03_a_c24.html Color (object) Color (object) A-C > Color (object) The Color object allows you to set and retrieve the RGB color value and color transform of movie clips. The Color object is supported by Flash 5 and later versions of the Flash Player. You must use the constructor new Color() to create an instance of the Color object before calling the methods of the Color object. Method summary for the Color object Method Description getRGB Returns the numeric RGB value set by the last setRGB call. getTransform Returns the transform information set by the last setTransform call. setRGB Sets the hexadecimal representation of the RGB value for a Color object. setTransform Sets the color transform for a Color object. Constructor for the Color object Syntax new Color ( target ) ; Arguments target The name of the movie clip the new color is applied to. Description Constructor; creates a Color object for the movie clip specified by the target argument. Player Flash 5 or later. Example The following example creates a new Color object called myColor for the movie myMovie : myColor = new Color( myMovie );html/03_a_c25.html Color.getRGB Color.getRGB A-C > Color.getRGB Syntax myColor .getRGB(); Arguments None. Description Method; returns the numeric values set by the last setRGB call. Player Flash 5 or later. Example The following code retrieves the RGB value as a hexadecimal string: value = (getRGB()).toString(16); See also Color.setRGBhtml/03_a_c26.html Color.getTransform Color.getTransform A-C > Color.getTransform Syntax myColor .getTransform(); Arguments None. Description Method; returns the transform value set by the last setTransform call. Player Flash 5 or later. See also Color.setTransformhtml/03_a_c27.html Color.setRGB Color.setRGB A-C > Color.setRGB Syntax myColor .setRGB( 0xRRGGBB ); Arguments 0xRRGGBB The hexadecimal or RGB color to be set. RR , GG , and BB each consist of two hexadecimal digits specifying the offset of each color component. Description Method; specifies an RGB color for the Color object. Calling this method overrides any previous settings by the setTransform method. Player Flash 5 or later. Example The following example sets the RGB color value for the movie clip myMovie : myColor = new Color(myMovie); myColor.setRGB(0x993366); See also Color.setTransformhtml/03_a_c28.html Color.setTransform Color.setTransform A-C > Color.setTransform Syntax myColor .setTransform( colorTransformObject ); Arguments colorTransformObject An object created using the constructor of the generic Object object, specifying color transform values for parameters. The color transform object must have the parameters ra , rb , ga , gb , ba , bb , aa , ab , which are explained below. Description Method; sets color transform information for a Color object. The colorTransformObject argument is an object that you create using the generic Object object with parameters specifying the percentage and offset values for the red, green, blue, and alpha (transparency) components of a color, entered in a 0xRRGGBBAA format. The parameters for a color transformobject are defined as follows: ra is the percentage for the red component (-100 to 100). rb is the offset for the red component (-255 to 255). ga is the percentage for the green component (-100 to 100). gb is the offset for the green component (-255 to 255). ba is the percentage for the blue component (-100 to 100). bb is the offset for the blue component (-255 to 255). aa is the percentage for alpha (-100 to 100). ab is the offset for alpha (-255 to 255). You create a color transformobject as follows: myColorTransform = new Object(); myColorTransform.ra = 50; myColorTransform.rb = 244; myColorTransform.ga = 40; myColorTransform.gb = 112; myColorTransform.ba = 12; myColorTransform.bb = 90; myColorTransform.aa = 40; myColorTransform.ab = 70; You could also use the following syntax: myColorTransform = { ra: '50', rb: '244', ga: '40', gb: '112', ba: '12', bb: '90', aa: '40', ab: '70'} Player Flash 5 or later. Example The following example shows the process of creating a new Color object for a target movie, creating a color transformobject with the parameters defined above using the Object constructor, and passing the color transform object to a Color object using the setTransform method. //Create a color object called myColor for the target myMovie myColor = new Color(myMovie); //Create a color transform object called myColorTransfrom using //the generic Object object myColorTransform = new Object; // Set the values for myColorTransform myColorTransform = { ra: '50', rb: '244', ga: '40', gb: '112', ba: '12', bb: '90', aa: '40', ab: '70'} //Associate the color transform object with the Color object created for myMovie myColor.setTransform(myColorTransform);html/03_a_c29.html continue continue A-C > continue Syntax continue; Arguments None. Description Action; appears within several types of loop statements. In a while loop, continue causes Flash to skip the rest of the loop body and jump to the top of the loop, where the condition is tested. In a do...while loop, continue causes Flash to skip the rest of the loop body and jump to the bottom of the loop, where the condition is tested. In a for loop, continue causes Flash to skip the rest of the loop body and jump to the evaluation of the for loop's post-expression. In a for...in loop, continue causes Flash to skip the rest of the loop body and jump back to the top of the loop, where the next value in the enumeration is processed. Player Flash 4 or later. See also do... while for for..in whilehtml/03_a_c3.html and and A-C > and Syntax condition1 and condition2 Arguments condition1,condition2 Conditions or expressions that evaluate to true or false . Description Operator; performs a logical AND operation in the Flash 4 Player. If both expressions evaluate to true , then the entire expression is true . Player Flash 4 or later. This operator has been deprecated in Flash 5, and users are encouraged to make use of the new && operator. See also && (short-circuit AND)html/03_a_c30.html_currentframe _currentframe A-C > _currentframe Syntax instancename ._currentframe Arguments instancename The name of a movie clip instance. Description Property (read-only); returns the number of the frame where the playhead is currently located in the Timeline. Player Flash 4 or later. Example The following example uses _currentframe to direct a movie to go five frames ahead of the frame containing the action: gotoAndStop(_currentframe + 5);html/03_a_c4.html Array (object) Array (object) A-C > Array (object) The Array object allows you to access and manipulate arrays. An array is an object whose properties are identified by a number representing their position in the array. This number is sometimes referred to as the index. All arrays are zero based, which means that the first element in the array is [0], the second element is [1], and so on. In the following example, myArray contains the months of the year, identified by number. myArray[0] = "January" myArray[1] = "February" myArray[2] = "March" myArray[3] = "April" To create an Array object, use the constructor new Array . To access the elements of an array use, the array access operator [ ]. Method Description concat Concatenates the arguments and returns them as a new array. join Joins all elements of an array into a string. pop Removes the last element of an array, and returns its value. push Adds one or more elements to the end of an array and returns the array's new length. reverse Reverses the direction of an array. shift Removes the first element from an array, and returns its value. slice Extracts a section of an array and returns it as a new array. sort Sorts an array in place. splice Adds and/or removes elements from an array. toString Returns a string value representing the elements in the Array object. unshift Adds one or more elements to the beginning of an array and returns the array's new length. Method summary for the Array object Property summary for the Array object Property Description length Returns the length of the array. Constructor for the Array object Syntax new Array(); new Array( length ); new Array( element0, element1, element2,...elementN ); Arguments length An integer specifying the number of elements in the array. In the case of noncontiguous elements, the length specifies the index number of the last element in the array plus 1. For more information, see the property Array.length . element0...elementN A list of two or more arbitrary values. The values can be numbers, names, or other elements specified in an array. The first element in an array always has the index or position 0. Description Constructor; allows you to access and manipulate elements in an array. Arrays are zero based and the elements are indexed by their ordinal number. If you don't specify any arguments, a zero-length array is created. Player Flash 5 or later. Example The following example creates a new Array object with an initial length of 0: myArray = new Array(); The following example creates the new Array object A-Team , with an initial length of 4: A-Team = new Array("Jody", "Mary", "Marcelle", "Judy"); The initial elements of the A-Team array are as follows: myArray[0] = "Jody" myArray[1] = "Mary" myArray[2] = "Marcelle" myArray[3] = "Judy" See also Array.lengthhtml/03_a_c5.html Array.concat Array.concat A-C > Array.concat Syntax myArray .concat( value0,value1,...valueN ); Arguments value0,...valueN Numbers, elements, or strings to be concatenated in a new array. Description Method; concatenates the elements specified in the arguments, if any, and creates and returns a new array. If the arguments specify an array, the elements of that array are concatenated, rather than the array itself. Player Flash 5 or later. Example The following code concatenates two arrays: alpha = new Array("a","b","c"); numeric = new Array(1,2,3); alphaNumeric=alpha.concat(numeric); // creates array ["a","b","c",1,2,3] The following code concatenates three arrays: num1=[1,3,5]; num2=[2,4,6]; num3=[7,8,9]; nums=num1.concat(num2,num3) // creates array [1,3,5,2,4,6,7,8,9]html/03_a_c6.html Array.join Array.join A-C > Array.join Syntax myArray .join(); myArray .join( separator ); Arguments separator A character or string that separates array elements in the returned string. If you omit this argument, a comma is used as the default separator. Description Method; converts the elements in an array to strings, concatenates them, inserts the specified separator between the elements, and returns the resulting string. Player Flash 5 or later. Example The following example creates an array, with three elements. It then joins the array three times: using the default separator, then a comma and a space, and then a plus sign. a = new Array("Earth","Moon","Sun") // assigns "Earth,Moon,Sun" to myVar1 myVar1=a.join(); // assigns "Earth, Moon, Sun" to myVar2 myVar2=a.join(", "); // assigns "Earth + Moon + Sun" to myVar3 myVar3=a.join(" + ");html/03_a_c7.html Array.length Array.length A-C > Array.length Syntax myArray .length; Arguments None. Description Property; contains the length of the array. This property is automatically updated when new elements are added to the array. During assignment myArray[index] = value ; if index is a number, and index+1 is a greater than the length property, the length property is updated to index + 1 . Player Flash 5 or later. Example The following code explains how the length property is updated: //initial length is 0 myArray = new Array(); //myArray.length is updated to 1 myArray[0] = 'a'; //myArray.length is updated to 2 myArray[1] = 'b'; //myArray.length is updated to 10 myArray[9] = 'c';html/03_a_c8.html Array.pop Array.pop A-C > Array.pop Syntax myArray .pop(); Arguments None. Description Method; removes the last element from an array and returns the value of that element. Player Flash 5 or later. Example The following code creates the myPets array containing four elements, then removes its last element: myPets = ["cat", "dog", "bird", "fish"]; popped = myPets.pop();html/03_a_c9.html Array.push Array.push A-C > Array.push Syntax myArray .push( value,.. . ); Arguments value One or more values to append to the array. Description Method; adds one or more elements to the end of an array and returns the array's new length. Player Flash 5 or later. Example The following code creates the myPets array containing two elements, then adds two elements to it. After the code executes, pushed contains 4. myPets = ["cat", "dog"]; pushed = myPets.push("bird", "fish");html/04_date1.html Date (object) Date (object) Date > Date (object) The Date object allows you to retrieve date and time values relative to universal time (Greenwich Mean Time, now called Universal Coordinated Time) or relative to the operating system on which the Flash Player is running. To call the methods of the Date object, you must first create an instance of the Date object using the constructor. The Date object requires the Flash 5 Player. The methods of the Date object are not static, but apply only to the individual instance of the Date object specified when the method is called. Method summary for Date object Method Description getDate Returns the day of the month of the specified Date object according to local time. getDay Returns the day of the month for the specified Date object according to local time. getFullYear Returns the four-digit year of the specified Date object according to local time. getHours Returns the hour of the specified Date object according to local time. getMilliseconds Returns the milliseconds of the specified Date object according to local time. getMinutes Returns the minutes of the specified Date object according to local time. getMonth Returns the month of the specified Date object according to local time. getSeconds Returns the seconds of the specified Date object according to local time. getTime Returns the number of milliseconds since midnight January 1, 1970, universal time, for the specified Date object. getTimezoneOffset Returns the difference, in minutes, between the computer's local time and the universal time. getUTCDate Returns the day (date) of the month of the specified Date object according to universal time. getUTCDay Returns the day of the week of the specified Date object according to universal time. getUTCFullYear Returns the four-digit year of the specified Date object according to universal time. getUTCHours Returns the hour of the specified Date object according to universal time. getUTCMilliseconds Returns the milliseconds of the specified Date object according to universal time. getUTCMinutes Returns the minute of the specified Date object according to universal time. getUTCMonth Returns the month of the specified Date object according to universal time. getUTCSeconds Returns the seconds of the specified Date object according to universal time. getYear Returns the year of the specified Date object according to local time. setDate Returns the day of the month of a specified Date object according to local time. setFullYear Sets the full year for a Date object according to local time. setHours Sets the hours for a Date object according to local time. setMilliseconds Sets the milliseconds for a Date object according to local time. setMinutes Sets the minutes for a Date object according to local time. setMonth Sets the month for a Date object according to local time. setSeconds Sets the seconds for a Date object according to local time. setTime Sets the date for the specified Date object in milliseconds. setUTCDate Sets the date of the specified Date object according to universal time. setUTCFullYear Sets the year of the specified Date object according to universal time. setUTCHours Sets the hour of the specified Date object according to universal time. setUTCMilliseconds Sets the milliseconds of the specified Date object according to universal time. setUTCMinutes Sets the minute of the specified Date object according to universal time. setUTCMonth Sets the month represented by the specified Date object according to universal time. setUTCSeconds Sets the seconds of the specified Date object according to universal time. setYear Sets the year for the specified Date object according to local time. toString Returns a string value representing the date and time stored in the specified Date object. Date.UTC Returns the number of milliseconds between midnight on January 1, 1970, universal time, and the specified time. Constructor for the Date object Syntax new Date(); new Date( year [, month [, date [, hour [, minute [, second [, millisecond ]]]]]] ); Arguments year A value of 0 to 99 indicates 1900 though 1999, otherwise all 4 digits of the year must be specified. month An integer from 0 (January) to 11 (December). This argument is optional. date An integer from 1 to 31. This argument is optional. hour An integer from 0 (midnight) to 23 (11 p.m.). minute An integer from 0 to 59. This argument is optional. second An integer from 0 to 59. This argument is optional. millisecond An integer from 0 to 999. This argument is optional. Description Object; constructs a new Date object holding the current date and time. Player Flash 5 or later. Example The following example retrieves the current date and time: now = new Date(); The following example creates a new Date object for a Gary's birthday, August 7, 1974: gary_birthday = new Date (74, 7, 7); The following example creates a new Date object, concatenates the returned values of the Date object methods getMonth , getDate , and getFullYear , and displays them in the text field specified by the variable dateTextField. myDate = new Date(); dateTextField = (mydate.getMonth() + "/" + myDate.getDate() + "/" + mydate.getFullYear());html/04_date10.html Date.getTime Date.getTime Date > Date.getTime Syntax myDate .getTime(); Arguments None. Description Method; returns the number of milliseconds (an integer from 0 to 999) since midnight January 1, 1970, universal time, for the specified Date object. Use this method to represent a specific instant in time when comparing two or more times defined in different time zones. Player Flash 5 or later.html/04_date11.html Date.getTimezoneOffset Date.getTimezoneOffset Date > Date.getTimezoneOffset Syntax mydate .getTimezoneOffset(); Arguments None. Description Method; returns the difference, in minutes, between the computer's local time and the universal time. Player Flash 5 or later. Example The following example returns the difference between the local daylight-saving time for San Francisco and the universal time. Daylight-savings time is factored into the returned result only if the date defined in the Date object is during the daylight-savings time. new Date().getTimezoneOffset(); The result is as follows: 420 (7 hours * 60 minutes/hour = 420 minutes)html/04_date12.html Date.getUTCDate Date.getUTCDate Date > Date.getUTCDate Syntax myDate .getUTCDate(); Arguments None. Description Method; returns the day (date) of the month in the specified Date object, according to universal time. Player Flash 5 or later.html/04_date13.html Date.getUTCDay Date.getUTCDay Date > Date.getUTCDay Syntax myDate .getUTCDate(); Arguments None. Description Method; returns the day of the week of the specified Date object, according to universal time.html/04_date14.html Date.getUTCFullYear Date.getUTCFullYear Date > Date.getUTCFullYear Syntax myDate .getUTCFullYear(); Arguments None. Description Method; returns the four-digit year of the specified Date object, according to universal time. Player Flash 5 or later.html/04_date15.html Date.getUTCHours Date.getUTCHours Date > Date.getUTCHours Syntax myDate .getUTCHours(); Arguments None. Description Method; returns the hours of the specified Date object, according to universal time. Player Flash 5 or later.html/04_date16.html Date.getUTCMilliseconds Date.getUTCMilliseconds Date > Date.getUTCMilliseconds Syntax myDate .getUTCMilliseconds(); Arguments None. Description Method; returns the milliseconds of the specified Date object, according to universal time. Player Flash 5 or later.html/04_date17.html Date.getUTCMinutes Date.getUTCMinutes Date > Date.getUTCMinutes Syntax myDate .getUTCMinutes(); Arguments None. Description Method; returns the minutes of the specified Date object, according to universal time. Player Flash 5 or later.html/04_date18.html Date.getUTCMonth Date.getUTCMonth Date > Date.getUTCMonth Syntax myDate .getUTCMonth(); Arguments None. Description Method; returns the month of the specified Date object, according to universal time. Player Flash 5 or later.html/04_date19.html Date.getUTCSeconds Date.getUTCSeconds Date > Date.getUTCSeconds Syntax myDate .getUTCSeconds(); Arguments None. Description Method; returns the seconds in the specified Date object, according to universal time. Player Flash 5 or later.html/04_date2.html Date.getDate Date.getDate Date > Date.getDate Syntax myDate .getDate(); Arguments None. Description Method; returns the day of the month (an integer from 1 to 31) of the specified Date object according to local time. Player Flash 5 or later.html/04_date20.html Date.getYear Date.getYear Date > Date.getYear Syntax myDate .getYear(); Arguments None. Description Method; returns the year of the specified Date object, according to local time. Local time is determined by the operating system on which the Flash Player is running. The year is the full year minus 1900. For example, the year 2000 is represented as 100. Player Flash 5 or later.html/04_date21.html Date.setDate Date.setDate Date > Date.setDate Syntax myDate .setDate( date ); Arguments date An integer from 1 to 31. Description Method; sets the day of the month for the specified Date object, according to local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/04_date22.html Date.setFullYear Date.setFullYear Date > Date.setFullYear Syntax myDate .setFullYear( year [, month [, date ]] ); Arguments year A four-digit number specifying a year. Two-digit numbers do not represent years; for example, 99 is not the year 1999, but the year 99. month An integer from 0 (January) to 11 (December). This argument is optional. date A number from 1 to 31. This argument is optional. Description Method; sets the year of the specified Date object, according to local time. If the month and date arguments are specified, they are also set to local time. Local time is determined by the operating system on which the Flash Player is running. The results of getUTCDay and getDay may change as a result of calling this method. Player Flash 5 or later.html/04_date23.html Date.setHours Date.setHours Date > Date.setHours Syntax myDate .setHours( hour ); Arguments hour An integer from 0 (midnight) to 23 (11 p.m.). Description Method; sets the hours for the specified Date object according to local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/04_date24.html Date.setMilliseconds Date.setMilliseconds Date > Date.setMilliseconds Syntax myDate .setMilliseconds( millisecond ); Arguments millisecond An integer from 0 to 999. Description Method; sets the milliseconds for the specified Date object according to local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/04_date25.html Date.setMinutes Date.setMinutes Date > Date.setMinutes Syntax myDate .setMinutes( minute ); Arguments minute An integer from 0 to 59. Description Method; sets the minutes for a specified Date object according to local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/04_date26.html Date.setMonth Date.setMonth Date > Date.setMonth Syntax myDate .setMonth( month [, date ]); Arguments month An integer from 0 (January) to 11 (December). date An integer from 1 to 31. This argument is optional. Description Method; sets the month for the specified Date object in local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/04_date27.html Date.setSeconds Date.setSeconds Date > Date.setSeconds Syntax myDate .setSeconds( second ); Arguments second An integer from 0 to 59. Description Method; sets the seconds for the specified Date object in local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/04_date28.html Date.setTime Date.setTime Date > Date.setTime Syntax myDate .setTime( millisecond ); Arguments millisecond An integer from 0 to 999. Description Method; sets the Date for the specified Date object in milliseconds. Player Flash 5 or later.html/04_date29.html Date.setUTCDate Date.setUTCDate Date > Date.setUTCDate Syntax myDate .setUTCDate( date ); Arguments date An integer from 1 to 31. Description Method; sets the date for the specified Date object in universal time. Calling this method does not modify the other fields of the specified Date, but the getUTCDay and getDay methods may report a new value if the day of the week changes as a result of calling this method. Player Flash 5 or later.html/04_date3.html Date.getDay Date.getDay Date > Date.getDay Syntax myDate .getDay(); Arguments None. Description Method; returns the day of the month (0 for Sunday, 1 for Monday, and so on) of the specified Date object according to local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/04_date30.html Date.setUTCFullYear Date.setUTCFullYear Date > Date.setUTCFullYear Syntax myDate .setUTCFullYear( year [, month [, date ]]); Arguments year The year specified as a full four-digit year, for example, 2000. month An integer from 0 (January) to 11 (December). This argument is optional. date An integer from 1 to 31. This argument is optional. Description Method; sets the year or the specified Date object ( mydate ) in universal time. Optionally, this method can also set the month and date represented by the specified Date object. No other fields of the Date object are modified. Calling setUTCFullyear may cause getUTCDay and getDay to report a new value if the day of the week changes as a result of this operation. Player Flash 5 or later.html/04_date31.html Date.setUTCHours Date.setUTCHours Date > Date.setUTCHours Syntax myDate .setUTCHours( hour [ , minute [ , second [ , millisecond ]]] )); Arguments hour An integer from 0 (midnight) to 23 (11p.m.). minute An integer from 0 to 59. This argument is optional. second An integer from 0 to 59. This argument is optional. millisecond An integer from 0 to 999. This argument is optional. Description Method; sets the hour for the specified Date object in universal time. Player Flash 5 or later.html/04_date32.html Date.setUTCMilliseconds Date.setUTCMilliseconds Date > Date.setUTCMilliseconds Syntax myDate .setUTCMilliseconds( millisecond ); Arguments millisecond An integer from 0 to 999. Description Method; sets the milliseconds for the specified Date object in universal time. Player Flash 5 or later.html/04_date33.html Date.setUTCMinutes Date.setUTCMinutes Date > Date.setUTCMinutes Syntax myDate .setUTCMinutes( minute [ , second [ , millisecond ]] )); Arguments minute An integer from 0 to 59. second An integer from 0 to 59. This argument is optional. millisecond An integer from 0 to 999. This argument is optional. Description Method; sets the minute for the specified Date object in universal time. Player Flash 5 or later.html/04_date34.html Date.setUTCMonth Date.setUTCMonth Date > Date.setUTCMonth Syntax myDate .setUTCMonth( month [, date ]); Arguments month An integer from 0 (January) to 11 (December). date An integer from 1 to 31. This argument is optional. Description Method; sets the month, and optionally the day (date), for the specified Date object in universal time. Calling this method does not modify the other fields of the specified Date object, but the getUTCDay and getDay methods may report a new value if the day of the week changes as a result of specifying the date argument when calling setUTCMonth . Player Flash 5 or later.html/04_date35.html Date.setUTCSeconds Date.setUTCSeconds Date > Date.setUTCSeconds Syntax myDate .setUTCSeconds( second [ , millisecond ] ) ); Arguments second An integer from 0 to 59. millisecond An integer from 0 to 999. This argument is optional. Description Method; sets the seconds for the specified Date object in universal time. Player Flash 5 or later.html/04_date36.html Date.setYear Date.setYear Date > Date.setYear Syntax myDate .setYear( year ); Arguments year A four-digit number, for example, 2000. Description Method; sets the year for the specified date object in local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/04_date37.html Date.toString Date.toString Date > Date.toString Syntax myDate .toString(); Arguments None. Description Method; returns a string value for the specified date object in a readable format. Player Flash 5 or later. Example The following example returns the information in the dateOfBirth Date object as a string: var dateOfBirth = newDate(74, 7, 7, 18, 15); trace (dateOfBirth.toString()); Output (for Pacific Standard Time): Wed Aug 7 18:15:00 GMT-0700 1974html/04_date38.html Date.UTC Date.UTC Date > Date.UTC Syntax Date.UTC( year , month [, date [, hour [, minute [, second [, millisecond ]]]]]); Arguments year A four-digit number, for example, 2000. month An integer from 0 (January) to 11 (December). date An integer from 1 to 31. This argument is optional. hour An integer from 0 (midnight) to 23 (11 p.m.). minute An integer from 0 to 59. This argument is optional. second An integer from 0 to 59. This argument is optional. millisecond An integer from 0 to 999. This argument is optional. Description Method; returns the number of milliseconds between midnight on January 1, 1970, universal time, and the time specified in the arguments. This is a static method that is invoked through the Date object constructor, not through a specific Date object. This method allows you to create a Date object that assumes universal time, whereas the Date constructor assumes local time. Player Flash 5 or later. Example The following example creates a new Date object gary_birthday defined in universal time. This is the universal time variation of the example used for the constructor method new Date() : gary_birthday = new Date(Date.UTC(1974, 7, 8));html/04_date4.html Date.getFullYear Date.getFullYear Date > Date.getFullYear Syntax myDate .getFullYear(); Arguments None. Description Method; returns the full year (a four-digit number, for example, 2000) of the specified Date object, according to local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later. Example The following example uses the constructor to create a new Date object and send the value returned by the getFullYear method to the Output window: myDate = new Date(); trace(myDate.getFullYear());html/04_date5.html Date.getHours Date.getHours Date > Date.getHours Syntax myDate .getHours(); Arguments None. Description Method; returns the hour (an integer from 0 to 23) of the specified Date object, according to local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/04_date6.html Date.getMilliseconds Date.getMilliseconds Date > Date.getMilliseconds Syntax myDate .getMilliseconds(); Arguments None. Description Method; returns the milliseconds (an integer from 0 to 999) of the specified Date object, according to local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/04_date7.html Date.getMinutes Date.getMinutes Date > Date.getMinutes Syntax myDate .getMinutes(); Arguments None. Description Method; returns the minutes (an integer from 0 to 59) of the specified Date object, according to local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/04_date8.html Date.getMonth Date.getMonth Date > Date.getMonth Syntax myDate .getMonth(); Arguments None. Description Method; returns the month (0 for January, 1 for February, and so on) of the specified Date object, according to local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/04_date9.html Date.getSeconds Date.getSeconds Date > Date.getSeconds Syntax myDate .getSeconds(); Arguments None. Description Method; returns the seconds (an integer from 0 to 59) of the specified Date object, according to local time. Local time is determined by the operating system on which the Flash Player is running. Player Flash 5 or later.html/05_de_i1.html delete delete De-I > delete Syntax delete ( reference ); Arguments reference The name of variable or object to eliminate. Description Operator; destroys the object or variable specified as the reference , and returns true if the object was successfully deleted; otherwise returns false . This operator is useful for freeing up memory used by scripts, although, delete is an operator, it is typically used as a statement: delete x; The delete operator may fail and return false if the reference does not exist, or may not be deleted. Predefined objects and properties, and variables declared with var , may not be deleted. Player Flash 5 or later. Example The following example creates an object, uses it, and then deletes it once it is no longer needed: account = new Object(); account.name = 'Jon'; account.balance = 10000; ... delete account; The following example deletes a property of an object: // create the new object "account" account = new Object(); // assign property name to the account account.name = 'Jon'; // delete the property delete account.name; The following is another example of deleting an object property: // create an Array object with length 0 array = new Array(); // Array.length is now 1 array[0] = "abc"; // add another element to the array,Array.length is now 2 array[1] = "def"; // add another element to array,Array.length is now 3 array[2] = "ghi"; // array[2] is deleted, but Array.length is not changed, delete array[2]; The following example illustrates the behavior of delete on object references: // create a new object, and assign the variable ref1 to refer to the object ref1 = new Object(); ref1.name = "Jody"; // copy the reference variable into a new variable, and delete ref1 ref2 = ref1; delete ref1; If ref1 had not been copied into ref2 , the object would have been deleted when we deleted ref1 , because there would be no references to it. If we were to delete ref2 , there would no longer be any references to the object, and it would be destroyed and the memory it was using would be made available. See also varhtml/05_de_i10.html_focusrect _focusrect De-I > _focusrect Syntax _focusrect = Boolean ; Arguments Boolean true or false . Description Property (global); specifies whether a yellow rectangle appears around the button that has the current focus. The default value true (nonzero) displays a yellow rectangle around the currently focused button or text field as the user presses the Tab key to navigate. Specify false to display only the button "over" state (if any is defined) as users navigate. Player Flash 4 or later.html/05_de_i11.html for for De-I > for Syntax for( init; condition; next ); { statement; } Arguments init An expression to evaluate before beginning the looping sequence, typically an assignment expression. A var statement is also permitted for this argument. condition An expression that evaluates to true or false . The condition is evaluated before each loop iteration; the loop exits when the condition evaluates to false . next An expression to evaluate after each loop iteration; usually an assignment expression using the ++ (increment) or -- (decrement) operators. statement A statement within the body of the loop to execute. Description Action; a loop construct that evaluates the init (initialize) expression once, and then begins a looping sequence by which, as long as the condition evaluates to true , statement is executed and the next expression is evaluated. Some properties can not be enumerated by the for or for..in actions. For example, the built-in methods of the Array object ( Array.sort and Array.reverse ) are not included in the enumeration of an Array object, and movie clip properties, such as _x and _y, are not enumerated. Player Flash 5 or later. Example The following example uses for to add the elements in an array: for(i=0; i<10; i++) { array [i] = (i + 5)*10; } Returns the following array: [50, 60, 70, 80, 90, 100, 110, 120, 130, 140] The following is an example of using for to perform the same action repeatedly. In the code below, the for loop adds the numbers from 1 to 100: var sum = 0; for (var i=1; i<=100; i++) { sum = sum + i; } See also ++ (increment) -- (decrement) for..in varhtml/05_de_i12.html for..in for..in De-I > for..in Syntax for(v ariableiterant in object ){ statement; } Arguments variableiterant The name of a variable to act as the iterant, referencing each property of an object or element in an array. object The name of an object to be iterated over. statement A statement to execute for each iteration. Description Action; loops through the properties of an object or element in an array, and executes the statement for each property of an object. Some properties can not be enumerated by the for or for..in actions. For example, the built-in methods of the Array object ( Array.sort and Array.reverse ) are not included in the enumeration of an Array object, and movie clip properties such as _x and _y are not enumerated. The for...in construct iterates over properties of objects in the iterated object's prototype chain. If the child's prototype is parent, iterating over the properties of the child with for...in , will also iterate over the properties of parent. Player Flash 5 or later. Example The following is an example of using for..in to iterate over the properties of an object: myObject = { name:'Tara', age:27, city:'San Francisco' }; for (name in myObject) { trace ("myObject." + name + " = " + myObject[name]); } The output of this example is as follows: myObject.name = Tara myObject.age = 27 myObject.city = San Francisco The following is an example of using the typeof operator with for..in to iterate over a particular type of child: for (name in myMovieClip) { if (typeof (myMovieClip[name]) = "movieclip") { trace ("I have a movie clip child named " + name); } } The following example enumerates the children of a movie clip and sends each to frame 2 in their respective Timelines. The RadioButtonGroup movie clip is a parent with several children, _RedRadioButton_ , _GreenRadioButton_ and _BlueRadioButton . for (var name in RadioButtonGroup) { RadioButtonGroup[name].gotoAndStop(2); }html/05_de_i13.html_framesloaded _framesloaded De-I > _framesloaded Syntax instancename ._framesloaded Arguments instancename The name of the movie clip instance to be evaluated. Description Property (read-only); the number of frames that have been loaded from a streaming movie. This property is useful for determining whether the contents of a specific frame, and all the frames before it, have loaded and are available locally in a user's browser. This property is useful for monitoring the download process of large movies. For example, you might want to display a message to users indicating that the movie is loading until a specified frame in the movie has finished loading. Player Flash 4 or later. Example The following is an example of using the _framesloaded property to coordinate the start of the movie to the number of frames loaded: if (_framesloaded >= _totalframes) { gotoAndPlay ("Scene 1", "start"); } else { setProperty ("_root.loader", _xscale, (_framesloaded/_totalframes)*100); }html/05_de_i14.html fscommand fscommand De-I > fscommand Syntax fscommand( command , arguments ); Arguments command A string passed to the host application for any use. arguments A string passed to the host application for any use. Description Action; allows the Flash movie to communicate with the program hosting the Flash Player. In a Web browser, fscommand calls the JavaScript function moviename_Dofscommand in the HTML page containing the Flash movie, where moviename is the name of the Flash Player as assigned by the NAME attribute of the EMBED tag or the ID property of the OBJECT tag. If the Flash Player is assigned the name theMovie , the JavaScript function called is theMovie_Dofscommand . Player Flash 3 or later.html/05_de_i15.html function function De-I > function Syntax function functionname ([ argument0, argument1,...argumentN ] ) { statement(s) } function ([ argument0, argument1,...argumentN ] ) { statement(s) } Arguments functionname The name of the new function. argument Zero or more strings, numbers, or objects to pass the function . statements Zero or more ActionScript statements you have defined for the body of the function . Description Action; a set of statements that you define to perform a certain task. You can declare , or define, a function in one location and call, or invoke, it from different scripts in a movie. When you define a function, you can also specify arguments for the function. Arguments are placeholders for values on which the function will operate. You can pass a function different arguments, also called parameters, each time you call it. Use the return action in a functions statement(s) to cause a function to return, or generate, a value. Usage 1: Declares a function with the specified functionname , arguments , and statement(s) . When a function is called, the function declaration is invoked. Forward referencing is permitted; within the same Action list, a function may be declared after it is called. A function declaration replaces any prior declaration of the same function. You can use this syntax wherever a statement is permitted. Usage 2: Creates an anonymous function and returns it. This syntax is used in expressions, and is particularly useful for installing methods in objects. Player Flash 5 or later. Example (Usage 1) The following example defines the function sqr , which accepts one argument, and returns the square(x*x) of the argument. Note that if the function is declared and used in the same script, the function declaration may appear after using the function. y=sqr(3); function sqr(x) { return x*x; } (Usage 2) The following function defines a Circle object: function Circle(radius) { this.radius = radius; } The following statement defines an anonymous function that calculates the area of a circle and attaches it to the object Circle as a method: Circle.prototype.area = function () {return Math.PI * this.radius * this.radius}html/05_de_i16.html ge (greater than or equal to—string specific) ge (greater than or equal to—string specific) De-I > ge (greater than or equal to—string specific) Syntax expression1 ge expression2 Arguments expression1, expression2 Numbers, strings, or variables. Description Operator (comparison); compares expression1 to expression2 and returns true if expression1 is greater than or equal to expression2 ; otherwise, returns false . Player Flash 4 or later. This operator has been deprecated in Flash 5; use of the new >= operator is recommended. See also >= (greater than or equal to)html/05_de_i17.html getProperty getProperty De-I > getProperty Syntax getProperty( instancename , property ); Arguments instancename The instance name of a movie clip for which the property is being retrieved. property A property of a movie clip, such as an x or y coordinate. Description Function; returns the value of the specified property for the movie clip instance. Player Flash 4 or later. Example The following example retrieves the horizontal axis coordinate ( _x ) for the movie clip myMovie : getProperty(_root.myMovie_item._x);html/05_de_i18.html getTimer getTimer De-I > getTimer Syntax getTimer(); Arguments None. Description Function; returns the number of milliseconds that have elapsed since the movie started playing. Player Flash 4 or later.html/05_de_i19.html getURL getURL De-I > getURL Syntax getURL( url [, window [, variables ]]); Arguments url The URL from which to obtain the document. The URL must be in the same subdomain as the URL where the movie currently resides. window An optional argument specifying the window or HTML frame that the document should be loaded into. Enter the name of a specific window or choose from the following reserved target names: _self specifies the current frame in the current window. _blank specifies a new window. _parent specifies the parent of the current frame. _top specifies the top-level frame in the current window. variables An optional argument specifying a method for sending variables. If there are no variables, omit this argument; otherwise, specify whether to load variables using a GET or POST method. GET appends the variables to the end of the URL, and is used for small numbers of variables. POST sends the variables in a separate HTTP header and is used for long strings of variables. Description Action; loads a document from a specific URL into a window, or passes variables to another application at a defined URL. To test this action, make sure the file to be loaded is at the specified location. To use an absolute URL (for example, http://www.myserver.com ), you need a network connection. Player Flash 2 or later. The GET and POST options are only available to Flash 4 and later versions of the Player. Example This example loads a new URL into a blank browser window. The getURL action targets the variable incomingAd as the url parameter so that you can change the loaded URL without having to edit the Flash movie. The incomingAd variable's value is passed into Flash earlier in the movie using a loadVariables action. on(release) { getURL(incomingAd, "_blank"); } See also loadVariables XML.send XML.sendAndLoad XMLSocket.sendhtml/05_de_i2.html do... while do... while De-I > do... while Syntax do { statement ; } while ( condition ); Arguments condition The condition to evaluate. statement The statement to execute as long as condition evaluates to true . Description Action; executes the statements, and then evaluates the condition in a loop for as long as the condition is true. Player Flash 4 or later. See also break continuehtml/05_de_i20.html getVersion getVersion De-I > getVersion Syntax getVersion(); Arguments None. Description Function; returns a string containing Flash Player version and platform information. This function does not work in test-movie mode, and will only return information for versions 5 or later of the Flash Player. Example The following is an example of a string returned by the getVersion function: WIN 5,0,17,0 This indicates that the platform is Windows, and the version number of the Flash Player is major version 5, minor version 17(5.0r17). Player Flash 5 or later.html/05_de_i21.html gotoAndPlay gotoAndPlay De-I > gotoAndPlay Syntax gotoAndPlay( scene, frame ); Arguments scene The scene name to which the playhead is sent. frame The frame number to which the playhead is sent. Description Action; sends the playhead to the specified frame in a scene and plays from that frame. If no scene is specified, the playhead goes to the specified frame in the current scene. Player Flash 2 or later. Example When the user clicks a button that the gotoAndPlay action is assigned to, the playhead is sent to frame 16 and starts to play. on(release) { gotoAndPlay(16); }html/05_de_i22.html gotoAndStop gotoAndStop De-I > gotoAndStop Syntax gotoAndStop( scene, frame ); Arguments scene The scene name to which the playhead is sent. frame The frame number to which the playhead is sent. Description Action; sends the playhead to the specified frame in a scene and stops it. If no scene is specified, the playhead is sent to the frame in the current scene. Player Flash 2 or later. Example When the user clicks a button that the gotoAndStop action is assigned to, the playhead is sent to frame 5 and the movie stops playing. on(release) { gotoAndStop(5); }html/05_de_i23.html gt (greater than —string specific) gt (greater than —string specific) De-I > gt (greater than —string specific) Syntax expression1 gt expression2 Arguments expression1, expression2 Numbers, strings, or variables. Description Operator (comparison); compares expression1 to expression2 and returns true if expression1 is greater than expression2 ; otherwise, returns false . Player Flash 4 or later. This operator has been deprecated in Flash 5; use of the new > operator is recommended. See also > (greater than)html/05_de_i24.html_height _height De-I > _height Syntax instancename ._height instancename ._height = value ; Arguments instancename An instance name of a movie clip for which the _height property is to be set or retrieved. value An integer specifying the height of the movie in pixels. Description Property; sets and retrieves the height of the space occupied by a movie's content. In previous versions of Flash, _height and _width were read-only properties; in Flash 5 these properties can be set. Player Flash 4 or later. Example The following code example sets the height and width of a movie clip when the user clicks the mouse: onClipEvent(mouseDown) { _width=200; _height=200; }html/05_de_i25.html_highquality _highquality De-I > _highquality Syntax _highquality = value; Arguments value The level of anti-aliasing applied to the movie. Specify 2 (BEST) to apply high quality with bitmap smoothing always on. Specify 1 (high quality) to apply anti-aliasing; this will smooth bitmaps if the movie does not contain animation. Specify 0 (low quality) to prevent anti-aliasing. Description Property (global); specifies the level of anti-aliasing applied to the current movie. Player Flash 4 or later. See also _quality toggleHighQualityhtml/05_de_i26.html if if De-I > if Syntax if( condition) { statement ; } Arguments conditional An expression that evaluates to true or false . For example, if(name == "Erica"), evaluates the variable name to see if it is "Erica." statements The instructions to execute if or when the condition evaluates to true . Description Action; evaluates a condition to determine the next action in a movie. If the condition is true , Flash runs the statements that follow. Use if to create branching logic in your scripts. Player Flash 4 or later. See also else for for..inhtml/05_de_i27.html ifFrameLoaded ifFrameLoaded De-I > ifFrameLoaded Syntax ifFrameLoaded( scene , frame ) { statement; } ifFrameLoaded( frame ) { statement; } Arguments scene The scene that is being queried. frame The frame number or frame label to load before the next statement is executed. Description Action; checks whether the contents of a specific frame are available locally. Use ifFrameLoaded to start playing a simple animation while the rest of the movie downloads to the local computer. The difference between using _framesloaded and ifFrameLoaded is that _framesloaded allows you to add if, or else statements, while ifFrameLoaded action allows you to specify a number of frames in one simple statement. Player Flash 3 or later. The ifFrameLoaded action is deprecated in Flash 5; use of the _framesloaded action is encouraged. See also _framesloadedhtml/05_de_i28.html#include #include De-I > #include Syntax #include " filename.as "; Arguments filename.as The filename to include; .as is the recommended file extension. Description Action; includes the contents of the file specified in the argument when the movie is tested, published, or exported. The #include action is invoked when you test, publish, or export. The #include action is checked when a syntax check occurs. Player N/Ahtml/05_de_i29.html Infinity Infinity De-I > Infinity Syntax Infinity Arguments None. Description Top-level variable; a predefined variable with the ECMA-262 value for infinity. Player Flash 5 or later.html/05_de_i3.html_droptarget _droptarget De-I > _droptarget Syntax draggableInstanceName ._droptarget Arguments draggableInstanceName The name of a movie clip instance that was the target of a startDrag action. Description Property (read-only); returns the absolute path in slash syntax notation of the movie clip instance on which the draggableInstanceName was dropped. The _droptarget property always returns a path that starts with / . To compare the _droptarget property of an instance to a reference, use eval to convert the returned value from slash syntax to a reference. Player Flash 4 or later. Example The following example evaluates the _droptarget property of the garbage movie clip instance and uses eval to convert it from slash syntax to a dot syntax reference. The garbage reference is then compared to the reference to the trash movie clip instance. If the two references are equivalent, the visibility of garbage is set to false . If they are not equivalent, the garbage instance is reset to its original position. if (eval(garbage._droptarget) == _root.trash) { garbage._visible = false; } else { garbage._x = x_pos; garbage._y = y_pos; } The variables x_pos and y_pos are set on frame 1 of the movie with the following script: x_pos = garbage._x; y_pos = garbage._y; See also startDraghtml/05_de_i30.html int int De-I > int Syntax int( value ); Arguments value A number to be rounded to an integer. Description Function; converts a decimal number to the closest integer value. Player Flash 4 or later. This function has been deprecated in Flash 5; use of the Math.floor method is recommended. See also Math.floorhtml/05_de_i31.html isFinite isFinite De-I > isFinite Syntax isFinite( expression ); Arguments expression The Boolean, variable, or other expression to be evaluated. Description Top-level function; evaluates the argument and returns true if it is a finite number, and false if it is infinity or negative infinity. The presence of infinity or negative infinity indicates a mathematical error condition such as division by 0. Player Flash 5 or later. Example The following are examples of return values for isFinite : isFinite(56) returns true isFinite(Number.POSITIVE_INFINITY) returns false isNaN(Number.POSITIVE_INFINITY) returns falsehtml/05_de_i32.html isNaN isNaN De-I > isNaN Syntax isNaN( expression ); Arguments expression The Boolean, variable, or other expression to be evaluated. Description Top-level function; evaluates the argument and returns true if the value is not a number ( NaN ), indicating the presence of mathematical errors. Player Flash 5 or later. Example The following illustrates the return value for isNan : isNan("Tree") returns true isNan(56) returns false isNaN(Number.POSITIVE_INFINITY) returns falsehtml/05_de_i4.html duplicateMovieClip duplicateMovieClip De-I > duplicateMovieClip Syntax duplicateMovieClip( target , newname , depth ); Arguments target The target path of the movie to duplicate. newname A unique identifier for the duplicate movie clip. depth The depth level of the movie clip. The depth level is the stacking order that determines how movie clips and other objects appear when they overlap. The first movie clip that your create, or instance that you drag onto the Stage, is assigned a depth of level 0. You must assign each successive or duplicated movie clip a different depth level to prevent it from replacing movies on occupied levels or the original movie clip. Description Action; creates an instance of a movie clip while the movie is playing. Duplicate movie clips always start at frame 1, no matter what frame the original movie clip was on. Variables in the parent movie clip are not copied into the duplicate movie clip. If the parent movie clip is deleted the duplicate movie clip is also deleted. Use the removeMovieClip action or method to delete a movie clip instance created with duplicateMovieClip . Player Flash 4 or later. Example This statement duplicates the movie clip instance flower ten times. The variable i is used to create a new instance name and a depth. on(release) { amount = 10; while(amount>0) { duplicateMovieClip (_root.flower, "mc" + i, i); setProperty("mc" + i, _x, random(275)); setProperty("mc" + i, _y, random(275)); setProperty("mc" + i, _alpha, random(275)); setProperty("mc" + i, _xscale, random(50)); setProperty("mc" + i, _yscale, random(50)); i = i + 1; amount = amount-1; } } See also removeMovieClip MovieClip.removeMovieCliphtml/05_de_i5.html else else De-I > else Syntax else { statement(s) }; Arguments statement(s) An alternative series of statements to run if the condition specified in the if statement is false . Description Action; specifies the actions, clauses, arguments, or other conditional to run if the initial if statement returns false . Player Flash 4 or later. See also ifhtml/05_de_i6.html eq (equal—string specific) eq (equal—string specific) De-I > eq (equal—string specific) Syntax expression1 eq expression2 Arguments expression1, expression2 Numbers, strings, or variables. Description Comparison operator; compares two expressions for equality and returns true if expression1 is equal to expression2 ; otherwise, returns false . Player Flash 1 or later. This operator has been deprecated in Flash 5; use of the new == (equality) operator is recommended. See also == (equality)html/05_de_i7.html escape escape De-I > escape Syntax escape( expression ); Arguments expression The expression to convert into a string and encode in a URL-encoded format. Description Function; converts the argument to a string and encodes it in a URL-encoded format, where all alphanumeric characters are escaped with % hexadecimal sequences. Player Flash 5 or later. Example escape("Hello{[World]} " ); The result of the above code is as follows: Hello%7B%5BWorld%5D%7D See also unescapehtml/05_de_i8.html eval eval De-I > eval Syntax eval( expression ); Arguments expression A string containing the name of a variable, property, object or movie clip to retrieve. Description Function; accesses variables, properties, objects, or movie clip by name. If the expression is a variable or a property, the value of the variable or property is returned. If the expression is an object or movie clip, a reference to the object or movie clip is returned. If the element named in the expression can not be found, undefined is returned. In Flash 4, the eval function was used to simulate an arrays. In Flash 5 it is recommended that you use the Array object to create arrays. Note: The ActionScript eval action is not the same as the JavaScript eval function, and cannot be used to evaluate statements. Player Flash 5 or later for full functionality. You can use eval when exporting to the Flash 4 Player, but you must use slash notation, and can only access variables, not properties or objects. Example The following example uses eval to determine the value of the variable x , and sets it to the value of y : x = 3; y = eval("x"); The following example uses eval to reference the movie clip object associated with a movie clip instance on the Stage, Ball : eval("_root.Ball"); See also Array (object)html/05_de_i9.html evaluate evaluate De-I > evaluate Syntax statement ; Arguments None. Description Action; creates a new empty line and inserts a ; for entering unique scripting statements using Expression field in the Actions panel. The evaluate statement also allows users who are scripting in the Flash 5 Actions panel's Normal Mode to call functions. Player Flash 5 or later.html/06_k_l1.html Key (object) Key (object) K-L > Key (object) The Key object is a top-level object that you can access without using a constructor. Use the methods for the Key object to build an interface that can be controlled by a user with a standard keyboard. The properties of the Key object are constants representing the keys most commonly used to control games. See Appendix B, "Keyboard Keys and Key Code Values," for a complete list of key code values. Example onClipEvent (enterFrame) { if(Key.isDown(Key.RIGHT)) { setProperty ("", _x, _x+10); } } or onClipEvent (enterFrame) { if(Key.isDown(39)) { setProperty("", _x, _x+10); } } Method summary for the Key object Method Description getAscii; Returns the ASCII value of the last key pressed. getCode; Returns the virtual key code of the last key pressed. isDown ; Returns true if the key specified in the argument is pressed. isToggled ; Returns true if the Num Lock or Caps Lock key is activated. Property summary for the Key object All of the properties for the Key object are constants. Property Description BACKSPACE Constant associated with the key code value for the Backspace key (9). CAPSLOCK Constant associated with the key code value for the Caps Lock key (20). CONTROL Constant associated with the key code value for the Control key (17). DELETEKEY Constant associated with the key code value for the Delete key (46). DOWN Constant associated with the key code value for the Down Arrow key (40). END Constant associated with the key code value for the End key (35). ENTER Constant associated with the key code value for the Enter key (13). ESCAPE Constant associated with the key code value for the Escape key (27). HOME Constant associated with the key code value for the Home key (36). INSERT Constant associated with the key code value for the Insert key (45). LEFT Constant associated with the key code value for the Left Arrow key (37). PGDN Constant associated with the key code value for the Page Down key (34). PGUP Constant associated with the key code value for the Page Up key (33). RIGHT Constant associated with the key code value for the Right Arrow key (39). SHIFT Constant associated with the key code value for the Shift key (16). SPACE Constant associated with the key code value for the Spacebar (32). TAB Constant associated with the key code value for the Tab key (9). UP Constant associated with the key code value for the Up Arrow key (38).html/06_k_l10.html Key.getAscii Key.getAscii K-L > Key.getAscii Syntax Key.getAscii(); Arguments None. Description Method; returns the ASCII code of the last key pressed or released. Player Flash 5 or later.html/06_k_l11.html Key.getCode Key.getCode K-L > Key.getCode Syntax Key.getCode(); Arguments None. Description Method; returns the key code value of the last key pressed. Use the information in Appendix B, "Keyboard Keys and Key Code Values," to match the returned key code value with the virtual key on a standard keyboard. Player Flash 5 or later.html/06_k_l12.html Key.HOME Key.HOME K-L > Key.HOME Syntax Key.HOME Arguments None. Description Property; constant associated with the key code value for the Home key (36). Player Flash 5 or later.html/06_k_l13.html Key.INSERT Key.INSERT K-L > Key.INSERT Syntax Key.INSERT Arguments None. Description Property; constant associated with the key code value for the Insert key (45). Player Flash 5 or later.html/06_k_l14.html Key.isDown Key.isDown K-L > Key.isDown Syntax Key.isDown ( keycode ); Arguments keycode The key code value assigned to a specific key, or a Key object property associated with a specific key. Appendix B, "Keyboard Keys and Key Code Values," lists all of the key codes associated with the keys on a standard keyboard. Description Method; returns true if the key specified in keycode is pressed. On the Macintosh, the key code values for the Caps Lock and Num Lock keys are identical. Player Flash 5 or later.html/06_k_l15.html Key.isToggled Key.isToggled K-L > Key.isToggled Syntax Key.isToggled ( keycode ) Arguments keycode The key code for Caps Lock (20) or Num Lock (144). Description Method; returns true if the Caps Lock or Num Lock key is activated (toggled). On the Macintosh, the key code values for these keys are identical. Player Flash 5 or later.html/06_k_l16.html Key.LEFT Key.LEFT K-L > Key.LEFT Syntax Key.LEFT Arguments None. Description Property; constant associated with the key code value for the Left Arrow key (37). Player Flash 5 or later.html/06_k_l17.html Key.PGDN Key.PGDN K-L > Key.PGDN Syntax Key.PGDN Arguments None. Description Property; constant associated with the key code value for the Page Down key (34). Player Flash 5 or later.html/06_k_l18.html Key.PGUP Key.PGUP K-L > Key.PGUP Syntax Key.PGUP Arguments None. Description Property; constant associated with the key code value for the Page Up key (33). Player Flash 5 or later.html/06_k_l19.html Key.RIGHT Key.RIGHT K-L > Key.RIGHT Syntax Key.RIGHT Arguments None. Description Property; constant associated with the key code value for the Right Arrow key (39). Player Flash 5 or later.html/06_k_l2.html Key.BACKSPACE Key.BACKSPACE K-L > Key.BACKSPACE Syntax Key.BACKSPACE Arguments None. Description Property; constant associated with the key code value for the Backspace key (9). Player Flash 5 or later.html/06_k_l20.html Key.SHIFT Key.SHIFT K-L > Key.SHIFT Syntax Key.SHIFT Arguments None. Description Property; constant associated with the key code value for the Shift key (16). Player Flash 5 or later.html/06_k_l21.html Key.SPACE Key.SPACE K-L > Key.SPACE Syntax Key.SPACE Arguments None. Description Property; constant associated with the key code value for the Spacebar (32). Player Flash 5 or later.html/06_k_l22.html Key.TAB Key.TAB K-L > Key.TAB Syntax Key.TAB Arguments None. Description Property; constant associated with the key code value for the Tab key (9). Player Flash 5 or later.html/06_k_l23.html Key.UP Key.UP K-L > Key.UP Syntax Key.UP Arguments None. Description Property; constant associated with the key code value for the Up Arrow key (38). Player Flash 5 or later.html/06_k_l24.html le (less than or equal to — string specific) le (less than or equal to — string specific) K-L > le (less than or equal to — string specific) Syntax expression1 le expression2 Arguments expression1,expression2 Numbers, strings, or variables. Description Operator (comparison); compares expression1 to expression2 and returns true if expression1 is less than or equal to expression2 ; otherwise, returns false . Player Flash 4 or later. This operator has been deprecated in Flash 5; use of the new <= operator is recommended. See also <= (less than or equal to)html/06_k_l25.html length length K-L > length Syntax length( expression ); length ( variable ); Arguments expression Any string. variable The name of a variable. Description String function; returns the length of the specified string or variable name. Player Flash 4 or later. This function, along with all of the string functions, has been deprecated in Flash 5. It is recommended that you use the methods and length property of the String object to perform the same operations. Example The following example returns the value of the string Hello : length("Hello"); The result is 5. See also " " (string delimiter) String.lengthhtml/06_k_l26.html_level _level K-L > _level Syntax _level N; Arguments N A nonnegative integer specifying a depth level. By default, _level is set to 0, the movie at the base of the hierarchy. Description Property; a reference to the root movie Timeline of levelN . You must load movies using the loadMovie action, before targeting them using the _level property. In the Flash Player, movies are assigned a number according to the order in which they were loaded. The movie that was loaded first is loaded at the bottom level, level 0. The movie in level 0 sets the frame rate, background color, and frame size for all subsequently loaded movies. Movies are then stacked in higher numbered levels above the movie in level 0. The level where a movie clip resides is also referred to as the depth level or depth. Player Flash 4 or later. Example The following example stops the Timeline of the movie in level 0: _level0.stop(); The following example sends the Timeline of the movie in level 4 to frame 5. The movie in level 4 must have previously been loaded with a loadMovie action: _level4.gotoAndStop(5); See also loadMovie MovieClip.swapDepthshtml/06_k_l27.html loadMovie loadMovie K-L > loadMovie Syntax loadMovie( url [, location / target , variables ]]); Arguments url An absolute or relative URL for the SWF file to load. A relative path must be relative to the SWF. The URL must be in the same subdomain as the URL where the movie currently resides. For use in the Flash Player or for testing in test-movie mode in the Flash authoring environment, all SWF files must be stored in the same folder, and the file names cannot include folder or disk drive specifications. target An optional argument specifying a target movie clip that will be replaced by the loaded movie. The loaded movie inherits the position, rotation, and scale properties of the targeted movie clip. Specifying a target is the same as specifying the location (level) of a target movie; you should not specify both. location An optional argument specifying the level into which the movie is loaded. The loaded movie inherits the position, rotation, and scale properties of the targeted movie clip. To load the new movie in addition to existing movies, specify a level that is not occupied by another movie. To replace an existing movie with the loaded movie, specify a level that is currently occupied by another movie. To replace the original movie and unload every level, load the new movie into level 0. The movie in level 0 sets the frame rate, background color, and frame size for all other loaded movies. variables An optional argument specifying a method for sending variables associated with the movie to load. The argument must be the string "GET" or "POST." If there are no variables, omit this argument; otherwise, specify whether to load variables using a GET or POST method. GET appends the variables to the end of the URL, and is used for small numbers of variables. POST sends the variables in a separate HTTP header and is used for long strings of variables. Description Action; plays additional movies without closing the Flash Player. Normally, the Flash Player displays a single Flash Player movie (SWF file) and then closes. The loadMovie action lets you display several movies at once or switch between movies without loading another HTML document. You can load movies into level that already have SWF files loaded. If you do, the new movie will replace the existing SWF file. If you load a new movie into Level 0, every level is unloaded, and Level 0 is replaced with the new file. Use the loadVariables action to keep the active movie, and update the variables with new values. Use the unloadMovie action to remove movies loaded with the loadMovie action. Player Flash 3 or later. Example This loadMovie statement is attached to a navigation button labeled Products. There is an invisible movie clip on the Stage with the instance name dropZone. The loadMovie action uses this movie clip as the target parameter to load the products in the SWF file, into the correct position on the Stage: on(release) { loadMovie("products.swf",_root.dropZone); } See also unloadMovie _levelhtml/06_k_l28.html loadVariables loadVariables K-L > loadVariables Syntax loadVariables ( url , location [ , variables ]); Arguments url An absolute or relative URL where the variables are located. The host for the URL must be in the same subdomain as the movie when accessed using a Web browser. location A level or target to receive the variables. In the Flash Player, movie files are assigned a number according to the order in which they were loaded. The first movie loads into the bottom level (level 0). Inside the loadMovie action, you must specify a level number for each successive movie. This argument is optional. variables An optional argument specifying a method for sending variables. If there are no variables, omit this argument; otherwise, specify whether to load variables using a GET or POST method. GET appends the variables to the end of the URL and is used for small numbers of variables. POST sends the variables in a separate HTTP header and is used for long strings of variables. Description Action; reads data from an external file, such as a text file or text generated by a CGI script, Active Server Pages (ASP), or Personal Home Page (PHP), and sets the values for variables in a movie or movie clip. This action can also be used to update variables in the active movie with new values. The text at the specified URL must be in the standard MIME format application/x-www-urlformencoded (a standard format used by CGI scripts). The movie and the variables to be loaded must reside at the same subdomain. Any number of variables can be specified. For example, the phrase below defines several variables: company=Macromedia&address=600+Townsend&city=San+Francisco&zip=94103 Player Flash 4 or later. Example This example loads information from a text file into text fields in the main Timeline (level 0). The variable names of the text fields must match the variable names in the data.txt file. on(release) { loadVariables("data.txt", 0); } See also getURL MovieClip.loadMovie MovieClip.loadVariableshtml/06_k_l29.html lt (less than — string specific) lt (less than — string specific) K-L > lt (less than — string specific) Syntax expression1 lt expression2 Arguments expression1, expression2 Numbers, strings, or variables. Description Operator (comparison); compares expression1 to expression2 and returns true if expression1 is less than expression2 ; otherwise, returns false . Player Flash 4 or later. This operator has been deprecated in Flash 5; use of the new < (less than) operator is recommended. See also < (less than)html/06_k_l3.html Key.CAPSLOCK Key.CAPSLOCK K-L > Key.CAPSLOCK Syntax Key.CAPSLOCK Arguments None. Description Property; constant associated with the key code value for the Caps Lock key (20). Player Flash 5 or later.html/06_k_l4.html Key.CONTROL Key.CONTROL K-L > Key.CONTROL Syntax Key.CONTROL Arguments None. Description Property; constant associated with the key code value for the Control key (17). Player Flash 5 or later.html/06_k_l5.html Key.DELETEKEY Key.DELETEKEY K-L > Key.DELETEKEY Syntax Key.DELETEKEY Arguments None. Description Property; constant associated with the key code value for the Delete key (46). Player Flash 5 or later.html/06_k_l6.html Key.DOWN Key.DOWN K-L > Key.DOWN Syntax Key.DOWN Arguments None. Description Property; constant associated with the key code value for the Down Arrow key (40). Player Flash 5 or later.html/06_k_l7.html Key.END Key.END K-L > Key.END Syntax Key.END Arguments None. Description Property; constant associated with the key code value for the End key (35). Player Flash 5 or later.html/06_k_l8.html Key.ENTER Key.ENTER K-L > Key.ENTER Syntax Key.ENTER Arguments None. Description Property; constant associated with the key code value for the Enter key (13). Player Flash 5 or later.html/06_k_l9.html Key.ESCAPE Key.ESCAPE K-L > Key.ESCAPE Syntax Key.ESCAPE Arguments None. Description Property; constant associated with the key code value for the Escape key (27). Player Flash 5 or later.html/07_math1.html Math (object) Math (object) Math > Math (object) The Math object is a top-level object that you can access without using a constructor. Use the methods and properties of this object to access and manipulate mathematical constants and functions. All of the properties and methods of the Math object are static, and must be called using the syntax Math.method( argument ) or Math.constant . In ActionScript, constants are defined with the maximum precision of double-precision IEEE-754 floating-point numbers. The Math object is fully supported in the Flash 5 Player. In the Flash 4 Player, methods of the Math object work, but they are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player. Several of the Math object methods take the radian of an angle as an argument. You can use the equation below to calculate radian values, or simply pass the equation (entering a value for degrees) for the radian argument. To calculate a radian value, use this formula: radian = Math.PI/180 * degree The following is an example of passing the equation as an argument to calculate the sine of a 45-degree angle: Math.SIN(Math.PI/180 * 45) is the same as Math.SIN(.7854) Method summary for the Math object Method Description abs Computes an absolute value. acos Computes an arc cosine. asin Computes an arc sine. atan Computes an arc tangent. atan2 Computes an angle from the x-axis to the point. ceil Rounds a number up to the nearest integer. cos Computes a cosine. exp Computes an exponential value. floor Rounds a number down to the nearest integer. log Computes a natural logarithm. max Returns the larger of the two integers. min Returns the smaller of the two integers. pow Computes x raised to the power of the y . random Returns a pseudo-random number between 0.0 and 1.0. round Rounds to the nearest integer. sin Computes a sine. sqrt Computes a square root. tan Computes a tangent. Property summary for the Math object All of the properties for the Math object are constants. Property Description E Euler's constant and the base of natural logarithms (approximately 2.718). LN2 The natural logarithm of 2 (approximately 0.693). LOG2E The base 2 logarithm of e (approximately 1.442). LN10 The natural logarithm of 10 (approximately 2.302). LOG10E The base 10 logarithm of e (approximately 0.434). PI The ratio of the circumference of a circle to its diameter (approximately 3.14159). SQRT1_2 The reciprocal of the square root of 1/2 (approximately 0.707). SQRT2 The square root of 2 (approximately 1.414).html/07_math10.html Math.exp Math.exp Math > Math.exp Syntax Math.exp( x ); Arguments x The exponent; a number or expression. Description Method; returns the value of the base of the natural logarithm ( e ), to the power of the exponent specified in the argument x . The constant Math.E can provide the value of e . Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math11.html Math.floor Math.floor Math > Math.floor Syntax Math.floor( x ); Arguments x A number or expression. Description Method; returns the floor of the number or expression specified in the argument x . The floor is the closest integer that is less than or equal to the specified number or expression. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player. Example The following returns a value of 12: Math.floor(12.5);html/07_math12.html Math.log Math.log Math > Math.log Syntax Math.log( x ); Arguments x A number or expression with a value greater than 0. Description Method; returns the natural logarithm of the argument x . Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math13.html Math.LOG2E Math.LOG2E Math > Math.LOG2E Syntax Math.LOG2E Arguments None. Description Constant; a mathematical constant for the base-2 logarithm of the constant e ( Math.E ), expressed as loge2, with an approximate value of 1.442695040888963387. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math14.html Math.LOG10E Math.LOG10E Math > Math.LOG10E Syntax Math.LOG10E Arguments None. Description Constant; a mathematical constant for the base-10 logarithm of the constant e ( Math.E ), expressed as log10e, with an approximate value of 0.43429448190325181667. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math15.html Math.LN2 Math.LN2 Math > Math.LN2 Syntax Math.LN2 Arguments None. Description Constant; a mathematical constant for the natural logarithm of 2, expressed as loge2, with an approximate value of 0.69314718055994528623. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math16.html Math.LN10 Math.LN10 Math > Math.LN10 Syntax Math.LN10 Arguments None. Description Constant; a mathematical constant for the natural logarithm of 10, expressed as loge10, with an approximate value of 2.3025850929940459011. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math17.html Math.max Math.max Math > Math.max Syntax Math.max( x , y ); Arguments x A number or expression. y A number or expression. Description Method; evaluates x and y and returns the larger value. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math18.html Math.min Math.min Math > Math.min Syntax Math.min( x , y ); Arguments x A number or expression. y A number or expression. Description Method; evaluates x and y and returns the smaller value. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math19.html Math.PI Math.PI Math > Math.PI Syntax Math.PI Arguments None. Description Constant; a mathematical constant for the ratio of the circumference of a circle to its diameter, expressed as pi, with a value of 3.14159265358979. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math2.html Math.abs Math.abs Math > Math.abs Syntax Math.abs(x); Arguments x Any number. Description Method; computes and returns an absolute value for the number specified by the argument x . Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math20.html Math.pow Math.pow Math > Math.pow Syntax Math.pow( x , y ); Arguments x A number to be raised to a power. y A number specifying a power the argument x is raised to. Description Method; computes and returns x to the power of y , xy . Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math21.html Math.random Math.random Math > Math.random Syntax Math.random(); Arguments None. Description Method; returns a pseudo-random number between 0.0 and 1.0. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player. See also randomhtml/07_math22.html Math.round Math.round Math > Math.round Syntax Math.round( x ); Arguments x Any number. Description Method; rounds the value of the argument x up or down to the nearest integer and returns the value. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math23.html Math.sin Math.sin Math > Math.sin Syntax Math.sin( x ); Arguments x An angle measured in radians. Description Method; computes and returns the sine of the specified angle in radians. Use the information outlined in the introduction to the Math object to calculate a radian. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player. See also Math (object)html/07_math24.html Math.sqrt Math.sqrt Math > Math.sqrt Syntax Math.sqrt (x ); Arguments x Any number or expression greater than or equal to 0. Description Method; computes and returns the square root of the specified number. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math25.html Math.SQRT1_2 Math.SQRT1_2 Math > Math.SQRT1_2 Syntax Math.SQRT1_2 Arguments None. Description Constant; a mathematical constant for the reciprocal of the square root of one half (1/2), with an approximate value of 0.707106781186. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math26.html Math.SQRT2 Math.SQRT2 Math > Math.SQRT2 Syntax Math.SQRT2 Arguments None. Description Constant; a mathematical constant for the square root of 2, with an approximate value of 1.414213562373. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math27.html Math.tan Math.tan Math > Math.tan Syntax Math.tan( x ); Arguments x An angle measured in radians. Description Method; computes and returns the tangent of the specified angle. Use the information outlined in the introduction to the Math object to calculate a radian. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math3.html Math.acos Math.acos Math > Math.acos Syntax Math.acos( x ); Arguments x A number from -1.0 to 1.0. Description Method; computes and returns the arc cosine of the number specified in the argument x , in radians. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math4.html Math.asin Math.asin Math > Math.asin Syntax Math.asin( x ); Arguments x A number from -1.0 to 1.0. Description Method; computes and returns the arc sine for the number specified in the argument x , in radians. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math5.html Math.atan Math.atan Math > Math.atan Syntax Math.atan( x ); Arguments x Any number. Description Method; computes and returns the arc tangent for the number specified in the argument x . The return value is between negative pi divided by 2, and positive pi divided by 2. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math6.html Math.atan2 Math.atan2 Math > Math.atan2 Syntax Math.atan2( y, x ); Arguments x A number specifying the x coordinate of the point. y A number specifying the y coordinate of the point. Description Method; computes and returns the arc tangent of y/x in radians. The return value represents the angle opposite the opposite angle of a right triangle, where x is the adjacent side length and y is the opposite side length. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math7.html Math.ceil Math.ceil Math > Math.ceil Syntax Math.ceil( x ); Arguments x A number or expression. Description Method; returns the ceiling of the specified number or expression. The ceiling of a number is the closest integer that is greater than or equal to the number. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math8.html Math.cos Math.cos Math > Math.cos Syntax Math.cos( x ); Arguments x An angle measured in radians. Description Method; returns the cosine (a value from -1.0 to 1.0) of the angle specified by the argument x . The angle x must be specified in radians. Use the information outlined in the introduction to the Math object to calculate a radian. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/07_math9.html Math.E Math.E Math > Math.E Syntax Math.E Arguments None. Description Constant; a mathematical constant for the base of natural logarithms, expressed as e . The approximate value of e is 2.71828. Player Flash 5 or later. In the Flash 4 Player, the methods and properties of the Math object are emulated using approximations and may not be as accurate as the non-emulated math functions supported by the Flash 5 Player.html/08_max_mov1.html maxscroll maxscroll Max-Mov > maxscroll Syntax variable_name .maxscroll = x Arguments variable_name The name of a variable associated with a text field. x The line number that is the maximum value allowed for the scroll property, based on the height of the text field. This is a read-only value set by Flash. Description Property; a read-only property that works with the scroll property to control the display of information in a text field. This property can be retrieved, but not modified. Player Flash 4 or later. See also scrollhtml/08_max_mov10.html MovieClip.attachMovie MovieClip.attachMovie Max-Mov > MovieClip.attachMovie Syntax anyMovieClip .attachMovie( idName , newname , depth ); Arguments idName The name of the movie in the library to attach. This is the name entered in the Identifier field in the Symbol Linkage Properties dialog box. newname A unique instance name for the movie clip being attached. depth An integer specifying the depth level where the movie is placed. Description Method; creates a new instance of a movie in the library and attaches it to the movie specified by anyMovieClip . Use the removeMovieClip or unloadMovie action or method to remove a movie attached with attachMovie . Player Flash 5 or later. See also removeMovieClip unloadMovie MovieClip.removeMovieClip MovieClip.unloadMoviehtml/08_max_mov11.html MovieClip.duplicateMovieClip MovieClip.duplicateMovieClip Max-Mov > MovieClip.duplicateMovieClip Syntax anyMovieClip .duplicateMovieClip( newname , depth ); Arguments newname A unique identifier for the duplicate movie clip. depth A number specifying the depth level where the movie specified is to be placed. Description Method; creates an instance of the specified movie clip while the movie is playing. Duplicated movie clips always start playing at frame 1, no matter what frame the original movie clip is on when the duplicateMovieClip method is called. Variables in the parent movie clip are not copied into the duplicate movie clip. If the parent movie clip is deleted the duplicate movie clip is also deleted. Movie clips added with duplicateMovieClip can be deleted with removeMovieClip action or method. Player Flash 5 or later. See also removeMovieClip MovieClip.removeMovieCliphtml/08_max_mov12.html MovieClip.getBounds MovieClip.getBounds Max-Mov > MovieClip.getBounds Syntax anyMovieClip .getBounds( targetCoordinateSpace ); Arguments targetCoordinateSpace The target path of the Timeline whose coordinate space you want to use as a reference point. Description Method; returns the minimum and maximum x and y coordinate values of the MovieClip for the target coordinate space specified in the argument. The return object will contain the properties {xMin, xMax, yMin, yMax} . Use the localToGlobal and globalToLocal methods of the MovieClip object to convert the movie clip's local coordinates to Stage coordinates, or Stage coordinates to local coordinates respectively. Player Flash 5 or later. Example The following example uses getBounds to retrieve the bounding box of the myMovieClip instance in the coordinate space of the main movie: myMovieClip.getBounds(._root); See also MovieClip.globalToLocal MovieClip.localToGlobalhtml/08_max_mov13.html MovieClip.getBytesLoaded MovieClip.getBytesLoaded Max-Mov > MovieClip.getBytesLoaded Syntax anyMovieClip .getBytesLoaded(); Arguments None. Description Method; returns the number of bytes loaded (streamed) for the specified Movie Clip object. Because internal movie clips load automatically, the return result for this method and MovieClip.getBytesTotal will be the same if the specified Movie Clip object references an internal movie clip. This method is intended for use on loaded movies. You can compare the value of getBytesLoaded with the value of getBytesTotal to determine what percentage of an external movie has loaded. Player Flash 5 or later.html/08_max_mov14.html MovieClip.getBytesTotal MovieClip.getBytesTotal Max-Mov > MovieClip.getBytesTotal Syntax anyMovieClip .getBytesTotal(); Arguments None. Description Method; returns the size, in bytes, of the specified Movie Clip object. For movie clips that are external, (the root movie or a movie clip that is being loaded into a target or a level) the return value is the size of the SWF file. Player Flash 5 or later.html/08_max_mov15.html MovieClip.getURL MovieClip.getURL Max-Mov > MovieClip.getURL Syntax anyMovieClip .getURL( URL [ ,window, variables ]] ); Arguments URL The URL from which to obtain the document. window An optional argument specifying the name, frame, or expression specifying the window or HTML frame that the document is loaded into. You can also use one of the following reserved target names: _self specifies the current frame in the current window, _blank specifies a new window, _parent specifies the parent of the current frame, _top specifies the top-level frame in the current window. variables An optional argument specifying a method for sending variables associated with the movie to load. If there are no variables, omit this argument; otherwise, specify whether to load variables using a GET or POST method. GET appends the variables to the end of the URL, and is used for small numbers of variables. POST sends the variables in a separate HTTP header and is used for long strings of variables. Description Method; loads a document from the specified URL into the specified window. The getURL method can also be used to pass variables to another application defined at the URL using a GET or POST method. Player Flash 5 or later.html/08_max_mov16.html MovieClip.globalToLocal MovieClip.globalToLocal Max-Mov > MovieClip.globalToLocal Syntax anyMovieClip .globalToLocal( point ); Arguments point The name or identifier of an object created with the generic Object object specifying the x and y coordinates as properties. Description Method; converts the point object from Stage (global) coordinates to the movie clip's (local) coordinates. Player Flash 5 or later. Example The following example converts the global x and y coordinates of the point object to the local coordinates of the movie clip: onClipEvent(mouseMove) { point = new object(); point.x = _root._xmouse; point.y = _root._ymouse; globalToLocal(point); _root.out = _xmouse + " === " + _ymouse; _root.out2 = point.x + " === " + point.y; updateAfterEvent(); } See also MovieClip.localToGlobal MovieClip.getBoundshtml/08_max_mov17.html MovieClip.gotoAndPlay MovieClip.gotoAndPlay Max-Mov > MovieClip.gotoAndPlay Syntax anyMovieClip .gotoAndPlay( frame ); Arguments frame The frame number to which the playhead will be sent. Description Method; starts playing the movie at the specified frame. Player Flash 5 or later.html/08_max_mov18.html MovieClip.gotoAndStop MovieClip.gotoAndStop Max-Mov > MovieClip.gotoAndStop Syntax anyMovieClip .gotoAndStop( frame ); Arguments frame The frame number to which the playhead will be sent. Description Method; stops the movie playing at the specified frame. Player Flash 5 or later.html/08_max_mov19.html MovieClip.hitTest MovieClip.hitTest Max-Mov > MovieClip.hitTest Syntax anyMovieClip .hitTest( x, y, shapeFlag ); anyMovieClip .hitTest( target ); Arguments x The x coordinate of the hit area on the Stage. y The y coordinate of the hit area on the Stage. The x and y coordinates are defined in the global coordinate space. target The target path of the hit area that may intersect or overlap with the instance specified by anyMovieClip . The target usually represents a button or text-entry field. shapeFlag A Boolean value specifying whether to evaluate the entire shape of the specified instance ( true ), or just the bounding box ( false ). This argument can only be specified if the hit area is identified using x and y coordinate arguments. Description Method; evaluates the instance specified by anyMovieClip to see if it overlaps or intersects with the hit area identified by the target or x and y coordinate arguments. Usage 1compares the x and y coordinates to the shape or bounding box of the specified instance, according to the shapeFlag setting. If shapeFlag is set to true , only the area actually occupied by the instance on the Stage is evaluated, and if x and y overlap at any point, a value of true is returned. This is useful for determining if the movie clip is within a specified hit, or hotspot, area. Usage 2 evaluates the bounding boxes of the target and specified instance, and returns true if they overlap or intersect at any point. Player Flash 5 or later. Example The following example uses hitTest with the x_mouse and y_mouse properties to determine whether the mouse is over the target's bounding box: if (hitTest( _root._xmouse, _root._ymouse, false)); The following example uses hitTest to determine if the movie clip ball overlaps or intersects with the movie clip square : if(_root.ball, hittest(_root.square)){ trace( " ball intersects square " ); } See also MovieClip.localToGlobal MovieClip.globalToLocal MovieClip.getBoundshtml/08_max_mov2.html mbchr mbchr Max-Mov > mbchr Syntax mbchr( number ); Arguments number The number to convert to a multibyte character. Description String function; converts an ASCII code number to a multibyte character. Player Flash 4 or later. This function has been deprecated in Flash 5; use of String.fromCharCode method is encouraged. See also String.fromCharCodehtml/08_max_mov20.html MovieClip.loadMovie MovieClip.loadMovie Max-Mov > MovieClip.loadMovie Syntax anyMovieClip .loadMovie( url [, variables ]); Arguments url An absolute or relative URL for the SWF file to load. A relative path must be relative to the SWF. The URL must be in the same subdomain as the URL where the movie currently resides. For use in the Flash Player or for testing in test-movie mode in the Flash authoring environment, all SWF files must be stored in the same folder, and the file names cannot include folder or disk drive specifications. variables An optional argument specifying a method for sending variables associated with the movie to load. The argument must be the string "GET" or "POST." If there are no variables, omit this argument; otherwise, specify whether to load variables using a GET or POST method. GET appends the variables to the end of the URL and is used for small numbers of variables. POST sends the variables in a separate HTTP header and is used for long strings of variables. Description Method; plays additional movies without closing the Flash Player. Normally, the Flash Player displays a single Flash Player movie (SWF file) and then closes. The loadMovie method allows you display several movies at once or switch between movies without loading another HTML document. Use the unloadMovie action to remove movies loaded with the loadMovie action. Use the loadVariables method to keep the active movie, and update the variables with new values. Player Flash 5 or later. See also MovieClip.loadVariables MovieClip.unloadMoviehtml/08_max_mov21.html MovieClip.loadVariables MovieClip.loadVariables Max-Mov > MovieClip.loadVariables Syntax anyMovieClip .loadVariables( url, variables ); Arguments url The absolute or relative URL for the external file. The host for the URL must be in the same subdomain as the movie clip. variables The method for retrieving the variables. GET appends the variables to the end of the URL, and is used for small numbers of variables. POST sends the variables in a separate HTTP header and is used for long strings of variables. Description Method; reads data from an external file and sets the values for variables in a movie or movie clip. The external file can be a text file generated by a CGI script, Active Server Pages (ASP), or PHP, and can contain any number of variables. This method can also be used to update variables in the active movie with new values. This method requires that the text at the URL be in the standard MIME format: application/x-www-urlformencoded (CGI script format). Player Flash 5 or later. See also MovieClip.loadMoviehtml/08_max_mov22.html MovieClip.localToGlobal MovieClip.localToGlobal Max-Mov > MovieClip.localToGlobal Syntax anyMovieClip .localToGlobal( point ); Arguments point The name or identifier of an object created with the Object object, specifying the x and y coordinates as properties. Description Method; converts the point object from the movie clip's (local) coordinates, to Stage (global) coordinates. Player Flash 5 or later. Example The following example converts x and y coordinates of the point object, from the movie clip's coordinates (local) to the Stage coordinates (global). The local x and y coordinates are specified using xmouse and ymouse to retrieve the x and y coordinates of the mouse position. onClipEvent(mouseMove) { point = new object(); point.x = _xmouse; point.y = _ymouse; _root.out3 = point.x + " === " + point.y; _root.out = _root._xmouse + " === " + _root._ymouse; localToGlobal(point); _root.out2 = point.x + " === " + point.y; updateAfterEvent(); } See also MovieClip.globalToLocalhtml/08_max_mov23.html MovieClip.nextFrame MovieClip.nextFrame Max-Mov > MovieClip.nextFrame Syntax anyMovieClip .nextFrame(); Arguments None. Description Method; sends the playhead to the next frame of the movie clip. Player Flash 5 or later.html/08_max_mov24.html MovieClip.play MovieClip.play Max-Mov > MovieClip.play Syntax anyMovieClip .play(); Arguments None. Description Method; plays the movie clip. Player Flash 5 or later.html/08_max_mov25.html MovieClip.prevFrame MovieClip.prevFrame Max-Mov > MovieClip.prevFrame Syntax anyMovieClip .prevFrame(); Arguments None. Description Method; sends the playhead to the previous frame and stops it. Player Flash 5 or later.html/08_max_mov26.html MovieClip.removeMovieClip MovieClip.removeMovieClip Max-Mov > MovieClip.removeMovieClip Syntax anyMovieClip .removeMovieClip(); Arguments None. Description Method; removes a movie clip instance created with the duplicateMovieclip action, or the duplicateMovieClip or attachMovie methods of the MovieClip object. Player Flash 5 or later. See also MovieClip.loadMovie MovieClip.attachMoviehtml/08_max_mov27.html MovieClip.startDrag MovieClip.startDrag Max-Mov > MovieClip.startDrag Syntax anyMovieClip .startDrag([ lock , left , right , top , bottom ]); Arguments lock A Boolean value specifying whether the draggable movie clip is locked to the center of the mouse position ( true ), or locked to the point where the user first clicked on the movie clip ( false ). This argument is optional. left , top , right , bottom Values relative to the coordinates of the movie clip's parent that specify a constraint rectangle for the movie clip. These arguments are optional. Description Method; allows the user to drag the specified movie clip. The movie remains draggable until explicitly stopped by calling the stopDrag method, or until another movie clip is made draggable. Only one movie clip is draggable at a time. Player Flash 5 or later. See also MovieClip.stopDrag _droptargethtml/08_max_mov28.html MovieClip.stop MovieClip.stop Max-Mov > MovieClip.stop Syntax anyMovieClip .stop(); Arguments None. Description Method; stops the movie clip currently playing. Player Flash 5 or later.html/08_max_mov29.html MovieClip.stopDrag MovieClip.stopDrag Max-Mov > MovieClip.stopDrag Syntax anyMovieClip .stopDrag(); Arguments None. Description Method; ends a drag action implemented with the startDrag method. A movie remains draggable until a stopDrag method is added, or until another movie becomes draggable. Only one movie clip is draggable at a time. Player Flash 5 or later. See also _droptarget MovieClip.startDraghtml/08_max_mov3.html mblength mblength Max-Mov > mblength Syntax mblength( string ); Arguments string A string. Description String function; returns the length of the multibyte character string. Player Flash 4 or later. This function has been deprecated in Flash 5; use of the String object and methods is recommended.html/08_max_mov30.html MovieClip.swapDepths MovieClip.swapDepths Max-Mov > MovieClip.swapDepths Syntax anyMovieClip .swapDepths( depth ); anyMovieClip .swapDepths( target ); Arguments target The movie clip instance whose depth that is being swapped by the instance specified in anyMovieClip . Both instances must have the same parent movie clip. depth A number specifying the depth level where the anyMovieClip is to be placed. Description Method; swaps the stacking, or z , order (depth level) of the specified instance with the movie specified by the target argument, or with the movie that currently occupies the depth level specified in the argument. Both movies must have the same parent movie clip. Swapping the depth level of movie clips has the effect of moving one movie in front of or behind the other. If a movie is tweening when this method is called, the tweening is stopped. Player Flash 5 or later. See also _levelhtml/08_max_mov31.html MovieClip.unloadMovie MovieClip.unloadMovie Max-Mov > MovieClip.unloadMovie Syntax anyMovieClip .unloadMovie(); Arguments None. Description Method; removes a movie clip loaded with the loadMovie or attachMovie MovieClip methods. Player Flash 5 or later. See also MovieClip.loadMovie MovieClip.attachMoviehtml/08_max_mov4.html mbord mbord Max-Mov > mbord Syntax mbord( character ); Arguments character The character to convert to a multibyte number. Description String function; converts the specified character to a multibyte number. Player Flash 4 or later. This function has been deprecated in Flash 5; use of the String . charCodeAt method is recommended. See also String.fromCharCodehtml/08_max_mov5.html mbsubstring mbsubstring Max-Mov > mbsubstring Syntax mbsubstring( value, index, count ); Arguments value The multibyte string from which to extract a new multibyte string. index The number of the first character to extract. count The number of characters to include in the extracted string, not including the index character. Description String function; extracts a new multibyte character string from a multibyte character string. Player Flash 4 or later. This function is deprecated in Flash 5; use of the string.substr method is recommended. See also String.substrhtml/08_max_mov6.html Mouse (object) Mouse (object) Max-Mov > Mouse (object) Use the methods of the Mouse object to hide and show the cursor in the movie. The mouse pointer is visible by default, but you can hide it and implement a custom cursor that you create using a movie clip. Mouse method summary Method Description hide Hides the cursor in the movie. show Displays the cursor in the movie.html/08_max_mov7.html Mouse.hide Mouse.hide Max-Mov > Mouse.hide Syntax Mouse.hide(); Arguments None. Description Method; hides the cursor in a movie. The cursor is visible by default. Player Flash 5 or later. Example The following code, attached to a movie clip on the main Timeline, hides the standard cursor and sets the x and y positions of the customCursor movie clip instance to the x and y mouse positions in the main Timeline: onClipEvent(enterFrame){ Mouse.hide(); customCursorMC_x = _root._xmouse; customCursorMC_y = _root._ymouse; } See also _xmouse _ymouse Mouse.showhtml/08_max_mov8.html Mouse.show Mouse.show Max-Mov > Mouse.show Syntax Mouse.show(); Arguments None. Description Method; makes the cursor visible in a movie. The cursor is visible by default. Player Flash 5 or later. See also _xmouse _ymouse Mouse.showhtml/08_max_mov9.html MovieClip (object) MovieClip (object) Max-Mov > MovieClip (object) The methods for the MovieClip object privide the same functionality as the standard actions that target movie clips. There are also additional methods that provide functionality that is not available using the standard actions listed in the Actions category of the Actions panel. You do not need to use a constructor method in order to call the methods of the MovieClip object; instead, you reference movie clip instances by name, using the following syntax: anyMovieClip .play(); anyMovieClip .gotoAndPlay(3); Method summary for the MovieClip object Method Description attachMovie Attaches a movie in the library. duplicateMovieClip Duplicates the specified movie clip. getBounds Returns the minimum and maximum x and y coordinates of a movie in a specified coordinate space. getBytesLoaded Returns the number of bytes loaded for the specified movie clip. getBytesTotal Returns the size of the movie clip in bytes. getURL Retrieves a document from a URL. globalToLocal Converts the point object from Stage coordinates to the local coordinates of the specified movie clip. gotoAndPlay Sends the playhead to a specific frame in the movie clip and plays the movie. gotoAndStop Sends the playhead to a specific frame in the movie clip and stops the movie. hitTest Returns true if bounding box of the specified movie clip intersects the bounding box of the target movie clip. loadMovie Loads the specified movie into the movie clip. loadVariables Loads variables from a URL or other location into the movie clip. localToGlobal Converts a Point object from the local coordinates of the movie clip to the global Stage coordinates. nextFrame Sends the playhead to the next frame of the movie clip. play Plays the specified movie clip. prevFrame Sends the playhead to the previous frame of the movie clip. removeMovieclip Removes the movie clip from the Timeline if it was created with a duplicateMovieClip action or method or the attachMovie method. startDrag Specifies a movie clip as draggable and begins dragging the movie clip. stop Stops the currently playing movie. stopDrag Stops the dragging of any movie clip that is being dragged. swapDepths Swaps the depth level of specified movie with the movie at a specific depth level. unloadMovie Removes a movie loaded with loadMovie .html/09_n_r1.html_name _name N-R > _name Syntax instancename . _name instancename . _name = value ; Arguments instancename An instance name of a movie clip for which the _name property is to be set or retrieved. value A string that specifies a new instance name. Description Property; specifies the movie clip instance name. Player Flash 4 or later.html/09_n_r10.html Number (function) Number (function) N-R > Number (function) Syntax Number( expression ); Arguments expression The string, Boolean, or other expression to convert to a number. Description Function; converts the argument x to a number and returns a value as follows: If x is a number, the return value is x . If x is a Boolean, the return value is 1 if x is true , 0 if x is false . If x is a string, the function attempts to parse x as a decimal number with an optional trailing exponent, that is, 1.57505e-3. If x is undefined, the return value is 0. This function is used to convert Flash 4 files containing deprecated operators that are imported into the Flash 5 authoring environment. See the & operator for more information. Player Flash 4 or later. See also Number (object)html/09_n_r11.html Number (object) Number (object) N-R > Number (object) The Number object is a simple wrapper object for the number data type, which means that you can manipulate primitive numeric values using the methods and properties associated with the Number object. The functionality provided by this object is identical to that of the JavaScript Number object. You must use the Number constructor when calling the methods of the Number object, but you do not need to use the constructor when calling the properties of the Number object. The following examples specify the syntax for calling the methods and properties of the Number object: This is an example of calling the toString method of the Number object: myNumber = new Number( 1234 ); myNumber.toString(); Returns a string containing the binary representation of the number 1234. This is an example of calling the MIN_VALUE property (also called a constant) of the Number object: smallest = Number.MIN_VALUE Method summary for the Number object Method Description toString Returns the string representation of a Number object. valueOf Returns the primitive value of a Number object. Property summary for the Number object Property Description MAX_VALUE Constant representing the largest representable number (double-precision IEEE-754). This number is approximately 1.7976931348623158e+308. MIN_VALUE Constant representing the smallest representable number (double-precision IEEE-754). This number is approximately 5e-324. NaN Constant representing the value for Not a Number (NaN). NEGATIVE_INFINITY Constant representing the value for negative infinity. POSITIVE_INFINITY Constant representing the value for positive infinity. This value is the same as the global variable Infinity. Constructor for the Number object Syntax myNumber = new Number( value ); Arguments value The numeric value of the Number object being created, or a value to be converted to a number. Description Constructor; creates a new Number object. You must use the Number constructor when using the toString and valueOf methods of the Number object. You do not use a constructor when using the properties of the Number object. The new Number constructor is primarily used as a placeholder. An instance of the Number object is not the same as the Number function that converts an argument to a primitive value. Player Flash 5 or later. Example The following code constructs new Number objects: n1 = new Number(3.4); n2 = new Number(-10); See also Number (function)html/09_n_r12.html Number.MAX_VALUE Number.MAX_VALUE N-R > Number.MAX_VALUE Syntax Number.MAX_VALUE Arguments None. Description Property; the largest representable number (double-precision IEEE-754). This number is approximately 1.79E+308. Player Flash 5 or later.html/09_n_r13.html Number.MIN_VALUE Number.MIN_VALUE N-R > Number.MIN_VALUE Syntax Number.MIN_VALUE Arguments None. Description Property; the smallest representable number (double-precision IEEE-754). This number is approximately 5e-324. Player Flash 5 or later.html/09_n_r14.html Number.NaN Number.NaN N-R > Number.NaN Syntax Number.NaN Arguments None. Description Property; the IEEE-754 value representing Not A Number ( NaN ). Player Flash 5 or later.html/09_n_r15.html Number.NEGATIVE_INFINITY Number.NEGATIVE_INFINITY N-R > Number.NEGATIVE_INFINITY Syntax Number.NEGATIVE_INFINITY Arguments None. Description Property; returns the IEEE-754 value representing negative infinity. This value is the same as the global variable Infinity. Negative infinity is a special numeric value that is returned when a mathematical operation or function returns a negative value larger than can be represented. Player Flash 5 or later.html/09_n_r16.html Number.POSITIVE_INFINITY Number.POSITIVE_INFINITY N-R > Number.POSITIVE_INFINITY Syntax Number.POSITIVE_INFINITY Arguments None. Description Property; returns the IEEE-754 value representing positive infinity. This value is the same as the global variable Infinity . Positive infinity is a special numeric value that is returned when a mathematical operation or function returns a value larger than can be represented. Player Flash 5 or later.html/09_n_r17.html Number.toString Number.toString N-R > Number.toString Syntax myNumber .toString( radix ); Arguments radix Specifies the numeric base (from 2 to 36) to use for the number-to-string conversion. If you do not specify the radix argument, the default value is 10. Description Method; returns the string representation of the specified Number object ( myNumber ). Player Flash 5 or later. Example The following example uses the Number . toString method, specifying 2 for the radix argument: myNumber = new Number ( 1000 ); ( 1000 ).toString(2); Returns a string containing the binary representation of the number 1000.html/09_n_r18.html Number.valueOf Number.valueOf N-R > Number.valueOf Syntax myNumber .valueOf(); Arguments None. Description Method; returns the primitive value type of the specified Number object, and converts the Number wrapper object to the primitive value type. Player Flash 5 or later.html/09_n_r19.html Object (object) Object (object) N-R > Object (object) The generic Object object is at the root of the ActionScript class hierarchy. The functionality of the generic Object object is a small subset of that provided by the JavaScript Object object. The generic Object object requires the Flash 5 Player. Method summary for the Object object Method Description toString Converts the specified object to a string, and returns it. valueOf Returns the primitive value of an Object object. Constructor for the Object object Syntax new Object(); new Object( value ); Arguments value A number, Boolean, or string to be converted to an object. This argument is optional. If you do not specify value , the constructor creates a new object with no defined properties. Description Constructor; creates a new Object object. Player Flash 5 or later. See also Sound.setTransform Color.setTransformhtml/09_n_r2.html NaN NaN N-R > NaN Syntax NaN Arguments None. Description Variable; a predefined variable with the IEEE-754 value for NaN (Not a Number). Player Flash 5 or later.html/09_n_r20.html Object.toString Object.toString N-R > Object.toString Syntax myObject .toString(); Arguments None. Description Method; converts the specified object to a string, and returns it. Player Flash 5 or later.html/09_n_r21.html Object.valueOf Object.valueOf N-R > Object.valueOf Syntax myObject .valueOf(); Arguments None. Description Method; returns the primitive value of the specified object. If the object does not have a primitive value, the object itself is returned. Player Flash 5 or later.html/09_n_r22.html onClipEvent onClipEvent N-R > onClipEvent Syntax onClipEvent( movieEvent );{ ... } Arguments A movieEvent is a trigger event that executes actions that are assigned to a movie clip instance. Any of the following values can be specified for the movieEvent argument: load The action is initiated as soon as the movie clip is instantiated and appears in the Timeline. unload The action is initiated in the first frame after the movie clip is removed from the Timeline. The actions associated with the Unload movie clip event are processed before any actions are attached to the affected frame. enterFrame The action is initiated as each frame is played, similar to actions attached to a movie clip. The actions associated with the OnEnterFrame movie clip event are processed after any actions that are attached to the affected frames. mouseMove The action is initiated every time the mouse is moved. Use the _xmouse and _ymouse properties to determine the current mouse position. mouseDown The action is initiated when the left mouse button is pressed. mouseUp The action is initiated when the left mouse button is released. keyDown The action is initiated when a key is pressed. Use the Key . getCode method to retrieve information about the last key pressed. keyUp The action is initiated when a key is released. Use the Key . getCode method to retrieve information about the last key pressed. data The action is initiated when data is received in a loadVariables or loadMovie action. When specified with a loadVariables action, the data event occurs only once, when the last variable is loaded. When specified with a loadMovie action, the data event occurs repeatedly, as each section of data is retrieved. Description Handler; triggers actions defined for a specific instance of a movie clip. Player Flash 5 or later. Example The following statement includes the script from an external file when the movie clip instance is loaded and first appears on the Timeline: onClipEvent(load) { #include "myScript.as" } The following example uses onClipEvent with the keyDown movie event. The keyDown movie event is usually used in conjunction with one or more methods and properties associated with the Key object. In the script below, key.getCode is used to find out which key the user has pressed; the returned value is associated with the RIGHT or LEFT Key object properties, and the movie is directed accordingly. onClipEvent(keyDown) { if (Key.getCode() == Key.RIGHT) { } _parent.nextFrame(); else if (Key.getCode() == Key.LEFT){ _parent.prevFrame(); } The following example uses onClipEvent with the mouseMove movie event. The the xmouse and ymouse properties track the position of the mouse. onClipEvent(mouseMove) { stageX=_root.xmouse; stageY=_root.ymouse; } See also on(mouseEvent) Key (object) _xmouse _ymousehtml/09_n_r23.html on(mouseEvent) on(mouseEvent) N-R > on(mouseEvent) Syntax on( mouseEvent ) { statement; } Arguments statement The instructions to execute when the mouseEvent takes place. A mouseEvent action can have one of the following arguments: press The mouse button is pressed while the pointer is over the button. release The mouse button is released while the pointer is over the button. releaseOutside The mouse button is released while the pointer is outside the button. rollOver The mouse pointer rolls over the button. rollOut The pointer rolls outside of the button area. dragOver While the pointer is over the button, the mouse button has been pressed while rolled outside the button, and then rolled back over the button. dragOut While the pointer is over the button, the mouse button is pressed and then rolls outside the button area. keyPress ( "key" ) The specified key is pressed. The key portion of the argument is specified using any of the key codes listed in the Appendix B, "Keyboard Keys and Key Code Values," or any of the key constants listed in the Property summary for the Key object . Description Handler; specifies the mouse event, or keypress that trigger an action. Player Flash 2 or later. Example In the following script, the startDrag action executes when the mouse is pressed and the conditional script is executed when the mouse is released and the object is dropped: on(press) { startDrag("rabbit"); } on(release) { if(getproperty("", _droptarget) == target) { setProperty ("rabbit", _x, _root.rabbit_x); setProperty ("rabbit", _y, _root.rabbit_y); } else { _root.rabbit_x = getProperty("rabbit", _x); _root.rabbit_y = getProperty("rabbit", _y); _root.target = "pasture"; } trace(_root.rabbit_y); trace(_root.rabbit_x); stopDrag(); } See also Key (object) onClipEventhtml/09_n_r24.html or or N-R > or Syntax condition1 or condition2 Arguments condition1,2 An expression that evaluates to true or false . Description Operator; evaluates condition1 and condition2 , and if either expression is true , then the whole expression is true . Player Flash 4 or later. This operator has been deprecated in Flash 5, and users are encouraged to make use of the new || operator. See also || (OR)html/09_n_r25.html ord ord N-R > ord Syntax ord( character ); Arguments character The character to convert to an ASCII code number. Description String function; converts characters to ASCII code numbers. Player Flash 4 or later. This function has been deprecated in Flash 5, and it is recommended that you use the methods and properties of the String object instead. See also String (object)html/09_n_r26.html_parent _parent N-R > _parent Syntax _parent. property = x _parent._parent. property = x Arguments property The property being specified for the current and parent movie clip. x The value set for the property. This is an optional argument and may not need to be set, depending on the property. Description Property; specifies or returns a reference to the movie clip that contains the current movie clip. The current movie clip is the movie clip containing the currently executing script. Use _parent to specify a relative path. Player Flash 4 or later. Example In the following example the movie clip desk is a child of the movie clip classroom . When the script below executes inside the movie clip desk , the playhead will jump to frame 10 in the Timeline of the movie clip classroom . _parent.gotoAndStop(10); See also _root targetPathhtml/09_n_r27.html parseFloat parseFloat N-R > parseFloat Syntax parseFloat( string ); Arguments string The string to parse and convert to a floating-point number. Description Function; converts a string to a floating-point number. The function parses and returns the numbers in the string, until the parser reaches a character that is not a part of the initial number. If the string does not begin with a number that can be parsed, parseFloat returns NaN or 0. White space preceding valid integers is ignored, as are trailing non-numeric characters. Player Flash 5 or later. Example The following are examples of using parseFloat to evaluate various types of numbers: parseFloat("-2") returns -2 parseFloat("2.5") returns 2.5 parseFloat("3.5e6") returns 3.5e6, or 3500000 parseFloat("foobar") returns NaNhtml/09_n_r28.html parseInt parseInt N-R > parseInt Syntax parseInt( expression, radix ); Arguments expression The string, floating-point number, or other expression to parse and convert to a integer. radix An integer representing the radix (base) of the number to parse. Legal values are from 2 and 36. This argument is optional. Description Function; converts a string to an integer. If the specified string in the arguments cannot be converted to a number, the function returns NaN or 0. Integers beginning with 0 or specifying a radix of 8 are interpreted as octal numbers. Integers beginning with 0x are interpreted as hexadecimal numbers. White space preceding valid integers is ignored, as are trailing nonnumeric characters. Player Flash 5 or later. Example The following are examples of using parseInt to evaluate various types of numbers: parseInt("3.5") returns 3.5 parseInt( " bar " ) returns NaN parseInt("4foo " ) returns 4 Hexadecimal conversion: parseInt( " 0x3F8 " ) returns 1016 parseInt("3E8", 16 ) returns 1000 Binary conversion: parseInt("1010", 2) returns 10 (the decimal representation of the binary 1010) Octal number parsing (in this case the octal number is identified by the radix, 8): parseInt("777", 8) returns 511 (the decimal representation of the octal 777)html/09_n_r29.html play play N-R > play Syntax play(); Arguments None. Description Action; moves the playhead forward in the Timeline. Player Flash 2 or later. Example The following code uses an if statement to check the value of a name the user enters. If the user enters Steve , the play action is called and the playhead moves forward in the Timeline. If the user enters anything other than Steve , the movie does not play and a text field with the variable name alert is displayed. stop(); if (name = "Steve") { play(); } else { alert = "You are not Steve!"; }html/09_n_r3.html ne (not equal — string specific) ne (not equal — string specific) N-R > ne (not equal — string specific) Syntax expression1 ne expression2 Arguments expression1, expression2 Numbers, strings, or variables. Description Operator (comparison); compares expression1 to expression2 and returns true if expression1 is not equal to expression2 ; otherwise, returns false . Player Flash 4 or later. This operator has been deprecated in Flash 5; use of the new != (not equal) operator is recommended. See also != (inequality)html/09_n_r30.html prevFrame prevFrame N-R > prevFrame Syntax prevFrame(); Arguments None. Description Action; sends the playhead to the previous frame and stops it. Player Flash 2 or later. Example When the user clicks a button that a prevFrame action is assigned to, the playhead is sent to the previous frame. on(release) { prevFrame(5); } See also MovieClip.prevFramehtml/09_n_r31.html prevScene prevScene N-R > prevScene Syntax prevScene(); Arguments None. Description Action; sends the playhead to frame 1 of the previous scene and stops it. Player Flash 2 or later. See also nextScenehtml/09_n_r32.html print print N-R > print Syntax print ( target , "bmovie"); print ( target , "bmax"); print ( target , "bframe"); Arguments target The instance name of movie clip to print. By default, all of the frames in the movie are printed. If you want to print only specific frames in the movie, designate frames for printing by attaching a #P frame label to those frames in the authoring environment. bmovie Designates the bounding box of a specific frame in a movie as the print area for all printable frames in the movie. Attach a #b label (in the authoring environment) to designate the frame whose bounding box you want to use as the print area. bmax Designates a composite of all of the bounding boxes, of all the printable frames, as the print area. Specify the bmax argument when the printable frames in your movie vary in size. bframe Designates that the bounding box of each printable frame be used as the print area for that frame. This changes the print area for each frame and scales the objects to fit the print area. Use bframe if you have objects of different sizes in each frame and want each object to fill the printed page. Description Action; prints the target movie clip according to the printer modifier specified in the argument. If you want to print only specific frames in the target movie, attach a #P frame label to the frames you want to print. Although the print action results in higher quality prints than the printAsBitmap action, it cannot be used to print movies that use alpha transparencies or special color effects. If you do not specify a print area argument, the print area is determined by the Stage size of the loaded movie by default. The movie does not inherit the main movie's Stage size. You can control the print area by specifying the bmovie , bmax , or bframe arguments. All of the printable elements in a movie must be fully loaded before printing can begin. The Flash Player printing feature supports PostScript and non-PostScript printers. Non-PostScript printers convert vectors to bitmaps. Player Flash 5 or later. Example The following example will print all of the printable frames in myMovie with the print area defined by the bounding box of the frame with the #b frame label attached: print("myMovie","bmovie"); The following example will print all of the printable frames in myMovie with a print area defined by the bounding box of each frame: print("myMovie","bframe"); See also printAsBitmaphtml/09_n_r33.html printAsBitmap printAsBitmap N-R > printAsBitmap Syntax printAsBitmap( target , " bmovie "); printAsBitmap( target , " bmax "); printAsBitmap( target , " bframe "); Arguments target The instance name of movie clip to print. By default, all of the frames in the movie are printed. If you want to print only specific frames in the movie, designate frames for printing by attaching a #P frame label to those frames in the authoring environment. bmovie Designates the bounding box of a specific frame in a movie as the print area for all printable frames in the movie. Attach a #b label (in the authoring environment) to designate the frame whose bounding box you want to use as the print area. bmax Designates a composite of all of the bounding boxes, of all the printable frames, as the print area. Specify the bmax argument when the printable frames in your movie vary in size. bframe Designates that the bounding box of each printable frame be used as the print area for that frame. This changes the print area for each frame and scales the objects to fit the print area. Use bframe if you have objects of different sizes in each frame and want each object to fill the printed page. Description Action; prints the target movie clip as a bitmap. Use printAsBitmap to print movies that contain frames with objects that use transparency or color effects. The printAsBitmap action prints at the highest available resolution of the printer in order to maintain as much definition and quality as possible. To calculate the printable file size of a frame designated to print as a bitmap, multiply pixel width by pixel height by printer resolution. If your movie does not contain alpha transparencies or color effects, it is recommended that you use the print action for better quality results. By default, the print area is determined by the Stage size of the loaded movie. The movie does not inherit the main movie's Stage size. You can control the print area by specifying the bmovie , bmax , or bframe arguments. All of the printable elements in a movie must be fully loaded before printing can begin. The Flash Player printing feature supports PostScript and non-PostScript printers. Non-PostScript printers convert vectors to bitmaps. Player Flash 5 or later. See also printhtml/09_n_r34.html_quality _quality N-R > _quality Syntax _quality _quality = x; Arguments x A string specifying one of the following values: LOW Low rendering quality. Graphics are not antialiased, bitmaps are not smoothed. MEDIUM Medium rendering quality. Graphics are antialiased using a 2x2 grid, but bitmaps are not smoothed. Suitable for movies that do not contain text. HIGH High rendering quality. Graphics are antialiased using a 4x4 grid, and bitmaps are smoothed if the movie is static. This is the default rendering quality setting used by Flash. BEST Very high rendering quality. Graphics are antialiased using a 4x4 grid, and bitmaps are always smoothed. Description Property (global); sets or retrieves the rendering quality used for a movie. Player Flash 5 or later. Example The following example sets the rendering for oldQuality to HIGH: oldQualtiy = _quality _quality = "HIGH"; See also _highqualityhtml/09_n_r35.html random random N-R > random Syntax random(); Arguments value The highest integer for which random will return a value. Description Function; returns a random integer between 0 and the integer specified in the value argument. Player Flash 4. This function is deprecated in Flash 5; use of the Math.random method is recommended. Example The following use of random returns a value of 0, 1, 2, 3, or 4: random(5); See also Math.randomhtml/09_n_r36.html removeMovieClip removeMovieClip N-R > removeMovieClip Syntax removeMovieClip( target ); Arguments target The target path of a movie clip instance created with duplicateMovieClip , or the instance name of a movie clip created with the attachMovie or duplicateMovie methods of the MovieClip object. Description Action; deletes a movie clip instance that was created with the attachMovie or duplicateMovieClip methods of the MovieClip object, or with the duplicateMovieClip action. Player Flash 4 or later. See also duplicateMovieClip MovieClip.duplicateMovieClip MovieClip.attachMovie MovieClip.removeMovieCliphtml/09_n_r37.html return return N-R > return Syntax return[ expression ]; return; Arguments expression A type, string, number, array, or object to evaluate and return as a value of the function. This argument is optional. Description Action; specifies the value returned by a function. When the return action is executed, the expression is evaluated and returned as a value of the function. The return action causes the function to stop executing. If the return statement is used alone, or if Flash does not encounter a return statement during the looping action, it returns null. Player Flash 5 or later. Example The following is an example of using return : function sum(a, b, c){ return a + b + c; } See also functionhtml/09_n_r38.html_root _root N-R > _root Syntax _root; _root. movieClip ; _root. action ; Arguments movieClip The instance name of a movie clip. action The value set for the property. This is an optional argument and may not need to be set depending on the property. Description Property; specifies or returns a reference to the root movie Timeline. If a movie has multiple levels, the root movie Timeline is on the level containing the currently executing script. For example, if a script in level 1 evaluates _root , level 1 is returned. Specifying _root is the same as using the slash notation ( / ) to specify an absolute path within the current level. Player Flash 4 or later. Example The following example stops the Timeline of the level containing the currently executing script: _rootl.stop(); The following example sends the Timeline in the current level to frame 3: _root.gotoAndStop(3); See also _parent targetPathhtml/09_n_r39.html_rotation _rotation N-R > _rotation Syntax instancename . _rotation instancename . _rotation = integer Arguments integer The number of degrees to rotate the movie clip. instancename The movie clip to rotate. Description Property; specifies the rotation of the movie clip in degrees. Player Flash 4 or later.html/09_n_r4.html new new N-R > new Syntax new constructor (); Arguments constructor A function followed by any optional arguments in the parentheses. The function is usually the name of the type of object (For example, Array, Math, Number, Object) to be constructed. Description Operator; creates a new, initially anonymous object, calls the function identified by the constructor argument, passes any optional arguments in the parentheses, and passes the newly created object as a value of the keyword this . The constructor function can then use this to instantiate the new object. The _prototype_ property of the constructor function's object is copied into the _proto_ property of the new object. As a result, the new object supports all of the methods and properties specified in the constructor function's Prototype object. Player Flash 5 or later. Example The following example creates the objects book1 and book2 using the new operator. function Book(name, price) { this.name = name; this.price = price; } book1 = new Book("Confederacy of Dunces", 19.95); book2 = new Book("The Floating Opera", 10.95); See also [] (array access operator) {} (object initializer) The constructor method section within an object entry.html/09_n_r5.html newline newline N-R > newline Syntax newline; Arguments None. Description Constant; inserts a carriage return character ( { ) inserting a blank line into the ActionScript code. Use newline to make space for information that is retrieved by a function or action in your code. Player Flash 4 or later.html/09_n_r6.html nextFrame nextFrame N-R > nextFrame Syntax nextFrame(); Arguments None. Description Action; sends the playhead to the next frame and stops it. Player Flash 2 or later. Example When the user clicks a button that a nextFrame action is assigned to, the playhead is sent to the next frame. on (release) { nextFrame(5); }html/09_n_r7.html nextScene nextScene N-R > nextScene Syntax nextScene(); Arguments None. Description Action; sends the playhead to frame 1 of the next scene and stops it. Player Flash 2 or later. Example This action is assigned to a button that, when pressed and released, sends the playhead to frame 1 of the next scene. on(release) { nextScene(); }html/09_n_r8.html not not N-R > not Syntax not expression Arguments expression Any variable or other expression that converts to a Boolean value. Description Operator; performs a logical NOT operation in the Flash 4 Player. Player Flash 4 or later. This operator has been deprecated in Flash 5; use of the new ! (logical NOT) operator is recommended. See also ! (logical NOT)html/09_n_r9.html null null N-R > null Syntax null Arguments None. Description Keyword; a special value that can be assigned to variables, or returned by a function if no data was provided. You can use null to represent values that are missing or do not have a defined data type. Player Flash 5 or later. Example In a numeric context, null evaluates to 0. Equality tests can be performed with null . In this statement, a binary tree node has no left child, so the field for its left child could be set to null . if (tree.left == null) { tree.left = new TreeNode(); }html/10_s1.html scroll scroll S > scroll Syntax variable_name .scroll = x Arguments variable_name The name of a variable associated with a text field. x The line number of the topmost visible line in the text field. You can specify this value or use the default value of 1. The Flash Player updates this value as the user scrolls up and down the text field. Description Property; controls the display of information in a text field associated with a variable. The scroll property defines where the text field begins displaying content; after you set it, the Flash Player updates it as the user scrolls through the text field. The scroll property is useful for directing users to a specific paragraph in a long passage, or creating scrolling text fields. This property can be retrieved and modified. Player Flash 4 or later. See also maxscrollhtml/10_s10.html setProperty setProperty S > setProperty Syntax setProperty( target , property , expression ); Arguments target The path to the instance name of the movie clip whose property is being set. property The property to be set. expression The value to which the property is set. Description Action; changes the property of a movie clip as the movie plays. Player Flash 4 or later. Example This statement sets the _alpha property of a movie clip named star to 30 percent when the button is clicked: on(release) { setProperty("star", _alpha = 30); } See also getPropertyhtml/10_s11.html Sound (object) Sound (object) S > Sound (object) The Sound object allows you to set and control sounds in a particular movie clip instance, or for the global Timeline, if you do not specify a target when creating a new sound object. You must use the constructor new Sound to create an instance of the Sound object before calling the methods of the Sound object. The Sound object is only supported for the Flash 5 Player. Method summary for the Sound object Method Description attachSound Attaches the sound specified in the argument. getPan Returns the value of the previous setPan call. getTransform Returns the value of the previous setTransform call. getVolume Returns the value of the previous setVolume call. setPan Sets the left/right balance of the sound. setTransform Sets transform for a sound. setVolume Sets the volume level for a sound. start Starts playing a sound from the beginning or, optionally, from an offset point set in the argument. stop Stops the specified sound or all sounds currently playing. Constructor for the Sound object Syntax new Sound(); new Sound( target ); Arguments target The movie clip instance that the Sound object applies to. This argument is optional. Description Method; creates a new Sound object for a specified movie clip. If you do not specify a target , the Sound object controls all of the sounds in the global Timeline. Player Flash 5 or later. Example GlobalSound = new Sound(); MovieSound = new Sound( mymovie );html/10_s12.html Sound.attachSound Sound.attachSound S > Sound.attachSound Syntax mySound .attachSound(" idName "); Arguments idName The name for the new instance of the sound. This is the same as the name entered for the identifier in the Symbol Linkage Properties dialog box. This argument must be enclosed in " " ( quotation marks). Description Method; attaches the sound specified in the idName argument to the specified Sound object. The sound must be in the library of the current movie and specified for export in the Symbol Linkage Properties dialog box. You must call Sound.start to start playing the sound. Player Flash 5 or later. See also Sound.starthtml/10_s13.html Sound.getPan Sound.getPan S > Sound.getPan Syntax mySound .getPan(); Arguments None. Description Method; returns the pan level set in the last setPan call as an integer from -100 to 100. The pan setting controls the left-right balance of the current and future sounds in a movie. This method is cumulative with the setVolume or setTransform methods. Player Flash 5 or later. See also Sound.setPan Sound.setTransformhtml/10_s14.html Sound.getTransform Sound.getTransform S > Sound.getTransform Syntax mySound .getTransform ( ); Arguments None. Description Method; returns the sound transform information for the specified Sound object set with the last setTransform call. Player Flash 5 or later. See also Sound.setTransformhtml/10_s15.html Sound.getVolume Sound.getVolume S > Sound.getVolume Syntax mySound .getVolume ( ); Arguments None. Description Method; returns the sound volume level as an integer from 0 to 100, where 0 is off and 100 is full volume. The default setting is 100. Player Flash 5 or later. See also Sound.setVolumehtml/10_s16.html Sound.setPan Sound.setPan S > Sound.setPan Syntax mySound .setPan( pan ); Arguments pan An integer specifying the left-right balance for a sound. The range of valid values is -100 to 100, where -100 uses only the the left channel, 100 uses only the right channel, and 0 balances the sound evenly between the two channels. Description Method; determines how the sound is played in the left and right channels (speakers). For mono sounds, pan affects which speaker (left or right) the sound plays through. This method is cumulative with the setVolume and setTransform methods, and calling this method deletes and updates previous setPan and setTransform settings. Player Flash 5 or later. Example The following example uses setVolume and setPan to control a sound object with the specified target "u2": onClipEvent(mouseDown) { // create a sound object and s = new Sound(this); // attach a sound in the library s.attachSound("u2"); //set volume at 50% s.setVolume(50); //turn off the sound in the right channel s.setPan(-100); //start 30 seconds into the sound and play it 5 times s.start(30, 5); See also Sound.setTransform Sound.setVolumehtml/10_s17.html Sound.setTransform Sound.setTransform S > Sound.setTransform Syntax mySound .setTransform( soundTransformObject ); Arguments soundTransformObject An object created with the constructor for the generic Object object. Description Method; sets the sound transform information for a Sound object. This method is cumulative with the setVolume and setPan methods, and calling this method deletes and updates any previous setPan or setVolume settings. This call is for expert users who want to add interesting effects to sounds. Sounds use a considerable amount of disk space and memory. Because stereo sounds use twice as much data as mono sounds, it's generally best to use 22-Khz 6-bit mono sounds. You can use the setTransform method to play mono sounds as stereo, play stereo sounds as mono, and to add interesting effects to sounds. The soundTransformObject argument is an object that you create using the constructor method of the generic Object object with parameters specifying how the sound is distributed to the left and right channels (speakers). The parameters for the soundTransformObject are as follows: 11 A percentage value specifying how much of the left input to play in the left speaker (-100 to 100). 1r A percentage value specifying how much of the right input to play in the left speaker (-100 to 100). rr A percentage value specifying how much of the right input to play in the right speaker (-100 to 100). rl A percentage value specifying how much of the left input to play in the right speaker (-100 to 100). The net result of the parameters is represented by the following formula: leftOutput = left input * ll + right input * lr rightOutput = right lnput * rr + left input * rl The values for left input or right input are determined by the type (stereo or mono) of sound in your movie. Stereo sounds divide the sound input evenly between the left and right speakers and have the following transform settings by default: ll = 100 lr = 0 rr = 100 rl = 0 Mono sounds play all sound input in the left speaker and have the following transform settings by default: ll = 100 lr = 100 rr = 0 rl = 0 Player Flash 5 or later. Example The following example creates a sound transform object that plays both the left and right channels in the left channel: mySoundTransformObject = new Object mySoundTransformObject.ll = 100 mySoundTransformObject.lr = 100 mySoundTransformObject.rr = 0 mySoundTransformObject.rl = 0 In order to apply the sound transform object to a Sound object, you need to pass the object to the Sound object using setTransform as follows: mySound.setTransform(mySoundTransformObject); The following are examples of settings that can be set using setTransform , but cannot be set using setVolume or setPan , even if combined. This code plays both the left and right channels through the left channel: mySound.setTransform( soundTransformObjectLeft ); In the above code, the soundTransformObjectLeft has the following parameters: 11 = 100 1r = 100 rr = 0 rl = 0 This code plays a stereo sound as mono: setTransform( soundTransformObjectMono ); In the above code, the soundTransformObjectMono has the following parameters: ll = 50 lr = 50 rr = 50 rl = 50 This code plays the left channel at half capacity and adds the rest of the left channel to the right channel: setTransform( soundTransformObjectHalf ); In the above code, the soundTransformObjectHalf has the following parameters: 11 = 50 lr = 0 rr = 100 rl = 50 See also Constructor for the Object objecthtml/10_s18.html Sound.setVolume Sound.setVolume S > Sound.setVolume Syntax mySound .setVolume( volume ); Arguments volume A number from 0 to 100 representing a volume level. 100 is full volume and 0 is no volume. The default setting is 100. Description Method; sets the volume for the Sound object. This method is cumulative with the setPan and setTransform methods. Player Flash 5 or later. Example The following example sets volume to 50% and transfers the sound over time from the left speaker to the right speaker: onClipEvent (load) { i = -100; s = new sound(); s.setVolume(50); } onClipEvent (enterFrame) { S.setPan(i++); } See also Sound.setPan Sound.setTransformhtml/10_s19.html Sound.start Sound.start S > Sound.start Syntax mySound .start(); mySound .start([ secondOffset, loop ]); secondOffset An optional argument allowing you to start the sound playing at a specific point. For example, if you have a 30-second sound and want the sound to start playing in the middle, specify 15 for the secondOffset argument. The sound is not delayed 15 seconds, but rather starts playing at the 15-second mark. loop An optional argument allowing you to specify the number of times the sound should loop. Description Method; starts playing the last attached sound from the beginning if no argument is specified, or starting at the point in the sound specified by the secondOffset argument. Player Flash 5 or later. See also Sound.setPan Sound.stophtml/10_s2.html Selection (object) Selection (object) S > Selection (object) The Selection object allows you to set and control the currently focused editable text field. The currently focused editable text field is the field where the user's mouse pointer is currently placed. Selection-span indexes are zero-based (where the first position is 0, the second position is 1, and so on). There is no constructor method for the Selection object, as there can only be one currently focused field at a time. Method summary for the Selection object Method Description getBeginIndex Returns the index at the beginning of selection span. Returns -1 if there is no index or currently selected field. getCaretIndex Returns the current caret position in the currently focused selection span. Returns -1 if there is no caret position or currently focused selection span. getEndIndex Returns the index at the end of the selection span. Returns -1 if there is no index or currently selected field. getFocus Returns the name of the variable for currently focused editable text field. Returns null if there is no currently focused editable text field. setFocus Focuses the editable text field associated with the variable specified in the argument. setSelection Sets the beginning and ending indexes of the selection span.html/10_s20.html Sound.stop Sound.stop S > Sound.stop Syntax mySound .stop(); mySound .stop([" idName" ]); Arguments idName An optional argument specifying a specific sound to stop playing. The idName argument must be enclosed in quotation marks(" "). Description Method; stops all sounds currently playing if no argument is specified, or just the sound specified in the idName argument. Player Flash 5 or later. See also Sound.starthtml/10_s21.html_soundbuftime _soundbuftime S > _soundbuftime Syntax _soundbuftime = integer; Arguments integer The number of seconds before the movie starts to stream. Description Property (global); establishes the number of seconds of streaming sound to prebuffer. The default value is 5 seconds. Player Flash 4 or later.html/10_s22.html startDrag startDrag S > startDrag Syntax startDrag( target ); startDrag( target ,[ lock ]); startDrag( target [, lock [, left , top , right , bottom ]]); Arguments target The target path of the movie clip to drag. lock A Boolean value specifying whether the draggable movie clip is locked to the center of the mouse position ( true ), or locked to the point where the user first clicked on the movie clip ( false ). This argument is optional. left , top , right , bottom Values relative to the coordinates of the movie clip's parent that specify a constraint rectangle for the movie clip. These arguments are optional. Description Action; makes the target movie clip draggable while the movie is playing. Only one movie clip can be dragged at a time. Once a startDrag operation is executed, the movie clip remains draggable until explicitly stopped by a stopDrag action, or until a startDrag action for another movie clip is called. Example To create a movie clip that users can position in any location, attach the startDrag and stopDrag actions to a button inside the movie clip, as in the following: on(press) { startDrag("",true); } on(release) { stopDrag(); } See also stopDrag _droptargethtml/10_s23.html stop stop S > stop Syntax stop; Arguments None. Description Action; stops the movie that is currently playing. The most common use of this action is to control movie clips with buttons. Player Flash 3 or later.html/10_s24.html stopAllSounds stopAllSounds S > stopAllSounds Syntax stopAllSounds(); Arguments None. Description Action; stops all sounds currently playing in a movie without stopping the playhead. Sounds set to stream will resume playing as the playhead move over the frames they are in. Player Flash 3 or later. Example The following code could be applied to a button that, when clicked, stops all sounds in the movie: on(release) { stopAllSounds(); } See also Sound (object)html/10_s25.html stopDrag stopDrag S > stopDrag Syntax stopDrag(); Arguments None. Description Action; stops the current drag operation. Player Flash 4 or later. Example This statement stops the drag action on the instance mc when the user releases the mouse button: on(press) { startDrag("mc"); } on(release) { stopdrag(); } See also startDrag _droptargethtml/10_s26.html String (function) String (function) S > String (function) Syntax String( expression ); Arguments expression The number, Boolean, variable, or object to convert to a string. Description Function; returns a string representation of the specified argument as follows: If x is Boolean, the return string is true or false . If x is a number, the return string is a decimal representation of the number. If x is a string, the return string is x . If x is an object, the return value is a string representation of the object generated by calling the string property for the object, or by calling object.toString if no such property exists. If x is a movie clip, the return value is the target path of the movie clip in slash (/) notation. If x is undefined, the return value is an empty string. Player Flash 3 or later. See also Object.toString Number.toString String (object) " " (string delimiter)html/10_s27.html" " (string delimiter) " " (string delimiter) S > " " (string delimiter) Syntax " text " Arguments text Any text. Description String delimiter; when used before and after a string, quotes indicate that the string is a literal—not a variable, numerical value, or other ActionScript element. Player Flash 4 or later. Example This statement uses quotes to indicate that the string "Prince Edward Island" is a literal string, and not the value of a variable: province = "Prince Edward Island" See also String (object) String (function)html/10_s28.html String (object) String (object) S > String (object) The String object is a wrapper for the string primitive data type, which allows you to use the methods and properties of the String object to manipulate primitive string value types. You can convert the value of any object into a string using the String() function. All of the methods of the String object, except for concat , fromCharCode , slice , and substr , are generic. This means the methods themselves call this.toString before performing their operations, and you can use these methods with other non-String objects. You can call any of the methods of the String object using the constructor method new String or using a string literal value. If you specify a string literal, the ActionScript interpreter automatically converts it to a temporary String object, calls the method, and then discards the temporary String object. You can also use the String.length property with a string literal. It is important that you do not confuse a string literal with an instance of the String object. In the following example the first line of code creates the string literal s1 , and the second line of code creates an instance of the String object s2 . s1 = "foo" s2 = new String("foo") It is recommended that you use string literals unless you specifically need to use a String object, as String objects can have counterintuitive behavior. Method summary for String object Method Description charAt Returns a number corresponding to the placement of the character in the string. charCodeAt Returns the value of the character at the given index as a 16-bit integer between 0 and 65535. concat Combines the text of two strings and returns a new string. fromCharCode Returns a string made up of the characters specified in the arguments. indexOf Searches the string and returns the index of the value specified in the arguments. If value occurs more than once, the index of the first occurrence is returned. If value is not found, -1 is returned. lastIndexOf Returns the last occurrence of substring within the string that appears before the start position specified in the argument, or -1 if not found. slice Extracts a section of a string and returns a new string. split Splits a String object into an array of strings by separating the string into substrings. substr Returns a specified number of characters in a string, beginning at the location specified in the argument. substring Returns the characters between two indexes, specified in the arguments, into the string. toLowerCase Converts the string to lowercase and returns the result. toUpperCase Converts the string to uppercase and returns the result. Property summary for the String object Property Description length Returns the length of the string. Constructor for the String object Syntax new String( value ); Arguments value The initial value of the new String object. Description Constructor; creates a new String object. Player Flash 5 or later. See also String (function) " " (string delimiter)html/10_s29.html String.charAt String.charAt S > String.charAt Syntax myString .charAt( index ); Arguments index The number of the character in the string to be returned. Description Method; returns the character specified by the argument index . The index of the first character in a string is 0. If index is not a number from 0 to string.length - 1, an empty string is returned. Player Flash 5 or later.html/10_s3.html Selection.getBeginIndex Selection.getBeginIndex S > Selection.getBeginIndex Syntax Selection.getBeginIndex(); Arguments None. Description Method; returns index at the beginning of the selection span. If no index exists or no field currently has the focus, the method returns -1. Selection span indexes are zero-based (where the first position is 0, the second position is 1, and so on). Player Flash 5 or later.html/10_s30.html String.charCodeAt String.charCodeAt S > String.charCodeAt Syntax myString .charCodeAt( index ); Arguments index The number of the character for which the value is retrieved. Description Method; returns the value of the character specified by index . The returned value is a 16-bit integer from 0 to 65535. This method is similar to string . charAt except that the returned value is for the character at a specific location, instead of a substring containing the character. Player Flash 5 or later.html/10_s31.html String.concat String.concat S > String.concat Syntax myString .concat( value1,...valueN ); Arguments value1,...valueN Zero or more values to be concatenated. Description Method; combines the specified values and returns a new string. If necessary, each value argument is converted to a string and appended, in order, to the end of the string. Player Flash 5 or later.html/10_s32.html String.fromCharCode String.fromCharCode S > String.fromCharCode Syntax myString .fromCharCode( c1,c2,...cN ); Arguments c1,c2,...cN The characters to be made into a string. Description Method; returns a string made up of the characters specified in the arguments. Player Flash 5 or later.html/10_s33.html String.indexOf String.indexOf S > String.indexOf Syntax myString .indexOf( value ); myString . index of ( value , start ); Arguments value An integer or string specifying the substring to be searched for within myString . start An integer specifying the starting point of the substring. This argument is optional. Description Method; searches the string and returns the position of the first occurrence of the specified value . If the value is not found, the method returns -1. Player Flash 5 or later.html/10_s34.html String.lastIndexOf String.lastIndexOf S > String.lastIndexOf Syntax myString .lastIndexOf( substring ); myString . lastIndexOf( substring , start ); Arguments substring An integer or string specifying the string to be searched for. start An integer specifying the starting point inside the substring. This argument is optional. Description Method; searches the string and returns the index of the last occurrence of substring found within the calling string. If substring is not found, the method returns -1. Player Flash 5 or later.html/10_s35.html String.length String.length S > String.length Syntax string.length Arguments None. Description Property; returns the number of characters in the specified String object. The index of the last character for any string x is x.length-1. Player Flash 5 or later.html/10_s36.html String.slice String.slice S > String.slice Syntax myString .slice( start , end ); Arguments start A number specifying the index of the starting point for the slice. If start is a negative number, the starting point is determined from the end of the string, where -1 is the last character. end A number specifying the index of the ending point for the slice. If end is not specified, the slice includes all characters from the start to the end of the string. If end is a negative number, the ending point is determined from the end of the string, where -1 is the last character. Description Method; extracts a slice, or substring, of the specified String object; then returns it as a new string without modifying the original String object. The returned string includes the start character and all characters up to (but not including) the end character. Player Flash 5 or later.html/10_s37.html String.split String.split S > String.split Syntax myString .split( delimiter ); Arguments delimiter The character used to delimit the string. Description Method; splits a String object by breaking the string wherever the specified delimiter argument occurs, and returns the substrings in an array. If no delimiter is specified, the returned array contains only one element—the string itself. If the delimiter is an empty string, each character in the String object becomes an element in the array. Player Flash 5 or later.html/10_s38.html String.substr String.substr S > String.substr Syntax myString .substr( start , length ); Arguments start An integer that indicates the position of the first character in the substring being created. If start is a negative number, the starting position is determined from the end of the string, where the -1 is the last character. length The number of characters in the substring being created. If length is not specified, the substring includes all of the characters from the start to the end of the string. Description Method; returns the characters in a string from the index specified in the start argument through the number of characters specified in the length argument. Player Flash 5 or later.html/10_s39.html String.substring String.substring S > String.substring Syntax myString .substring( from , to ); Arguments from An integer that indicates the position of the first character in the substring being created. Valid values for from are 0 through string.length - 1. to An integer that is 1+ the index of the last character in the substring being created. Valid values for to are 1 through string.length . If the to argument is not specified, the end of the substring is the end of the string. If from equals to , the method returns an empty string. If from is greater than to , the arguments are automatically swapped before the function executes. Description Method; returns a string consisting of the characters between the points specified by the from and to arguments. Player Flash 5 or later.html/10_s4.html Selection.getCaretIndex Selection.getCaretIndex S > Selection.getCaretIndex Syntax Selection.getCaretIndex(); Arguments None. Description Method; returns the index of the blinking cursor position. If there is no blinking mouse pointer displayed, the method returns -1. Selection span indexes are zero-based (where the first position is 0, the second position is 1, and so on). Player Flash 5 or later.html/10_s40.html String.toLowerCase String.toLowerCase S > String.toLowerCase Syntax myString .toLowerCase(); Arguments None. Description Method; returns a copy of the String object, with all of the uppercase characters converted to lowercase. Player Flash 5 or later.html/10_s41.html String.toUpperCase String.toUpperCase S > String.toUpperCase Syntax myString .toUpperCase(); Arguments None. Description Method; returns a copy of the String object, with all of the lowercase characters converted to uppercase. Player Flash 5 or later.html/10_s42.html substring substring S > substring Syntax substring( string , index , count ); Arguments string The string from which to extract the new string. index The number of the first character to extract. count The number of characters to include in the extracted string, not including the index character. Description String function; extracts part of a string. Player Flash 4 or later. This function has been deprecated in Flash 5. See also String.substringhtml/10_s5.html Selection.getEndIndex Selection.getEndIndex S > Selection.getEndIndex Syntax Selection.getEndIndex(); Arguments None. Description Method; returns the ending index of the currently focused selection span. If no index exists, or if there is no currently focused selection span, the method returns -1. Selection span indexes are zero-based (where the first position is 0, the second position is 1, and so on). Player Flash 5 or later.html/10_s6.html Selection.getFocus Selection.getFocus S > Selection.getFocus Syntax Selection.getFocus(); Arguments None. Description Method; returns the name of the variable of the currently focused editable text field. If no text field is currently focused, the method returns null . Player Flash 5 or later. Example The following code returns the name of the variable: _root. anyMovieClip .myTextField.html/10_s7.html Selection.setFocus Selection.setFocus S > Selection.setFocus Syntax Selection.setFocus( variable ); Arguments variable A string specifying the name of a variable associated with a text field using dot or slash notation. Description Method; focuses the editable text field associated with the specified variable . Player Flash 5 or later.html/10_s8.html Selection.setSelection Selection.setSelection S > Selection.setSelection Syntax Selection.setSelection( start, end ); Arguments start The beginning index of the selection span. end The ending index of the selection span. Description Method; sets the selection span of the currently focused text field. The new selection span will begin at the index specified in the start argument, and end at the index specified in the end argument. Selection span indexes are zero-based (where the first position is 0, the second position is 1, and so on). This method has no effect if there is no currently focused text field. Player Flash 5 or later.html/10_s9.html set set S > set Syntax variable = expression ; set( variable , expression ); Arguments variable The name of the container that holds the value of the expression argument. expression The value (or a phrase that can be evaluated to a value) that is assigned to the variable. Description Action; assigns a value to a variable. A variable is a container that holds information. The container itself is always the same, but the contents can change. By changing the value of a variable as the movie plays, you can record and save information about what the user has done, record values that change as the movie plays, or evaluate whether a condition is true or false . Variables can hold either numbers or strings of characters. Each movie and movie clip has its own set of variables, and each variable has its own value independent of variables in other movies or movie clips. ActionScript is an untyped language. That means that variables do not need to be explicitly defined as containing either a number or a string. Flash interprets the data type as an integer or string accordingly. Use the set statement in conjunction with the call action to pass or return values. Player Flash 4 or later. Example This example sets a variable called orig _ x_pos that stores the original x axis position of the ship movie clip in order to reset the ship to its starting location later in the movie: on(release) { set(x_pos, getProperty ("ship", _x )); } This is equivalent to writing the following: on(release) { orig_x_pos = getProperty ("ship", _x ); } See also var callhtml/11_t_w1.html_target _target T-W > _target Syntax instancename ._target Arguments instancename The name of a movie clip instance. Description Property (read-only); returns the target path of the movie clip instance specified in the instancename argument. Player Flash 4 or later.html/11_t_w10.html unloadMovie unloadMovie T-W > unloadMovie Syntax unloadMovie( location ); Arguments location The depth level or target movie clip from which to unload the movie. Description Action; removes a movie from the Flash Player that was previously loaded using the loadMovie action. Player Flash 3 or later. Example The following example unloads the main movie, leaving the Stage blank: unloadMovie(_root); The following example unloads the movie at level 15, when the user clicks the mouse: on(press) { unloadMovie(_level15); } See also loadMoviehtml/11_t_w11.html updateAfterEvent updateAfterEvent T-W > updateAfterEvent Syntax updateAfterEvent( movie clip event ); Arguments movie clip event You can specify one of the following values as a movie clip event: mouseMove The action is initiated every time the mouse is moved. Use the _xmouse and _ymouse properties to determine the current mouse position. mouseDown The action is initiated if the left mouse button is pressed. mouseUp The action is initiated if the left mouse button is released. keyDown The action is initiated when a key is pressed. Use the Key . getCode method to retrieve information about the last key pressed. keyUp The action is initiated when a key is released. Use the key . getCode method to retrieve information about the last key pressed. Description Action; updates the display (independent of the frames per second set for the movie) after the clip event specified in the arguments has completed. This action is not listed in the Flash Actions panel. Using updateAfterEvent with drag actions that specify the _x and _y properties during the mouse move allows objects to drag smoothly without a flickering screen effect. Player Flash 5 or later. See also onClipEventhtml/11_t_w12.html_url _url T-W > _url Syntax instancename . _url Arguments instancename The target movie clip. Description Property (read only); retrieves the URL of the SWF file from which the movie clip was downloaded. Player Flash 4 or later?html/11_t_w13.html var var T-W > var Syntax var variableName1 [= value1 ] [..., variableNameN [= valueN ]]; Arguments variableName The name of the variable to declare. value The value being assigned to the variable. Description Action; used to declare local variables. If you declare local variables inside a function, the variables are defined for the function and expire at the end of the function call. If variables are not declared inside a block, but the action list was executed with a call action, the variables are local and expire at the end of the current list. If variables are not declared inside a block and the current action list was not executed with the call action, the variables are not local. Player Flash 5 or later.html/11_t_w14.html_visible _visible T-W > _visible Syntax instancename ._visible instancename ._visible = Boolean ; Arguments Boolean Enter a true or false value to specify whether the movie clip is visible. Description Property; determines whether or not the movie specified by the instancename argument is visible. Movie clips that are not visible (property set to false ) are disabled. For example, a button in a movie clip with the _visible property set to false cannot be clicked. Player Flash 4 or later.html/11_t_w15.html void void T-W > void Syntax void ( expression ); Arguments expression An expression of any value. Description Operator; a unary operator that discards the expression value and returns an undefined value. The void operator is often used to evaluate a URL in order to test for side effects without displaying the evaluated expression in the browser window. The void operator is also used in comparisons using the == operator to test for undefined values. Player Flash 5 or later.html/11_t_w16.html while while T-W > while Syntax while( condition ) { statement(s) ; } Arguments condition The statement that is reevaluated each time the while action is executed. If the statement evaluates to true , the expression in the statement(s) is run. statement(s) The expression to run if the condition evaluates to true . Description Action; runs a statement or series of statements repeatedly in a loop as long as the condition argument is true . At the end of each while action, Flash restarts the loop by retesting the condition. If the condition is false or equal to 0, Flash skips to the first statement after the while action. Looping is commonly used to perform an action while a counter variable is less than a specified value. At the end of each loop, the counter is incremented until the threshold value is reached, the condition is no longer true , and the loop ends. Player Flash 4 or later. Example This example duplicates five movie clips on the Stage, each with a randomly generated x and y position, xscale and yscale , and _alpha property to achieve a scattered effect. The variable foo is initialized with the value 0. The condition argument is set so that the while loop will run five times, or as long as the value of the variable foo is less than 5. Inside the while loop, a movie clip is duplicated and setProperty is used to adjust the various properties of the duplicated movie clip. The last statement of the loop increments foo so that when the value reaches 5, the condition argument evaluates to false , and the loop will not be executed. on(release) { foo = 0; while(foo < 5) { duplicateMovieClip("/flower", "mc" + foo, foo); setProperty("mc" + foo, _x, random(275)); setProperty("mc" + foo, _y, random(275)); setProperty("mc" + foo, _alpha, random(275)); setProperty("mc" + foo, _xscale, random(200)); setProperty("mc" + foo, _yscale, random(200)); foo = foo + 1; } } See also do... while continuehtml/11_t_w17.html_width _width T-W > _width Syntax instancename . _width instancename . _width = value ; Arguments value The width of the movie in pixels. instancename An instance name of a movie clip for which the _width property is to be set or retrieved. Description Property; sets the width of the movie. In previous versions of Flash, _height and _width were read-only properties; in Flash 5 they can be set as well as retrieved. Player Flash 4 as a read-only property. In Flash 5 or later, this property can be set as well as retrieved. Example The following code example sets the height and width properties of a movie clip when the user clicks the mouse: onclipEvent(mouseDown) { _width=200; _height=200; } See also _heighthtml/11_t_w18.html with with T-W > with Syntax with ( object ) { statement(s) ; } Arguments object An instance of an ActionScript object or movie clip. statement(s) An action or group of actions enclosed in curly braces. Description Action; temporarily changes the scope (or target path) used for evaluating expressions and actions in the statement(s) . After the with action executes, the scope chain is restored to its original state. The object becomes the context in which the properties, variables, and functions are read. For example, if object is myArray , and two of the properties specified are length and concat , those properties are automatically read as myArray . length and myArray.concat . In another example, if object is state.california , it is as if any actions or statements inside the with action were called from inside the california instance. To find the value of an identifier in the statement(s) , ActionScript starts at the beginning of the scope chain specified by the object and searches for the identifier at each level of the scope chain, in a specific order. The scope chain used by the with action to resolve identifiers starts with the first item in the following list and continues to the last, as follows: object referenced by innermost with action object referenced by outermost with action Activation object (A temporary object that is automatically created when a function is called that holds the local variables called in the function.) Movie clip containing currently executing script Global object (predefined objects such as Math, String) In Flash 5 the with action replaces the deprecated tellTarget action. You are encouraged to use with instead of tellTarget because it is a standard ActionScript extension to the ECMA-262 standard. The principal difference between the with and tellTarget actions is that with takes a reference to a movie clip or other object as its argument, while tellTarget takes a target path string identifying a movie clip, and cannot be used to target objects. To set a variable inside a with action, the variable must have been delared outside the with action or you must enter the full path to the Timeline on which you want the variable to live. If you set a variable in a with action without having declared it, the with action will look for the value according to the scope chain. If the variable doesn't already exist, the new value will be set on the Timeline from which the with action was called. Example The following example sets the x and y properties of the someOtherMovieClip instance, and then instructs someOtherMovieClip to go to frame 3 and stop: with (someOtherMovieClip) { _x = 50; _y = 100; gotoAndStop(3); } The following code snippet is how you would write the preceding code without using a with action: someOtherMovieClip._x = 50; someOtherMovieClip._y = 100; someOtherMovieClip.gotoAndStop(3); This code could also be written using the tellTarget action: tellTarget ("someOtherMovieClip") { _x = 50; _y = 100; gotoAndStop(3); } The with action is useful for accessing multiple items in a scope chain list simultaneously. In the following example, the built-in Math object is placed at the front of the scope chain. Setting Math as a default object resolves the identifiers cos , sin , and PI to Math.cos , Math.sin , and Math.PI , respectively. The identifiers a , x , y , and r are not methods or properties of the Math object, but since they exist in the object activation scope of the function polar , they resolve to the corresponding local variables. function polar(r){ var a, x, y with (Math) { a = PI * r * r x = r * cos(PI) y = r * sin(PI/2) } trace("area = " +a) trace("x = " + x) trace("y = " + y) } You can use nested with actions to access information in multiple scopes. In the following example, the instance fresno and the instance salinas are children of the instance california . The statement sets the _alpha values of fresno and salinas without changing the _alpha value of california . with (california){ with (fresno){ _alpha = 20; } with (salinas){ _alpha = 40; } } See also tellTargethtml/11_t_w2.html targetPath targetPath T-W > targetPath Syntax targetpath( movieClipObject ); Arguments movieClipObject Reference (for example, _root or _parent ) to the movie clip for which the target path is being retrieved. Description Function; returns a string containing the target path of movieClipObject . The target path is returned in dot notation. To retrieve the target path in slash notation, use the _target property. Player Flash 5 or later. Example The following examples are equivalent. The first example uses dot notation, and the second example uses slash notation. targetPath (Board.Block[index*2+1]) { play(); } Is equivalent to: tellTarget ("Board/Block:" + (index*2+1)) { play(); } See also evalhtml/11_t_w3.html tellTarget tellTarget T-W > tellTarget Syntax tellTarget( target ) { statement; } Arguments target A target path string specifying the Timeline to be controlled. statement Instructions applied to the targeted Timeline. Description Action; applies the instructions specified in the statements argument to the Timeline specified in the target argument. The tellTarget action is useful for navigation controls. Assign tellTarget to buttons that stop or start movie clips elsewhere on the Stage. You can also make movie clips go to a particular frame in that clip. For example, you might assign tellTarget to buttons that stop or start movie clips on the Stage or prompt movie clips to jump to a particular frame. The tellTarget action is very similar to the with action, except that with takes a movie clip or other object as a target , and tellTarget requires a target path to a movie clip and cannot control objects. Player Flash 3 or later. This action is deprecated in Flash 5; use of the with action is recommended. Example This tellTarget statement controls the movie clip instance ball on the main Timeline. Frame 1 of the movie clip is blank and has a stop action so that it isn't visible on the Stage. When the button with the following action is clicked, tellTarget tells the playhead in the movie clip ball to go to frame 2 and play the animation that starts there. on(release) { tellTarget("ball") { gotoAndPlay(2); } } See also withhtml/11_t_w4.html this this T-W > this Syntax this Arguments None. Description Keyword; references an object or movie clip instance. The keyword this has the same purpose and function in ActionScript as it does in JavaScript, with some additional functionality. In ActionScript, when a script executes, this references the movie clip instance that contains the script. When used with a method invocation, this contains a reference to the object that contains the executed method. Player Flash 5 or later. Example In the following example, the keyword this references the Circle object: function Circle(radius){ this.radius = radius; this.area = math.PI * radius * radius; } In the following statement assigned to a frame, the keyword this references the current movie clip: //sets the alpha property of the current movie clip to 20. this._alpha = 20; In the following statement inside an onClipEvent handler, the keyword this references the current movie clip: //when the movie clip loads, a startDrag operation is initiated for the current movie clip. onClipEvent (load) { startDrag (this, true); } See also newhtml/11_t_w5.html toggleHighQuality toggleHighQuality T-W > toggleHighQuality Syntax toggleHighQuality(); Arguments None. Description Action; turns antialiasing on and off in the Flash Player. Antialiasing smooths the edges of objects and slows down the movie playback. The toggleHighQuality action affects all movies in the Flash Player. Player Flash 2 or later. Example The following code could be applied to a button that, when clicked, would toggle antialiasing on and off: on(release) { toggleHighQuality(); } See also _quality _highqualityhtml/11_t_w6.html_totalframes _totalframes T-W > _totalframes Syntax instancename ._totalframes Arguments instancename The name of the movie clip to evaluate. Description Property (read-only); evaluates the movie clip specified in the instancename argument and returns the total number of frames in the movie. Player Flash 4 or later.html/11_t_w7.html trace trace T-W > trace Syntax trace( expression ); Arguments expression A statement to evaluate. When you test the movie, the results of the expression argument are displayed in the Output window. Description Action; evaluates the expression and displays the results in the Output window in test-movie mode. Use trace to record programming notes or to display messages in the Output window while testing a movie. Use the expression parameter to check if a condition exists, or to display values in the Output window. The trace action is similar to the alert function in JavaScript. Player Flash 4 or later. Example This example is from a game in which a draggable movie clip instance named rabbi must be released on a specific target. A conditional statement evaluates the _droptarget property and executes different actions depending on where rabbi is released. The trace action is used at the end of the script to evaluate the location of the rabbi movie clip, and display the results in the Output window. If rabbi doesn't behave as expected (for example, if it snaps to the wrong target), the values sent to the Output window by the trace action will help you determine the problem in the script. on(press) { rabbi.startDrag(); } on(release) { if(eval(_droptarget) != target) { rabbi._x = rabbi_x; rabbi._y = rabbi_y; } else { rabbi_x = rabbi._x; rabbi_y = rabbi._y; target = "_root.pasture"; } trace("rabbi_y = " + rabbi_y); trace("rabbi_x = " + rabbi_x); stopDrag(); }html/11_t_w8.html typeof typeof T-W > typeof Syntax typeof ( expression ); Arguments expression A string, movie clip, object, or function. Description Operator; a unary operator placed before a single argument. Causes Flash to evaluate expression ; the result is a string specifying whether the expression is a string, movie clip, object, or function. Player Flash 5 or later.html/11_t_w9.html unescape unescape T-W > unescape Syntax unescape(x); Arguments x A string with hexadecimal sequences to escape. Description Top-level function; evaluates the argument x as a string, decodes the string from a URL-encoded format (converting all hexadecimal sequences to ASCII characters), and returns the string. Player Flash 5 or later. Example The following example illustrates the escape-to-unescape conversion process. escape("Hello{[World]}"); The escaped result is as follows: ("Hello%7B%5BWorld%5D%7D'); Use unescape to return to the original format: unescape("Hello%7B%5BWorld%5D%7D") The result is as follows: Hello{[World]}html/12_x_z1.html_x _x X-Z > _x Syntax instancename . _x instancename . _x = integer Arguments integer The local x coordinate of the movie. instancename The name of a movie clip instance. Description Property; sets the x coordinate of movie relative to the local coordinates of the parent movie clip. If a movie clip is in the main Timeline, then its coordinate system refers to the upper left corner of the Stage as (0, 0). If the move clip is inside another movie clip that has transformations, the movie clip is in the local coordinate system of the enclosing movie clip. Thus, for a movie clip rotated 90º counterclockwise, the movie clip's children inherit a coordinate system that is rotated 90º counterclockwise. The movie clip's coordinates refer to the registration point position. Player Flash 3 or later. See also _y _xscalehtml/12_x_z10.html XML.firstChild XML.firstChild X-Z > XML.firstChild Syntax myXML .firstChild; Arguments None. Description Property (read-only); evaluates the specified XML object and references the first child in the parent node's children list. This property is null if the node does not have children. This property is undefined if the node is a text node. This is a read-only property and cannot be used to manipulate child nodes; use the methods appendChild , insertBefore , and removeNode to manipulate child nodes. Player Flash 5 or later. See also XML.appendChild XML.insertBefore XML.removeNodehtml/12_x_z11.html XML.haschildNodes XML.haschildNodes X-Z > XML.haschildNodes Syntax myXML .hasChildNodes(); Arguments None. Description Method; evaluates the specified XML object and returns true if there are child nodes; otherwise, returns false . Player Flash 5 or later. Example The following example uses the information from the XML object in a user-defined function: if (rootNode.hasChildNodes()) { myfunc (rootNode.firstChild); }html/12_x_z12.html XML.insertBefore XML.insertBefore X-Z > XML.insertBefore Syntax myXML .insertBefore( childNode, beforeNode ); Arguments childNod e The node to be inserted. beforeNode The node before the insertion point for the childNode . Description Method; inserts a new child node into the XML object's child list, before the beforeNode . Player Flash 5 or later.html/12_x_z13.html XML.lastChild XML.lastChild X-Z > XML.lastChild Syntax myXML .lastChild; Arguments None. Description Property (read-only); evaluates the XML object and references the last child in the parent node's child list. This method returns null if the node does not have children. This is a read-only property and cannot be used to manipulate child nodes; use the methods appendChild , insertBefore , and removeNode to manipulate child nodes. Player Flash 5 or later. See also XML.appendChild XML.insertBefore XML.removeNodehtml/12_x_z14.html XML.load XML.load X-Z > XML.load Syntax myXML .load( url ); Arguments url The URL where the XML document to be loaded is located. The URL must be in the same subdomain as the URL where the movie currently resides. Description Method; loads an XML document from the specified URL, and replaces the contents of the specified XML object with the downloaded XML data. The load process is asynchronous; it does not finish immediately after the load method is executed. When load is executed, the XML object property loaded is set to false . When the XML data finishes downloading, the loaded property is set to true , and the onLoad method is invoked. The XML data is not parsed until it is completely downloaded. If the XML object previously contained any XML trees, they are discarded. You can specify your own callback function in place of the onLoad method. Player Flash 5 or later. Example The following is a simple example using XML.load : doc = new XML(); doc.load ("theFile.xml"); See also XML.onLoad XML.loadedhtml/12_x_z15.html XML.loaded XML.loaded X-Z > XML.loaded Syntax myXML .loaded; Arguments None. Description Property (read-only); determines whether the document loading process initiated by the XML.load call has completed. If the process completes successfully, the method returns true ; otherwise, it returns false . Player Flash 5 or later. Example The following example uses XML.loaded in a simple script. if (doc.loaded) { gotoAndPlay(4) }html/12_x_z16.html XML.nextSibling XML.nextSibling X-Z > XML.nextSibling Syntax myXML .nextSibling; Arguments None. Description Property (read-only); evaluates the XML object and references the next sibling in the parent node's child list. This method returns null if the node does not have a next sibling node. This is a read-only property and cannot be used to manipulate child nodes. Use the methods appendChild , insertBefore , and removeNode to manipulate child nodes. Player Flash 5 or later. See also XML.appendChild XML.insertBefore XML.removeNodehtml/12_x_z17.html XML.nodeName XML.nodeName X-Z > XML.nodeName Syntax myXML .nodeName; Arguments None. Description Property; takes or returns the node name of the XML object. If the XML object is an XML element ( nodeType == 1), nodeName is the name of the tag representing the node in the XML file. For example, TITLE is the nodeName of an HTML TITLE tag. If the XML object is a text node ( nodeType == 3), the nodeName is null . Player Flash 5 or later. See also XML.nodeTypehtml/12_x_z18.html XML.nodeType XML.nodeType X-Z > XML.nodeType Syntax myXML .nodeType; Arguments None. Description Property (read-only); takes or returns a nodeType value, where 1 is a XML element and 3 is a text node. Player Flash 5 or later. See also XML.nodeValuehtml/12_x_z19.html XML.nodeValue XML.nodeValue X-Z > XML.nodeValue Syntax myXML .nodeValue; Arguments None. Description Property; returns the node value of the XML object. If the XML object is a text node, the nodeType is 3, and the nodeValue is the text of the node. If the XML object is an XML element, it has a null nodeValue and is read-only. Player Flash 5 or later. See also XML.nodeTypehtml/12_x_z2.html XML (object) XML (object) X-Z > XML (object) Use the methods and properties of the XML object to load, parse, send, build, and manipulate XML document trees. You must use the constructor new XML() to create an instance of the XML object before calling any of the methods of the XML object. XML is supported by Flash 5 or later versions of the Flash Player. Method summary for the XML object Method Description appendChild Appends a node to the end of the specified object's child list. cloneNode Clones the specified node and, optionally, recursively clones all children. createElement Creates a new XML element. createTextNode Creates a new XML text node. hasChildNodes Returns true if the specified node has child nodes; otherwise, returns false . insertBefore Inserts a node in front of an existing node in the specified node's child list. load Loads a document (specified by the XML object) from a URL. onLoad A callback function for load and sendAndLoad. parseXML Parses an XML document into the specified XML object tree. removeNode Removes the specified node from its parent. send Sends the specified XML object to a URL. sendAndLoad Sends the specified XML object to a URL and loads the server response into another XML object. toString Converts the specified node and any children to XML text. Property summary for the XML object Property Description docTypeDecl Sets and returns information about an XML document's DOCTYPE declaration. firstChild References the first child in the list for the specified node. lastChild References the last child in the list for the specified node. loaded Checks if the specified XML object has loaded. nextSibling References the next sibling in the parent node's child list. nodeName Returns the tag name of an XML element. nodeType Re turns the type of the specified node (XML element or text node). nodeValue Returns the text of the specified node if the node is a text node. parentNode References the parent node of the specified node. previousSibling References the previous sibling in the parent node's child list. status Returns a numeric status code indicating the success or failure of an XML document parsing operation. xmlDecl Sets and returns information about an XML document's document declaration. Collections summary for the XML object Method Description attributes Returns an associative array containing all of the attributes of the specified node. childNodes Returns an array containing references to the child nodes of the specified node. Constructor for the XML object Syntax new XML(); new XML( source ); Arguments source The XML document parsed to create the new XML object. Description Constructor; creates a new XML object. You must use the constructor method to create an instance of the XML object before calling any of the XML object methods. The first syntax constructs a new, empty XML object. The second syntax constructs a new XML object by parsing the XML document specified in the source argument, and populates the newly created XML object with the resulting XML document tree. Note: The createElement and createTextnode methods are the 'constructor' methods for creating the elements and text nodes in an XML document tree. Player Flash 5 or later. Example The following example creates an new empty XML object: myXML = new XML(); See also XML.createTextNode XML.createElementhtml/12_x_z20.html XML.onLoad XML.onLoad X-Z > XML.onLoad Syntax myXML .onLoad( success ); Arguments success A boolean value indicating whether the XML object was successfully loaded with a XML.load or XML.sendAndLoad operation. Description Method; invoked by the Flash Player when an XML document is received from the server. If the XML document is received successfully, the success argument is true . If the document was not received, or if an error occurred in receiving the response from the server, the success argument is false . The default implementation of this method is not active. To override the default implementation, you must assign a function containing your own actions. Player Flash 5 or later. Example The following example creates a simple Flash movie for a simple e-commerce storefront application. We use the sendAndLoad method to transmit an XML element containing the user's name and password, and install an onLoad handler to handle the reply from the server. var myLoginReply = new XML(); myLoginReply.onLoad = myOnLoad; myXML.sendAndLoad("http://www.samplestore.com/login.cgi", myLoginReply); function myOnLoad(success) { if (success) { if (e.firstChild.nodeName == "LOGINREPLY" && e.firstChild.attributes.status == "OK") { gotoAndPlay("loggedIn") } else { gotoAndStop("loginFailed") } } else { gotoAndStop("connectionFailed") } } See also function XML.load XML.sendAndLoadhtml/12_x_z21.html XML.parentNode XML.parentNode X-Z > XML.parentNode Syntax myXML .parentNode; Arguments None. Description Property (read-only); references the parent node of the specified XML object, or returns null if the node has no parent. This is a read-only property and cannot be used to manipulate child nodes; use the methods appendChild , insertBefore , and removeNode to manipulate children. Player Flash 5 or later.html/12_x_z22.html XML.parseXML XML.parseXML X-Z > XML.parseXML Syntax myXML .parseXML( source ); Arguments source The XML text to be parsed and passed to the specified XML object. Description Method; parses the XML text specified in the source argument, and populates the specified XML object with the resulting XML tree. Any existing trees in the XML object are discarded. Player Flash 5 or later.html/12_x_z23.html XML.previousSibling XML.previousSibling X-Z > XML.previousSibling Syntax myXML .previousSibling; Description Property (read-only); evaluates the XML object and references the previous sibling in the parent node's child list. Returns null if the node does not have a previous sibling node. This is a read-only property and cannot be used to manipulate child nodes; use the methods appendChild , insertBefore , and removeNode to manipulate child nodes. Player Flash 5 or later.html/12_x_z24.html XML.removeNode XML.removeNode X-Z > XML.removeNode Syntax myXML .removeNode(); Arguments None. Description Method; removes the specified XML object from its parent. Player Flash 5 or later.html/12_x_z25.html XML.send XML.send X-Z > XML.send Syntax myXML .send( url ); myXML .send( url, window ); Arguments url The destination URL for the specified XML object. window The browser window to display data returned by the server: _self specifies the current frame in the current window, _blank specifies a new window, _parent specifies the parent of the current frame, and _top specifies the top-level frame in the current window. Description Method; encodes the specified XML object into a XML document and sends it to the specified URL using the POST method. Player Flash 5 or later.html/12_x_z26.html XML.sendAndLoad XML.sendAndLoad X-Z > XML.sendAndLoad Syntax myXML .sendAndLoad( url,targetXMLobject ); Arguments url The destination URL for the specified XML object. The URL must be in the same subdomain as the URL where the movie was downloaded from. targetXMLobject An XML object created with the XML constructor method that will receive the return information from the server. Description Method; encodes the specified XML object into a XML document, sends it to the specified URL using the POST method, downloads the server's response and then loads it into the targetXMLobject specified in the arguments. The server response is loaded in the same manner used by the load method. Player Flash 5 or later. See also XML.loadhtml/12_x_z27.html XML.status XML.status X-Z > XML.status Syntax myXML . status; Arguments None. Description Property; automatically sets and returns a numeric value indicating whether an XML document was successfully parsed into an XML object. The following is a list of the numeric status codes and a description of each: 0 No error; parse completed successfully. -2 A CDATA section was not properly terminated. -3 The XML declaration was not properly terminated. -4 The DOCTYPE declaration was not properly terminated. -5 A comment was not properly terminated. -6 An XML element was malformed. -7 Out of memory. -8 An attribute value was not properly terminated. -9 A start-tag was not matched with an end-tag. -10 An end-tag was encountered without a matching start-tag. Player Flash 5 or later.html/12_x_z28.html XML.toString XML.toString X-Z > XML.toString Syntax myXML .toString(); Arguments None. Description Method; evaluates the specified XML object, constructs a textural representation of the XML structure including the node, children, and attributes, and returns the result as a string. For top-level XML objects (those created with the constructor), XML.toString outputs the document's XML declaration (stored in XML.xmlDecl ), followed by the document's DOCTYPE declaration (stored in XML.docTypeDecl ), followed by the text representation of all XML nodes in the object. The XML declaration is not output if XML.xmlDecl is undefined. The DOCTYPE declaration is not output if XML.docTypeDecl is undefined. Player Flash 5 or later. Example The following code is an example of the XML.toString method: node = new XML("<h1>test</h1>"); trace(node.toString()); sends <H1>test</H1> to the output window See also XML.xmlDecl XML.docTypeDeclhtml/12_x_z29.html XML.xmlDecl XML.xmlDecl X-Z > XML.xmlDecl Syntax myXML .xmlDecl; Arguments None. Description Property; sets and returns information about a document's XML declaration. After the XML document is parsed into an XML object, this property is set using the text of the document's XML declaration. This property is set using a string representation of the XML declaration, not an XML node object. If no XML declaration was encountered during a parse operation, the property is set to undefined. XML.toString outputs the contents of XML.xmlDecl before any other text in the XML object. If XML.xmlDecl contains the undefined type, no XML declaration is output. Player Flash 5 or later. Example The following example uses XML.xmlDecl to set the XML document declaration for an XML object: myXML . xmlDecl = "<?xml version=\"1.0\" ?>"; See also XML.toString XML.docTypeDeclhtml/12_x_z3.html XML.appendChild XML.appendChild X-Z > XML.appendChild Syntax myXML .appendChild( childNode ); Arguments childNode The child node to be added to the specified XML object's child list. Description Method; appends the specified child node to the XML object's child list. The appended child node is placed in the tree structure once removed from its existing parent node, if any. Player Flash 5 or later. Example The following example clones the last node from doc1 and appends it to doc2 : doc1 = new XML(src1); doc2 = new XML(); node = doc1.lastChild.cloneNode(true); doc2.appendChild(node);html/12_x_z30.html XMLSocket (object) XMLSocket (object) X-Z > XMLSocket (object) The XMLSocket object implements client sockets that allow the computer running the Flash Player to communicate with a server computer identified by an IP address or domain name. Using the XMLSocket object To use the XMLSocket object, the server computer must run a daemon that understands the protocol used by the XMLSocket object. The protocol is as follows: XML messages are sent over a full-duplex TCP/IP stream socket connection. Each XML message is a complete XML document, terminated by a zero byte. An unlimited number of XML messages can be sent and received over a single XMLSocket connection. The XMLSocket object is useful for client-server applications that require low latency, such as real-time chat systems. A traditional HTTP-based chat solution frequently polls the server and downloads new messages using an HTTP request. In contrast, an XMLSocket chat solution maintains an open connection to the server, which allows the server to immediately send incoming messages without a request from the client. Setting up a server to communicate with the XMLSocket object can be challenging. If your application does not require real-time interactivity, use the loadVariables action, or Flash's HTTP-based XML server connectivity ( XML.load , XML.sendAndLoad , XML.send ), instead of the XMLSocket object. To use the methods of the XMLSocket object, you must first use the constructor, new XMLSocket , to create a new XMLSocket object. XMLSocket and security Because the XMLSocket object establishes and maintains an open connection to the server, the following restrictions have been placed on the XMLSocket object for security reasons: The XMLSocket.connect method can connect only to TCP port numbers greater than or equal to 1024. One consequence of this restriction is that the server daemons that communicate with the XMLSocket object must also be assigned to port numbers greater than or equal to 1024. Port numbers below 1024 are often used by system services such as FTP, Telnet, and HTTP, thus barring the XMLSocket object from these ports. The port number restriction limits the possibility that these resources will be inappropriately accessed and abused. The XMLSocket.connect method can connect only to computers in the same subdomain where the SWF file (movie) resides. This restriction does not apply to movies running off a local disk. (This restriction is identical to the security rules for loadVariables , XML.sendAndLoad , and XML.load .) Method summary for the XMLSocket object Method Description close Closes an open socket connection. connect Establishes a connection to the specified server. onClose A callback function that is invoked when an XMLSocket connection is closed. onConnect A callback function that is invoked when an XMLSocket connection is established. onXML A callback function that is invoked when an XML object arrives from the server. send Sends an XML object to the server. Constructor for the XMLSocket object Syntax new XMLSocket(); Arguments None. Description Constructor; creates a new XMLSocket object. The XMLSocket object is not initially connected to any server. You must call the XMLSocket.connect method to connect the object to a server. Player Flash 5 or later. Example myXMLSocket = new XMLSocket(); See also XMLSocket.connecthtml/12_x_z31.html XMLSocket.close XMLSocket.close X-Z > XMLSocket.close Syntax myXMLSocket .close(); Arguments None. Description Method; closes the connection specified by XMLSocket object. Player Flash 5 or later. See also XMLSocket.connecthtml/12_x_z32.html XMLSocket.connect XMLSocket.connect X-Z > XMLSocket.connect Syntax myXMLSocket .connect( host, port ); Arguments host A fully qualified DNS domain name, or a IP address in the form aaa.bbb.ccc.ddd. You can also specify null to connect to the host server on which the movie resides. port The TCP port number on the host used to establish a connection. The port number must be 1024 or higher. Description Method; establishes a connection to the specified Internet host using the specified TCP port (must be 1024 or higher), and returns true or false depending on whether a connection is successfully established. If you don't know the port number of your Internet host machine, contact your network administrator. If the Flash Netscape plug-in or ActiveX control is being used, the host specified in the argument must have the same subdomain as the host from where the movie was downloaded. If you specify null for the host argument, the host contacted will be the host where the movie calling XMLSocket.connect resides. For example, if the movie was downloaded from http://www.yoursite.com, specifying null for the host argument is the same as entering the IP address for www.yoursite.com. If XMLSocket.connect returns a value of true , the initial stage of the connection process is successful; later, the XMLSocket.onConnect method is invoked to determine whether the final connection succeeded or failed. If XMLSocket.connect returns false , a connection could not be established. Player Flash 5 or later. Example The following example uses XMLSocket.connect to connect to the host where the movie resides, and uses trace to display the return value indicating the success or failure of the connection: function myOnConnect(success) { if (success) { trace ("Connection succeeded!") } else { trace ("Connection failed!") } } socket = new XMLSocket() socket.onConnect = myOnConnect if (!socket.connect(null, 2000)) { trace ("Connection failed!") } See also function XMLSocket.onConnecthtml/12_x_z33.html XMLSocket.onClose XMLSocket.onClose X-Z > XMLSocket.onClose Syntax myXMLSocket .onClose(); Arguments None. Description Method; a callback function that is invoked only when an open connection is closed by the server. The default implementation of this method performs no actions. To override the default implementation, you must assign a function containing your own actions. Player Flash 5 or later. See also function XMLSocket.onConnecthtml/12_x_z34.html XMLSocket.onConnect XMLSocket.onConnect X-Z > XMLSocket.onConnect Syntax myXMLSocket .onConnect( success ); Arguments success A Boolean value indicating whether a socket connection was successfully established ( true or false ). Description Method; a callback function invoked by the Flash Player when a connection request initiated through the XMLSocket.connect method has succeeded or failed. If the connection succeeded, the success argument is true ; otherwise the success argument is false . The default implementation of this method performs no actions. To override the default implementation, you must assign a function containing your own actions. Player Flash 5 or later. Example The following example illustrates the process of specifying a replacement function for the onConnect method in a simple chat application. The function controls which screen the users are taken to, depending on whether a connection is successfully established. If the connection is successfully established, users are taken to the main chat screen on the frame labeled startChat . If the connection is not successful, users go to a screen with troubleshooting information on the frame labeled connectionFailed . function myOnConnect(success) { if (success) { gotoAndPlay("startChat") } else { gotoAndStop("connectionFailed") } } After creating the XMLSocket object using the constructor method, the script installs the onConnect method using the assignment operator: socket = new XMLSocket() socket.onConnect = myOnConnect Finally, the connection is initiated. If connect returns false , the movie is sent directly to the frame labeled connectionFailed , and onConnect is never invoked. If connect returns true , the movie jumps to a frame labeled waitForConnection , which is the "Please wait" screen. The movie remains on the waitForConnection frame until the onConnect handler is invoked, which happens at some point in the future depending on network latency. if (!socket.connect(null, 2000)) { gotoAndStop("connectionFailed") } else { gotoAndStop("waitForConnection") } See also XMLSocket.connect functionhtml/12_x_z35.html XMLSocket.onXML XMLSocket.onXML X-Z > XMLSocket.onXML Syntax myXMLSocket .onXML( object ); Argument object An instance of the XML object containing a parsed XML document received from a server. Description Method; a callback function invoked by the Flash Player when the specified XML object containing an XML document arrives over an open XMLSocket connection. An XMLSocket connection may be used to transfer an unlimited number of XML documents between the client and the server. Each document is terminated with a zero byte. When the Flash Player receives the zero byte, it parses all of the XML received since the previous zero byte, or since the connection was established if this is the first message received. Each batch of parsed XML is treated as a single XML document and passed to the onXML method. The default implementation of this method performs no actions. To override the default implementation, you must assign a function containing actions that you define. Player Flash 5 or later. Example The following function overrides the default implementation of the onXML method in a simple chat application. The function myOnXML instructs the chat application to recognize a single XML element, MESSAGE , in the following format: <MESSAGE USER="John" TEXT="Hello, my name is John!" />. The onXML handler must first be installed in the XMLSocket object as follows: socket.onXML = myOnXML; The function displayMessage is assumed to be a user-defined function that displays the message received to the user. function myOnXML(doc) { var e = doc.firstChild; if (e != null && e.nodeName == "MESSAGE") { displayMessage(e.attributes.user, e.attributes.text); } } See also functionhtml/12_x_z36.html XMLSocket.send XMLSocket.send X-Z > XMLSocket.send Syntax myXMLSocket .send( object ); Arguments object An XML object or other data to transmit to the server. Description Method; converts the XML object or data specified in the object argument to a string and transmits it to the server, followed by a zero byte. If object is an XML object, the string is the XML textual representation of the XML object. The send operation is asynchronous; it returns immediately, but the data may be transmitted at a later time. The XMLSocket.send method does not return a value indicating whether the data was successfully transmitted. If the myXMLSocket object is not connected to the server (using XMLSocket.connect ), the XMLSocket.send operation will fail. Player Flash 5 or later. Example The following example illustrates how you could specify a user name and password to send the XML object myXML to the server: var myXML = new XML(); var myLogin = myXML.createElement("login"); myLogin.attributes.username = usernameTextField; myLogin.attributes.password = passwordTextField; myXML.appendChild(myLogin); myXMLSocket.send(myXML); See also XMLSocket.connecthtml/12_x_z37.html_xmouse _xmouse X-Z > _xmouse Syntax instancename ._xmouse Arguments instancename The name of a movie clip instance. Description Property (read-only); returns the x coordinate of the mouse position. Player Flash 5 or later. See also Mouse (object) _ymousehtml/12_x_z38.html_xscale _xscale X-Z > _xscale Syntax instancename . _xscale instancename . _xscale = percentage ; Arguments percentage A percentage value specifying the percentage for horizontally scaling the movie. The default value is 100. instancename The name of a movie clip instance. Description Property; determines the horizontal scale ( percentage ) of the movie clip as applied from the registration point of the movie clip. The default registration point is (0,0). Scaling the local coordinate system affects the _x and _y property settings, which are defined in whole pixels. For example, if the parent movie clip is scaled to 50%, setting the _x property moves an object in the movie clip by half the number of pixels as it would if the movie were at 100%. Player Flash 4 or later. See also _xscalehtml/12_x_z39.html_y _y X-Z > _y Syntax instancename . _y instancename . _y = integer ; Arguments integer The local y coordinate of the movie clip. instancename The name of a movie clip instance. Description Property; sets the y coordinate of movie relative to the local coordinates of the parent movie clip. If a movie clip is in the main Timeline, then its coordinate system refers to the upper left corner of the Stage as (0, 0). If the move clip is inside another movie clip that has transformations, the movie clip is in the local coordinate system of the enclosing movie clip. Thus, for a movie clip rotated 90º counterclockwise, the movie clip's children inherit a coordinate system that is rotated 90º counterclockwise. The movie clip's coordinates refer to the registration point position. Player Flash 3 or later. See also _yscalehtml/12_x_z4.html XML.attributes XML.attributes X-Z > XML.attributes Syntax myXML .attributes; Arguments None. Description Collection (read-write); returns an associative array containing all attributes of the specified XML object. Player Flash 5 or later. Example The following example writes the names of the XML attributes to the Output window: str = "<mytag name=\"Val\"> intem </mytage>"; doc = new XML(str); y = doc.fristChild.attributes.name; trace (y); doc.firstChild.attributes.order = "first"; z = doc.firstChild.attributes.order trace(z); The following is written to the Output window: Val Firsthtml/12_x_z40.html_ymouse _ymouse X-Z > _ymouse Syntax instancename ._ymouse Arguments instancename The name of a movie clip instance. Description Property (read-only); indicates the y coordinate of the mouse position. Player Flash 5 or later. See also Mouse (object) _xmousehtml/12_x_z41.html_yscale _yscale X-Z > _yscale Syntax instancename ._yscale instancename ._yscale = percentage ; Arguments percentage A percentage value specifying the percentage for vertically scaling the movie. The default value is 100. instancename The name of a movie clip instance. Description Property; sets the vertical scale ( percentage ) of the movie clip as applied from the registration point of the movie clip. The default registration point is (0,0). Scaling the local coordinate system affects the _x and _y property settings, which are defined in whole pixels. For example, if the parent movie clip is scaled to 50%, setting the _x property moves an object in the movie clip by half the number of pixels as it would if the movie were at 100%. Player Flash 4 or later. See also _x _yhtml/12_x_z5.html XML.childNodes XML.childNodes X-Z > XML.childNodes Syntax myXML .childNodes; Arguments None. Description Collection (read-only); returns an array of the specified XML object's children. Each element in the array is a reference to an XML object that represents a child node. This is a read-only property and cannot be used to manipulate child nodes. Use the methods appendChild , insertBefore , and removeNode to manipulate child nodes. This collection is undefined for text nodes (nodeType == 3). Player Flash 5 or later.html/12_x_z6.html XML.cloneNode XML.cloneNode X-Z > XML.cloneNode Syntax myXML .cloneNode( deep ); Arguments deep Boolean value specifying whether the children of the specified XML object are recursively cloned. Description Method; constructs and returns a new XML node of the same type, name, value, and attributes as the specified XML object. If deep is set to true , all child nodes are recursively cloned, resulting in an exact copy of the original object's document tree. Player Flash 5 or later.html/12_x_z7.html XML.createElement XML.createElement X-Z > XML.createElement Syntax myXML .createElement( name ); Arguments name The tag name of the XML element being created. Description Method; creates a new XML element with the name specified in the argument. The new element initially has no parent and no children. The method returns a reference to the newly created XML object representing the element. This method and createTextNode are the constructor methods for creating nodes for an XML object. Player Flash 5 or later.html/12_x_z8.html XML.createTextNode XML.createTextNode X-Z > XML.createTextNode Syntax myXML .createTextNode( text ); Arguments text The text used to create the new text node. Description Method; creates a new XML text node with the specified text. The new node initially has no parent, and text nodes cannot have children. This method returns a reference to the XML object representing the new text node. This method and createElement are the constructor methods for creating nodes for an XML object. Player Flash 5 or later.html/12_x_z9.html XML.docTypeDecl XML.docTypeDecl X-Z > XML.docTypeDecl Syntax myXML . XMLdocTypeDecl; Arguments None. Description Property; sets and returns information about the XML document DOCTYPE declaration. After the XML text has been parsed into an XML object, the XML.docTypeDecl property of the XML object is set to the text of the XML document's DOCTYPE declaration. For example, <!DOCTYPE greeting SYSTEM "hello.dtd"> . This property is set using a string representation of the DOCTYPE declaration, not an XML node object. ActionScript's XML parser is not a validating parser. The DOCTYPE declaration is read by the parser and stored in the docTypeDecl property, but no DTD validation is performed. If no DOCTYPE declaration was encountered during a parse operation, XML.docTypeDecl is set to undefined. XML.toString outputs the contents of XML.docTypeDecl immediately after the XML declaration stored in XML.xmlDecl , and before any other text in the XML object. If XML.docTypeDecl is undefined, no DOCTYPE declaration is output. Player Flash 5 or later. Example The following example uses XML.docTypeDecl to set the DOCTYPE declaration for an XML object. myXML . docTypeDecl = "<!DOCTYPE greeting SYSTEM \"hello.dtd\">"; See also XML.toString XML.xmlDecl